Update to PostgreSQL 8.4.3
This commit is contained in:
parent
9cc5f2029d
commit
446c31a8ed
@ -1,2 +1,2 @@
|
|||||||
postgresql-8.4.2.tar.bz2
|
postgresql-8.4.3.tar.bz2
|
||||||
postgresql-8.4.2-US.pdf
|
postgresql-8.4.3-US.pdf
|
||||||
|
@ -4,12 +4,12 @@ for PostgreSQL, but it's not very tenable in the Fedora/RHEL world.
|
|||||||
Dike out the check.
|
Dike out the check.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur postgresql-8.4.2.orig/configure.in postgresql-8.4.2/configure.in
|
diff -Naur postgresql-8.4.3.orig/configure.in postgresql-8.4.3/configure.in
|
||||||
--- postgresql-8.4.2.orig/configure.in 2009-09-03 20:36:50.000000000 -0400
|
--- postgresql-8.4.3.orig/configure.in 2009-09-03 20:36:50.000000000 -0400
|
||||||
+++ postgresql-8.4.2/configure.in 2009-09-04 13:03:07.000000000 -0400
|
+++ postgresql-8.4.3/configure.in 2009-09-04 13:03:07.000000000 -0400
|
||||||
@@ -19,10 +19,6 @@
|
@@ -19,10 +19,6 @@
|
||||||
|
|
||||||
AC_INIT([PostgreSQL], [8.4.2], [pgsql-bugs@postgresql.org])
|
AC_INIT([PostgreSQL], [8.4.3], [pgsql-bugs@postgresql.org])
|
||||||
|
|
||||||
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
|
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
|
||||||
-Untested combinations of 'autoconf' and PostgreSQL versions are not
|
-Untested combinations of 'autoconf' and PostgreSQL versions are not
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
Latest systemtap versions require the probes.o file after all, per bug #557266.
|
|
||||||
This patch will be incorporated upstream soon.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur postgresql-8.4.2.orig/src/backend/Makefile postgresql-8.4.2/src/backend/Makefile
|
|
||||||
--- postgresql-8.4.2.orig/src/backend/Makefile 2009-09-05 17:14:13.000000000 -0400
|
|
||||||
+++ postgresql-8.4.2/src/backend/Makefile 2010-01-20 17:21:37.000000000 -0500
|
|
||||||
@@ -20,13 +20,13 @@
|
|
||||||
|
|
||||||
include $(srcdir)/common.mk
|
|
||||||
|
|
||||||
-# As of 9/2009:
|
|
||||||
-# * The probes.o file is necessary for dtrace support on Solaris.
|
|
||||||
-# * OS X's dtrace doesn't use it and doesn't even recognize the -G option.
|
|
||||||
-# * Systemtap's dtrace will take -G, but it produces a useless empty file.
|
|
||||||
-# So, build probes.o only on Solaris.
|
|
||||||
-# This will likely need adjustment as other platforms add dtrace support.
|
|
||||||
-ifeq ($(PORTNAME), solaris)
|
|
||||||
+# As of 1/2010:
|
|
||||||
+# The probes.o file is necessary for dtrace support on Solaris, and on recent
|
|
||||||
+# versions of systemtap. (Older systemtap releases just produce an empty
|
|
||||||
+# file, but that's okay.) However, OS X's dtrace doesn't use it and doesn't
|
|
||||||
+# even recognize the -G option. So, build probes.o except on Darwin.
|
|
||||||
+# This might need adjustment as other platforms add dtrace support.
|
|
||||||
+ifneq ($(PORTNAME), darwin)
|
|
||||||
ifeq ($(enable_dtrace), yes)
|
|
||||||
LOCALOBJS += utils/probes.o
|
|
||||||
endif
|
|
@ -52,8 +52,8 @@
|
|||||||
Summary: PostgreSQL client programs
|
Summary: PostgreSQL client programs
|
||||||
Name: postgresql
|
Name: postgresql
|
||||||
%global majorversion 8.4
|
%global majorversion 8.4
|
||||||
Version: 8.4.2
|
Version: 8.4.3
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||||
# recognizes it as an independent license, so we do as well.
|
# recognizes it as an independent license, so we do as well.
|
||||||
License: PostgreSQL
|
License: PostgreSQL
|
||||||
@ -74,12 +74,12 @@ Source14: postgresql.pam
|
|||||||
Source15: postgresql-bashprofile
|
Source15: postgresql-bashprofile
|
||||||
Source16: filter-requires-perl-Pg.sh
|
Source16: filter-requires-perl-Pg.sh
|
||||||
|
|
||||||
|
# Comments for these patches are in the patch files.
|
||||||
Patch1: rpm-pgsql.patch
|
Patch1: rpm-pgsql.patch
|
||||||
Patch2: postgresql-ac-version.patch
|
Patch2: postgresql-ac-version.patch
|
||||||
Patch3: postgresql-logging.patch
|
Patch3: postgresql-logging.patch
|
||||||
Patch4: postgresql-oom-adj.patch
|
Patch4: postgresql-oom-adj.patch
|
||||||
Patch6: postgresql-perl-rpath.patch
|
Patch6: postgresql-perl-rpath.patch
|
||||||
Patch7: postgresql-dtrace.patch
|
|
||||||
|
|
||||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex autoconf gawk
|
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex autoconf gawk
|
||||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||||
@ -282,7 +282,6 @@ system, including regression tests and benchmarks.
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
|
||||||
|
|
||||||
autoconf
|
autoconf
|
||||||
|
|
||||||
@ -714,6 +713,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 14 2010 Tom Lane <tgl@redhat.com> 8.4.3-1
|
||||||
|
- Update to PostgreSQL 8.4.3, for various fixes described at
|
||||||
|
http://www.postgresql.org/docs/8.4/static/release-8-4-3.html
|
||||||
|
|
||||||
* Mon Feb 22 2010 Tom Lane <tgl@redhat.com> 8.4.2-8
|
* Mon Feb 22 2010 Tom Lane <tgl@redhat.com> 8.4.2-8
|
||||||
- Bring init script into some modicum of compliance with Fedora/LSB standards
|
- Bring init script into some modicum of compliance with Fedora/LSB standards
|
||||||
Resolves: #201043
|
Resolves: #201043
|
||||||
|
@ -1,60 +1,72 @@
|
|||||||
For the RPMs, we want the custom installation directories to end in
|
For the RPMs, we want the custom installation directories to end in
|
||||||
/pgsql not /postgresql. This is historical but not worth changing.
|
/pgsql not /postgresql. This is historical but not worth changing.
|
||||||
|
|
||||||
|
Notice that this patch also makes the appending of /pgsql unconditional.
|
||||||
|
This is to avoid unexpected behavior if the RPM is built in a working
|
||||||
|
directory whose path happens to include "postgres" or "pgsql" already.
|
||||||
|
However, datadir and sysconfdir are already set up in the specfile's
|
||||||
|
configure call, so we do not have to append anything to them.
|
||||||
|
|
||||||
diff -Naur postgresql-8.4.0.orig/src/Makefile.global.in postgresql-8.4.0/src/Makefile.global.in
|
|
||||||
--- postgresql-8.4.0.orig/src/Makefile.global.in 2009-06-22 23:46:00.000000000 -0400
|
diff -Naur postgresql-8.4.3.orig/src/Makefile.global.in postgresql-8.4.3/src/Makefile.global.in
|
||||||
+++ postgresql-8.4.0/src/Makefile.global.in 2009-08-12 23:14:53.000000000 -0400
|
--- postgresql-8.4.3.orig/src/Makefile.global.in 2009-06-22 23:46:00.000000000 -0400
|
||||||
@@ -54,7 +54,7 @@
|
+++ postgresql-8.4.3/src/Makefile.global.in 2010-03-13 22:18:12.000000000 -0500
|
||||||
|
@@ -54,8 +54,7 @@
|
||||||
# Installation directories
|
# Installation directories
|
||||||
#
|
#
|
||||||
# These are set by the equivalent --xxxdir configure options. We
|
# These are set by the equivalent --xxxdir configure options. We
|
||||||
-# append "postgresql" to some of them, if the string does not already
|
-# append "postgresql" to some of them, if the string does not already
|
||||||
+# append "pgsql" to some of them, if the string does not already
|
-# contain "pgsql" or "postgres", in order to avoid directory clutter.
|
||||||
# contain "pgsql" or "postgres", in order to avoid directory clutter.
|
+# append "pgsql" to some of them, in order to avoid directory clutter.
|
||||||
#
|
#
|
||||||
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
||||||
@@ -75,14 +75,14 @@
|
# by configure, since the installation tree may have been relocated.
|
||||||
|
@@ -73,45 +72,23 @@
|
||||||
|
bindir := @bindir@
|
||||||
|
|
||||||
datadir := @datadir@
|
datadir := @datadir@
|
||||||
ifeq "$(findstring pgsql, $(datadir))" ""
|
-ifeq "$(findstring pgsql, $(datadir))" ""
|
||||||
ifeq "$(findstring postgres, $(datadir))" ""
|
-ifeq "$(findstring postgres, $(datadir))" ""
|
||||||
-override datadir := $(datadir)/postgresql
|
-override datadir := $(datadir)/postgresql
|
||||||
+override datadir := $(datadir)/pgsql
|
-endif
|
||||||
endif
|
-endif
|
||||||
endif
|
|
||||||
|
|
||||||
sysconfdir := @sysconfdir@
|
sysconfdir := @sysconfdir@
|
||||||
ifeq "$(findstring pgsql, $(sysconfdir))" ""
|
-ifeq "$(findstring pgsql, $(sysconfdir))" ""
|
||||||
ifeq "$(findstring postgres, $(sysconfdir))" ""
|
-ifeq "$(findstring postgres, $(sysconfdir))" ""
|
||||||
-override sysconfdir := $(sysconfdir)/postgresql
|
-override sysconfdir := $(sysconfdir)/postgresql
|
||||||
+override sysconfdir := $(sysconfdir)/pgsql
|
-endif
|
||||||
endif
|
-endif
|
||||||
endif
|
|
||||||
|
libdir := @libdir@
|
||||||
|
|
||||||
@@ -91,7 +91,7 @@
|
|
||||||
pkglibdir = $(libdir)
|
pkglibdir = $(libdir)
|
||||||
ifeq "$(findstring pgsql, $(pkglibdir))" ""
|
-ifeq "$(findstring pgsql, $(pkglibdir))" ""
|
||||||
ifeq "$(findstring postgres, $(pkglibdir))" ""
|
-ifeq "$(findstring postgres, $(pkglibdir))" ""
|
||||||
-override pkglibdir := $(pkglibdir)/postgresql
|
-override pkglibdir := $(pkglibdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
+override pkglibdir := $(pkglibdir)/pgsql
|
+override pkglibdir := $(pkglibdir)/pgsql
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -100,7 +100,7 @@
|
includedir := @includedir@
|
||||||
|
|
||||||
pkgincludedir = $(includedir)
|
pkgincludedir = $(includedir)
|
||||||
ifeq "$(findstring pgsql, $(pkgincludedir))" ""
|
-ifeq "$(findstring pgsql, $(pkgincludedir))" ""
|
||||||
ifeq "$(findstring postgres, $(pkgincludedir))" ""
|
-ifeq "$(findstring postgres, $(pkgincludedir))" ""
|
||||||
-override pkgincludedir := $(pkgincludedir)/postgresql
|
-override pkgincludedir := $(pkgincludedir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
+override pkgincludedir := $(pkgincludedir)/pgsql
|
+override pkgincludedir := $(pkgincludedir)/pgsql
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
@@ -109,7 +109,7 @@
|
mandir := @mandir@
|
||||||
|
|
||||||
docdir := @docdir@
|
docdir := @docdir@
|
||||||
ifeq "$(findstring pgsql, $(docdir))" ""
|
-ifeq "$(findstring pgsql, $(docdir))" ""
|
||||||
ifeq "$(findstring postgres, $(docdir))" ""
|
-ifeq "$(findstring postgres, $(docdir))" ""
|
||||||
-override docdir := $(docdir)/postgresql
|
-override docdir := $(docdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
+override docdir := $(docdir)/pgsql
|
+override docdir := $(docdir)/pgsql
|
||||||
endif
|
|
||||||
endif
|
htmldir := @htmldir@
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user