Update to postgresql 14

Update postgresql-setup to v8.7
This commit is contained in:
Filip Janus 2022-01-05 11:15:31 +01:00
parent 260f86c44a
commit 371af17e4f
5 changed files with 41 additions and 39 deletions

0
.gitignore vendored Normal file → Executable file
View File

View File

@ -1,10 +1,7 @@
Default to stderr-based logging with a week's worth of daily logfiles.
diff -Naur postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample postgresql-9.1rc1/src/backend/utils/misc/postgresql.conf.sample
--- postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample 2011-08-18 17:23:13.000000000 -0400
+++ postgresql-9.1rc1/src/backend/utils/misc/postgresql.conf.sample 2011-08-18 18:39:39.697526799 -0400
@@ -279,7 +279,7 @@
diff -up postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample.patch2 postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample
--- postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample.patch2 2021-06-21 23:07:55.000000000 +0200
+++ postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample 2021-06-25 19:37:21.868632721 +0200
@@ -435,7 +435,7 @@
# requires logging_collector to be on.
# This is used when logging to stderr:
@ -13,7 +10,7 @@ diff -Naur postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample
# into log files. Required to be on for
# csvlogs.
# (change requires restart)
@@ -355,11 +355,11 @@
@@ -443,16 +443,16 @@
# These are only used if logging_collector is on:
#log_directory = 'log' # directory where log files are written,
# can be absolute or relative to PGDATA
@ -22,15 +19,6 @@ diff -Naur postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample
# can include strftime() escapes
#log_file_mode = 0600 # creation mode for log files,
# begin with 0 to use octal notation
-#log_truncate_on_rotation = off # If on, an existing log file with the
+log_truncate_on_rotation = on # If on, an existing log file with the
# same name as the new log file will be
# truncated rather than appended to.
# But such truncation only occurs on
@@ -367,9 +367,9 @@
# or size-driven rotation. Default is
# off, meaning append to existing files
# in all cases.
-#log_rotation_age = 1d # Automatic rotation of logfiles will
+log_rotation_age = 1d # Automatic rotation of logfiles will
# happen after that time. 0 disables.
@ -38,4 +26,8 @@ diff -Naur postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample
+log_rotation_size = 0 # Automatic rotation of logfiles will
# happen after that much log output.
# 0 disables.
-#log_truncate_on_rotation = off # If on, an existing log file with the
+log_truncate_on_rotation = on # If on, an existing log file with the
# same name as the new log file will be
# truncated rather than appended to.
# But such truncation only occurs on

View File

@ -6,9 +6,9 @@ rhbz#1618698 change, rather provide pg_server_config binary, which int urn means
that we'll have to fix only a minimal set of packages which really build
PostgreSQL server modules.
diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/bin/pg_config/Makefile
--- postgresql-13.1/src/bin/pg_config/Makefile.patch9 2020-11-18 09:28:30.885453275 +0100
+++ postgresql-13.1/src/bin/pg_config/Makefile 2020-11-18 09:31:33.926325327 +0100
diff -ur postgresql-14rc1/src/bin/pg_config/Makefile pgsql14/src/bin/pg_config/Makefile
--- postgresql-14rc1/src/bin/pg_config/Makefile 2021-09-20 23:33:01.000000000 +0200
+++ pgsql14/src/bin/pg_config/Makefile 2021-09-22 10:48:06.484093152 +0200
@@ -11,6 +11,8 @@
PGFILEDESC = "pg_config - report configuration information"
PGAPPICON=win32
@ -18,7 +18,7 @@ diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/b
subdir = src/bin/pg_config
top_builddir = ../../..
include $(top_builddir)/src/Makefile.global
@@ -19,22 +21,22 @@ OBJS = \
@@ -19,22 +21,22 @@
$(WIN32RES) \
pg_config.o
@ -47,12 +47,12 @@ diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/b
rm -rf tmp_check
check:
diff -up postgresql-13.1/src/bin/pg_config/nls.mk.patch9 postgresql-13.1/src/bin/pg_config/nls.mk
--- postgresql-13.1/src/bin/pg_config/nls.mk.patch9 2020-11-18 09:28:30.885453275 +0100
+++ postgresql-13.1/src/bin/pg_config/nls.mk 2020-11-18 09:32:00.735599526 +0100
diff -ur postgresql-14rc1/src/bin/pg_config/nls.mk pgsql14/src/bin/pg_config/nls.mk
--- postgresql-14rc1/src/bin/pg_config/nls.mk 2021-09-20 23:33:01.000000000 +0200
+++ pgsql14/src/bin/pg_config/nls.mk 2021-09-22 10:48:51.492460567 +0200
@@ -1,4 +1,4 @@
# src/bin/pg_config/nls.mk
-CATALOG_NAME = pg_config
+CATALOG_NAME = pg_server_config
AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ru sv tr uk vi zh_CN
AVAIL_LANGUAGES = cs de el es fr he it ja ko pl pt_BR ru sv tr uk vi zh_CN
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c

View File

@ -59,8 +59,8 @@
Summary: PostgreSQL client programs
Name: postgresql
%global majorversion 13
Version: %{majorversion}.5
%global majorversion 14
Version: %{majorversion}.1
Release: 1%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
@ -72,12 +72,12 @@ Url: http://www.postgresql.org/
# in-place upgrade of an old database. In most cases it will not be critical
# that this be kept up with the latest minor release of the previous series;
# but update when bugs affecting pg_dump output are fixed.
%global prevmajorversion 12
%global prevversion %{prevmajorversion}.9
%global prevmajorversion 13
%global prevversion %{prevmajorversion}.5
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
%global precise_version %{?epoch:%epoch:}%version-%release
%global setup_version 8.6
%global setup_version 8.7
%global service_name postgresql.service
@ -779,7 +779,6 @@ rm $RPM_BUILD_ROOT/%{_datadir}/man/man1/ecpg.1
# Drop libraries.
rm lib/lib{ecpg,ecpg_compat,pgtypes}.so*
rm share/*.bki
rm share/*description
rm share/*.sample
rm share/*.sql
rm share/*.txt
@ -846,7 +845,7 @@ find_lang_bins server.lst \
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \
postgres pg_checksums pg_verifybackup
find_lang_bins contrib.lst \
pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
pg_amcheck pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
find_lang_bins main.lst \
pg_dump pg_upgrade pgscripts psql \
%if ! %external_libpq
@ -940,8 +939,8 @@ make -C postgresql-setup-%{setup_version} check
%files contrib -f contrib.lst
%doc contrib/spi/*.example
%{_bindir}/oid2name
%{_bindir}/pg_amcheck
%{_bindir}/pg_archivecleanup
%{_bindir}/pg_standby
%{_bindir}/pg_test_fsync
%{_bindir}/pg_test_timing
%{_bindir}/pg_waldump
@ -975,11 +974,13 @@ make -C postgresql-setup-%{setup_version} check
%{_datadir}/pgsql/extension/lo*
%{_datadir}/pgsql/extension/ltree*
%{_datadir}/pgsql/extension/moddatetime*
%{_datadir}/pgsql/extension/old_snapshot*
%{_datadir}/pgsql/extension/pageinspect*
%{_datadir}/pgsql/extension/pg_buffercache*
%{_datadir}/pgsql/extension/pg_freespacemap*
%{_datadir}/pgsql/extension/pg_prewarm*
%{_datadir}/pgsql/extension/pg_stat_statements*
%{_datadir}/pgsql/extension/pg_surgery*
%{_datadir}/pgsql/extension/pg_trgm*
%{_datadir}/pgsql/extension/pg_visibility*
%{_datadir}/pgsql/extension/pgcrypto*
@ -1031,11 +1032,13 @@ make -C postgresql-setup-%{setup_version} check
%{_libdir}/pgsql/ltree_plpython3.so
%endif
%{_libdir}/pgsql/moddatetime.so
%{_libdir}/pgsql/old_snapshot.so
%{_libdir}/pgsql/pageinspect.so
%{_libdir}/pgsql/passwordcheck.so
%{_libdir}/pgsql/pg_buffercache.so
%{_libdir}/pgsql/pg_freespacemap.so
%{_libdir}/pgsql/pg_stat_statements.so
%{_libdir}/pgsql/pg_surgery.so
%{_libdir}/pgsql/pg_trgm.so
%{_libdir}/pgsql/pg_visibility.so
%{_libdir}/pgsql/pgcrypto.so
@ -1051,9 +1054,9 @@ make -C postgresql-setup-%{setup_version} check
%{_libdir}/pgsql/tsm_system_time.so
%{_libdir}/pgsql/unaccent.so
%{_mandir}/man1/oid2name.*
%{_mandir}/man1/pg_amcheck.*
%{_mandir}/man1/pg_archivecleanup.*
%{_mandir}/man1/pg_recvlogical.*
%{_mandir}/man1/pg_standby.*
%{_mandir}/man1/pg_test_fsync.*
%{_mandir}/man1/pg_test_timing.*
%{_mandir}/man1/pg_waldump.*
@ -1101,6 +1104,8 @@ make -C postgresql-setup-%{setup_version} check
%{_datadir}/pgsql/postgres.bki
%{_datadir}/pgsql/snowball_create.sql
%{_datadir}/pgsql/sql_features.txt
%{_datadir}/pgsql/system_constraints.sql
%{_datadir}/pgsql/system_functions.sql
%{_datadir}/pgsql/system_views.sql
%{_datadir}/pgsql/timezonesets/
%{_datadir}/pgsql/tsearch_data/
@ -1242,6 +1247,11 @@ make -C postgresql-setup-%{setup_version} check
%changelog
* Wed Jan 05 2022 Filip Januš <fjanus@redhat.com> - 14.1-1
- Update to 14.1
- Update postgresql-setup to v8.7
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_14
* Mon Dec 13 2021 Marek Kulik <mkulik@redhat.com> - 13.5-1
- Update to 13.5
Remove patch postgresql-pgcrypto-openssl3-init.patch - already in upstream

8
sources Normal file → Executable file
View File

@ -1,6 +1,6 @@
SHA512 (postgresql-12.9.tar.bz2) = 11697d8283f5df5a9c74c2406e94d1b6da6df8358ad48f3b773825aab98e8395f9fd4e3fc8b1e6ebad3743c3dadbda8b795d4fe84a447d7913223e136cf2b88f
SHA512 (postgresql-12.9.tar.bz2.sha256) = e06887f94a470d723c8d65ece5a32358da1881411ad92cc4ef35c9f6e8aa05a0485c729e07ab381cda4b53fe6fdaec1b07c2d0200ee8823ec45849e8a8f277f0
SHA512 (postgresql-14.1.tar.bz2) = 4a0bec157d5464bb9e5f5c0eb0efdede55526e03f6f4d660b87d161a47705eb152fa0878960b1581bce42a5ed28a1f457825ea54e8d22e34b5b8eb36473ceefd
SHA512 (postgresql-14.1.tar.bz2.sha256) = 99edebb68b62a11d4698423deae2a9349b98128909221d7ca9aff347061d56dcd11bd8a6e445dcde27b6556598a73d7beea01ea08dccca7ed517d28377145a5d
SHA512 (postgresql-13.5.tar.bz2) = c76effbca8ee63be48fa3aeb39c7038221848fe83ca2afc4e0904ba8c6a50b89aa2ad37080d4e3be75e9bdc2d6ca6dfefcda334ef55a5e1a8954bb955ce905e5
SHA512 (postgresql-13.5.tar.bz2.sha256) = f79b6cbf7b7929de9312ece511fd7dad80b0b3fbfca98613db1d2825c4e77a9bf7cd4e790e2bc6fd827bc95eaf5105ff1df20af4bec2848779d01b1eb9100b81
SHA512 (postgresql-setup-8.6.tar.gz) = dc687670cd58070512833271d8f3e7e4308c47cba1ad4c93e3d5f61acf07f390ed048f4d7f1567d2826f19a253562e13e56407dcf81a42f42c61ac96d8fe3178
SHA512 (postgresql-13.5-US.pdf) = 8b36ab05c7e54eeb13b38bc51fa51727df20578c305573cfc6b9773780999e86e5a3aae07e14062b9cafc9e684a2a699adf7bf69b8d78501c5b9a97502e89e5b
SHA512 (postgresql-setup-8.7.tar.gz) = 741f036be517e7d9725e4f146ca7dac8b8a16b6a93d045a64ef268487f48faad6b08317b58e07ad16a31002d2a10de0ac32513a4935c3f22f48ec768a742d1fc
SHA512 (postgresql-14.1-US.pdf) = b35314ddb53235143b58f3a785fb9f2db785e2e707803477c2f79575a79aa205455d2394a13bd7c519034fa1ccefe63eb2f793bc6b25c6a90ef4defdef69452e