Update to PostgreSQL 8.0.4, fix several minor packaging problems.
This commit is contained in:
parent
e8f554df7d
commit
32269db0ad
10
.cvsignore
10
.cvsignore
@ -1,8 +1,8 @@
|
||||
postgresql-8.0.3.tar.bz2
|
||||
PyGreSQL-3.6.1.tgz
|
||||
postgresql-8.0.4.tar.bz2
|
||||
PyGreSQL-3.6.2.tgz
|
||||
pgtcl1.5.2.tar.gz
|
||||
pgtcldocs-20041108.zip
|
||||
postgresql-8.0-311.jdbc2.jar
|
||||
postgresql-8.0-311.jdbc2ee.jar
|
||||
postgresql-8.0-311.jdbc3.jar
|
||||
postgresql-8.0-312.jdbc2.jar
|
||||
postgresql-8.0-312.jdbc2ee.jar
|
||||
postgresql-8.0-312.jdbc3.jar
|
||||
postgresql-8.0-US.pdf
|
||||
|
@ -7,6 +7,13 @@ We also remove some direct hacks on LIBOBJS because modern Autoconf
|
||||
doesn't like them; not worth fixing properly since they won't be
|
||||
invoked on our systems anyway.
|
||||
|
||||
Finally, tweak Makefile.in to ensure that the -L switch for libpq appears
|
||||
before any -L for the Tcl libraries during the link. This prevents the
|
||||
generated library from being bound to the wrong version of libpq when
|
||||
building on a machine that has an older version of libpq already installed
|
||||
(bug #166665).
|
||||
|
||||
|
||||
diff -Naur Pgtcl.orig/aclocal.m4 Pgtcl/aclocal.m4
|
||||
--- Pgtcl.orig/aclocal.m4 2004-02-15 15:15:37.000000000 -0500
|
||||
+++ Pgtcl/aclocal.m4 2005-03-11 18:26:44.610459295 -0500
|
||||
@ -61,3 +68,17 @@ diff -Naur Pgtcl.orig/aclocal.m4 Pgtcl/aclocal.m4
|
||||
;;
|
||||
GNU*)
|
||||
SHLIB_CFLAGS="-fPIC"
|
||||
|
||||
|
||||
diff -Naur Pgtcl.orig/Makefile.in Pgtcl/Makefile.in
|
||||
--- Pgtcl.orig/Makefile.in 2004-06-13 17:49:14.000000000 -0400
|
||||
+++ Pgtcl/Makefile.in 2005-10-04 14:23:37.000000000 -0400
|
||||
@@ -121,7 +121,7 @@
|
||||
SHLIB_LD = @SHLIB_LD@
|
||||
SHLIB_LDFLAGS = @SHLIB_LDFLAGS@
|
||||
# Added EXTRA_LIBS for special cases like -lssl
|
||||
-SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ $(PG_LIBS) $(TCL_LIBS) @EXTRA_LIBS@
|
||||
+SHLIB_LD_LIBS = $(PG_LIBS) @SHLIB_LD_LIBS@ $(TCL_LIBS) @EXTRA_LIBS@
|
||||
STLIB_LD = @STLIB_LD@
|
||||
TCL_DEFS = @TCL_DEFS@
|
||||
TCL_BIN_DIR = @TCL_BIN_DIR@
|
||||
|
22
postgresql-perl-rpath.patch
Normal file
22
postgresql-perl-rpath.patch
Normal file
@ -0,0 +1,22 @@
|
||||
We configure Postgres with --disable-rpath because for the most part we
|
||||
want to leave it to ldconfig to determine where libraries are. However,
|
||||
for some reason the Perl package puts libperl.so in a nonstandard place
|
||||
and doesn't add that place to the ldconfig search path. I think this
|
||||
is a Perl packaging bug, myself, but apparently it's not going to change.
|
||||
So work around it by adding an rpath spec to plperl.so (only).
|
||||
Per bug #162198.
|
||||
|
||||
|
||||
diff -Naur postgresql-8.0.4.orig/src/pl/plperl/GNUmakefile postgresql-8.0.4/src/pl/plperl/GNUmakefile
|
||||
--- postgresql-8.0.4.orig/src/pl/plperl/GNUmakefile 2005-07-17 00:05:49.000000000 -0400
|
||||
+++ postgresql-8.0.4/src/pl/plperl/GNUmakefile 2005-10-04 12:15:27.000000000 -0400
|
||||
@@ -27,6 +27,9 @@
|
||||
|
||||
rpathdir = $(perl_archlibexp)/CORE
|
||||
|
||||
+# Force rpath to be used even though we disable it everywhere else
|
||||
+LDFLAGS += $(rpath)
|
||||
+
|
||||
|
||||
NAME = plperl
|
||||
SO_MAJOR_VERSION = 0
|
2
postgresql.pam
Normal file
2
postgresql.pam
Normal file
@ -0,0 +1,2 @@
|
||||
#%PAM-1.0
|
||||
auth required pam_stack.so service=system-auth
|
@ -32,17 +32,17 @@
|
||||
%{!?kerberos:%define kerberos 1}
|
||||
%{!?nls:%define nls 1}
|
||||
%{!?pam:%define pam 1}
|
||||
%{!?xml:%define xml 1}
|
||||
%{!?pgfts:%define pgfts 1}
|
||||
%{!?runselftest:%define runselftest 1}
|
||||
|
||||
# Python major version.
|
||||
%{expand: %%define pyver %(python -c 'import sys;print(sys.version[0:3])')}
|
||||
%{expand: %%define pynextver %(python -c 'import sys;print(float(sys.version[0:3])+0.1)')}
|
||||
|
||||
|
||||
Summary: PostgreSQL client programs and libraries.
|
||||
Name: postgresql
|
||||
Version: 8.0.3
|
||||
Version: 8.0.4
|
||||
|
||||
# Conventions for PostgreSQL Global Development Group RPM releases:
|
||||
|
||||
@ -71,13 +71,14 @@ Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.t
|
||||
Source3: postgresql.init
|
||||
Source4: Makefile.regress
|
||||
Source6: README.rpm-dist
|
||||
Source8: http://jdbc.postgresql.org/download/postgresql-8.0-311.jdbc2.jar
|
||||
Source9: http://jdbc.postgresql.org/download/postgresql-8.0-311.jdbc2ee.jar
|
||||
Source10: http://jdbc.postgresql.org/download/postgresql-8.0-311.jdbc3.jar
|
||||
Source8: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc2.jar
|
||||
Source9: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc2ee.jar
|
||||
Source10: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc3.jar
|
||||
Source14: postgresql.pam
|
||||
Source15: postgresql-bashprofile
|
||||
Source16: filter-requires-perl-Pg.sh
|
||||
Source17: postgresql-8.0-US.pdf
|
||||
Source18: ftp://ftp.druid.net/pub/distrib/PyGreSQL-3.6.1.tgz
|
||||
Source18: ftp://ftp.druid.net/pub/distrib/PyGreSQL-3.6.2.tgz
|
||||
Source19: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcl1.5.2.tar.gz
|
||||
Source20: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcldocs-20041108.zip
|
||||
Patch1: rpm-pgsql.patch
|
||||
@ -85,6 +86,7 @@ Patch2: postgresql-src-tutorial.patch
|
||||
Patch3: postgresql-logging.patch
|
||||
Patch4: postgresql-test.patch
|
||||
Patch5: pgtcl-no-rpath.patch
|
||||
Patch6: postgresql-perl-rpath.patch
|
||||
Buildrequires: perl glibc-devel bison flex
|
||||
Prereq: /sbin/ldconfig initscripts
|
||||
%if %python
|
||||
@ -108,12 +110,14 @@ BuildPrereq: e2fsprogs-devel
|
||||
%if %nls
|
||||
BuildPrereq: gettext >= 0.10.35
|
||||
%endif
|
||||
|
||||
%if %pam
|
||||
%if %non6xpamdeps
|
||||
BuildPrereq: pam-devel
|
||||
%endif
|
||||
%endif
|
||||
%if %xml
|
||||
BuildPrereq: libxml2-devel
|
||||
%endif
|
||||
|
||||
Url: http://www.postgresql.org/
|
||||
|
||||
@ -280,7 +284,6 @@ Summary: Development module for Python code to access a PostgreSQL DB.
|
||||
Group: Applications/Databases
|
||||
Requires: libpq.so
|
||||
Requires: python mx
|
||||
Conflicts: python < %pyver, python >= %pynextver
|
||||
Obsoletes: rh-postgresql-python
|
||||
|
||||
%description python
|
||||
@ -330,6 +333,8 @@ popd
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
# patch5 is applied later
|
||||
%patch6 -p1
|
||||
|
||||
#call autoconf 2.53 or greater
|
||||
%aconfver
|
||||
@ -410,6 +415,9 @@ CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
|
||||
|
||||
make %{?_smp_mflags} all
|
||||
make %{?_smp_mflags} -C contrib all
|
||||
%if %xml
|
||||
make %{?_smp_mflags} -C contrib/xml2 all
|
||||
%endif
|
||||
|
||||
# Have to hack makefile to put correct path into tutorial scripts
|
||||
sed "s|C=\`pwd\`;|C=%{_libdir}/pgsql/tutorial;|" < src/tutorial/Makefile > src/tutorial/GNUmakefile
|
||||
@ -461,6 +469,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
make -C contrib DESTDIR=$RPM_BUILD_ROOT install
|
||||
%if %xml
|
||||
make -C contrib/xml2 DESTDIR=$RPM_BUILD_ROOT install
|
||||
%endif
|
||||
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/pgsql/tutorial
|
||||
cp src/tutorial/* $RPM_BUILD_ROOT%{_libdir}/pgsql/tutorial
|
||||
@ -495,6 +506,14 @@ then
|
||||
install -m 755 postgresql.init $RPM_BUILD_ROOT/etc/rc.d/init.d/postgresql
|
||||
fi
|
||||
|
||||
%if %pam
|
||||
if [ -d /etc/pam.d ]
|
||||
then
|
||||
install -d $RPM_BUILD_ROOT/etc/pam.d
|
||||
install -m 644 %{SOURCE14} $RPM_BUILD_ROOT/etc/pam.d/postgresql
|
||||
fi
|
||||
%endif
|
||||
|
||||
# Remove stuff we don't want to ship.
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/findoidjoins
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/make_oidjoins_check
|
||||
@ -684,6 +703,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pgsql/tsearch.so
|
||||
%{_libdir}/pgsql/tsearch2.so
|
||||
%{_libdir}/pgsql/user_locks.so
|
||||
%if %xml
|
||||
%{_libdir}/pgsql/pgxml.so
|
||||
%endif
|
||||
%{_datadir}/pgsql/contrib/
|
||||
%{_bindir}/DBMirror.pl
|
||||
%{_bindir}/clean_pending.pl
|
||||
@ -708,6 +730,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files server -f server.lst
|
||||
%defattr(-,root,root)
|
||||
/etc/rc.d/init.d/postgresql
|
||||
%if %pam
|
||||
/etc/pam.d/postgresql
|
||||
%endif
|
||||
%attr (755,root,root) %dir /etc/sysconfig/pgsql
|
||||
%{_bindir}/initdb
|
||||
%{_bindir}/ipcclean
|
||||
@ -804,6 +829,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 4 2005 Tom Lane <tgl@redhat.com> 8.0.4-1
|
||||
- Update to PostgreSQL 8.0.4, PyGreSQL 3.6.2, and jdbc driver build 312
|
||||
- Add rpath to plperl.so (bug #162198)
|
||||
- Adjust pgtcl link command to ensure it binds to correct libpq (bug #166665)
|
||||
- Remove obsolete Conflicts: against other python versions (bug #166754)
|
||||
- Add /etc/pam.d/postgresql (bug #167040)
|
||||
- Include contrib/xml2 in build (bug #167492)
|
||||
|
||||
* Tue May 10 2005 Tom Lane <tgl@redhat.com> 8.0.3-1
|
||||
- Update to PostgreSQL 8.0.3 (includes security and data-loss fixes; see
|
||||
bz#156727, CAN-2005-1409, CAN-2005-1410)
|
||||
|
10
sources
10
sources
@ -1,8 +1,8 @@
|
||||
c0914a133ce6c1e0f1d8b93982d6e881 postgresql-8.0.3.tar.bz2
|
||||
057c2d93f333ff2ed2177a8b87e19c0c PyGreSQL-3.6.1.tgz
|
||||
381bd337cf703220aafdf1ee24dae78d postgresql-8.0.4.tar.bz2
|
||||
1f2694ea546c852c5a0ba2b17f7c5ce1 PyGreSQL-3.6.2.tgz
|
||||
d19dfdcb54c334495d32456a043e0232 pgtcl1.5.2.tar.gz
|
||||
3d504b46231914d61fd49175f67e8715 pgtcldocs-20041108.zip
|
||||
5d5d0d8e97ea3d117380068131b136ac postgresql-8.0-311.jdbc2.jar
|
||||
c4d7009a4baaf06858a2923066ba2529 postgresql-8.0-311.jdbc2ee.jar
|
||||
0ae011c390d94566326c61aad3ad9b6a postgresql-8.0-311.jdbc3.jar
|
||||
e51763911fe5ccec81bf4201f25e3f53 postgresql-8.0-312.jdbc2.jar
|
||||
ebb4384c3d116482c8ed438ac96461fc postgresql-8.0-312.jdbc2ee.jar
|
||||
41bcf06cdf7a3c84efd2fdd894303b24 postgresql-8.0-312.jdbc3.jar
|
||||
2edd229aa83105175a1212a001dd030a postgresql-8.0-US.pdf
|
||||
|
Loading…
Reference in New Issue
Block a user