import postgresql-15.2-1.module+el9.2.0+18159+266a3926
This commit is contained in:
commit
30365e2dd4
4
.gitignore
vendored
Normal file
4
.gitignore
vendored
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
SOURCES/postgresql-13.7.tar.bz2
|
||||||
|
SOURCES/postgresql-15.2-US.pdf
|
||||||
|
SOURCES/postgresql-15.2.tar.bz2
|
||||||
|
SOURCES/postgresql-setup-8.8.tar.gz
|
4
.postgresql.metadata
Normal file
4
.postgresql.metadata
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
cb4c0aed7cee21f3a1f4756fc61054d8ba756e2b SOURCES/postgresql-13.7.tar.bz2
|
||||||
|
782baa9b34c7fc8cd487ef426fc4321c3f9e34a9 SOURCES/postgresql-15.2-US.pdf
|
||||||
|
8c7706a7ef267e49026434378836b76e4d4ad532 SOURCES/postgresql-15.2.tar.bz2
|
||||||
|
c5aa3e8b728c67b294815931c91c86aa61932bb5 SOURCES/postgresql-setup-8.8.tar.gz
|
69
SOURCES/Makefile.regress
Normal file
69
SOURCES/Makefile.regress
Normal file
@ -0,0 +1,69 @@
|
|||||||
|
#
|
||||||
|
# Simplified makefile for running the PostgreSQL regression tests
|
||||||
|
# in an RPM installation
|
||||||
|
#
|
||||||
|
|
||||||
|
# maximum simultaneous connections for parallel tests
|
||||||
|
MAXCONNOPT =
|
||||||
|
ifdef MAX_CONNECTIONS
|
||||||
|
MAXCONNOPT += --max-connections=$(MAX_CONNECTIONS)
|
||||||
|
endif
|
||||||
|
|
||||||
|
# locale
|
||||||
|
NOLOCALE =
|
||||||
|
ifdef NO_LOCALE
|
||||||
|
NOLOCALE += --no-locale
|
||||||
|
endif
|
||||||
|
|
||||||
|
srcdir := .
|
||||||
|
|
||||||
|
REGRESS_OPTS += --dlpath=.
|
||||||
|
|
||||||
|
pg_regress_locale_flags = $(if $(ENCODING),--encoding=$(ENCODING)) $(NOLOCALE)
|
||||||
|
|
||||||
|
pg_regress_installcheck = ./pg_regress --inputdir=$(srcdir) --bindir=@bindir@ $(pg_regress_locale_flags)
|
||||||
|
|
||||||
|
# Test input and expected files. These are created by pg_regress itself, so we
|
||||||
|
# don't have a rule to create them. We do need rules to clean them however.
|
||||||
|
ifile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/input/*.source)))
|
||||||
|
input_files := $(foreach file, $(ifile_list), sql/$(file).sql)
|
||||||
|
ofile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/output/*.source)))
|
||||||
|
output_files := $(foreach file, $(ofile_list), expected/$(file).out)
|
||||||
|
|
||||||
|
abs_srcdir := $(shell pwd)
|
||||||
|
abs_builddir := $(shell pwd)
|
||||||
|
|
||||||
|
check: installcheck-parallel
|
||||||
|
|
||||||
|
installcheck: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/serial_schedule $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
installcheck-parallel: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/parallel_schedule $(MAXCONNOPT) $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
# The tests command the server to write into testtablespace and results.
|
||||||
|
# On a SELinux-enabled system this will fail unless we mark those directories
|
||||||
|
# as writable by the server.
|
||||||
|
cleandirs:
|
||||||
|
-rm -rf testtablespace results
|
||||||
|
mkdir testtablespace results
|
||||||
|
if test -x /usr/bin/chcon && ! test -f /.dockerenv; then \
|
||||||
|
/usr/bin/chcon -u system_u -r object_r -t postgresql_db_t testtablespace results ; \
|
||||||
|
fi
|
||||||
|
|
||||||
|
# old interfaces follow...
|
||||||
|
|
||||||
|
runcheck: check
|
||||||
|
runtest: installcheck
|
||||||
|
runtest-parallel: installcheck-parallel
|
||||||
|
|
||||||
|
|
||||||
|
##
|
||||||
|
## Clean up
|
||||||
|
##
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
rm -f $(output_files) $(input_files)
|
||||||
|
rm -rf testtablespace
|
||||||
|
rm -rf results tmp_check log
|
||||||
|
rm -f regression.diffs regression.out regress.out run_check.out
|
58
SOURCES/generate-pdf.sh
Executable file
58
SOURCES/generate-pdf.sh
Executable file
@ -0,0 +1,58 @@
|
|||||||
|
#! /bin/sh
|
||||||
|
|
||||||
|
# This script builds the PDF version of the PostgreSQL documentation.
|
||||||
|
#
|
||||||
|
# In principle we could do this as part of the RPM build, but there are
|
||||||
|
# good reasons not to:
|
||||||
|
# 1. The build would take longer and have a larger BuildRequires footprint.
|
||||||
|
# 2. The generated PDF has timestamps in it, which would inevitably result
|
||||||
|
# in multilib conflicts due to slightly different timestamps.
|
||||||
|
# So instead, we run this manually when rebasing to a new upstream release,
|
||||||
|
# and treat the resulting PDF as a separate Source file.
|
||||||
|
#
|
||||||
|
# You will need to have the docbook packages installed to run this.
|
||||||
|
# Expect it to take about 20 minutes and use about 160MB of disk.
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
# Pass package version (e.g., 9.1.2) as argument
|
||||||
|
VERSION=$1
|
||||||
|
|
||||||
|
test -z "$VERSION" && VERSION=`awk '/^Version:/ { print $2; }' postgresql.spec`
|
||||||
|
|
||||||
|
TARGETFILE=postgresql-$VERSION-US.pdf
|
||||||
|
test -f "$TARGETFILE" && echo "$TARGETFILE exists" && exit 1
|
||||||
|
|
||||||
|
echo Building $TARGETFILE ...
|
||||||
|
|
||||||
|
# Unpack postgresql
|
||||||
|
|
||||||
|
rm -rf postgresql-$VERSION
|
||||||
|
|
||||||
|
tar xfj postgresql-$VERSION.tar.bz2
|
||||||
|
|
||||||
|
cd postgresql-$VERSION
|
||||||
|
|
||||||
|
# Apply any patches that affect the PDF documentation
|
||||||
|
|
||||||
|
# patch -p1 < ../xxx.patch
|
||||||
|
|
||||||
|
# Configure ...
|
||||||
|
|
||||||
|
./configure >/dev/null
|
||||||
|
|
||||||
|
# Build the PDF docs
|
||||||
|
|
||||||
|
cd doc/src/sgml
|
||||||
|
|
||||||
|
make postgres-US.pdf >make.log
|
||||||
|
|
||||||
|
mv -f postgres-US.pdf ../../../../$TARGETFILE
|
||||||
|
|
||||||
|
# Clean up
|
||||||
|
|
||||||
|
cd ../../../..
|
||||||
|
|
||||||
|
rm -rf postgresql-$VERSION
|
||||||
|
|
||||||
|
exit 0
|
1
SOURCES/postgresql-13.7.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-13.7.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
|||||||
|
1b905bf4f3d83614a393b3c51fd345910fd261e4f5124a68d9a1fdd3a2a46399 postgresql-13.7.tar.bz2
|
1
SOURCES/postgresql-15.2.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-15.2.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
|||||||
|
99a2171fc3d6b5b5f56b757a7a3cb85d509a38e4273805def23941ed2b8468c7 postgresql-15.2.tar.bz2
|
4
SOURCES/postgresql-bashprofile
Normal file
4
SOURCES/postgresql-bashprofile
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
[ -f /etc/profile ] && source /etc/profile
|
||||||
|
|
||||||
|
PGDATA=/var/lib/pgsql/data
|
||||||
|
export PGDATA
|
43
SOURCES/postgresql-external-libpq.patch
Normal file
43
SOURCES/postgresql-external-libpq.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
We don't build/install interfaces by upstream's implicit rules.
|
||||||
|
|
||||||
|
This patch is used on two places; postgresql.spec and libecpg.spec -- keep those
|
||||||
|
in sync!
|
||||||
|
|
||||||
|
Related: rhbz#1618698
|
||||||
|
|
||||||
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
|
index bcdbd95..4bea236 100644
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||||
|
backend/utils/mb/conversion_procs \
|
||||||
|
backend/snowball \
|
||||||
|
include \
|
||||||
|
- interfaces \
|
||||||
|
backend/replication/libpqwalreceiver \
|
||||||
|
backend/replication/pgoutput \
|
||||||
|
fe_utils \
|
||||||
|
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||||
|
index b9d86ac..29df69f 100644
|
||||||
|
--- a/src/Makefile.global.in
|
||||||
|
+++ b/src/Makefile.global.in
|
||||||
|
@@ -549,7 +549,7 @@ endif
|
||||||
|
# How to link to libpq. (This macro may be used as-is by backend extensions.
|
||||||
|
# Client-side code should go through libpq_pgport or libpq_pgport_shlib,
|
||||||
|
# instead.)
|
||||||
|
-libpq = -L$(libpq_builddir) -lpq
|
||||||
|
+libpq = -lpq
|
||||||
|
|
||||||
|
# libpq_pgport is for use by client executables (not libraries) that use libpq.
|
||||||
|
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||||
|
@@ -579,7 +579,6 @@ endif
|
||||||
|
# Commonly used submake targets
|
||||||
|
|
||||||
|
submake-libpq: | submake-generated-headers
|
||||||
|
- $(MAKE) -C $(libpq_builddir) all
|
||||||
|
|
||||||
|
submake-libpgport: | submake-generated-headers
|
||||||
|
$(MAKE) -C $(top_builddir)/src/port all
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
33
SOURCES/postgresql-logging.patch
Normal file
33
SOURCES/postgresql-logging.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -ur postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample patched/src/backend/utils/misc/postgresql.conf.sample
|
||||||
|
--- postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample 2022-10-10 22:57:37.000000000 +0200
|
||||||
|
+++ patched/src/backend/utils/misc/postgresql.conf.sample 2022-10-13 10:51:57.000000000 +0200
|
||||||
|
@@ -448,7 +448,7 @@
|
||||||
|
# logging_collector to be on.
|
||||||
|
|
||||||
|
# This is used when logging to stderr:
|
||||||
|
-#logging_collector = off # Enable capturing of stderr, jsonlog,
|
||||||
|
+logging_collector = on # Enable capturing of stderr, jsonlog,
|
||||||
|
# and csvlog into log files. Required
|
||||||
|
# to be on for csvlogs and jsonlogs.
|
||||||
|
# (change requires restart)
|
||||||
|
@@ -456,16 +456,16 @@
|
||||||
|
# These are only used if logging_collector is on:
|
||||||
|
#log_directory = 'log' # directory where log files are written,
|
||||||
|
# can be absolute or relative to PGDATA
|
||||||
|
-#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log' # log file name pattern,
|
||||||
|
+log_filename = 'postgresql-%a.log' # log file name pattern,
|
||||||
|
# can include strftime() escapes
|
||||||
|
#log_file_mode = 0600 # creation mode for log files,
|
||||||
|
# begin with 0 to use octal notation
|
||||||
|
-#log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
# happen after that time. 0 disables.
|
||||||
|
-#log_rotation_size = 10MB # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_size = 0 # Automatic rotation of logfiles will
|
||||||
|
# happen after that much log output.
|
||||||
|
# 0 disables.
|
||||||
|
-#log_truncate_on_rotation = off # If on, an existing log file with the
|
||||||
|
+log_truncate_on_rotation = on # If on, an existing log file with the
|
||||||
|
# same name as the new log file will be
|
||||||
|
# truncated rather than appended to.
|
||||||
|
# But such truncation only occurs on
|
12
SOURCES/postgresql-no-libecpg.patch
Normal file
12
SOURCES/postgresql-no-libecpg.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up postgresql-13.1/src/interfaces/Makefile.patch10 postgresql-13.1/src/interfaces/Makefile
|
||||||
|
--- postgresql-13.1/src/interfaces/Makefile.patch10 2021-02-02 21:33:23.235292305 +0100
|
||||||
|
+++ postgresql-13.1/src/interfaces/Makefile 2021-02-02 21:33:30.281365440 +0100
|
||||||
|
@@ -12,7 +12,7 @@ subdir = src/interfaces
|
||||||
|
top_builddir = ../..
|
||||||
|
include $(top_builddir)/src/Makefile.global
|
||||||
|
|
||||||
|
-SUBDIRS = libpq ecpg
|
||||||
|
+SUBDIRS = libpq
|
||||||
|
|
||||||
|
$(recurse)
|
||||||
|
|
58
SOURCES/postgresql-server-pg_config.patch
Normal file
58
SOURCES/postgresql-server-pg_config.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
We should ideally provide '/bin/pg_config' in postgresql-server-devel, and
|
||||||
|
provide no pg_config binary in libpq package. But most of the Fedora packages
|
||||||
|
that use pg_config actually only build against PG libraries (and
|
||||||
|
postgresql-server-devel isn't needed). So.., to avoid the initial rush around
|
||||||
|
rhbz#1618698 change, rather provide pg_server_config binary, which int urn means
|
||||||
|
that we'll have to fix only a minimal set of packages which really build
|
||||||
|
PostgreSQL server modules.
|
||||||
|
|
||||||
|
diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/bin/pg_config/Makefile
|
||||||
|
--- postgresql-13.1/src/bin/pg_config/Makefile.patch9 2020-11-18 09:28:30.885453275 +0100
|
||||||
|
+++ postgresql-13.1/src/bin/pg_config/Makefile 2020-11-18 09:31:33.926325327 +0100
|
||||||
|
@@ -11,6 +11,8 @@
|
||||||
|
PGFILEDESC = "pg_config - report configuration information"
|
||||||
|
PGAPPICON=win32
|
||||||
|
|
||||||
|
+PG_CONFIG = pg_server_config$(X)
|
||||||
|
+
|
||||||
|
subdir = src/bin/pg_config
|
||||||
|
top_builddir = ../../..
|
||||||
|
include $(top_builddir)/src/Makefile.global
|
||||||
|
@@ -19,22 +21,22 @@ OBJS = \
|
||||||
|
$(WIN32RES) \
|
||||||
|
pg_config.o
|
||||||
|
|
||||||
|
-all: pg_config
|
||||||
|
+all: $(PG_CONFIG)
|
||||||
|
|
||||||
|
-pg_config: $(OBJS) | submake-libpgport
|
||||||
|
- $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
|
||||||
|
+$(PG_CONFIG): $(OBJS) | submake-libpgport
|
||||||
|
+ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
|
||||||
|
|
||||||
|
install: all installdirs
|
||||||
|
- $(INSTALL_SCRIPT) pg_config$(X) '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ $(INSTALL_SCRIPT) $(PG_CONFIG) '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
installdirs:
|
||||||
|
$(MKDIR_P) '$(DESTDIR)$(bindir)'
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
- rm -f '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ rm -f '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
- rm -f pg_config$(X) $(OBJS)
|
||||||
|
+ rm -f $(PG_CONFIG) $(OBJS)
|
||||||
|
rm -rf tmp_check
|
||||||
|
|
||||||
|
check:
|
||||||
|
diff -up postgresql-13.1/src/bin/pg_config/nls.mk.patch9 postgresql-13.1/src/bin/pg_config/nls.mk
|
||||||
|
--- postgresql-13.1/src/bin/pg_config/nls.mk.patch9 2020-11-18 09:28:30.885453275 +0100
|
||||||
|
+++ postgresql-13.1/src/bin/pg_config/nls.mk 2020-11-18 09:32:00.735599526 +0100
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
# src/bin/pg_config/nls.mk
|
||||||
|
-CATALOG_NAME = pg_config
|
||||||
|
+CATALOG_NAME = pg_server_config
|
||||||
|
AVAIL_LANGUAGES = cs de el es fr he it ja ka ko pl pt_BR ru sv tr uk vi zh_CN
|
||||||
|
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
53
SOURCES/postgresql-var-run-socket.patch
Normal file
53
SOURCES/postgresql-var-run-socket.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
Change the built-in default socket directory to be /var/run/postgresql.
|
||||||
|
For backwards compatibility with (probably non-libpq-based) clients that
|
||||||
|
might still expect to find the socket in /tmp, also create a socket in
|
||||||
|
/tmp. This is to resolve communication problems with clients operating
|
||||||
|
under systemd's PrivateTmp environment, which won't be using the same
|
||||||
|
global /tmp directory as the server; see bug #825448.
|
||||||
|
|
||||||
|
Note that we apply the socket directory change at the level of the
|
||||||
|
hard-wired defaults in the C code, not by just twiddling the setting in
|
||||||
|
postgresql.conf.sample; this is so that the change will take effect on
|
||||||
|
server package update, without requiring any existing postgresql.conf
|
||||||
|
to be updated. (Of course, a user who dislikes this behavior can still
|
||||||
|
override it via postgresql.conf.)
|
||||||
|
|
||||||
|
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
|
||||||
|
index 9481f2d..75532c7 100644
|
||||||
|
--- a/src/backend/utils/misc/guc.c
|
||||||
|
+++ b/src/backend/utils/misc/guc.c
|
||||||
|
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] =
|
||||||
|
},
|
||||||
|
&Unix_socket_directories,
|
||||||
|
#ifdef HAVE_UNIX_SOCKETS
|
||||||
|
- DEFAULT_PGSOCKET_DIR,
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||||
|
#else
|
||||||
|
"",
|
||||||
|
#endif
|
||||||
|
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
|
||||||
|
index feeff9e..3e3d784 100644
|
||||||
|
--- a/src/bin/initdb/initdb.c
|
||||||
|
+++ b/src/bin/initdb/initdb.c
|
||||||
|
@@ -1234,7 +1234,7 @@ setup_config(void)
|
||||||
|
|
||||||
|
#ifdef HAVE_UNIX_SOCKETS
|
||||||
|
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
|
||||||
|
- DEFAULT_PGSOCKET_DIR);
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp");
|
||||||
|
#else
|
||||||
|
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
|
||||||
|
#endif
|
||||||
|
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
|
||||||
|
index e278fa0..9ee15d4 100644
|
||||||
|
--- a/src/include/pg_config_manual.h
|
||||||
|
+++ b/src/include/pg_config_manual.h
|
||||||
|
@@ -201,7 +201,7 @@
|
||||||
|
* support them yet.
|
||||||
|
*/
|
||||||
|
#ifndef WIN32
|
||||||
|
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||||
|
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||||
|
#else
|
||||||
|
#define DEFAULT_PGSOCKET_DIR ""
|
||||||
|
#endif
|
3
SOURCES/postgresql.pam
Normal file
3
SOURCES/postgresql.pam
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
#%PAM-1.0
|
||||||
|
auth include password-auth
|
||||||
|
account include password-auth
|
1
SOURCES/postgresql.tmpfiles.d
Normal file
1
SOURCES/postgresql.tmpfiles.d
Normal file
@ -0,0 +1 @@
|
|||||||
|
d /run/postgresql 0755 postgres postgres -
|
72
SOURCES/rpm-pgsql.patch
Normal file
72
SOURCES/rpm-pgsql.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
For the RPMs, we want the custom installation directories to end in
|
||||||
|
/pgsql not /postgresql. This is historical but not worth changing.
|
||||||
|
|
||||||
|
Notice that this patch also makes the appending of /pgsql unconditional.
|
||||||
|
This is to avoid unexpected behavior if the RPM is built in a working
|
||||||
|
directory whose path happens to include "postgres" or "pgsql" already.
|
||||||
|
However, datadir and sysconfdir are already set up in the specfile's
|
||||||
|
configure call, so we do not have to append anything to them.
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in
|
||||||
|
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400
|
||||||
|
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400
|
||||||
|
@@ -55,8 +55,7 @@
|
||||||
|
# Installation directories
|
||||||
|
#
|
||||||
|
# These are set by the equivalent --xxxdir configure options. We
|
||||||
|
-# append "postgresql" to some of them, if the string does not already
|
||||||
|
-# contain "pgsql" or "postgres", in order to avoid directory clutter.
|
||||||
|
+# append "pgsql" to some of them, in order to avoid directory clutter.
|
||||||
|
#
|
||||||
|
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
||||||
|
# by configure, since the installation tree may have been relocated.
|
||||||
|
@@ -74,45 +73,23 @@
|
||||||
|
bindir := @bindir@
|
||||||
|
|
||||||
|
datadir := @datadir@
|
||||||
|
-ifeq "$(findstring pgsql, $(datadir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(datadir))" ""
|
||||||
|
-override datadir := $(datadir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
sysconfdir := @sysconfdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(sysconfdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(sysconfdir))" ""
|
||||||
|
-override sysconfdir := $(sysconfdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
libdir := @libdir@
|
||||||
|
|
||||||
|
pkglibdir = $(libdir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkglibdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkglibdir))" ""
|
||||||
|
-override pkglibdir := $(pkglibdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkglibdir := $(pkglibdir)/pgsql
|
||||||
|
|
||||||
|
includedir := @includedir@
|
||||||
|
|
||||||
|
pkgincludedir = $(includedir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkgincludedir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkgincludedir))" ""
|
||||||
|
-override pkgincludedir := $(pkgincludedir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkgincludedir := $(pkgincludedir)/pgsql
|
||||||
|
|
||||||
|
mandir := @mandir@
|
||||||
|
|
||||||
|
docdir := @docdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(docdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(docdir))" ""
|
||||||
|
-override docdir := $(docdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override docdir := $(docdir)/pgsql
|
||||||
|
|
||||||
|
htmldir := @htmldir@
|
||||||
|
|
1238
SPECS/postgresql.spec
Normal file
1238
SPECS/postgresql.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user