Rebase to PostgreSQL 15
Add llvm pointer patch Add new build require for perl-FindBin Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_15
This commit is contained in:
parent
1dd177012a
commit
222fe7473a
191
postgresql-15.0-llvm_pointer.patch
Normal file
191
postgresql-15.0-llvm_pointer.patch
Normal file
@ -0,0 +1,191 @@
|
||||
# From 0fed706031df781bb5889a859c47379e3c37f4f4 Mon Sep 17 00:00:00 2001
|
||||
# From: Thomas Munro <thomas.munro@gmail.com>
|
||||
# Date: Thu, 22 Sep 2022 23:38:56 +1200
|
||||
# Subject: [PATCH v2] WIP: jit: LLVM 15: Minimal changes.
|
||||
|
||||
# Per https://llvm.org/docs/OpaquePointers.html, support for non-opaque
|
||||
# pointers still exists and we can request that on our context. We have
|
||||
# until LLVM 16 to move to opaque pointers.
|
||||
# ---
|
||||
# src/backend/jit/llvm/llvmjit.c | 18 +++++++
|
||||
# src/backend/jit/llvm/meson.build | 3 ++
|
||||
# configure | 89 ++++++++++++++++++++++++++++++++
|
||||
# configure.ac | 3 ++
|
||||
# 4 files changed, 113 insertions(+)
|
||||
|
||||
diff --git a/src/backend/jit/llvm/llvmjit.c b/src/backend/jit/llvm/llvmjit.c
|
||||
index fd3eecf27d3..bccfcfa9698 100644
|
||||
--- a/src/backend/jit/llvm/llvmjit.c
|
||||
+++ b/src/backend/jit/llvm/llvmjit.c
|
||||
@@ -798,6 +798,16 @@ llvm_session_initialize(void)
|
||||
LLVMInitializeNativeAsmPrinter();
|
||||
LLVMInitializeNativeAsmParser();
|
||||
|
||||
+ /*
|
||||
+ * When targetting an llvm version with opaque pointers enabled by
|
||||
+ * default, turn them off for the context we build our code in. Don't need
|
||||
+ * to do so for other contexts (e.g. llvm_ts_context) - once the IR is
|
||||
+ * generated, it carries the necessary information.
|
||||
+ */
|
||||
+#if LLVM_VERSION_MAJOR > 14
|
||||
+ LLVMContextSetOpaquePointers(LLVMGetGlobalContext(), false);
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* Synchronize types early, as that also includes inferring the target
|
||||
* triple.
|
||||
@@ -1112,7 +1122,11 @@ llvm_resolve_symbols(LLVMOrcDefinitionGeneratorRef GeneratorObj, void *Ctx,
|
||||
LLVMOrcJITDylibRef JD, LLVMOrcJITDylibLookupFlags JDLookupFlags,
|
||||
LLVMOrcCLookupSet LookupSet, size_t LookupSetSize)
|
||||
{
|
||||
+#if LLVM_VERSION_MAJOR > 14
|
||||
+ LLVMOrcCSymbolMapPairs symbols = palloc0(sizeof(LLVMOrcCSymbolMapPair) * LookupSetSize);
|
||||
+#else
|
||||
LLVMOrcCSymbolMapPairs symbols = palloc0(sizeof(LLVMJITCSymbolMapPair) * LookupSetSize);
|
||||
+#endif
|
||||
LLVMErrorRef error;
|
||||
LLVMOrcMaterializationUnitRef mu;
|
||||
|
||||
@@ -1230,7 +1244,11 @@ llvm_create_jit_instance(LLVMTargetMachineRef tm)
|
||||
* Symbol resolution support for "special" functions, e.g. a call into an
|
||||
* SQL callable function.
|
||||
*/
|
||||
+#if LLVM_VERSION_MAJOR > 14
|
||||
+ ref_gen = LLVMOrcCreateCustomCAPIDefinitionGenerator(llvm_resolve_symbols, NULL, NULL);
|
||||
+#else
|
||||
ref_gen = LLVMOrcCreateCustomCAPIDefinitionGenerator(llvm_resolve_symbols, NULL);
|
||||
+#endif
|
||||
LLVMOrcJITDylibAddGenerator(LLVMOrcLLJITGetMainJITDylib(lljit), ref_gen);
|
||||
|
||||
return lljit;
|
||||
# diff --git a/src/backend/jit/llvm/meson.build b/src/backend/jit/llvm/meson.build
|
||||
# index de2e624ab58..e5a702163b7 100644
|
||||
# --- a/src/backend/jit/llvm/meson.build
|
||||
# +++ b/src/backend/jit/llvm/meson.build
|
||||
# @@ -51,6 +51,9 @@ endif
|
||||
|
||||
# # XXX: Need to determine proper version of the function cflags for clang
|
||||
# bitcode_cflags = ['-fno-strict-aliasing', '-fwrapv']
|
||||
# +if llvm.version().version_compare('>=15.0')
|
||||
# + bitcode_cflags += ['-Xclang', '-no-opaque-pointers']
|
||||
# +endif
|
||||
# bitcode_cflags += cppflags
|
||||
|
||||
# XXX: Worth improving on the logic to find directories here
|
||||
diff --git a/configure b/configure
|
||||
index 1caca21b625..cf457a0ed4a 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7391,6 +7391,95 @@ if test x"$pgac_cv_prog_CLANGXX_cxxflags__fexcess_precision_standard" = x"yes";
|
||||
fi
|
||||
|
||||
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ${CLANG} supports -Xclang -no-opaque-pointers, for BITCODE_CFLAGS" >&5
|
||||
+$as_echo_n "checking whether ${CLANG} supports -Xclang -no-opaque-pointers, for BITCODE_CFLAGS... " >&6; }
|
||||
+if ${pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ pgac_save_CFLAGS=$CFLAGS
|
||||
+pgac_save_CC=$CC
|
||||
+CC=${CLANG}
|
||||
+CFLAGS="${BITCODE_CFLAGS} -Xclang -no-opaque-pointers"
|
||||
+ac_save_c_werror_flag=$ac_c_werror_flag
|
||||
+ac_c_werror_flag=yes
|
||||
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers=yes
|
||||
+else
|
||||
+ pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers=no
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ac_c_werror_flag=$ac_save_c_werror_flag
|
||||
+CFLAGS="$pgac_save_CFLAGS"
|
||||
+CC="$pgac_save_CC"
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers" >&5
|
||||
+$as_echo "$pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers" >&6; }
|
||||
+if test x"$pgac_cv_prog_CLANG_cflags__Xclang__no_opaque_pointers" = x"yes"; then
|
||||
+ BITCODE_CFLAGS="${BITCODE_CFLAGS} -Xclang -no-opaque-pointers"
|
||||
+fi
|
||||
+
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ${CLANGXX} supports -Xclang -no-opaque-pointers, for BITCODE_CXXFLAGS" >&5
|
||||
+$as_echo_n "checking whether ${CLANGXX} supports -Xclang -no-opaque-pointers, for BITCODE_CXXFLAGS... " >&6; }
|
||||
+if ${pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ pgac_save_CXXFLAGS=$CXXFLAGS
|
||||
+pgac_save_CXX=$CXX
|
||||
+CXX=${CLANGXX}
|
||||
+CXXFLAGS="${BITCODE_CXXFLAGS} -Xclang -no-opaque-pointers"
|
||||
+ac_save_cxx_werror_flag=$ac_cxx_werror_flag
|
||||
+ac_cxx_werror_flag=yes
|
||||
+ac_ext=cpp
|
||||
+ac_cpp='$CXXCPP $CPPFLAGS'
|
||||
+ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
|
||||
+
|
||||
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_cxx_try_compile "$LINENO"; then :
|
||||
+ pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers=yes
|
||||
+else
|
||||
+ pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers=no
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ac_ext=c
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
+
|
||||
+ac_cxx_werror_flag=$ac_save_cxx_werror_flag
|
||||
+CXXFLAGS="$pgac_save_CXXFLAGS"
|
||||
+CXX="$pgac_save_CXX"
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers" >&5
|
||||
+$as_echo "$pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers" >&6; }
|
||||
+if test x"$pgac_cv_prog_CLANGXX_cxxflags__Xclang__no_opaque_pointers" = x"yes"; then
|
||||
+ BITCODE_CXXFLAGS="${BITCODE_CXXFLAGS} -Xclang -no-opaque-pointers"
|
||||
+fi
|
||||
+
|
||||
+
|
||||
NOT_THE_CFLAGS=""
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ${CLANG} supports -Wunused-command-line-argument, for NOT_THE_CFLAGS" >&5
|
||||
$as_echo_n "checking whether ${CLANG} supports -Wunused-command-line-argument, for NOT_THE_CFLAGS... " >&6; }
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 10fa55dd154..ecc6c495db9 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -625,6 +625,9 @@ if test "$with_llvm" = yes ; then
|
||||
PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, BITCODE_CFLAGS, [-fexcess-precision=standard])
|
||||
PGAC_PROG_VARCXX_VARFLAGS_OPT(CLANGXX, BITCODE_CXXFLAGS, [-fexcess-precision=standard])
|
||||
|
||||
+ PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, BITCODE_CFLAGS, [-Xclang -no-opaque-pointers])
|
||||
+ PGAC_PROG_VARCXX_VARFLAGS_OPT(CLANGXX, BITCODE_CXXFLAGS, [-Xclang -no-opaque-pointers])
|
||||
+
|
||||
NOT_THE_CFLAGS=""
|
||||
PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, NOT_THE_CFLAGS, [-Wunused-command-line-argument])
|
||||
if test -n "$NOT_THE_CFLAGS"; then
|
||||
--
|
||||
2.37.3.542.gdd3f6c4cae
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,16 +1,16 @@
|
||||
diff -up postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample.patch2 postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample
|
||||
--- postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample.patch2 2021-06-21 23:07:55.000000000 +0200
|
||||
+++ postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample 2021-06-25 19:37:21.868632721 +0200
|
||||
@@ -435,7 +435,7 @@
|
||||
# requires logging_collector to be on.
|
||||
diff -up postgresql-15.0_original/src/backend/utils/misc/postgresql.conf.sample postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample
|
||||
--- postgresql-15.0_original/src/backend/utils/misc/postgresql.conf.sample 2022-09-27 16:57:00.652909198 +0200
|
||||
+++ postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample 2022-09-27 17:01:56.073606108 +0200
|
||||
@@ -449,7 +449,7 @@
|
||||
# logging_collector to be on.
|
||||
|
||||
# This is used when logging to stderr:
|
||||
-#logging_collector = off # Enable capturing of stderr and csvlog
|
||||
+logging_collector = on # Enable capturing of stderr and csvlog
|
||||
# into log files. Required to be on for
|
||||
# csvlogs.
|
||||
-#logging_collector = off # Enable capturing of stderr, jsonlog,
|
||||
+logging_collector = on # Enable capturing of stderr, jsonlog,
|
||||
# and csvlog into log files. Required
|
||||
# to be on for csvlogs and jsonlogs.
|
||||
# (change requires restart)
|
||||
@@ -443,16 +443,16 @@
|
||||
@@ -457,16 +457,16 @@
|
||||
# These are only used if logging_collector is on:
|
||||
#log_directory = 'log' # directory where log files are written,
|
||||
# can be absolute or relative to PGDATA
|
||||
@ -22,8 +22,7 @@ diff -up postgresql-14beta2/src/backend/utils/misc/postgresql.conf.sample.patch2
|
||||
-#log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||
+log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||
# happen after that time. 0 disables.
|
||||
-#log_rotation_size = 10MB # Automatic rotation of logfiles will
|
||||
+log_rotation_size = 0 # Automatic rotation of logfiles will
|
||||
#log_rotation_size = 10MB # Automatic rotation of logfiles will
|
||||
# happen after that much log output.
|
||||
# 0 disables.
|
||||
-#log_truncate_on_rotation = off # If on, an existing log file with the
|
||||
|
@ -39,34 +39,22 @@ diff -ur postgresql-13.4/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out postgr
|
||||
from keytbl, encdata where keytbl.id=3 and encdata.id=3;
|
||||
pgp_pub_decrypt
|
||||
-----------------
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/Makefile postgresql-13.4.patched/contrib/pgcrypto/Makefile
|
||||
--- postgresql-13.4/contrib/pgcrypto/Makefile 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/Makefile 2021-09-01 08:26:47.207164873 -0400
|
||||
@@ -5,7 +5,7 @@
|
||||
INT_TESTS = sha2
|
||||
|
||||
OSSL_SRCS = openssl.c pgp-mpi-openssl.c
|
||||
-OSSL_TESTS = sha2 des 3des cast5
|
||||
+OSSL_TESTS = sha2
|
||||
|
||||
ZLIB_TST = pgp-compression
|
||||
ZLIB_OFF_TST = pgp-zlib-DISABLED
|
||||
@@ -49,12 +49,13 @@
|
||||
diff -ur postgresql-15.0_original/contrib/pgcrypto/Makefile postgresql-15.0/contrib/pgcrypto/Makefile
|
||||
--- postgresql-15.0_original/contrib/pgcrypto/Makefile 2022-09-05 23:12:45.000000000 +0200
|
||||
+++ postgresql-15.0/contrib/pgcrypto/Makefile 2022-09-27 17:12:54.463159362 +0200
|
||||
@@ -39,9 +39,9 @@
|
||||
pgcrypto--1.0--1.1.sql
|
||||
PGFILEDESC = "pgcrypto - cryptographic functions"
|
||||
|
||||
-REGRESS = init md5 sha1 hmac-md5 hmac-sha1 blowfish rijndael \
|
||||
+REGRESS = init md5 sha1 hmac-md5 hmac-sha1 rijndael \
|
||||
$(CF_TESTS) \
|
||||
- sha2 des 3des cast5 \
|
||||
- crypt-des crypt-md5 crypt-blowfish crypt-xdes \
|
||||
+REGRESS = init md5 sha1 hmac-md5 hmac-sha1 rijndael \
|
||||
+ sha2 \
|
||||
+ crypt-md5 \
|
||||
pgp-armor pgp-decrypt pgp-encrypt $(CF_PGP_TESTS) \
|
||||
pgp-pubkey-decrypt pgp-pubkey-encrypt pgp-info
|
||||
|
||||
+#REGRESS = init pgp-pubkey-decrypt pgp-decrypt \
|
||||
EXTRA_CLEAN = gen-rtab
|
||||
|
||||
ifdef USE_PGXS
|
||||
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql
|
||||
--- postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-09-01 08:16:12.525212175 -0400
|
||||
|
@ -1,61 +0,0 @@
|
||||
From eb39610f82679e015dd990a3fbba1c62e399c32a Mon Sep 17 00:00:00 2001
|
||||
From: Tom Lane <tgl@sss.pgh.pa.us>
|
||||
Date: Wed, 1 Jun 2022 16:15:47 -0400
|
||||
Subject: [PATCH] Fix pl/perl test case so it will still work under Perl 5.36.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Perl 5.36 has reclassified the warning condition that this test
|
||||
case used, so that the expected error fails to appear. Tweak
|
||||
the test so it instead exercises a case that's handled the same
|
||||
way in all Perl versions of interest.
|
||||
|
||||
This appears to meet our standards for back-patching into
|
||||
out-of-support branches: it changes no user-visible behavior
|
||||
but enables testing of old branches with newer tools.
|
||||
Hence, back-patch as far as 9.2.
|
||||
|
||||
Dagfinn Ilmari Mannsåker, per report from Jitka Plesníková.
|
||||
|
||||
Discussion: https://postgr.es/m/564579.1654093326@sss.pgh.pa.us
|
||||
---
|
||||
src/pl/plperl/expected/plperl.out | 6 +++---
|
||||
src/pl/plperl/sql/plperl.sql | 4 ++--
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/pl/plperl/expected/plperl.out b/src/pl/plperl/expected/plperl.out
|
||||
index d8a1ff5dd8..e3d7c8896a 100644
|
||||
--- a/src/pl/plperl/expected/plperl.out
|
||||
+++ b/src/pl/plperl/expected/plperl.out
|
||||
@@ -724,9 +724,9 @@ DO $do$ use strict; my $name = "foo"; my $ref = $$name; $do$ LANGUAGE plperl;
|
||||
ERROR: Can't use string ("foo") as a SCALAR ref while "strict refs" in use at line 1.
|
||||
CONTEXT: PL/Perl anonymous code block
|
||||
-- check that we can "use warnings" (in this case to turn a warn into an error)
|
||||
--- yields "ERROR: Useless use of sort in scalar context."
|
||||
-DO $do$ use warnings FATAL => qw(void) ; my @y; my $x = sort @y; 1; $do$ LANGUAGE plperl;
|
||||
-ERROR: Useless use of sort in scalar context at line 1.
|
||||
+-- yields "ERROR: Useless use of sort in void context."
|
||||
+DO $do$ use warnings FATAL => qw(void) ; my @y; sort @y; 1; $do$ LANGUAGE plperl;
|
||||
+ERROR: Useless use of sort in void context at line 1.
|
||||
CONTEXT: PL/Perl anonymous code block
|
||||
-- make sure functions marked as VOID without an explicit return work
|
||||
CREATE OR REPLACE FUNCTION myfuncs() RETURNS void AS $$
|
||||
diff --git a/src/pl/plperl/sql/plperl.sql b/src/pl/plperl/sql/plperl.sql
|
||||
index b0d950b230..bb0b8ce4cb 100644
|
||||
--- a/src/pl/plperl/sql/plperl.sql
|
||||
+++ b/src/pl/plperl/sql/plperl.sql
|
||||
@@ -469,8 +469,8 @@ DO $$ use blib; $$ LANGUAGE plperl;
|
||||
DO $do$ use strict; my $name = "foo"; my $ref = $$name; $do$ LANGUAGE plperl;
|
||||
|
||||
-- check that we can "use warnings" (in this case to turn a warn into an error)
|
||||
--- yields "ERROR: Useless use of sort in scalar context."
|
||||
-DO $do$ use warnings FATAL => qw(void) ; my @y; my $x = sort @y; 1; $do$ LANGUAGE plperl;
|
||||
+-- yields "ERROR: Useless use of sort in void context."
|
||||
+DO $do$ use warnings FATAL => qw(void) ; my @y; sort @y; 1; $do$ LANGUAGE plperl;
|
||||
|
||||
-- make sure functions marked as VOID without an explicit return work
|
||||
CREATE OR REPLACE FUNCTION myfuncs() RETURNS void AS $$
|
||||
--
|
||||
2.35.1
|
||||
|
@ -47,12 +47,12 @@ diff -ur postgresql-14rc1/src/bin/pg_config/Makefile pgsql14/src/bin/pg_config/M
|
||||
rm -rf tmp_check
|
||||
|
||||
check:
|
||||
diff -ur postgresql-14rc1/src/bin/pg_config/nls.mk pgsql14/src/bin/pg_config/nls.mk
|
||||
--- postgresql-14rc1/src/bin/pg_config/nls.mk 2021-09-20 23:33:01.000000000 +0200
|
||||
+++ pgsql14/src/bin/pg_config/nls.mk 2021-09-22 10:48:51.492460567 +0200
|
||||
diff -ur postgresql-15.0_original/src/bin/pg_config/nls.mk postgresql-15.0/src/bin/pg_config/nls.mk
|
||||
--- postgresql-15.0_original/src/bin/pg_config/nls.mk 2022-09-05 23:12:45.000000000 +0200
|
||||
+++ postgresql-15.0/src/bin/pg_config/nls.mk 2022-09-27 17:04:14.618932977 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
# src/bin/pg_config/nls.mk
|
||||
-CATALOG_NAME = pg_config
|
||||
+CATALOG_NAME = pg_server_config
|
||||
AVAIL_LANGUAGES = cs de el es fr he it ja ko pl pt_BR ru sv tr uk vi zh_CN
|
||||
AVAIL_LANGUAGES = cs de el es fr he it ja ka ko pl pt_BR ru sv tr uk vi zh_CN
|
||||
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
||||
|
@ -63,9 +63,9 @@
|
||||
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 14
|
||||
Version: %{majorversion}.3
|
||||
Release: 10%{?dist}
|
||||
%global majorversion 15
|
||||
Version: %{majorversion}.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
# recognizes it as an independent license, so we do as well.
|
||||
@ -76,8 +76,8 @@ Url: http://www.postgresql.org/
|
||||
# in-place upgrade of an old database. In most cases it will not be critical
|
||||
# that this be kept up with the latest minor release of the previous series;
|
||||
# but update when bugs affecting pg_dump output are fixed.
|
||||
%global prevmajorversion 13
|
||||
%global prevversion %{prevmajorversion}.7
|
||||
%global prevmajorversion 14
|
||||
%global prevversion %{prevmajorversion}.3
|
||||
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||
%global precise_version %{?epoch:%epoch:}%version-%release
|
||||
|
||||
@ -118,10 +118,8 @@ Patch10: postgresql-datalayout-mismatch-on-s390.patch
|
||||
Patch12: postgresql-no-libecpg.patch
|
||||
# This patch disables deprecated ciphers in the test suite
|
||||
Patch14: postgresql-pgcrypto-openssl3-tests.patch
|
||||
# Fix compatibility with Python 3.11
|
||||
Patch15: postgresql-SPI-s-handling-of-errors-during-transaction-comm.patch
|
||||
# Fix compatibility with Perl 5.36
|
||||
Patch16: postgresql-pl-perl-test-case.patch
|
||||
# This patch enables to build PostgreSQL 15 with llvm 15
|
||||
Patch15: postgresql-15.0-llvm_pointer.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: lz4-devel
|
||||
@ -129,6 +127,7 @@ BuildRequires: gcc
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
|
||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||
BuildRequires: perl(Opcode)
|
||||
BuildRequires: perl-FindBin
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
BuildRequires: perl-generators
|
||||
%endif
|
||||
@ -444,7 +443,6 @@ goal of accelerating analytics queries.
|
||||
%patch10 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
# We used to run autoconf here, but there's no longer any real need to,
|
||||
# since Postgres ships with a reasonably modern configure script.
|
||||
|
||||
@ -1001,6 +999,7 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_datadir}/pgsql/extension/pg_surgery*
|
||||
%{_datadir}/pgsql/extension/pg_trgm*
|
||||
%{_datadir}/pgsql/extension/pg_visibility*
|
||||
%{_datadir}/pgsql/extension/pg_walinspect*
|
||||
%{_datadir}/pgsql/extension/pgcrypto*
|
||||
%{_datadir}/pgsql/extension/pgrowlocks*
|
||||
%{_datadir}/pgsql/extension/pgstattuple*
|
||||
@ -1059,6 +1058,9 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_libdir}/pgsql/pg_surgery.so
|
||||
%{_libdir}/pgsql/pg_trgm.so
|
||||
%{_libdir}/pgsql/pg_visibility.so
|
||||
%{_libdir}/pgsql/basebackup_to_shell.so
|
||||
%{_libdir}/pgsql/basic_archive.so
|
||||
%{_libdir}/pgsql/pg_walinspect.so
|
||||
%{_libdir}/pgsql/pgcrypto.so
|
||||
%{_libdir}/pgsql/pgrowlocks.so
|
||||
%{_libdir}/pgsql/pgstattuple.so
|
||||
@ -1265,6 +1267,12 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 27 2022 Ondrej Sloup <osloup@redhat.com> - 15.1-1
|
||||
- Update to v15
|
||||
- Add llvm pointer patch
|
||||
- Add new build require for perl-FindBin
|
||||
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_15
|
||||
|
||||
* Thu Sep 01 2022 Ondrej Sloup <osloup@redhat.com> - 14.3-10
|
||||
- Add dependency on util-linux to make runuser available (rhbz#2071437)
|
||||
|
||||
|
9
sources
9
sources
@ -1,6 +1,3 @@
|
||||
SHA512 (postgresql-13.7.tar.bz2) = 9254f21519c8d4e926f70082503bb5593c91064a3d2a4ea18ac503dfd9aa94751d6f01ce00fca9fec9b2b7af40caf8d0951b661dd8be4d6aa87c1e35b6fa7a41
|
||||
SHA512 (postgresql-13.7.tar.bz2.sha256) = a6e3601c6f8370318631820cb0f9858e49ea7d672652fe68ca0c0603e4fd28851fe1966a0825c8dafab11e15a0856486d82406f5b2d033917da0328089ca3f37
|
||||
SHA512 (postgresql-14.3.tar.bz2) = 70e6f67b5729a23f80b92b04e3fad2e09596b939660e3ddebf499d06af946459a45a019279e05413673e7b65d09a28a0440ed3c2ae565068466ed37e2d4f6f17
|
||||
SHA512 (postgresql-14.3.tar.bz2.sha256) = 29a4b501bdd17ad36e6b7c8c8e7c2f418b72c70811317409ad067d2d059e6adaf511efa367393d6837dcab458537fb3f297e9046bfc38072dc5d1af6338404f5
|
||||
SHA512 (postgresql-setup-8.7.tar.gz) = 741f036be517e7d9725e4f146ca7dac8b8a16b6a93d045a64ef268487f48faad6b08317b58e07ad16a31002d2a10de0ac32513a4935c3f22f48ec768a742d1fc
|
||||
SHA512 (postgresql-14.3-US.pdf) = 5069ff8030f8bf780dfa026ee968aeb56f93e2f3625af63f145db83d879dd2a332a0994e184391ed502be9ec8a015ba895f098b4aa64cd56c9466d5cfde6b7fd
|
||||
SHA512 (postgresql-15.0.tar.bz2) = 537d223be619d8b192756791cb614638f7188532f981e233bbfa8c0245adf5afe94ba5160d771af77f7d4ead41bcf346cbb2197e1358a6411ead06b19e29f120
|
||||
SHA512 (postgresql-15.0.tar.bz2.sha256) = 9da21058369ceac6870f5394853ba58c90f0b5dbcd1524f170033598d6cd5e38b4329373e97f242c4f56a93ae0b1a212e762740149937f519db22ed7435c6fe8
|
||||
SHA512 (postgresql-15.0-US.pdf) = 97f685740ed384b7e1c439f326a2cd1771aac47accba64ec70f8d7d370944c163ad9c4bc61328358a6f442d44d01a7c426cfb2a57c99dfa4580a298a8db145a0
|
||||
|
Loading…
Reference in New Issue
Block a user