import postgresql-10.6-1.module+el8+2469+5ecd5aae
This commit is contained in:
commit
12277a2d91
4
.gitignore
vendored
Normal file
4
.gitignore
vendored
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
SOURCES/postgresql-10.6-US.pdf
|
||||||
|
SOURCES/postgresql-10.6.tar.bz2
|
||||||
|
SOURCES/postgresql-9.2.24.tar.bz2
|
||||||
|
SOURCES/postgresql-setup-8.2.tar.gz
|
4
.postgresql.metadata
Normal file
4
.postgresql.metadata
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
498591e271f9017f544ccb00778d0b27ad21d730 SOURCES/postgresql-10.6-US.pdf
|
||||||
|
d3b460e9be7df545b55c994ff854cbb3f6381f28 SOURCES/postgresql-10.6.tar.bz2
|
||||||
|
63d6966ccdbab6aae1f9754fdb8e341ada1ef653 SOURCES/postgresql-9.2.24.tar.bz2
|
||||||
|
c1f5190ed00adbcca38ec6f57c1452222450bb0e SOURCES/postgresql-setup-8.2.tar.gz
|
67
SOURCES/Makefile.regress
Normal file
67
SOURCES/Makefile.regress
Normal file
@ -0,0 +1,67 @@
|
|||||||
|
#
|
||||||
|
# Simplified makefile for running the PostgreSQL regression tests
|
||||||
|
# in an RPM installation
|
||||||
|
#
|
||||||
|
|
||||||
|
# maximum simultaneous connections for parallel tests
|
||||||
|
MAXCONNOPT =
|
||||||
|
ifdef MAX_CONNECTIONS
|
||||||
|
MAXCONNOPT += --max-connections=$(MAX_CONNECTIONS)
|
||||||
|
endif
|
||||||
|
|
||||||
|
# locale
|
||||||
|
NOLOCALE =
|
||||||
|
ifdef NO_LOCALE
|
||||||
|
NOLOCALE += --no-locale
|
||||||
|
endif
|
||||||
|
|
||||||
|
srcdir := .
|
||||||
|
|
||||||
|
REGRESS_OPTS += --dlpath=.
|
||||||
|
|
||||||
|
pg_regress_locale_flags = $(if $(ENCODING),--encoding=$(ENCODING)) $(NOLOCALE)
|
||||||
|
|
||||||
|
pg_regress_installcheck = ./pg_regress --inputdir=$(srcdir) --bindir=@bindir@ $(pg_regress_locale_flags)
|
||||||
|
|
||||||
|
# Test input and expected files. These are created by pg_regress itself, so we
|
||||||
|
# don't have a rule to create them. We do need rules to clean them however.
|
||||||
|
ifile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/input/*.source)))
|
||||||
|
input_files := $(foreach file, $(ifile_list), sql/$(file).sql)
|
||||||
|
ofile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/output/*.source)))
|
||||||
|
output_files := $(foreach file, $(ofile_list), expected/$(file).out)
|
||||||
|
|
||||||
|
abs_srcdir := $(shell pwd)
|
||||||
|
abs_builddir := $(shell pwd)
|
||||||
|
|
||||||
|
check: installcheck-parallel
|
||||||
|
|
||||||
|
installcheck: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/serial_schedule $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
installcheck-parallel: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/parallel_schedule $(MAXCONNOPT) $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
# The tests command the server to write into testtablespace and results.
|
||||||
|
# On a SELinux-enabled system this will fail unless we mark those directories
|
||||||
|
# as writable by the server.
|
||||||
|
cleandirs:
|
||||||
|
-rm -rf testtablespace results
|
||||||
|
mkdir testtablespace results
|
||||||
|
[ -x /usr/bin/chcon ] && /usr/bin/chcon -u system_u -r object_r -t postgresql_db_t testtablespace results
|
||||||
|
|
||||||
|
# old interfaces follow...
|
||||||
|
|
||||||
|
runcheck: check
|
||||||
|
runtest: installcheck
|
||||||
|
runtest-parallel: installcheck-parallel
|
||||||
|
|
||||||
|
|
||||||
|
##
|
||||||
|
## Clean up
|
||||||
|
##
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
rm -f $(output_files) $(input_files)
|
||||||
|
rm -rf testtablespace
|
||||||
|
rm -rf results tmp_check log
|
||||||
|
rm -f regression.diffs regression.out regress.out run_check.out
|
58
SOURCES/generate-pdf.sh
Executable file
58
SOURCES/generate-pdf.sh
Executable file
@ -0,0 +1,58 @@
|
|||||||
|
#! /bin/sh
|
||||||
|
|
||||||
|
# This script builds the PDF version of the PostgreSQL documentation.
|
||||||
|
#
|
||||||
|
# In principle we could do this as part of the RPM build, but there are
|
||||||
|
# good reasons not to:
|
||||||
|
# 1. The build would take longer and have a larger BuildRequires footprint.
|
||||||
|
# 2. The generated PDF has timestamps in it, which would inevitably result
|
||||||
|
# in multilib conflicts due to slightly different timestamps.
|
||||||
|
# So instead, we run this manually when rebasing to a new upstream release,
|
||||||
|
# and treat the resulting PDF as a separate Source file.
|
||||||
|
#
|
||||||
|
# You will need to have the docbook packages installed to run this.
|
||||||
|
# Expect it to take about 20 minutes and use about 160MB of disk.
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
# Pass package version (e.g., 9.1.2) as argument
|
||||||
|
VERSION=$1
|
||||||
|
|
||||||
|
test -z "$VERSION" && VERSION=`awk '/^Version:/ { print $2; }' postgresql.spec`
|
||||||
|
|
||||||
|
TARGETFILE=postgresql-$VERSION-US.pdf
|
||||||
|
test -f "$TARGETFILE" && echo "$TARGETFILE exists" && exit 1
|
||||||
|
|
||||||
|
echo Building $TARGETFILE ...
|
||||||
|
|
||||||
|
# Unpack postgresql
|
||||||
|
|
||||||
|
rm -rf postgresql-$VERSION
|
||||||
|
|
||||||
|
tar xfj postgresql-$VERSION.tar.bz2
|
||||||
|
|
||||||
|
cd postgresql-$VERSION
|
||||||
|
|
||||||
|
# Apply any patches that affect the PDF documentation
|
||||||
|
|
||||||
|
# patch -p1 < ../xxx.patch
|
||||||
|
|
||||||
|
# Configure ...
|
||||||
|
|
||||||
|
./configure >/dev/null
|
||||||
|
|
||||||
|
# Build the PDF docs
|
||||||
|
|
||||||
|
cd doc/src/sgml
|
||||||
|
|
||||||
|
make postgres-US.pdf >make.log
|
||||||
|
|
||||||
|
mv -f postgres-US.pdf ../../../../$TARGETFILE
|
||||||
|
|
||||||
|
# Clean up
|
||||||
|
|
||||||
|
cd ../../../..
|
||||||
|
|
||||||
|
rm -rf postgresql-$VERSION
|
||||||
|
|
||||||
|
exit 0
|
1
SOURCES/postgresql-10.6.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-10.6.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
|||||||
|
68a8276f08bda8fbefe562faaf8831cb20664a7a1d3ffdbbcc5b83e08637624b postgresql-10.6.tar.bz2
|
1
SOURCES/postgresql-9.2.24.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-9.2.24.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
|||||||
|
a754c02f7051c2f21e52f8669a421b50485afcde9a581674d6106326b189d126 postgresql-9.2.24.tar.bz2
|
4
SOURCES/postgresql-bashprofile
Normal file
4
SOURCES/postgresql-bashprofile
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
[ -f /etc/profile ] && source /etc/profile
|
||||||
|
|
||||||
|
PGDATA=/var/lib/pgsql/data
|
||||||
|
export PGDATA
|
41
SOURCES/postgresql-logging.patch
Normal file
41
SOURCES/postgresql-logging.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
Default to stderr-based logging with a week's worth of daily logfiles.
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample postgresql-9.1rc1/src/backend/utils/misc/postgresql.conf.sample
|
||||||
|
--- postgresql-9.1rc1.orig/src/backend/utils/misc/postgresql.conf.sample 2011-08-18 17:23:13.000000000 -0400
|
||||||
|
+++ postgresql-9.1rc1/src/backend/utils/misc/postgresql.conf.sample 2011-08-18 18:39:39.697526799 -0400
|
||||||
|
@@ -279,7 +279,7 @@
|
||||||
|
# requires logging_collector to be on.
|
||||||
|
|
||||||
|
# This is used when logging to stderr:
|
||||||
|
-#logging_collector = off # Enable capturing of stderr and csvlog
|
||||||
|
+logging_collector = on # Enable capturing of stderr and csvlog
|
||||||
|
# into log files. Required to be on for
|
||||||
|
# csvlogs.
|
||||||
|
# (change requires restart)
|
||||||
|
@@ -355,11 +355,11 @@
|
||||||
|
# These are only used if logging_collector is on:
|
||||||
|
#log_directory = 'log' # directory where log files are written,
|
||||||
|
# can be absolute or relative to PGDATA
|
||||||
|
-#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log' # log file name pattern,
|
||||||
|
+log_filename = 'postgresql-%a.log' # log file name pattern,
|
||||||
|
# can include strftime() escapes
|
||||||
|
#log_file_mode = 0600 # creation mode for log files,
|
||||||
|
# begin with 0 to use octal notation
|
||||||
|
-#log_truncate_on_rotation = off # If on, an existing log file with the
|
||||||
|
+log_truncate_on_rotation = on # If on, an existing log file with the
|
||||||
|
# same name as the new log file will be
|
||||||
|
# truncated rather than appended to.
|
||||||
|
# But such truncation only occurs on
|
||||||
|
@@ -367,9 +367,9 @@
|
||||||
|
# or size-driven rotation. Default is
|
||||||
|
# off, meaning append to existing files
|
||||||
|
# in all cases.
|
||||||
|
-#log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
# happen after that time. 0 disables.
|
||||||
|
-#log_rotation_size = 10MB # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_size = 0 # Automatic rotation of logfiles will
|
||||||
|
# happen after that much log output.
|
||||||
|
# 0 disables.
|
||||||
|
|
49
SOURCES/postgresql-man.patch
Normal file
49
SOURCES/postgresql-man.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
PostgreSQL ecpg/initdb manual page fixes
|
||||||
|
|
||||||
|
This was generated based on automatic Red Hat manual page scan (private
|
||||||
|
RHBZ#948933).
|
||||||
|
|
||||||
|
diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
|
||||||
|
--- ./doc/src/sgml/man1/ecpg.1.man948933 2014-12-16 02:13:15.000000000 +0100
|
||||||
|
+++ ./doc/src/sgml/man1/ecpg.1 2014-12-23 11:26:37.883644047 +0100
|
||||||
|
@@ -80,6 +80,11 @@ INFORMIX_SE\&.
|
||||||
|
Define a C preprocessor symbol\&.
|
||||||
|
.RE
|
||||||
|
.PP
|
||||||
|
+\fB\-h \fR
|
||||||
|
+.RS 4
|
||||||
|
+Parse a header file, this option includes option \fB\-c\fR\&.
|
||||||
|
+.RE
|
||||||
|
+.PP
|
||||||
|
\fB\-i\fR
|
||||||
|
.RS 4
|
||||||
|
Parse system include files as well\&.
|
||||||
|
@@ -128,6 +133,11 @@ Allow question mark as placeholder for c
|
||||||
|
.RE
|
||||||
|
.RE
|
||||||
|
.PP
|
||||||
|
+\fB\-\-regression\fR
|
||||||
|
+.RS 4
|
||||||
|
+Run in regression testing mode\&.
|
||||||
|
+.RE
|
||||||
|
+.PP
|
||||||
|
\fB\-t\fR
|
||||||
|
.RS 4
|
||||||
|
Turn on autocommit of transactions\&. In this mode, each SQL command is automatically committed unless it is inside an explicit transaction block\&. In the default mode, commands are committed only when
|
||||||
|
diff -up ./doc/src/sgml/man1/initdb.1.man948933 ./doc/src/sgml/man1/initdb.1
|
||||||
|
--- ./doc/src/sgml/man1/initdb.1.man948933 2014-12-16 02:13:21.000000000 +0100
|
||||||
|
+++ ./doc/src/sgml/man1/initdb.1 2014-12-23 11:26:37.883644047 +0100
|
||||||
|
@@ -281,6 +281,13 @@ determines that an error prevented it fr
|
||||||
|
.PP
|
||||||
|
Other options:
|
||||||
|
.PP
|
||||||
|
+\fB\-s\fR
|
||||||
|
+.br
|
||||||
|
+\fB\-\-show\fR
|
||||||
|
+.RS 4
|
||||||
|
+Print the internal settings, then exit\&.
|
||||||
|
+.RE
|
||||||
|
+.PP
|
||||||
|
\fB\-V\fR
|
||||||
|
.br
|
||||||
|
\fB\-\-version\fR
|
33
SOURCES/postgresql-no-libs.patch
Normal file
33
SOURCES/postgresql-no-libs.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
|
index febbced..9737b55 100644
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||||
|
backend/utils/mb/conversion_procs \
|
||||||
|
backend/snowball \
|
||||||
|
include \
|
||||||
|
- interfaces \
|
||||||
|
backend/replication/libpqwalreceiver \
|
||||||
|
backend/replication/pgoutput \
|
||||||
|
fe_utils \
|
||||||
|
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||||
|
index 4ed5174..d0e0dae 100644
|
||||||
|
--- a/src/Makefile.global.in
|
||||||
|
+++ b/src/Makefile.global.in
|
||||||
|
@@ -457,7 +457,7 @@ endif
|
||||||
|
|
||||||
|
# This macro is for use by libraries linking to libpq. (Because libpgport
|
||||||
|
# isn't created with the same link flags as libpq, it can't be used.)
|
||||||
|
-libpq = -L$(libpq_builddir) -lpq
|
||||||
|
+libpq = -lpq
|
||||||
|
|
||||||
|
# This macro is for use by client executables (not libraries) that use libpq.
|
||||||
|
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||||
|
@@ -483,7 +483,6 @@ endif
|
||||||
|
# Commonly used submake targets
|
||||||
|
|
||||||
|
submake-libpq:
|
||||||
|
- $(MAKE) -C $(libpq_builddir) all
|
||||||
|
|
||||||
|
submake-libpgport:
|
||||||
|
$(MAKE) -C $(top_builddir)/src/port all
|
51
SOURCES/postgresql-server-pg_config.patch
Normal file
51
SOURCES/postgresql-server-pg_config.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
diff --git a/src/bin/pg_config/Makefile b/src/bin/pg_config/Makefile
|
||||||
|
index c410087..e546b7b 100644
|
||||||
|
--- a/src/bin/pg_config/Makefile
|
||||||
|
+++ b/src/bin/pg_config/Makefile
|
||||||
|
@@ -11,28 +11,30 @@
|
||||||
|
PGFILEDESC = "pg_config - report configuration information"
|
||||||
|
PGAPPICON=win32
|
||||||
|
|
||||||
|
+PG_CONFIG = pg_server_config$(X)
|
||||||
|
+
|
||||||
|
subdir = src/bin/pg_config
|
||||||
|
top_builddir = ../../..
|
||||||
|
include $(top_builddir)/src/Makefile.global
|
||||||
|
|
||||||
|
OBJS= pg_config.o $(WIN32RES)
|
||||||
|
|
||||||
|
-all: pg_config
|
||||||
|
+all: $(PG_CONFIG)
|
||||||
|
|
||||||
|
-pg_config: $(OBJS) | submake-libpgport
|
||||||
|
- $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
|
||||||
|
+$(PG_CONFIG): $(OBJS) | submake-libpgport
|
||||||
|
+ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
|
||||||
|
|
||||||
|
install: all installdirs
|
||||||
|
- $(INSTALL_SCRIPT) pg_config$(X) '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ $(INSTALL_SCRIPT) $(PG_CONFIG) '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
installdirs:
|
||||||
|
$(MKDIR_P) '$(DESTDIR)$(bindir)'
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
- rm -f '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ rm -f '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
- rm -f pg_config$(X) $(OBJS)
|
||||||
|
+ rm -f $(PG_CONFIG) $(OBJS)
|
||||||
|
rm -rf tmp_check
|
||||||
|
|
||||||
|
check:
|
||||||
|
diff --git a/src/bin/pg_config/nls.mk b/src/bin/pg_config/nls.mk
|
||||||
|
index 1d41f90ee0..0f34f371cc 100644
|
||||||
|
--- a/src/bin/pg_config/nls.mk
|
||||||
|
+++ b/src/bin/pg_config/nls.mk
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
# src/bin/pg_config/nls.mk
|
||||||
|
-CATALOG_NAME = pg_config
|
||||||
|
+CATALOG_NAME = pg_server_config
|
||||||
|
AVAIL_LANGUAGES = cs de es fr he it ja ko nb pl pt_BR ro ru sv ta tr zh_CN zh_TW
|
||||||
|
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
53
SOURCES/postgresql-var-run-socket.patch
Normal file
53
SOURCES/postgresql-var-run-socket.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
Change the built-in default socket directory to be /var/run/postgresql.
|
||||||
|
For backwards compatibility with (probably non-libpq-based) clients that
|
||||||
|
might still expect to find the socket in /tmp, also create a socket in
|
||||||
|
/tmp. This is to resolve communication problems with clients operating
|
||||||
|
under systemd's PrivateTmp environment, which won't be using the same
|
||||||
|
global /tmp directory as the server; see bug #825448.
|
||||||
|
|
||||||
|
Note that we apply the socket directory change at the level of the
|
||||||
|
hard-wired defaults in the C code, not by just twiddling the setting in
|
||||||
|
postgresql.conf.sample; this is so that the change will take effect on
|
||||||
|
server package update, without requiring any existing postgresql.conf
|
||||||
|
to be updated. (Of course, a user who dislikes this behavior can still
|
||||||
|
override it via postgresql.conf.)
|
||||||
|
|
||||||
|
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
|
||||||
|
index 9481f2d..75532c7 100644
|
||||||
|
--- a/src/backend/utils/misc/guc.c
|
||||||
|
+++ b/src/backend/utils/misc/guc.c
|
||||||
|
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] =
|
||||||
|
},
|
||||||
|
&Unix_socket_directories,
|
||||||
|
#ifdef HAVE_UNIX_SOCKETS
|
||||||
|
- DEFAULT_PGSOCKET_DIR,
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||||
|
#else
|
||||||
|
"",
|
||||||
|
#endif
|
||||||
|
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
|
||||||
|
index feeff9e..3e3d784 100644
|
||||||
|
--- a/src/bin/initdb/initdb.c
|
||||||
|
+++ b/src/bin/initdb/initdb.c
|
||||||
|
@@ -1234,7 +1234,7 @@ setup_config(void)
|
||||||
|
|
||||||
|
#ifdef HAVE_UNIX_SOCKETS
|
||||||
|
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
|
||||||
|
- DEFAULT_PGSOCKET_DIR);
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp");
|
||||||
|
#else
|
||||||
|
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
|
||||||
|
#endif
|
||||||
|
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
|
||||||
|
index e278fa0..9ee15d4 100644
|
||||||
|
--- a/src/include/pg_config_manual.h
|
||||||
|
+++ b/src/include/pg_config_manual.h
|
||||||
|
@@ -169,7 +169,7 @@
|
||||||
|
* here's where to twiddle it. You can also override this at runtime
|
||||||
|
* with the postmaster's -k switch.
|
||||||
|
*/
|
||||||
|
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||||
|
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||||
|
|
||||||
|
/*
|
||||||
|
* This is the default event source for Windows event log.
|
3
SOURCES/postgresql.pam
Normal file
3
SOURCES/postgresql.pam
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
#%PAM-1.0
|
||||||
|
auth include password-auth
|
||||||
|
account include password-auth
|
1
SOURCES/postgresql.tmpfiles.d
Normal file
1
SOURCES/postgresql.tmpfiles.d
Normal file
@ -0,0 +1 @@
|
|||||||
|
d /var/run/postgresql 0755 postgres postgres -
|
72
SOURCES/rpm-pgsql.patch
Normal file
72
SOURCES/rpm-pgsql.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
For the RPMs, we want the custom installation directories to end in
|
||||||
|
/pgsql not /postgresql. This is historical but not worth changing.
|
||||||
|
|
||||||
|
Notice that this patch also makes the appending of /pgsql unconditional.
|
||||||
|
This is to avoid unexpected behavior if the RPM is built in a working
|
||||||
|
directory whose path happens to include "postgres" or "pgsql" already.
|
||||||
|
However, datadir and sysconfdir are already set up in the specfile's
|
||||||
|
configure call, so we do not have to append anything to them.
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in
|
||||||
|
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400
|
||||||
|
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400
|
||||||
|
@@ -55,8 +55,7 @@
|
||||||
|
# Installation directories
|
||||||
|
#
|
||||||
|
# These are set by the equivalent --xxxdir configure options. We
|
||||||
|
-# append "postgresql" to some of them, if the string does not already
|
||||||
|
-# contain "pgsql" or "postgres", in order to avoid directory clutter.
|
||||||
|
+# append "pgsql" to some of them, in order to avoid directory clutter.
|
||||||
|
#
|
||||||
|
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
||||||
|
# by configure, since the installation tree may have been relocated.
|
||||||
|
@@ -74,45 +73,23 @@
|
||||||
|
bindir := @bindir@
|
||||||
|
|
||||||
|
datadir := @datadir@
|
||||||
|
-ifeq "$(findstring pgsql, $(datadir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(datadir))" ""
|
||||||
|
-override datadir := $(datadir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
sysconfdir := @sysconfdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(sysconfdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(sysconfdir))" ""
|
||||||
|
-override sysconfdir := $(sysconfdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
libdir := @libdir@
|
||||||
|
|
||||||
|
pkglibdir = $(libdir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkglibdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkglibdir))" ""
|
||||||
|
-override pkglibdir := $(pkglibdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkglibdir := $(pkglibdir)/pgsql
|
||||||
|
|
||||||
|
includedir := @includedir@
|
||||||
|
|
||||||
|
pkgincludedir = $(includedir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkgincludedir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkgincludedir))" ""
|
||||||
|
-override pkgincludedir := $(pkgincludedir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkgincludedir := $(pkgincludedir)/pgsql
|
||||||
|
|
||||||
|
mandir := @mandir@
|
||||||
|
|
||||||
|
docdir := @docdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(docdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(docdir))" ""
|
||||||
|
-override docdir := $(docdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override docdir := $(docdir)/pgsql
|
||||||
|
|
||||||
|
htmldir := @htmldir@
|
||||||
|
|
2240
SPECS/postgresql.spec
Normal file
2240
SPECS/postgresql.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user