Rebase to upstream release 12.1

Resolves: BZ#1801396
    Version: 12.1-1
This commit is contained in:
Patrik Novotný 2020-02-12 14:19:52 +01:00
parent 261eac466c
commit 01110f9fc1
4 changed files with 74 additions and 29 deletions

View File

@ -18,19 +18,19 @@ index bcdbd95..4bea236 100644
backend/replication/pgoutput \ backend/replication/pgoutput \
fe_utils \ fe_utils \
diff --git a/src/Makefile.global.in b/src/Makefile.global.in diff --git a/src/Makefile.global.in b/src/Makefile.global.in
index 9a4a8a3..2bdfb77 100644 index b9d86ac..29df69f 100644
--- a/src/Makefile.global.in --- a/src/Makefile.global.in
+++ b/src/Makefile.global.in +++ b/src/Makefile.global.in
@@ -513,7 +513,7 @@ endif @@ -549,7 +549,7 @@ endif
# How to link to libpq. (This macro may be used as-is by backend extensions.
# This macro is for use by libraries linking to libpq. (Because libpgport # Client-side code should go through libpq_pgport or libpq_pgport_shlib,
# isn't created with the same link flags as libpq, it can't be used.) # instead.)
-libpq = -L$(libpq_builddir) -lpq -libpq = -L$(libpq_builddir) -lpq
+libpq = -lpq +libpq = -lpq
# This macro is for use by client executables (not libraries) that use libpq. # libpq_pgport is for use by client executables (not libraries) that use libpq.
# We force clients to pull symbols from the non-shared libraries libpgport # We force clients to pull symbols from the non-shared libraries libpgport
@@ -539,7 +539,6 @@ endif @@ -579,7 +579,6 @@ endif
# Commonly used submake targets # Commonly used submake targets
submake-libpq: | submake-generated-headers submake-libpq: | submake-generated-headers
@ -38,3 +38,6 @@ index 9a4a8a3..2bdfb77 100644
submake-libpgport: | submake-generated-headers submake-libpgport: | submake-generated-headers
$(MAKE) -C $(top_builddir)/src/port all $(MAKE) -C $(top_builddir)/src/port all
--
2.21.0

View File

@ -55,5 +55,5 @@ index 1d41f90..0f34f37 100644
# src/bin/pg_config/nls.mk # src/bin/pg_config/nls.mk
-CATALOG_NAME = pg_config -CATALOG_NAME = pg_config
+CATALOG_NAME = pg_server_config +CATALOG_NAME = pg_server_config
AVAIL_LANGUAGES = cs de es fr he it ja ko nb pl pt_BR ro ru sv ta tr vi zh_CN zh_TW AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ro ru sv tr uk vi zh_CN zh_TW
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c

View File

@ -32,6 +32,7 @@
%{!?beta:%global beta 0} %{!?beta:%global beta 0}
%{!?test:%global test 1} %{!?test:%global test 1}
%{!?llvmjit:%global llvmjit 1}
%{!?upgrade:%global upgrade 1} %{!?upgrade:%global upgrade 1}
%{!?plpython:%global plpython 1} %{!?plpython:%global plpython 1}
%{!?plpython3:%global plpython3 1} %{!?plpython3:%global plpython3 1}
@ -58,9 +59,9 @@
Summary: PostgreSQL client programs Summary: PostgreSQL client programs
Name: postgresql Name: postgresql
%global majorversion 11 %global majorversion 12
Version: 11.6 Version: %{majorversion}.1
Release: 2%{?dist} Release: 1%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI # The PostgreSQL license is very similar to other MIT licenses, but the OSI
# recognizes it as an independent license, so we do as well. # recognizes it as an independent license, so we do as well.
@ -71,14 +72,15 @@ Url: http://www.postgresql.org/
# in-place upgrade of an old database. In most cases it will not be critical # in-place upgrade of an old database. In most cases it will not be critical
# that this be kept up with the latest minor release of the previous series; # that this be kept up with the latest minor release of the previous series;
# but update when bugs affecting pg_dump output are fixed. # but update when bugs affecting pg_dump output are fixed.
%global prevversion 10.11 %global prevversion 11.6
%global prevmajorversion 10 %global prevmajorversion 11
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion} %global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
%global precise_version %{?epoch:%epoch:}%version-%release %global precise_version %{?epoch:%epoch:}%version-%release
%global setup_version 8.4 %global setup_version 8.4
%global service_name postgresql.service %global service_name postgresql.service
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2 Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
# The PDF file is generated by generate-pdf.sh, which see for comments # The PDF file is generated by generate-pdf.sh, which see for comments
Source1: postgresql-%{version}-US.pdf Source1: postgresql-%{version}-US.pdf
@ -303,13 +305,12 @@ Install this if you want to write database functions in Perl.
%if %plpython %if %plpython
%package plpython2 %package plpython
Summary: The Python2 procedural language for PostgreSQL Summary: The Python2 procedural language for PostgreSQL
Requires: %{name}-server%{?_isa} = %precise_version Requires: %{name}-server%{?_isa} = %precise_version
Provides: %{name}-plpython = %precise_version Provides: %{name}-plpython2 = %precise_version
Obsoletes: %{name}-plpython < %precise_version
%description plpython2 %description plpython
The postgresql-plpython package contains the PL/Python procedural language, The postgresql-plpython package contains the PL/Python procedural language,
which is an extension to the PostgreSQL database server. which is an extension to the PostgreSQL database server.
Install this if you want to write database functions in Python 2. Install this if you want to write database functions in Python 2.
@ -352,6 +353,30 @@ PostgreSQL database management system, including regression tests and
benchmarks. benchmarks.
%endif %endif
%if %llvmjit
%package llvmjit
Summary: Just-in-time compilation support for PostgreSQL
Requires: %{name}-server%{?_isa} = %{version}-%{release}
%if 0%{?rhel} && 0%{?rhel} == 7
Requires: llvm5.0 >= 5.0
%else
Requires: llvm => 5.0
%endif
Provides: postgresql-llvmjit >= %{version}-%{release}
%ifarch ppc64 ppc64le
AutoReq: 0
Requires: advance-toolchain-%{atstring}-runtime
%endif
BuildRequires: llvm-devel >= 5.0 clang-devel >= 5.0
%description llvmjit
The postgresql-llvmjit package contains support for
just-in-time compiling parts of PostgreSQL queries. Using LLVM it
compiles e.g. expressions and tuple deforming into native code, with the
goal of accelerating analytics queries.
%endif
%prep %prep
( (
@ -361,7 +386,7 @@ benchmarks.
sha256sum -c %{SOURCE17} sha256sum -c %{SOURCE17}
%endif %endif
) )
%setup -q -a 12 %setup -q -a 12 -n postgresql-%{version}
%patch1 -p1 %patch1 -p1
%patch2 -p1 %patch2 -p1
%patch5 -p1 %patch5 -p1
@ -471,6 +496,9 @@ common_configure_options='
%if %icu %if %icu
--with-icu --with-icu
%endif %endif
%if %llvmjit
--with-llvm
%endif
' '
%if %plpython3 %if %plpython3
@ -832,7 +860,7 @@ find_lang_bins ()
find_lang_bins devel.lst pg_server_config find_lang_bins devel.lst pg_server_config
find_lang_bins server.lst \ find_lang_bins server.lst \
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \ initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \
postgres pg_verify_checksums postgres pg_checksums
find_lang_bins contrib.lst \ find_lang_bins contrib.lst \
pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
find_lang_bins main.lst \ find_lang_bins main.lst \
@ -877,7 +905,7 @@ make -C postgresql-setup-%{setup_version} check
# FILES sections. # FILES sections.
%files -f main.lst %files -f main.lst
%doc doc/KNOWN_BUGS doc/MISSING_FEATURES doc/TODO %doc doc/KNOWN_BUGS doc/MISSING_FEATURES doc/TODO
%doc COPYRIGHT README HISTORY doc/bug.template %doc COPYRIGHT README HISTORY
%doc README.rpm-dist %doc README.rpm-dist
%{_bindir}/clusterdb %{_bindir}/clusterdb
%{_bindir}/createdb %{_bindir}/createdb
@ -906,6 +934,11 @@ make -C postgresql-setup-%{setup_version} check
%{_mandir}/man1/reindexdb.* %{_mandir}/man1/reindexdb.*
%{_mandir}/man1/vacuumdb.* %{_mandir}/man1/vacuumdb.*
%{_mandir}/man7/* %{_mandir}/man7/*
%if %llvmjit
# Install bitcode directory along with the main package,
# so that extensions can use this dir.
%dir %{_libdir}/pgsql/bitcode
%endif
%files docs %files docs
@ -971,7 +1004,6 @@ make -C postgresql-setup-%{setup_version} check
%{_datadir}/pgsql/extension/seg* %{_datadir}/pgsql/extension/seg*
%{_datadir}/pgsql/extension/tablefunc* %{_datadir}/pgsql/extension/tablefunc*
%{_datadir}/pgsql/extension/tcn* %{_datadir}/pgsql/extension/tcn*
%{_datadir}/pgsql/extension/timetravel*
%{_datadir}/pgsql/extension/tsm_system_rows* %{_datadir}/pgsql/extension/tsm_system_rows*
%{_datadir}/pgsql/extension/tsm_system_time* %{_datadir}/pgsql/extension/tsm_system_time*
%{_datadir}/pgsql/extension/unaccent* %{_datadir}/pgsql/extension/unaccent*
@ -1038,7 +1070,6 @@ make -C postgresql-setup-%{setup_version} check
%{_libdir}/pgsql/tablefunc.so %{_libdir}/pgsql/tablefunc.so
%{_libdir}/pgsql/tcn.so %{_libdir}/pgsql/tcn.so
%{_libdir}/pgsql/test_decoding.so %{_libdir}/pgsql/test_decoding.so
%{_libdir}/pgsql/timetravel.so
%{_libdir}/pgsql/tsm_system_rows.so %{_libdir}/pgsql/tsm_system_rows.so
%{_libdir}/pgsql/tsm_system_time.so %{_libdir}/pgsql/tsm_system_time.so
%{_libdir}/pgsql/unaccent.so %{_libdir}/pgsql/unaccent.so
@ -1078,14 +1109,13 @@ make -C postgresql-setup-%{setup_version} check
%{_bindir}/pg_recvlogical %{_bindir}/pg_recvlogical
%{_bindir}/pg_resetwal %{_bindir}/pg_resetwal
%{_bindir}/pg_rewind %{_bindir}/pg_rewind
%{_bindir}/pg_verify_checksums %{_bindir}/pg_checksums
%{_bindir}/postgres %{_bindir}/postgres
%{_bindir}/postgresql-setup %{_bindir}/postgresql-setup
%{_bindir}/postmaster %{_bindir}/postmaster
%dir %{_datadir}/pgsql %dir %{_datadir}/pgsql
%{_datadir}/pgsql/*.sample %{_datadir}/pgsql/*.sample
%dir %{_datadir}/pgsql/contrib %dir %{_datadir}/pgsql/contrib
%{_datadir}/pgsql/conversion_create.sql
%dir %{_datadir}/pgsql/extension %dir %{_datadir}/pgsql/extension
%{_datadir}/pgsql/extension/plpgsql* %{_datadir}/pgsql/extension/plpgsql*
%{_datadir}/pgsql/information_schema.sql %{_datadir}/pgsql/information_schema.sql
@ -1120,7 +1150,7 @@ make -C postgresql-setup-%{setup_version} check
%{_mandir}/man1/pg_receivewal.* %{_mandir}/man1/pg_receivewal.*
%{_mandir}/man1/pg_resetwal.* %{_mandir}/man1/pg_resetwal.*
%{_mandir}/man1/pg_rewind.* %{_mandir}/man1/pg_rewind.*
%{_mandir}/man1/pg_verify_checksums.* %{_mandir}/man1/pg_checksums.*
%{_mandir}/man1/postgres.* %{_mandir}/man1/postgres.*
%{_mandir}/man1/postgresql-new-systemd-unit.* %{_mandir}/man1/postgresql-new-systemd-unit.*
%{_mandir}/man1/postgresql-setup.* %{_mandir}/man1/postgresql-setup.*
@ -1158,6 +1188,8 @@ make -C postgresql-setup-%{setup_version} check
%files static %files static
%{_libdir}/libpgcommon.a %{_libdir}/libpgcommon.a
%{_libdir}/libpgport.a %{_libdir}/libpgport.a
%{_libdir}/libpgcommon_shlib.a
%{_libdir}/libpgport_shlib.a
%if %upgrade %if %upgrade
@ -1178,6 +1210,13 @@ make -C postgresql-setup-%{setup_version} check
%{macrosdir}/macros.%name-upgrade %{macrosdir}/macros.%name-upgrade
%endif %endif
%if %llvmjit
%files llvmjit
%defattr(-,root,root)
%{_libdir}/pgsql/bitcode/*
%{_libdir}/pgsql/llvmjit.so
%{_libdir}/pgsql/llvmjit_types.bc
%endif
%if %plperl %if %plperl
%files plperl -f plperl.lst %files plperl -f plperl.lst
@ -1194,7 +1233,7 @@ make -C postgresql-setup-%{setup_version} check
%if %plpython %if %plpython
%files plpython2 -f plpython.lst %files plpython -f plpython.lst
%{_datadir}/pgsql/extension/plpython2* %{_datadir}/pgsql/extension/plpython2*
%{_datadir}/pgsql/extension/plpythonu* %{_datadir}/pgsql/extension/plpythonu*
%{_libdir}/pgsql/plpython2.so %{_libdir}/pgsql/plpython2.so
@ -1215,6 +1254,9 @@ make -C postgresql-setup-%{setup_version} check
%changelog %changelog
* Tue Feb 11 2020 Patrik Novotný <panovotn@redhat.com> - 12.1-1
- Rebase to upstream release 12.1
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 11.6-2 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 11.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1,6 +1,6 @@
SHA512 (postgresql-10.11.tar.bz2) = ce90b34e74d423b6db1f0e840b8e09579965c020fa2cfe3e567b604d3354d91e00a4347d559876be829aa89db44f84736e154495708ba9908f1d850446a1fc7b
SHA512 (postgresql-10.11.tar.bz2.sha256) = 1e98c65329440b032896d6ac45a0fb33478b45562e5b0833e6f9d2f7a94d7a99fe78f4820f18890b37d36f9bba6def317f0fca8a73404eeb8ddfd863deea47a8
SHA512 (postgresql-11.6.tar.bz2) = de6833c0df8dbac7bc498ac573dc4c3645070d9bbdd6b5d89db3ef41e86e7fc19d5e6450aa46ee2a1392d86c33acf6b9364b2863caac49f45351a46647feecbd SHA512 (postgresql-11.6.tar.bz2) = de6833c0df8dbac7bc498ac573dc4c3645070d9bbdd6b5d89db3ef41e86e7fc19d5e6450aa46ee2a1392d86c33acf6b9364b2863caac49f45351a46647feecbd
SHA512 (postgresql-11.6.tar.bz2.sha256) = cb462b2ed50c6cb1e6afe914cae9a6a47fb81bcca313b1489e36a61fa0b5fa884b201e81e105fb361f344b2ccd3e123267438513bf534276d9f629f6ac3a48ce SHA512 (postgresql-11.6.tar.bz2.sha256) = cb462b2ed50c6cb1e6afe914cae9a6a47fb81bcca313b1489e36a61fa0b5fa884b201e81e105fb361f344b2ccd3e123267438513bf534276d9f629f6ac3a48ce
SHA512 (postgresql-12.1.tar.bz2) = f45b1762fd60b6f7419305d108b7fc521e3a7afa833d3aacccba814465baf40d19f57ff9bf2909d726c4c94a1cd99a39f1aa8e45fd0364cdedbcbed36ff48caf
SHA512 (postgresql-12.1.tar.bz2.sha256) = 275a72bb1e27c6ec4385722cd53d7244186885a402d613d1c6a45c1173154559791713dfbdf5af11b596a867cec7eb6be949c734badd3c458b0a9345b37bd899
SHA512 (postgresql-setup-8.4.tar.gz) = eb73767d5c676481598aeb545e15027a29a438aa29480ad414f6af31c9df61138a51f5425999b4b35e776a3dbbb28c887790ea9771abc3328158dd1d34b1dce1 SHA512 (postgresql-setup-8.4.tar.gz) = eb73767d5c676481598aeb545e15027a29a438aa29480ad414f6af31c9df61138a51f5425999b4b35e776a3dbbb28c887790ea9771abc3328158dd1d34b1dce1
SHA512 (postgresql-11.6-US.pdf) = d7d4cb3290928282b393f07c65baf36902c70a8ea930c4f24aa78c66460bf54865fc38ce61980acec7c20b14cad56c4e950e94ceac1e5008ec8a21c6e4cbdf02 SHA512 (postgresql-12.1-US.pdf) = 348001219af9a4a98b2fd54228ccf019947eefb90f971a25c3a9660135b559b3d4b8f938f965a5a2e7ffb00d05f227c73c737120c9f0794aa9744e0dca613f64