* Tue Sep 21 2006 Dan Walsh <dwalsh@redhat.com> 1.30.29-4
- More translations - Compile with -pie
This commit is contained in:
parent
7e8bdec007
commit
0e300cf3bd
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/audit2allow/avc.py policycoreutils-1.30.29/audit2allow/avc.py
|
||||
--- nsapolicycoreutils/audit2allow/avc.py 2006-09-14 08:07:24.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/audit2allow/avc.py 2006-09-18 15:58:50.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/audit2allow/avc.py 2006-09-21 10:20:57.000000000 -0400
|
||||
@@ -357,6 +357,15 @@
|
||||
break
|
||||
else:
|
||||
@ -20,7 +20,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/audit2a
|
||||
Binary files nsapolicycoreutils/restorecon/restorecon and policycoreutils-1.30.29/restorecon/restorecon differ
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restorecon/restorecon.8 policycoreutils-1.30.29/restorecon/restorecon.8
|
||||
--- nsapolicycoreutils/restorecon/restorecon.8 2006-08-28 16:58:19.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/restorecon/restorecon.8 2006-09-15 09:19:49.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/restorecon/restorecon.8 2006-09-21 10:20:57.000000000 -0400
|
||||
@@ -23,6 +23,9 @@
|
||||
|
||||
.SH "OPTIONS"
|
||||
@ -33,7 +33,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
.TP
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restorecon/restorecon.c policycoreutils-1.30.29/restorecon/restorecon.c
|
||||
--- nsapolicycoreutils/restorecon/restorecon.c 2006-09-01 22:32:11.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/restorecon/restorecon.c 2006-09-15 09:19:49.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/restorecon/restorecon.c 2006-09-21 13:54:34.000000000 -0400
|
||||
@@ -11,9 +11,10 @@
|
||||
* restorecon [-Rnv] pathname...
|
||||
*
|
||||
@ -61,7 +61,36 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
static int force = 0;
|
||||
#define STAT_BLOCK_SIZE 1
|
||||
static int pipe_fds[2] = { -1, -1 };
|
||||
@@ -129,7 +132,7 @@
|
||||
@@ -62,6 +65,7 @@
|
||||
static int add_exclude(const char *directory)
|
||||
{
|
||||
struct stat sb;
|
||||
+ int len=0;
|
||||
if (directory == NULL || directory[0] != '/') {
|
||||
fprintf(stderr, "Full path required for exclude: %s.\n",
|
||||
directory);
|
||||
@@ -85,12 +89,18 @@
|
||||
return 1;
|
||||
}
|
||||
|
||||
- excludeArray[excludeCtr].directory = strdup(directory);
|
||||
+ len = strlen(directory);
|
||||
+ if (len > 1 && directory[len-1] == '/') {
|
||||
+ excludeArray[excludeCtr].directory = calloc(1,len--);
|
||||
+ strncpy(excludeArray[excludeCtr].directory, directory, len);
|
||||
+ } else
|
||||
+ excludeArray[excludeCtr].directory = strdup(directory);
|
||||
+
|
||||
if (!excludeArray[excludeCtr].directory) {
|
||||
fprintf(stderr, "Out of memory.\n");
|
||||
return 1;
|
||||
}
|
||||
- excludeArray[excludeCtr++].size = strlen(directory);
|
||||
+ excludeArray[excludeCtr++].size = len;
|
||||
|
||||
return 0;
|
||||
}
|
||||
@@ -129,7 +139,7 @@
|
||||
void usage(const char *const name)
|
||||
{
|
||||
fprintf(stderr,
|
||||
@ -70,7 +99,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
name);
|
||||
exit(1);
|
||||
}
|
||||
@@ -160,6 +163,8 @@
|
||||
@@ -160,6 +170,8 @@
|
||||
}
|
||||
|
||||
if (lstat(filename, &st) != 0) {
|
||||
@ -79,7 +108,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
fprintf(stderr, "lstat(%s) failed: %s\n", filename,
|
||||
strerror(errno));
|
||||
return 1;
|
||||
@@ -249,7 +254,10 @@
|
||||
@@ -249,7 +261,10 @@
|
||||
freecon(scontext);
|
||||
return 1;
|
||||
}
|
||||
@ -91,7 +120,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
if (verbose)
|
||||
printf("%s reset %s context %s->%s\n",
|
||||
progname, filename,
|
||||
@@ -322,6 +330,8 @@
|
||||
@@ -322,6 +337,8 @@
|
||||
close(pipe_fds[1]);
|
||||
if (rc == -1 || rc > 0) {
|
||||
if (nftw(buf, apply_spec, 1024, FTW_PHYS)) {
|
||||
@ -100,8 +129,11 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
fprintf(stderr,
|
||||
"%s: error while labeling files under %s\n",
|
||||
progname, buf);
|
||||
@@ -353,11 +363,14 @@
|
||||
@@ -351,13 +368,17 @@
|
||||
progname = argv[0];
|
||||
if (is_selinux_enabled() <= 0)
|
||||
exit(0);
|
||||
+
|
||||
set_matchpathcon_flags(MATCHPATHCON_NOTRANS);
|
||||
|
||||
- while ((opt = getopt(argc, argv, "pFrRnvf:o:e:")) > 0) {
|
||||
@ -116,7 +148,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
case 'r':
|
||||
case 'R':
|
||||
recurse = 1;
|
||||
@@ -370,13 +383,17 @@
|
||||
@@ -370,13 +391,17 @@
|
||||
exit(1);
|
||||
break;
|
||||
case 'o':
|
||||
@ -140,17 +172,46 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restore
|
||||
break;
|
||||
case 'v':
|
||||
if (progress) {
|
||||
@@ -428,5 +445,7 @@
|
||||
@@ -421,6 +446,7 @@
|
||||
if (strcmp(file_name, "-") != 0)
|
||||
fclose(f);
|
||||
} else {
|
||||
+ if (optind >= argc) usage(argv[0]);
|
||||
for (i = optind; i < argc; i++) {
|
||||
process(argv[i]);
|
||||
}
|
||||
@@ -428,5 +454,7 @@
|
||||
if (outfile)
|
||||
fclose(outfile);
|
||||
|
||||
+ if (change) return change_ctr;
|
||||
+ if (! change) return change_ctr;
|
||||
+
|
||||
return errors;
|
||||
}
|
||||
Binary files nsapolicycoreutils/restorecon/restorecon.o and policycoreutils-1.30.29/restorecon/restorecon.o differ
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-1.30.29/restorecond/Makefile
|
||||
--- nsapolicycoreutils/restorecond/Makefile 2006-08-28 16:58:19.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/restorecond/Makefile 2006-09-21 17:03:00.000000000 -0400
|
||||
@@ -5,14 +5,14 @@
|
||||
INITDIR = $(DESTDIR)/etc/rc.d/init.d
|
||||
SELINUXDIR = $(DESTDIR)/etc/selinux
|
||||
|
||||
-CFLAGS ?= -g -Werror -Wall -W
|
||||
+CFLAGS ?= -g -Werror -Wall -W -fpie
|
||||
override CFLAGS += -I$(PREFIX)/include -D_FILE_OFFSET_BITS=64
|
||||
LDLIBS += -lselinux -lsepol -L$(PREFIX)/lib
|
||||
|
||||
all: restorecond
|
||||
|
||||
restorecond: restorecond.o utmpwatcher.o stringslist.o
|
||||
- $(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)
|
||||
+ $(CC) -pie $(LDFLAGS) -o $@ $^ $(LDLIBS)
|
||||
|
||||
install: all
|
||||
[ -d $(MANDIR)/man8 ] || mkdir -p $(MANDIR)/man8
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-1.30.29/scripts/fixfiles
|
||||
--- nsapolicycoreutils/scripts/fixfiles 2006-09-01 22:32:11.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/scripts/fixfiles 2006-09-15 09:20:06.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/scripts/fixfiles 2006-09-21 10:20:57.000000000 -0400
|
||||
@@ -117,7 +117,7 @@
|
||||
exit $?
|
||||
fi
|
||||
@ -179,7 +240,7 @@ diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/scripts
|
||||
usage
|
||||
diff --exclude-from=exclude --exclude='*.po' -N -u -r nsapolicycoreutils/scripts/fixfiles.8 policycoreutils-1.30.29/scripts/fixfiles.8
|
||||
--- nsapolicycoreutils/scripts/fixfiles.8 2006-08-28 16:58:19.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/scripts/fixfiles.8 2006-09-15 09:23:17.000000000 -0400
|
||||
+++ policycoreutils-1.30.29/scripts/fixfiles.8 2006-09-21 10:20:57.000000000 -0400
|
||||
@@ -3,9 +3,9 @@
|
||||
fixfiles \- fix file security contexts.
|
||||
|
||||
|
@ -5,7 +5,7 @@
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 1.30.29
|
||||
Release: 3
|
||||
Release: 4
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -122,6 +122,10 @@ fi
|
||||
[ -x /sbin/service ] && /sbin/service restorecond condrestart
|
||||
|
||||
%changelog
|
||||
* Tue Sep 21 2006 Dan Walsh <dwalsh@redhat.com> 1.30.29-4
|
||||
- More translations
|
||||
- Compile with -pie
|
||||
|
||||
* Mon Sep 18 2006 Dan Walsh <dwalsh@redhat.com> 1.30.29-3
|
||||
- Add translations
|
||||
- Fix audit2allow -l
|
||||
|
Loading…
Reference in New Issue
Block a user