Initial import of plexus-classworlds (#500246).

This commit is contained in:
Andrew Overholt 2009-08-17 20:49:55 +00:00
parent 30dca08f59
commit f2b6b10820
8 changed files with 421 additions and 0 deletions

View File

@ -0,0 +1 @@
plexus-classworlds-1.2-alpha-9-src.tar.gz

1
import.log Normal file
View File

@ -0,0 +1 @@
plexus-classworlds-1_2-0_a9_6_jpp6:HEAD:plexus-classworlds-1.2-0.a9.6.jpp6.src.rpm:1250542121

View File

@ -0,0 +1,99 @@
<project name="plexus-classworlds" default="jar" basedir=".">
<property name="maven.build.output" value="target/classes"/>
<property name="maven.build.directory" value="target"/>
<property name="maven.build.final.name" value="plexus-classworlds-1.2-alpha-9"/>
<property name="maven.test.reports" value="${maven.build.directory}/test-reports"/>
<property name="maven.test.output" value="target/test-classes"/>
<property name="maven.repo.local" value="${user.home}/.m2/repository"/>
<property name="javadocdir" value="target/site/apidocs"></property>
<path id="build.classpath">
<fileset dir="${maven.repo.local}">
<include name="junit/junit/3.8.2/junit-3.8.2.jar"/>
</fileset>
</path>
<target name="clean" description="Clean the output directory">
<delete dir="${maven.build.directory}"/>
</target>
<target name="compile" depends="get-deps" description="Compile the code">
<mkdir dir="${maven.build.output}"/>
<javac destdir="${maven.build.output}" excludes="**/package.html" debug="true" deprecation="true" optimize="false">
<src>
<pathelement location="src/main/java"/>
</src>
<classpath refid="build.classpath"/>
</javac>
</target>
<target name="jar" depends="compile,test" description="Clean the JAR">
<jar jarfile="${maven.build.directory}/${maven.build.final.name}.jar" basedir="${maven.build.output}" excludes="**/package.html"/>
</target>
<target name="compile-tests" depends="junit-present, compile" description="Compile the test code" if="junit.present">
<mkdir dir="${maven.test.output}"/>
<javac destdir="${maven.test.output}" excludes="**/package.html" debug="true" deprecation="true" optimize="false">
<src>
<pathelement location="src/test/java"/>
</src>
<classpath>
<path refid="build.classpath"/>
<pathelement location="${maven.build.output}"/>
</classpath>
</javac>
<copy todir="${maven.test.output}">
<fileset dir="src/test/resources"/>
</copy>
</target>
<target name="test" depends="junit-present, compile-tests" if="junit.present" description="Run the test cases">
<mkdir dir="${maven.test.reports}"/>
<junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
<sysproperty key="basedir" value="."/>
<formatter type="xml"/>
<formatter type="plain" usefile="false"/>
<classpath>
<path refid="build.classpath"/>
<pathelement location="${maven.build.output}"/>
<pathelement location="${maven.test.output}"/>
</classpath>
<batchtest todir="${maven.test.reports}">
<fileset dir="src/test/java">
<include name="**/*Test.java"/>
<exclude name="**/*Abstract*Test.java"/>
</fileset>
</batchtest>
</junit>
</target>
<target name="test-junit-present">
<available classname="junit.framework.Test" property="junit.present"/>
</target>
<target name="junit-present" depends="test-junit-present" unless="junit.present">
<echo>================================= WARNING ================================</echo>
<echo> Junit isn&apos;t present in your $ANT_HOME/lib directory. Tests not executed. </echo>
<echo>==========================================================================</echo>
</target>
<target name="test-offline">
<condition property="maven.mode.offline">
<equals arg1="${build.sysclasspath}" arg2="only"/>
</condition>
</target>
<target name="get-deps" depends="test-offline" description="Download all dependencies" unless="maven.mode.offline">
<mkdir dir="${maven.repo.local}"/>
<mkdir dir="/var/home/jpp/rebuild/free/BUILD/plexus-classworlds-1.2-alpha-9/junit/junit/3.8.2"/>
<get src="file:///var/home/jpp/rebuild/free/BUILD/plexus-classworlds-1.2-alpha-9/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
<get src="file:///var/home/jpp/rebuild/free/BUILD/plexus-classworlds-1.2-alpha-9/external_repo/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
<get src="file:///var/home/jpp/rebuild/free/BUILD/plexus-classworlds-1.2-alpha-9/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
<get src="http://snapshots.maven.codehaus.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
<get src="file:///usr/share/maven2/repository/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
<get src="http://repo1.maven.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar" dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar" usetimestamp="true" ignoreerrors="true"/>
</target>
<target name="javadoc" description="o Generate javadoc" depends="get-deps">
<mkdir dir="${javadocdir}"></mkdir>
<tstamp>
<format pattern="-yyyy" property="year"></format>
</tstamp>
<property name="copyright" value="Copyright &amp;copy; . All Rights Reserved."></property>
<property name="title" value="Plexus Classworlds 1.2-alpha-9 API"></property>
<javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/main/java" packagenames="org.codehaus.plexus.*">
<classpath>
<path refid="build.classpath"></path>
</classpath>
</javadoc>
</target>
</project>

View File

@ -0,0 +1,27 @@
<dependencies>
<dependency>
<maven>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>3.8.1</version>
</maven>
<jpp>
<groupId>JPP</groupId>
<artifactId>junit</artifactId>
<version>3.8.2</version>
</jpp>
</dependency>
<dependency>
<maven>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-utils</artifactId>
<version>1.0.4</version>
</maven>
<jpp>
<groupId>JPP/plexus</groupId>
<artifactId>utils</artifactId>
<version>1.4.5</version>
</jpp>
</dependency>
</dependencies>

View File

@ -0,0 +1,16 @@
--- pom.xml.sav 2007-08-14 16:29:45.000000000 +0200
+++ pom.xml 2007-08-14 16:30:40.000000000 +0200
@@ -31,6 +31,13 @@
<inceptionYear>2002</inceptionYear>
<dependencies>
<dependency>
+ <groupId>org.codehaus.plexus</groupId>
+ <artifactId>plexus-utils</artifactId>
+ <version>1.0.4</version>
+ <type>jar</type>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>3.8.1</version>

View File

@ -0,0 +1,47 @@
<settings>
<profiles>
<profile>
<id>JPP</id>
<repositories>
<repository>
<id>internal</id>
<layout>jpp</layout>
<url>__JPP_URL_PLACEHOLDER__</url>
</repository>
<repository>
<id>external</id>
<layout>jpp</layout>
<url>__JAVADIR_PLACEHOLDER__</url>
</repository>
<repository>
<id>local</id>
<layout>jpp</layout>
<url>__MAVENREPO_DIR_PLACEHOLDER__</url>
</repository>
</repositories>
<pluginRepositories>
<pluginRepository>
<id>plugins-internal</id>
<name>plugins-internal</name>
<layout>jpp</layout>
<url>__JPP_URL_PLACEHOLDER__</url>
</pluginRepository>
<pluginRepository>
<id>plugins-external</id>
<name>plugins-external</name>
<layout>jpp</layout>
<url>__JAVADIR_PLACEHOLDER__</url>
</pluginRepository>
<pluginRepository>
<id>plugins-maven</id>
<name>plugins-maven</name>
<layout>jpp</layout>
<url>__MAVENDIR_PLUGIN_PLACEHOLDER__</url>
</pluginRepository>
</pluginRepositories>
</profile>
</profiles>
<activeProfiles>
<activeProfile>JPP</activeProfile>
</activeProfiles>
</settings>

229
plexus-classworlds.spec Normal file
View File

@ -0,0 +1,229 @@
# Copyright (c) 2000-2007, JPackage Project
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
#
# 1. Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright
# notice, this list of conditions and the following disclaimer in the
# documentation and/or other materials provided with the
# distribution.
# 3. Neither the name of the JPackage Project nor the names of its
# contributors may be used to endorse or promote products derived
# from this software without specific prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
# If you don't want to build with maven, and use straight ant instead,
# give rpmbuild option '--without maven'
%define with_maven %{!?_without_maven:1}%{?_without_maven:0}
%define without_maven %{?_without_maven:1}%{!?_without_maven:0}
%define parent plexus
%define subname classworlds
%define namedversion 1.2-alpha-9
Name: %{parent}-%{subname}
Version: 1.2
Release: 0.a9.6%{?dist}
Epoch: 0
Summary: Plexus Classworlds Classloader Framework
License: ASL 2.0 and Plexus
Group: Development/Java
URL: http://plexus.codehaus.org/
# svn export http://svn.codehaus.org/plexus/plexus-classworlds/tags/plexus-classworlds-1.2-alpha-9/ plexus-classworlds
# tar czf plexus-classworlds-1.0-alpha-9.tar.gz plexus-classworlds/
Source0: %{name}-%{namedversion}-src.tar.gz
Source1: plexus-classworlds-1.2-build.xml
Source3: plexus-classworlds-settings.xml
Source4: plexus-classworlds-1.2-jpp-depmap.xml
Patch0: plexus-classworlds-1.2-pom_xml.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if ! %{gcj_support}
BuildArch: noarch
%endif
BuildRequires: jpackage-utils >= 0:1.7.3
BuildRequires: ant >= 0:1.6.5
BuildRequires: jakarta-commons-logging
BuildRequires: xml-commons-jaxp-1.3-apis
%if %{with_maven}
BuildRequires: maven2 >= 2.0.4-10jpp
BuildRequires: maven2-plugin-compiler
BuildRequires: maven2-plugin-install
BuildRequires: maven2-plugin-jar
BuildRequires: maven2-plugin-javadoc
BuildRequires: maven2-plugin-resources
BuildRequires: maven2-plugin-surefire = 2.3
BuildRequires: maven-surefire-provider-junit = 2.3
BuildRequires: maven-doxia
BuildRequires: maven-doxia-sitetools
BuildRequires: maven-release
%endif
BuildRequires: plexus-utils
%if %{gcj_support}
BuildRequires: java-gcj-compat-devel
Requires(post): java-gcj-compat
Requires(postun): java-gcj-compat
%endif
Requires(post): jpackage-utils >= 0:1.7.2
Requires(postun): jpackage-utils >= 0:1.7.2
%if %{gcj_support}
BuildRequires: java-gcj-compat-devel
Requires(post): java-gcj-compat
Requires(postun): java-gcj-compat
%endif
%description
Classworlds is a framework for container developers
who require complex manipulation of Java's ClassLoaders.
Java's native ClassLoader mechanims and classes can cause
much headache and confusion for certain types of
application developers. Projects which involve dynamic
loading of components or otherwise represent a 'container'
can benefit from the classloading control provided by
classworlds.
%package javadoc
Summary: Javadoc for %{name}
Group: Development/Documentation
Requires(post): /bin/rm,/bin/ln
Requires(postun): /bin/rm
%description javadoc
Javadoc for %{name}.
%prep
%setup -q -n %{name}-%{namedversion}
for j in $(find . -name "*.jar" | grep -v /test-data/ | grep -v /test-jars/); do
mv $j $j.no
done
cp %{SOURCE1} build.xml
cp %{SOURCE3} settings.xml
%patch0 -b .sav
ln -sf $(build-classpath xml-commons-jaxp-1.3-apis) lib/xml-apis-1.3.02.jar
ln -sf $(build-classpath ant) lib/ant-1.6.5.jar
ln -sf $(build-classpath commons-logging) lib/commons-logging-1.0.3.jar
%build
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mkdir -p $MAVEN_REPO_LOCAL
# org.codehaus.plexus.classworlds.strategy.StrategyTest fails
# upstream, so ignore failures for now
%if %{with_maven}
mvn-jpp \
-e \
-Dmaven.test.failure.ignore=true \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
install javadoc:javadoc
%else
export CLASSPATH=
CLASSPATH=$CLASSPATH:target/classes:target/test-classes
ant -Dbuild.sysclasspath=only jar javadoc
%endif
%install
rm -rf $RPM_BUILD_ROOT
# jars
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}/plexus
install -pm 644 target/%{name}-%{namedversion}.jar \
$RPM_BUILD_ROOT%{_javadir}/plexus/%{subname}-%{version}.jar
%add_to_maven_depmap org.codehaus.plexus %{name} %{namedversion} JPP/%{parent} %{subname}
(cd $RPM_BUILD_ROOT%{_javadir}/%{parent} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
# pom
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
install -pm 644 pom.xml $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{parent}-%{subname}.pom
# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
%if %{gcj_support}
%{_bindir}/aot-compile-rpm
%endif
%clean
rm -rf $RPM_BUILD_ROOT
%post
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
%{_bindir}/rebuild-gcj-db
fi
%endif
%postun
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
%{_bindir}/rebuild-gcj-db
fi
%endif
%files
%defattr(-,root,root,-)
%{_javadir}/%{parent}
%{_datadir}/maven2
%{_mavendepmapfragdir}
%if %{gcj_support}
%dir %attr(-,root,root) %{_libdir}/gcj/%{name}
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{subname}*-%{version}.jar.*
%endif
%files javadoc
%defattr(-,root,root,-)
%doc %{_javadocdir}/*
%changelog
* Thu May 14 2009 Fernando Nasser <fnasser@redhat.com> 0:1.2-0.a9.6
- Fix license specification
* Tue Apr 28 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.5
- Add BRs maven2-plugin-surfire*, maven-doxia*
- Rebuild with maven2-2.0.8 built in non-bootstrap mode
* Mon Mar 16 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.4
- rebuild with new maven2 2.0.8 built in bootstrap mode
* Tue Jan 13 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.3jpp.1
- re-build with maven
* Tue Jan 06 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.2jpp.1
- Imported into devel from dbhole's maven 2.0.8 packages
* Wed Jan 30 2008 Deepak Bhole <dbhole@redhat.com> 0:1.2-0.a9.1jpp.1
- Initial build -- merged from JPackage

View File

@ -0,0 +1 @@
8d47284e931d04d75a264beea546aedc plexus-classworlds-1.2-alpha-9-src.tar.gz