diff --git a/.cvsignore b/.cvsignore
index e69de29..991b0d2 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -0,0 +1 @@
+plexus-classworlds-1.2-alpha-9-src.tar.gz
diff --git a/import.log b/import.log
new file mode 100644
index 0000000..81b9074
--- /dev/null
+++ b/import.log
@@ -0,0 +1 @@
+plexus-classworlds-1_2-0_a9_6_jpp6:HEAD:plexus-classworlds-1.2-0.a9.6.jpp6.src.rpm:1250542121
diff --git a/plexus-classworlds-1.2-build.xml b/plexus-classworlds-1.2-build.xml
new file mode 100644
index 0000000..b771eaa
--- /dev/null
+++ b/plexus-classworlds-1.2-build.xml
@@ -0,0 +1,99 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+ ================================= WARNING ================================
+ Junit isn't present in your $ANT_HOME/lib directory. Tests not executed.
+ ==========================================================================
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/plexus-classworlds-1.2-jpp-depmap.xml b/plexus-classworlds-1.2-jpp-depmap.xml
new file mode 100644
index 0000000..14cb08e
--- /dev/null
+++ b/plexus-classworlds-1.2-jpp-depmap.xml
@@ -0,0 +1,27 @@
+
+
+
+ junit
+ junit
+ 3.8.1
+
+
+ JPP
+ junit
+ 3.8.2
+
+
+
+
+ org.codehaus.plexus
+ plexus-utils
+ 1.0.4
+
+
+ JPP/plexus
+ utils
+ 1.4.5
+
+
+
+
diff --git a/plexus-classworlds-1.2-pom_xml.patch b/plexus-classworlds-1.2-pom_xml.patch
new file mode 100644
index 0000000..45bf2ca
--- /dev/null
+++ b/plexus-classworlds-1.2-pom_xml.patch
@@ -0,0 +1,16 @@
+--- pom.xml.sav 2007-08-14 16:29:45.000000000 +0200
++++ pom.xml 2007-08-14 16:30:40.000000000 +0200
+@@ -31,6 +31,13 @@
+ 2002
+
+
++ org.codehaus.plexus
++ plexus-utils
++ 1.0.4
++ jar
++ test
++
++
+ junit
+ junit
+ 3.8.1
diff --git a/plexus-classworlds-settings.xml b/plexus-classworlds-settings.xml
new file mode 100644
index 0000000..efe7bd7
--- /dev/null
+++ b/plexus-classworlds-settings.xml
@@ -0,0 +1,47 @@
+
+
+
+ JPP
+
+
+ internal
+ jpp
+ __JPP_URL_PLACEHOLDER__
+
+
+ external
+ jpp
+ __JAVADIR_PLACEHOLDER__
+
+
+ local
+ jpp
+ __MAVENREPO_DIR_PLACEHOLDER__
+
+
+
+
+ plugins-internal
+ plugins-internal
+ jpp
+ __JPP_URL_PLACEHOLDER__
+
+
+ plugins-external
+ plugins-external
+ jpp
+ __JAVADIR_PLACEHOLDER__
+
+
+ plugins-maven
+ plugins-maven
+ jpp
+ __MAVENDIR_PLUGIN_PLACEHOLDER__
+
+
+
+
+
+ JPP
+
+
diff --git a/plexus-classworlds.spec b/plexus-classworlds.spec
new file mode 100644
index 0000000..fd3124a
--- /dev/null
+++ b/plexus-classworlds.spec
@@ -0,0 +1,229 @@
+# Copyright (c) 2000-2007, JPackage Project
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the
+# distribution.
+# 3. Neither the name of the JPackage Project nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
+
+# If you don't want to build with maven, and use straight ant instead,
+# give rpmbuild option '--without maven'
+
+%define with_maven %{!?_without_maven:1}%{?_without_maven:0}
+%define without_maven %{?_without_maven:1}%{!?_without_maven:0}
+
+%define parent plexus
+%define subname classworlds
+%define namedversion 1.2-alpha-9
+
+Name: %{parent}-%{subname}
+Version: 1.2
+Release: 0.a9.6%{?dist}
+Epoch: 0
+Summary: Plexus Classworlds Classloader Framework
+License: ASL 2.0 and Plexus
+Group: Development/Java
+URL: http://plexus.codehaus.org/
+# svn export http://svn.codehaus.org/plexus/plexus-classworlds/tags/plexus-classworlds-1.2-alpha-9/ plexus-classworlds
+# tar czf plexus-classworlds-1.0-alpha-9.tar.gz plexus-classworlds/
+Source0: %{name}-%{namedversion}-src.tar.gz
+
+Source1: plexus-classworlds-1.2-build.xml
+Source3: plexus-classworlds-settings.xml
+Source4: plexus-classworlds-1.2-jpp-depmap.xml
+
+Patch0: plexus-classworlds-1.2-pom_xml.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+%if ! %{gcj_support}
+BuildArch: noarch
+%endif
+
+BuildRequires: jpackage-utils >= 0:1.7.3
+BuildRequires: ant >= 0:1.6.5
+BuildRequires: jakarta-commons-logging
+BuildRequires: xml-commons-jaxp-1.3-apis
+%if %{with_maven}
+BuildRequires: maven2 >= 2.0.4-10jpp
+BuildRequires: maven2-plugin-compiler
+BuildRequires: maven2-plugin-install
+BuildRequires: maven2-plugin-jar
+BuildRequires: maven2-plugin-javadoc
+BuildRequires: maven2-plugin-resources
+BuildRequires: maven2-plugin-surefire = 2.3
+BuildRequires: maven-surefire-provider-junit = 2.3
+BuildRequires: maven-doxia
+BuildRequires: maven-doxia-sitetools
+BuildRequires: maven-release
+%endif
+BuildRequires: plexus-utils
+%if %{gcj_support}
+BuildRequires: java-gcj-compat-devel
+Requires(post): java-gcj-compat
+Requires(postun): java-gcj-compat
+%endif
+
+Requires(post): jpackage-utils >= 0:1.7.2
+Requires(postun): jpackage-utils >= 0:1.7.2
+
+%if %{gcj_support}
+BuildRequires: java-gcj-compat-devel
+Requires(post): java-gcj-compat
+Requires(postun): java-gcj-compat
+%endif
+
+%description
+Classworlds is a framework for container developers
+who require complex manipulation of Java's ClassLoaders.
+Java's native ClassLoader mechanims and classes can cause
+much headache and confusion for certain types of
+application developers. Projects which involve dynamic
+loading of components or otherwise represent a 'container'
+can benefit from the classloading control provided by
+classworlds.
+
+%package javadoc
+Summary: Javadoc for %{name}
+Group: Development/Documentation
+Requires(post): /bin/rm,/bin/ln
+Requires(postun): /bin/rm
+
+%description javadoc
+Javadoc for %{name}.
+
+%prep
+%setup -q -n %{name}-%{namedversion}
+for j in $(find . -name "*.jar" | grep -v /test-data/ | grep -v /test-jars/); do
+ mv $j $j.no
+done
+cp %{SOURCE1} build.xml
+cp %{SOURCE3} settings.xml
+%patch0 -b .sav
+ln -sf $(build-classpath xml-commons-jaxp-1.3-apis) lib/xml-apis-1.3.02.jar
+ln -sf $(build-classpath ant) lib/ant-1.6.5.jar
+ln -sf $(build-classpath commons-logging) lib/commons-logging-1.0.3.jar
+
+%build
+
+export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
+mkdir -p $MAVEN_REPO_LOCAL
+
+# org.codehaus.plexus.classworlds.strategy.StrategyTest fails
+# upstream, so ignore failures for now
+
+%if %{with_maven}
+mvn-jpp \
+ -e \
+ -Dmaven.test.failure.ignore=true \
+ -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
+ install javadoc:javadoc
+
+%else
+export CLASSPATH=
+CLASSPATH=$CLASSPATH:target/classes:target/test-classes
+
+ant -Dbuild.sysclasspath=only jar javadoc
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+# jars
+install -d -m 755 $RPM_BUILD_ROOT%{_javadir}/plexus
+install -pm 644 target/%{name}-%{namedversion}.jar \
+ $RPM_BUILD_ROOT%{_javadir}/plexus/%{subname}-%{version}.jar
+%add_to_maven_depmap org.codehaus.plexus %{name} %{namedversion} JPP/%{parent} %{subname}
+
+(cd $RPM_BUILD_ROOT%{_javadir}/%{parent} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
+
+# pom
+install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
+install -pm 644 pom.xml $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{parent}-%{subname}.pom
+
+# javadoc
+install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
+cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
+ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
+
+%if %{gcj_support}
+%{_bindir}/aot-compile-rpm
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%update_maven_depmap
+%if %{gcj_support}
+if [ -x %{_bindir}/rebuild-gcj-db ]
+then
+ %{_bindir}/rebuild-gcj-db
+fi
+%endif
+
+%postun
+%update_maven_depmap
+%if %{gcj_support}
+if [ -x %{_bindir}/rebuild-gcj-db ]
+then
+ %{_bindir}/rebuild-gcj-db
+fi
+%endif
+
+%files
+%defattr(-,root,root,-)
+%{_javadir}/%{parent}
+%{_datadir}/maven2
+%{_mavendepmapfragdir}
+%if %{gcj_support}
+%dir %attr(-,root,root) %{_libdir}/gcj/%{name}
+%attr(-,root,root) %{_libdir}/gcj/%{name}/%{subname}*-%{version}.jar.*
+%endif
+
+%files javadoc
+%defattr(-,root,root,-)
+%doc %{_javadocdir}/*
+
+%changelog
+* Thu May 14 2009 Fernando Nasser 0:1.2-0.a9.6
+- Fix license specification
+
+* Tue Apr 28 2009 Yong Yang 0:1.2-0.a9.5
+- Add BRs maven2-plugin-surfire*, maven-doxia*
+- Rebuild with maven2-2.0.8 built in non-bootstrap mode
+
+* Mon Mar 16 2009 Yong Yang 0:1.2-0.a9.4
+- rebuild with new maven2 2.0.8 built in bootstrap mode
+
+* Tue Jan 13 2009 Yong Yang 0:1.2-0.a9.3jpp.1
+- re-build with maven
+
+* Tue Jan 06 2009 Yong Yang 0:1.2-0.a9.2jpp.1
+- Imported into devel from dbhole's maven 2.0.8 packages
+
+* Wed Jan 30 2008 Deepak Bhole 0:1.2-0.a9.1jpp.1
+- Initial build -- merged from JPackage
diff --git a/sources b/sources
index e69de29..e87a008 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+8d47284e931d04d75a264beea546aedc plexus-classworlds-1.2-alpha-9-src.tar.gz