update to 5.2.10 - security and bug fix release
This commit is contained in:
parent
bc3d8326a5
commit
ca0ae5dd38
@ -1 +1 @@
|
||||
php-5.2.9.tar.bz2
|
||||
php-5.2.10.tar.bz2
|
||||
|
113
php-5.2.10-gnusrc.patch
Normal file
113
php-5.2.10-gnusrc.patch
Normal file
@ -0,0 +1,113 @@
|
||||
diff -up php-5.2.10/configure.in.gnusrc php-5.2.10/configure.in
|
||||
--- php-5.2.10/configure.in.gnusrc 2009-06-17 14:22:41.000000000 +0200
|
||||
+++ php-5.2.10/configure.in 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.2.10/ext/interbase/interbase.c.gnusrc php-5.2.10/ext/interbase/interbase.c
|
||||
--- php-5.2.10/ext/interbase/interbase.c.gnusrc 2008-12-31 12:17:38.000000000 +0100
|
||||
+++ php-5.2.10/ext/interbase/interbase.c 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php-5.2.10/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.2.10/ext/pdo_firebird/firebird_driver.c
|
||||
--- php-5.2.10/ext/pdo_firebird/firebird_driver.c.gnusrc 2009-04-18 20:56:58.000000000 +0200
|
||||
+++ php-5.2.10/ext/pdo_firebird/firebird_driver.c 2009-06-21 10:01:52.000000000 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#ifdef ZEND_ENGINE_2
|
||||
diff -up php-5.2.10/ext/standard/file.c.gnusrc php-5.2.10/ext/standard/file.c
|
||||
--- php-5.2.10/ext/standard/file.c.gnusrc 2009-05-24 18:02:22.000000000 +0200
|
||||
+++ php-5.2.10/ext/standard/file.c 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
||||
|
||||
#ifdef HAVE_FNMATCH
|
||||
#ifndef _GNU_SOURCE
|
||||
-#define _GNU_SOURCE
|
||||
#endif
|
||||
#include <fnmatch.h>
|
||||
#endif
|
||||
diff -up php-5.2.10/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.2.10/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php-5.2.10/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-01-20 16:43:05.000000000 +0100
|
||||
+++ php-5.2.10/ext/zlib/zlib_fopen_wrapper.c 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c,v 1.46.2.1.2.7 2009/01/20 15:43:05 felipe Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php-5.2.10/main/php.h.gnusrc php-5.2.10/main/php.h
|
||||
--- php-5.2.10/main/php.h.gnusrc 2008-12-31 12:17:47.000000000 +0100
|
||||
+++ php-5.2.10/main/php.h 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php-5.2.10/main/streams/cast.c.gnusrc php-5.2.10/main/streams/cast.c
|
||||
--- php-5.2.10/main/streams/cast.c.gnusrc 2009-06-03 10:59:19.000000000 +0200
|
||||
+++ php-5.2.10/main/streams/cast.c 2009-06-21 10:02:10.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c,v 1.12.2.1.2.6 2009/06/03 08:59:19 kalle Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.2.10/main/streams/memory.c.gnusrc php-5.2.10/main/streams/memory.c
|
||||
--- php-5.2.10/main/streams/memory.c.gnusrc 2009-05-16 22:28:02.000000000 +0200
|
||||
+++ php-5.2.10/main/streams/memory.c 2009-06-21 10:02:25.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c,v 1.8.2.6.2.21 2009/05/16 20:28:02 lbarnaud Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
||||
diff -up php-5.2.10/main/streams/streams.c.gnusrc php-5.2.10/main/streams/streams.c
|
||||
--- php-5.2.10/main/streams/streams.c.gnusrc 2009-05-17 16:59:24.000000000 +0200
|
||||
+++ php-5.2.10/main/streams/streams.c 2009-06-21 10:02:42.000000000 +0200
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c,v 1.82.2.6.2.38 2009/05/17 14:59:24 lbarnaud Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.2.10/Zend/zend_language_parser.c.gnusrc php-5.2.10/Zend/zend_language_parser.c
|
||||
--- php-5.2.10/Zend/zend_language_parser.c.gnusrc 2009-06-17 14:35:33.000000000 +0200
|
||||
+++ php-5.2.10/Zend/zend_language_parser.c 2009-06-21 09:59:48.000000000 +0200
|
||||
@@ -356,6 +356,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
@ -1,113 +0,0 @@
|
||||
diff -up php-5.2.9/configure.in.gnusrc php-5.2.9/configure.in
|
||||
--- php-5.2.9/configure.in.gnusrc 2009-02-25 15:56:50.000000000 +0100
|
||||
+++ php-5.2.9/configure.in 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.2.9/ext/interbase/interbase.c.gnusrc php-5.2.9/ext/interbase/interbase.c
|
||||
--- php-5.2.9/ext/interbase/interbase.c.gnusrc 2008-12-31 12:17:38.000000000 +0100
|
||||
+++ php-5.2.9/ext/interbase/interbase.c 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php-5.2.9/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.2.9/ext/pdo_firebird/firebird_driver.c
|
||||
--- php-5.2.9/ext/pdo_firebird/firebird_driver.c.gnusrc 2008-12-31 12:17:41.000000000 +0100
|
||||
+++ php-5.2.9/ext/pdo_firebird/firebird_driver.c 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#include "php_ini.h"
|
||||
diff -up php-5.2.9/ext/standard/file.c.gnusrc php-5.2.9/ext/standard/file.c
|
||||
--- php-5.2.9/ext/standard/file.c.gnusrc 2008-12-31 12:17:44.000000000 +0100
|
||||
+++ php-5.2.9/ext/standard/file.c 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
||||
|
||||
#ifdef HAVE_FNMATCH
|
||||
#ifndef _GNU_SOURCE
|
||||
-#define _GNU_SOURCE
|
||||
#endif
|
||||
#include <fnmatch.h>
|
||||
#endif
|
||||
diff -up php-5.2.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.2.9/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php-5.2.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-01-20 16:43:05.000000000 +0100
|
||||
+++ php-5.2.9/ext/zlib/zlib_fopen_wrapper.c 2009-02-27 19:35:38.000000000 +0100
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c,v 1.46.2.1.2.7 2009/01/20 15:43:05 felipe Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php-5.2.9/main/php.h.gnusrc php-5.2.9/main/php.h
|
||||
--- php-5.2.9/main/php.h.gnusrc 2008-12-31 12:17:47.000000000 +0100
|
||||
+++ php-5.2.9/main/php.h 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php-5.2.9/main/streams/cast.c.gnusrc php-5.2.9/main/streams/cast.c
|
||||
--- php-5.2.9/main/streams/cast.c.gnusrc 2008-12-31 12:17:48.000000000 +0100
|
||||
+++ php-5.2.9/main/streams/cast.c 2009-02-27 19:36:07.000000000 +0100
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c,v 1.12.2.1.2.3 2008/12/31 11:17:48 sebastian Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.2.9/main/streams/memory.c.gnusrc php-5.2.9/main/streams/memory.c
|
||||
--- php-5.2.9/main/streams/memory.c.gnusrc 2008-12-31 12:17:48.000000000 +0100
|
||||
+++ php-5.2.9/main/streams/memory.c 2009-02-27 19:36:40.000000000 +0100
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c,v 1.8.2.6.2.20 2008/12/31 11:17:48 sebastian Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
||||
diff -up php-5.2.9/main/streams/streams.c.gnusrc php-5.2.9/main/streams/streams.c
|
||||
--- php-5.2.9/main/streams/streams.c.gnusrc 2009-01-08 20:21:25.000000000 +0100
|
||||
+++ php-5.2.9/main/streams/streams.c 2009-02-27 19:37:04.000000000 +0100
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c,v 1.82.2.6.2.33 2009/01/08 19:21:25 felipe Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.2.9/Zend/zend_language_parser.c.gnusrc php-5.2.9/Zend/zend_language_parser.c
|
||||
--- php-5.2.9/Zend/zend_language_parser.c.gnusrc 2009-02-25 16:39:52.000000000 +0100
|
||||
+++ php-5.2.9/Zend/zend_language_parser.c 2009-02-27 19:33:40.000000000 +0100
|
||||
@@ -356,6 +356,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
38
php.spec
38
php.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.2.9
|
||||
Version: 5.2.10
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
@ -18,7 +18,7 @@ Source2: php.ini
|
||||
Source3: macros.php
|
||||
|
||||
# Build fixes
|
||||
Patch1: php-5.2.9-gnusrc.patch
|
||||
Patch1: php-5.2.10-gnusrc.patch
|
||||
Patch2: php-5.2.8-install.patch
|
||||
Patch3: php-5.2.4-norpath.patch
|
||||
Patch4: php-5.2.8-phpize64.patch
|
||||
@ -98,7 +98,7 @@ Provides: php-ftp, php-gettext, php-gmp, php-hash, php-iconv, php-libxml
|
||||
Provides: php-reflection, php-session, php-shmop, php-simplexml, php-sockets
|
||||
Provides: php-spl, php-tokenizer, php-openssl, php-pcre
|
||||
Provides: php-zlib, php-json, php-zip, php-dbase
|
||||
Obsoletes: php-openssl, php-pecl-zip, php-json, php-dbase
|
||||
Obsoletes: php-openssl, php-pecl-zip, php-pecl-json, php-json, php-dbase
|
||||
|
||||
%description common
|
||||
The php-common package contains files used by both the php
|
||||
@ -229,6 +229,26 @@ BuildRequires: libxml2-devel
|
||||
The php-soap package contains a dynamic shared object that will add
|
||||
support to PHP for using the SOAP web services protocol.
|
||||
|
||||
%package interbase
|
||||
Summary: A module for PHP applications that use Interbase/Firebird databases
|
||||
Group: Development/Languages
|
||||
BuildRequires: firebird-devel
|
||||
Requires: php-common = %{version}-%{release}, php-pdo
|
||||
Provides: php_database, php-firebird, php-pdo_firebird
|
||||
|
||||
%description interbase
|
||||
The php-interbase package contains a dynamic shared object that will add
|
||||
database support through Interbase/Firebird to PHP.
|
||||
|
||||
InterBase is the name of the closed-source variant of this RDBMS that was
|
||||
developed by Borland/Inprise.
|
||||
|
||||
Firebird is a commercially independent project of C and C++ programmers,
|
||||
technical advisors and supporters developing and enhancing a multi-platform
|
||||
relational database management system based on the source code released by
|
||||
Inprise Corp (now known as Borland Software Corp) under the InterBase Public
|
||||
License.
|
||||
|
||||
%package snmp
|
||||
Summary: A module for PHP applications that query SNMP-managed devices
|
||||
Group: Development/Languages
|
||||
@ -535,6 +555,8 @@ build --enable-force-cgi-redirect \
|
||||
--with-ldap=shared --with-ldap-sasl \
|
||||
--with-mysql=shared,%{_prefix} \
|
||||
--with-mysqli=shared,%{_bindir}/mysql_config \
|
||||
--with-interbase=shared,%{_libdir}/firebird \
|
||||
--with-pdo-firebird=shared,%{_libdir}/firebird \
|
||||
--enable-dom=shared \
|
||||
--with-pgsql=shared \
|
||||
--enable-wddx=shared \
|
||||
@ -623,7 +645,7 @@ make -C build-cgi install INSTALL_ROOT=$RPM_BUILD_ROOT
|
||||
|
||||
# Install the default configuration file and icons
|
||||
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/
|
||||
install -m 644 $RPM_SOURCE_DIR/php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
|
||||
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
|
||||
install -m 755 -d $RPM_BUILD_ROOT%{contentdir}/icons
|
||||
install -m 644 *.gif $RPM_BUILD_ROOT%{contentdir}/icons/
|
||||
|
||||
@ -651,7 +673,7 @@ for mod in pgsql mysql mysqli odbc ldap snmp xmlrpc imap \
|
||||
mbstring ncurses gd dom xsl soap bcmath dba xmlreader xmlwriter \
|
||||
pdo pdo_mysql pdo_pgsql pdo_odbc pdo_sqlite json zip \
|
||||
dbase mcrypt mhash tidy pdo_dblib mssql pspell curl wddx \
|
||||
posix sysvshm sysvsem sysvmsg recode; do
|
||||
posix sysvshm sysvsem sysvmsg recode interbase pdo_firebird; do
|
||||
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${mod}.ini <<EOF
|
||||
; Enable ${mod} extension module
|
||||
extension=${mod}.so
|
||||
@ -673,6 +695,7 @@ cat files.pdo_dblib >> files.mssql
|
||||
cat files.pdo_mysql >> files.mysql
|
||||
cat files.pdo_pgsql >> files.pgsql
|
||||
cat files.pdo_odbc >> files.odbc
|
||||
cat files.pdo_firebird >> files.interbase
|
||||
|
||||
# sysv* and posix in packaged in php-process
|
||||
cat files.sysv* files.posix > files.process
|
||||
@ -775,8 +798,13 @@ rm files.* macros.php
|
||||
%files pspell -f files.pspell
|
||||
%files process -f files.process
|
||||
%files recode -f files.recode
|
||||
%files interbase -f files.interbase
|
||||
|
||||
%changelog
|
||||
* Sat Jun 21 2009 Remi Collet <Fedora@famillecollet.com> 5.2.10-1
|
||||
- update to 5.2.10
|
||||
- add interbase sub-package
|
||||
|
||||
* Sat Feb 28 2009 Remi Collet <Fedora@FamilleCollet.com> - 5.2.9-1
|
||||
- update to 5.2.9
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user