114 lines
4.1 KiB
Diff
114 lines
4.1 KiB
Diff
diff -up php-5.2.10/configure.in.gnusrc php-5.2.10/configure.in
|
|
--- php-5.2.10/configure.in.gnusrc 2009-06-17 14:22:41.000000000 +0200
|
|
+++ php-5.2.10/configure.in 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
|
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
|
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
|
|
|
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
|
+
|
|
dnl Setting up the PHP version based on the information above.
|
|
dnl -------------------------------------------------------------------------
|
|
|
|
diff -up php-5.2.10/ext/interbase/interbase.c.gnusrc php-5.2.10/ext/interbase/interbase.c
|
|
--- php-5.2.10/ext/interbase/interbase.c.gnusrc 2008-12-31 12:17:38.000000000 +0100
|
|
+++ php-5.2.10/ext/interbase/interbase.c 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -24,7 +24,6 @@
|
|
#include "config.h"
|
|
#endif
|
|
|
|
-#define _GNU_SOURCE
|
|
|
|
#include "php.h"
|
|
|
|
diff -up php-5.2.10/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.2.10/ext/pdo_firebird/firebird_driver.c
|
|
--- php-5.2.10/ext/pdo_firebird/firebird_driver.c.gnusrc 2009-04-18 20:56:58.000000000 +0200
|
|
+++ php-5.2.10/ext/pdo_firebird/firebird_driver.c 2009-06-21 10:01:52.000000000 +0200
|
|
@@ -22,7 +22,6 @@
|
|
#include "config.h"
|
|
#endif
|
|
|
|
-#define _GNU_SOURCE
|
|
|
|
#include "php.h"
|
|
#ifdef ZEND_ENGINE_2
|
|
diff -up php-5.2.10/ext/standard/file.c.gnusrc php-5.2.10/ext/standard/file.c
|
|
--- php-5.2.10/ext/standard/file.c.gnusrc 2009-05-24 18:02:22.000000000 +0200
|
|
+++ php-5.2.10/ext/standard/file.c 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
|
|
|
#ifdef HAVE_FNMATCH
|
|
#ifndef _GNU_SOURCE
|
|
-#define _GNU_SOURCE
|
|
#endif
|
|
#include <fnmatch.h>
|
|
#endif
|
|
diff -up php-5.2.10/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.2.10/ext/zlib/zlib_fopen_wrapper.c
|
|
--- php-5.2.10/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-01-20 16:43:05.000000000 +0100
|
|
+++ php-5.2.10/ext/zlib/zlib_fopen_wrapper.c 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -19,8 +19,6 @@
|
|
|
|
/* $Id: zlib_fopen_wrapper.c,v 1.46.2.1.2.7 2009/01/20 15:43:05 felipe Exp $ */
|
|
|
|
-#define _GNU_SOURCE
|
|
-
|
|
#include "php.h"
|
|
#include "php_zlib.h"
|
|
#include "fopen_wrappers.h"
|
|
diff -up php-5.2.10/main/php.h.gnusrc php-5.2.10/main/php.h
|
|
--- php-5.2.10/main/php.h.gnusrc 2008-12-31 12:17:47.000000000 +0100
|
|
+++ php-5.2.10/main/php.h 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -30,6 +30,7 @@
|
|
#define PHP_HAVE_STREAMS
|
|
#define YYDEBUG 0
|
|
|
|
+#include "php_config.h"
|
|
#include "php_version.h"
|
|
#include "zend.h"
|
|
#include "zend_qsort.h"
|
|
diff -up php-5.2.10/main/streams/cast.c.gnusrc php-5.2.10/main/streams/cast.c
|
|
--- php-5.2.10/main/streams/cast.c.gnusrc 2009-06-03 10:59:19.000000000 +0200
|
|
+++ php-5.2.10/main/streams/cast.c 2009-06-21 10:02:10.000000000 +0200
|
|
@@ -18,7 +18,6 @@
|
|
|
|
/* $Id: cast.c,v 1.12.2.1.2.6 2009/06/03 08:59:19 kalle Exp $ */
|
|
|
|
-#define _GNU_SOURCE
|
|
#include "php.h"
|
|
#include "php_globals.h"
|
|
#include "php_network.h"
|
|
diff -up php-5.2.10/main/streams/memory.c.gnusrc php-5.2.10/main/streams/memory.c
|
|
--- php-5.2.10/main/streams/memory.c.gnusrc 2009-05-16 22:28:02.000000000 +0200
|
|
+++ php-5.2.10/main/streams/memory.c 2009-06-21 10:02:25.000000000 +0200
|
|
@@ -18,7 +18,6 @@
|
|
|
|
/* $Id: memory.c,v 1.8.2.6.2.21 2009/05/16 20:28:02 lbarnaud Exp $ */
|
|
|
|
-#define _GNU_SOURCE
|
|
#include "php.h"
|
|
|
|
PHPAPI int php_url_decode(char *str, int len);
|
|
diff -up php-5.2.10/main/streams/streams.c.gnusrc php-5.2.10/main/streams/streams.c
|
|
--- php-5.2.10/main/streams/streams.c.gnusrc 2009-05-17 16:59:24.000000000 +0200
|
|
+++ php-5.2.10/main/streams/streams.c 2009-06-21 10:02:42.000000000 +0200
|
|
@@ -21,7 +21,6 @@
|
|
|
|
/* $Id: streams.c,v 1.82.2.6.2.38 2009/05/17 14:59:24 lbarnaud Exp $ */
|
|
|
|
-#define _GNU_SOURCE
|
|
#include "php.h"
|
|
#include "php_globals.h"
|
|
#include "php_network.h"
|
|
diff -up php-5.2.10/Zend/zend_language_parser.c.gnusrc php-5.2.10/Zend/zend_language_parser.c
|
|
--- php-5.2.10/Zend/zend_language_parser.c.gnusrc 2009-06-17 14:35:33.000000000 +0200
|
|
+++ php-5.2.10/Zend/zend_language_parser.c 2009-06-21 09:59:48.000000000 +0200
|
|
@@ -356,6 +356,8 @@
|
|
#include "zend_API.h"
|
|
#include "zend_constants.h"
|
|
|
|
+#include <string.h>
|
|
+
|
|
|
|
#define YYERROR_VERBOSE
|
|
#define YYSTYPE znode
|