* Wed Nov 25 2009 Joe Orton <jorton@redhat.com> - 5.3.1-2
- fix build with autoconf 2.6x
This commit is contained in:
parent
da991dabd3
commit
8c9c36e8af
79
php-5.3.1-aconf26x.patch
Normal file
79
php-5.3.1-aconf26x.patch
Normal file
@ -0,0 +1,79 @@
|
|||||||
|
|
||||||
|
Fix use of divert() to work with autoconf 2.6x.
|
||||||
|
|
||||||
|
--- php-5.3.1/configure.in.aconf26x
|
||||||
|
+++ php-5.3.1/configure.in
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
## $Id$ -*- autoconf -*-
|
||||||
|
dnl ## Process this file with autoconf to produce a configure script.
|
||||||
|
|
||||||
|
-divert(1)
|
||||||
|
+divert(1001)
|
||||||
|
|
||||||
|
dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
||||||
|
dnl ## set the PHP version, deal with platform-specific compile
|
||||||
|
@@ -307,7 +307,7 @@ sinclude(TSRM/threads.m4)
|
||||||
|
sinclude(TSRM/tsrm.m4)
|
||||||
|
|
||||||
|
|
||||||
|
-divert(2)
|
||||||
|
+divert(1002)
|
||||||
|
|
||||||
|
dnl ## Diversion 2 is where we set PHP-specific options and come up
|
||||||
|
dnl ## with reasonable default values for them. We check for pthreads here
|
||||||
|
@@ -346,7 +346,7 @@ if test "$enable_maintainer_zts" = "yes"
|
||||||
|
PTHREADS_FLAGS
|
||||||
|
fi
|
||||||
|
|
||||||
|
-divert(3)
|
||||||
|
+divert(1003)
|
||||||
|
|
||||||
|
dnl ## In diversion 3 we check for compile-time options to the PHP
|
||||||
|
dnl ## core and how to deal with different system dependencies.
|
||||||
|
@@ -693,7 +693,7 @@ if test "x$php_crypt_r" = "x1"; then
|
||||||
|
PHP_CRYPT_R_STYLE
|
||||||
|
fi
|
||||||
|
|
||||||
|
-divert(4)
|
||||||
|
+divert(1004)
|
||||||
|
|
||||||
|
dnl ## In diversion 4 we check user-configurable general settings.
|
||||||
|
|
||||||
|
@@ -934,7 +934,7 @@ else
|
||||||
|
AC_MSG_RESULT([using system default])
|
||||||
|
fi
|
||||||
|
|
||||||
|
-divert(5)
|
||||||
|
+divert(1005)
|
||||||
|
|
||||||
|
dnl ## In diversion 5 we check which extensions should be compiled.
|
||||||
|
dnl ## All of these are normally in the extension directories.
|
||||||
|
--- php-5.3.1/ext/standard/config.m4.aconf26x
|
||||||
|
+++ php-5.3.1/ext/standard/config.m4
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
dnl $Id$ -*- autoconf -*-
|
||||||
|
|
||||||
|
-divert(3)dnl
|
||||||
|
+divert(1003)dnl
|
||||||
|
|
||||||
|
dnl
|
||||||
|
dnl Check if flush should be called explicitly after buffered io
|
||||||
|
@@ -220,7 +220,7 @@ dnl
|
||||||
|
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
|
||||||
|
AC_FUNC_FNMATCH
|
||||||
|
|
||||||
|
-divert(5)dnl
|
||||||
|
+divert(1005)dnl
|
||||||
|
|
||||||
|
dnl
|
||||||
|
dnl Check if there is a support means of creating a new process
|
||||||
|
--- php-5.3.1/scripts/phpize.m4.aconf26x
|
||||||
|
+++ php-5.3.1/scripts/phpize.m4
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
dnl This file becomes configure.in for self-contained extensions.
|
||||||
|
|
||||||
|
-divert(1)
|
||||||
|
+divert(1001)
|
||||||
|
|
||||||
|
AC_PREREQ(2.13)
|
||||||
|
AC_INIT(config.m4)
|
8
php.spec
8
php.spec
@ -14,7 +14,7 @@
|
|||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.3.1
|
Version: 5.3.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: PHP
|
License: PHP
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -32,6 +32,7 @@ Patch4: php-5.3.0-phpize64.patch
|
|||||||
Patch5: php-5.2.0-includedir.patch
|
Patch5: php-5.2.0-includedir.patch
|
||||||
Patch6: php-5.2.4-embed.patch
|
Patch6: php-5.2.4-embed.patch
|
||||||
Patch7: php-5.3.0-recode.patch
|
Patch7: php-5.3.0-recode.patch
|
||||||
|
Patch8: php-5.3.1-aconf26x.patch
|
||||||
# Filed upstream: http://bugs.php.net/50209
|
# Filed upstream: http://bugs.php.net/50209
|
||||||
Patch9: php-5.3.0-libedit.patch
|
Patch9: php-5.3.0-libedit.patch
|
||||||
|
|
||||||
@ -430,6 +431,7 @@ support for using the enchant library to PHP.
|
|||||||
%patch5 -p1 -b .includedir
|
%patch5 -p1 -b .includedir
|
||||||
%patch6 -p1 -b .embed
|
%patch6 -p1 -b .embed
|
||||||
%patch7 -p1 -b .recode
|
%patch7 -p1 -b .recode
|
||||||
|
%patch8 -p1 -b .aconf26x
|
||||||
%patch9 -p1 -b .libedit
|
%patch9 -p1 -b .libedit
|
||||||
|
|
||||||
%patch20 -p1 -b .shutdown
|
%patch20 -p1 -b .shutdown
|
||||||
@ -517,6 +519,7 @@ libtoolize --force --copy
|
|||||||
cat `aclocal --print-ac-dir`/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >build/libtool.m4
|
cat `aclocal --print-ac-dir`/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >build/libtool.m4
|
||||||
|
|
||||||
# Regenerate configure scripts (patches change config.m4's)
|
# Regenerate configure scripts (patches change config.m4's)
|
||||||
|
touch configure.in
|
||||||
./buildconf --force
|
./buildconf --force
|
||||||
|
|
||||||
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
|
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
|
||||||
@ -860,6 +863,9 @@ rm files.* macros.php
|
|||||||
%files enchant -f files.enchant
|
%files enchant -f files.enchant
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 25 2009 Joe Orton <jorton@redhat.com> - 5.3.1-2
|
||||||
|
- fix build with autoconf 2.6x
|
||||||
|
|
||||||
* Fri Nov 20 2009 Remi Collet <Fedora@famillecollet.com> 5.3.1-1
|
* Fri Nov 20 2009 Remi Collet <Fedora@famillecollet.com> 5.3.1-1
|
||||||
- update to 5.3.1
|
- update to 5.3.1
|
||||||
- remove openssl patch (merged upstream)
|
- remove openssl patch (merged upstream)
|
||||||
|
Loading…
Reference in New Issue
Block a user