8c9c36e8af
- fix build with autoconf 2.6x
80 lines
1.9 KiB
Diff
80 lines
1.9 KiB
Diff
|
|
Fix use of divert() to work with autoconf 2.6x.
|
|
|
|
--- php-5.3.1/configure.in.aconf26x
|
|
+++ php-5.3.1/configure.in
|
|
@@ -1,7 +1,7 @@
|
|
## $Id$ -*- autoconf -*-
|
|
dnl ## Process this file with autoconf to produce a configure script.
|
|
|
|
-divert(1)
|
|
+divert(1001)
|
|
|
|
dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
|
dnl ## set the PHP version, deal with platform-specific compile
|
|
@@ -307,7 +307,7 @@ sinclude(TSRM/threads.m4)
|
|
sinclude(TSRM/tsrm.m4)
|
|
|
|
|
|
-divert(2)
|
|
+divert(1002)
|
|
|
|
dnl ## Diversion 2 is where we set PHP-specific options and come up
|
|
dnl ## with reasonable default values for them. We check for pthreads here
|
|
@@ -346,7 +346,7 @@ if test "$enable_maintainer_zts" = "yes"
|
|
PTHREADS_FLAGS
|
|
fi
|
|
|
|
-divert(3)
|
|
+divert(1003)
|
|
|
|
dnl ## In diversion 3 we check for compile-time options to the PHP
|
|
dnl ## core and how to deal with different system dependencies.
|
|
@@ -693,7 +693,7 @@ if test "x$php_crypt_r" = "x1"; then
|
|
PHP_CRYPT_R_STYLE
|
|
fi
|
|
|
|
-divert(4)
|
|
+divert(1004)
|
|
|
|
dnl ## In diversion 4 we check user-configurable general settings.
|
|
|
|
@@ -934,7 +934,7 @@ else
|
|
AC_MSG_RESULT([using system default])
|
|
fi
|
|
|
|
-divert(5)
|
|
+divert(1005)
|
|
|
|
dnl ## In diversion 5 we check which extensions should be compiled.
|
|
dnl ## All of these are normally in the extension directories.
|
|
--- php-5.3.1/ext/standard/config.m4.aconf26x
|
|
+++ php-5.3.1/ext/standard/config.m4
|
|
@@ -1,6 +1,6 @@
|
|
dnl $Id$ -*- autoconf -*-
|
|
|
|
-divert(3)dnl
|
|
+divert(1003)dnl
|
|
|
|
dnl
|
|
dnl Check if flush should be called explicitly after buffered io
|
|
@@ -220,7 +220,7 @@ dnl
|
|
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
|
|
AC_FUNC_FNMATCH
|
|
|
|
-divert(5)dnl
|
|
+divert(1005)dnl
|
|
|
|
dnl
|
|
dnl Check if there is a support means of creating a new process
|
|
--- php-5.3.1/scripts/phpize.m4.aconf26x
|
|
+++ php-5.3.1/scripts/phpize.m4
|
|
@@ -1,6 +1,6 @@
|
|
dnl This file becomes configure.in for self-contained extensions.
|
|
|
|
-divert(1)
|
|
+divert(1001)
|
|
|
|
AC_PREREQ(2.13)
|
|
AC_INIT(config.m4)
|