Update to 0.20

- New upstream release 0.20
  - Methods were renamed for brevity: s/_package//
  - Convert Package::Stash into a module which loads either the XS or pure perl
    implementation, depending on what's available
  - Use Test::Fatal instead of Test::Exception
  - Use Dist::CheckConflicts
  - Silence deprecation warnings for the method renaming for now
- New script and manpage: package-stash-conflicts
- New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
- New build requirements:
  - perl(Dist::CheckConflicts)
  - perl(Package::DeprecationManager)
  - perl(Package::Stash::XS)
  - perl(Test::LeakTrace)
  - perl(Test::Requires)
  - perl(Test::Script)
- Update patches for old ExtUtils::MakeMaker and Test::More versions
- Add new patch to work around absence of Test::Requires in EPEL-4
- Require perl(Package::Stash::XS) for performance and consistency
- Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
This commit is contained in:
Paul Howarth 2011-01-07 12:09:42 +00:00
parent c8cbe39a53
commit a39aa3c820
7 changed files with 411 additions and 154 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/Package-Stash-0.08.tar.gz /Package-Stash-0.20.tar.gz

View File

@ -1,131 +0,0 @@
diff -up Package-Stash-0.08/t/01-basic.t.orig Package-Stash-0.08/t/01-basic.t
--- Package-Stash-0.08/t/01-basic.t.orig 2010-09-19 02:17:49.000000000 +0100
+++ Package-Stash-0.08/t/01-basic.t 2010-09-20 11:37:09.187162663 +0100
@@ -1,7 +1,7 @@
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 110;
use Test::Exception;
use Package::Stash;
@@ -323,5 +323,3 @@
);
}
}
-
-done_testing;
diff -up Package-Stash-0.05/t/02-extension.t.orig Package-Stash-0.05/t/02-extension.t
--- Package-Stash-0.05/t/02-extension.t.orig 2010-05-14 17:41:34.000000000 +0100
+++ Package-Stash-0.05/t/02-extension.t 2010-06-07 09:53:18.571099744 +0100
@@ -1,7 +1,7 @@
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 15;
use Test::Exception;
{
@@ -66,5 +66,3 @@ lives_ok {
} '... created %Foo::baz successfully';
ok(!defined($Foo::{baz}), '... the %baz slot has still not been created');
-
-done_testing;
diff -up Package-Stash-0.05/t/03-io.t.orig Package-Stash-0.05/t/03-io.t
--- Package-Stash-0.05/t/03-io.t.orig 2010-05-14 17:41:34.000000000 +0100
+++ Package-Stash-0.05/t/03-io.t 2010-06-07 09:53:18.575099708 +0100
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 11;
use Test::Exception;
{
@@ -46,5 +46,3 @@ use Package::Stash;
ok($stash->has_package_symbol('baz'), "has baz");
is($stash->get_package_symbol('baz'), *Foo::foo{IO}, "got the right baz");
}
-
-done_testing;
diff -up Package-Stash-0.05/t/04-get.t.orig Package-Stash-0.05/t/04-get.t
--- Package-Stash-0.05/t/04-get.t.orig 2010-06-13 18:13:45.000000000 +0100
+++ Package-Stash-0.05/t/04-get.t 2010-06-14 14:32:39.855811492 +0100
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 10;
use Package::Stash;
@@ -62,5 +62,3 @@
is_deeply($stash->get_or_add_package_symbol('@foo'), [1],
"got the right variable");
}
-
-done_testing;
diff -up Package-Stash-0.05/t/05-isa.t.orig Package-Stash-0.05/t/05-isa.t
--- Package-Stash-0.05/t/05-isa.t.orig 2010-05-14 17:41:34.000000000 +0100
+++ Package-Stash-0.05/t/05-isa.t 2010-06-07 09:55:14.591128547 +0100
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 1;
use Package::Stash;
@@ -16,6 +16,8 @@ use Package::Stash;
my $stash = Package::Stash->new('Foo');
my @ISA = ('Bar');
@{$stash->get_package_symbol('@ISA')} = @ISA;
-isa_ok('Foo', 'Bar');
-done_testing;
+SKIP: {
+skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
+isa_ok('Foo', 'Bar');
+}
diff -up Package-Stash-0.05/t/06-addsub.t.orig Package-Stash-0.05/t/06-addsub.t
--- Package-Stash-0.05/t/06-addsub.t.orig 2010-06-13 18:13:45.000000000 +0100
+++ Package-Stash-0.05/t/06-addsub.t 2010-06-14 14:14:10.462975877 +0100
@@ -1,7 +1,7 @@
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 7;
use Test::Exception;
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
@@ -41,5 +41,3 @@
is $DB::sub{'Foo::dunk'}, sprintf "%s:%d-%d", "FileName", 100, 199,
'... got the right %DB::sub value for dunk with specified args';
-
-done_testing;
diff -up Package-Stash-0.05/t/10-synopsis.t.orig Package-Stash-0.05/t/10-synopsis.t
--- Package-Stash-0.05/t/10-synopsis.t.orig 2010-05-14 17:41:34.000000000 +0100
+++ Package-Stash-0.05/t/10-synopsis.t 2010-06-07 09:53:18.596164680 +0100
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 3;
use Package::Stash;
@@ -14,5 +14,3 @@ $stash->add_package_symbol('%foo', {bar
ok(!$stash->has_package_symbol('$foo'), "doesn't have anything in scalar slot");
my $namespace = $stash->namespace;
is_deeply(*{ $namespace->{foo} }{HASH}, {bar => 1}, "namespace works properly");
-
-done_testing;

View File

@ -1,30 +1,30 @@
--- Package-Stash-0.08/Makefile.PL 2010-09-19 02:17:49.000000000 +0100 --- Package-Stash-0.20/Makefile.PL.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.08/Makefile.PL 2010-09-20 11:34:35.619285663 +0100 +++ Package-Stash-0.20/Makefile.PL 2011-01-04 13:33:09.585268028 +0000
@@ -4,7 +4,7 @@ @@ -3,7 +3,7 @@
BEGIN { require 5.8.3; }
use strict;
use warnings;
-use ExtUtils::MakeMaker 6.31; -use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker; +use ExtUtils::MakeMaker;
check_conflicts();
my %WriteMakefileArgs = (
@@ -16,7 +16,7 @@ @@ -16,7 +16,7 @@
'Test::More' => '0.88'
}, },
'CONFIGURE_REQUIRES' => { 'CONFIGURE_REQUIRES' => {
'Dist::CheckConflicts' => '0.02',
- 'ExtUtils::MakeMaker' => '6.31' - 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '0' + 'ExtUtils::MakeMaker' => '0'
}, },
'DISTNAME' => 'Package-Stash', 'DISTNAME' => 'Package-Stash',
'EXE_FILES' => [], 'EXE_FILES' => [
@@ -48,6 +48,9 @@ @@ -49,6 +49,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES} }
unless eval { ExtUtils::MakeMaker->VERSION(6.52) }; }
+delete $WriteMakefileArgs{LICENSE} +delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) }; + unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+ +
WriteMakefile(%WriteMakefileArgs); delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

View File

@ -0,0 +1,48 @@
diff -up Package-Stash-0.20/t/20-leaks.t.orig Package-Stash-0.20/t/20-leaks.t
--- Package-Stash-0.20/t/20-leaks.t.orig 2011-01-04 16:31:03.000000000 +0000
+++ Package-Stash-0.20/t/20-leaks.t 2011-01-04 16:32:31.507953903 +0000
@@ -4,8 +4,12 @@ use warnings;
use lib 't/lib';
use Test::More;
use Test::Fatal;
-use Test::Requires 'Test::LeakTrace';
-plan tests => 25;
+eval "use Test::LeakTrace";
+if ($@) {
+ plan skip_all => "Test::LeakTrace required for this test";
+} else {
+ plan tests => 25;
+}
use Package::Stash;
use Symbol;
diff -up Package-Stash-0.20/t/21-leaks-debug.t.orig Package-Stash-0.20/t/21-leaks-debug.t
--- Package-Stash-0.20/t/21-leaks-debug.t.orig 2011-01-04 16:31:03.000000000 +0000
+++ Package-Stash-0.20/t/21-leaks-debug.t 2011-01-04 16:32:53.018560833 +0000
@@ -4,8 +4,12 @@ use warnings;
use lib 't/lib';
use Test::More;
use Test::Fatal;
-use Test::Requires 'Test::LeakTrace';
-plan tests => 25;
+eval "use Test::LeakTrace";
+if ($@) {
+ plan skip_all => "Test::LeakTrace required for this test";
+} else {
+ plan tests => 25;
+}
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
diff -up Package-Stash-0.20/t/impl-selection/11-basic-xs.t.orig Package-Stash-0.20/t/impl-selection/11-basic-xs.t
--- Package-Stash-0.20/t/impl-selection/11-basic-xs.t.orig 2011-01-04 16:31:03.410468453 +0000
+++ Package-Stash-0.20/t/impl-selection/11-basic-xs.t 2011-01-04 16:31:03.413468538 +0000
@@ -3,7 +3,7 @@ use strict;
use warnings;
use Test::More tests => 124;
use Test::Fatal;
-use Test::Requires 'Package::Stash::XS';
+use Package::Stash::XS;
BEGIN { $Package::Stash::IMPLEMENTATION = 'XS' }

View File

@ -0,0 +1,294 @@
diff -up Package-Stash-0.20/t/01-basic.t.orig Package-Stash-0.20/t/01-basic.t
--- Package-Stash-0.20/t/01-basic.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/01-basic.t 2011-01-04 16:27:28.114396136 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 122;
use Test::Fatal;
use Package::Stash;
@@ -416,5 +416,3 @@ like(exception {
"list_all_symbols CODE",
);
}
-
-done_testing;
diff -up Package-Stash-0.20/t/02-extension.t.orig Package-Stash-0.20/t/02-extension.t
--- Package-Stash-0.20/t/02-extension.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/02-extension.t 2011-01-04 16:27:28.145397010 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 15;
use Test::Fatal;
{
@@ -70,5 +70,3 @@ is(exception {
}, undef, '... created %Foo::baz successfully');
ok(!defined($Foo::{baz}), '... the %baz slot has still not been created');
-
-done_testing;
diff -up Package-Stash-0.20/t/03-io.t.orig Package-Stash-0.20/t/03-io.t
--- Package-Stash-0.20/t/03-io.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/03-io.t 2011-01-04 16:27:28.145397010 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 11;
use Test::Fatal;
{
@@ -47,5 +47,3 @@ use Package::Stash;
ok($stash->has_symbol('baz'), "has baz");
is($stash->get_symbol('baz'), *Foo::foo{IO}, "got the right baz");
}
-
-done_testing;
diff -up Package-Stash-0.20/t/04-get.t.orig Package-Stash-0.20/t/04-get.t
--- Package-Stash-0.20/t/04-get.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/04-get.t 2011-01-04 16:27:28.146397038 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 36;
use Package::Stash;
use Scalar::Util;
@@ -182,5 +182,3 @@ use Scalar::Util;
"stash has the right variable");
}
}
-
-done_testing;
diff -up Package-Stash-0.20/t/05-isa.t.orig Package-Stash-0.20/t/05-isa.t
--- Package-Stash-0.20/t/05-isa.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/05-isa.t 2011-01-04 16:27:28.146397038 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 1;
use Package::Stash;
@@ -17,6 +17,7 @@ use Package::Stash;
my $stash = Package::Stash->new('Foo');
my @ISA = ('Bar');
@{$stash->get_or_add_symbol('@ISA')} = @ISA;
+SKIP: {
+skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
isa_ok('Foo', 'Bar');
-
-done_testing;
+}
diff -up Package-Stash-0.20/t/06-addsub.t.orig Package-Stash-0.20/t/06-addsub.t
--- Package-Stash-0.20/t/06-addsub.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/06-addsub.t 2011-01-04 16:27:28.147397066 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 7;
use Test::Fatal;
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
@@ -42,5 +42,3 @@ $foo_stash->add_symbol(
is $DB::sub{'Foo::dunk'}, sprintf "%s:%d-%d", "FileName", 100, 199,
'... got the right %DB::sub value for dunk with specified args';
-
-done_testing;
diff -up Package-Stash-0.20/t/07-edge-cases.t.orig Package-Stash-0.20/t/07-edge-cases.t
--- Package-Stash-0.20/t/07-edge-cases.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/07-edge-cases.t 2011-01-04 16:27:28.147397066 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 11;
use Package::Stash;
@@ -51,5 +51,3 @@ is(ref($constant), 'CODE', "expanded a c
# was here)
is(ref($stash->get_symbol('$glob')), '', "nothing yet");
is(ref($stash->get_or_add_symbol('$glob')), 'SCALAR', "got an empty scalar");
-
-done_testing;
diff -up Package-Stash-0.20/t/10-synopsis.t.orig Package-Stash-0.20/t/10-synopsis.t
--- Package-Stash-0.20/t/10-synopsis.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/10-synopsis.t 2011-01-04 16:27:28.147397066 +0000
@@ -2,7 +2,7 @@
use strict;
use warnings;
use lib 't/lib';
-use Test::More;
+use Test::More tests => 3;
use Package::Stash;
@@ -15,5 +15,3 @@ $stash->add_symbol('%foo', {bar => 1});
ok(!$stash->has_symbol('$foo'), "doesn't have anything in scalar slot");
my $namespace = $stash->namespace;
is_deeply(*{ $namespace->{foo} }{HASH}, {bar => 1}, "namespace works properly");
-
-done_testing;
diff -up Package-Stash-0.20/t/20-leaks.t.orig Package-Stash-0.20/t/20-leaks.t
--- Package-Stash-0.20/t/20-leaks.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/20-leaks.t 2011-01-04 16:28:24.656990649 +0000
@@ -5,6 +5,7 @@ use lib 't/lib';
use Test::More;
use Test::Fatal;
use Test::Requires 'Test::LeakTrace';
+plan tests => 25;
use Package::Stash;
use Symbol;
@@ -136,7 +137,10 @@ use Symbol;
ok($foo->has_symbol('@ISA'));
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
+ SKIP: {
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
isa_ok('Foo', 'Exporter');
+ }
}
{
@@ -190,5 +194,3 @@ use Symbol;
eval { $foo->get_or_add_symbol('&blorg') };
} "doesn't leak on errors";
}
-
-done_testing;
diff -up Package-Stash-0.20/t/21-leaks-debug.t.orig Package-Stash-0.20/t/21-leaks-debug.t
--- Package-Stash-0.20/t/21-leaks-debug.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/21-leaks-debug.t 2011-01-04 16:30:26.617430549 +0000
@@ -5,6 +5,7 @@ use lib 't/lib';
use Test::More;
use Test::Fatal;
use Test::Requires 'Test::LeakTrace';
+plan tests => 25;
BEGIN { $^P |= 0x210 } # PERLDBf_SUBLINE
@@ -138,7 +139,10 @@ use Symbol;
ok($foo->has_symbol('@ISA'));
is(ref($foo->get_symbol('@ISA')), 'ARRAY');
is_deeply($foo->get_symbol('@ISA'), ['Exporter']);
+ SKIP: {
+ skip "Test::More >= 0.88 needed for isa_ok() tests on classes", 1 if $Test::More::VERSION < 0.88;
isa_ok('Foo', 'Exporter');
+ }
}
{
@@ -192,5 +196,3 @@ use Symbol;
eval { $foo->get_or_add_symbol('&blorg') };
} "doesn't leak on errors";
}
-
-done_testing;
diff -up Package-Stash-0.20/t/impl-selection/01-choice.t.orig Package-Stash-0.20/t/impl-selection/01-choice.t
--- Package-Stash-0.20/t/impl-selection/01-choice.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/impl-selection/01-choice.t 2011-01-04 16:27:28.149397123 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 2;
my $has_xs = eval "require Package::Stash::XS; 1";
@@ -13,5 +13,3 @@ my $expected = $has_xs ? 'XS' : 'PP';
is($Package::Stash::IMPLEMENTATION, $expected,
"autodetected properly: $expected");
can_ok('Package::Stash', 'new');
-
-done_testing;
diff -up Package-Stash-0.20/t/impl-selection/02-env.t.orig Package-Stash-0.20/t/impl-selection/02-env.t
--- Package-Stash-0.20/t/impl-selection/02-env.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/impl-selection/02-env.t 2011-01-04 16:27:28.149397123 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 4;
# XXX: work around dumb core segfault bug when you delete stashes
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
@@ -25,5 +25,3 @@ SKIP: {
is(get_impl, 'XS', "autodetected properly: XS");
can_ok('Package::Stash', 'new');
}
-
-done_testing;
diff -up Package-Stash-0.20/t/impl-selection/03-var.t.orig Package-Stash-0.20/t/impl-selection/03-var.t
--- Package-Stash-0.20/t/impl-selection/03-var.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/impl-selection/03-var.t 2011-01-04 16:27:28.150397151 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 4;
# XXX: work around dumb core segfault bug when you delete stashes
sub get_impl { eval '$Package::Stash::IMPLEMENTATION' }
@@ -25,5 +25,3 @@ SKIP: {
is(get_impl, 'XS', "autodetected properly: XS");
can_ok('Package::Stash', 'new');
}
-
-done_testing;
diff -up Package-Stash-0.20/t/impl-selection/10-basic-pp.t.orig Package-Stash-0.20/t/impl-selection/10-basic-pp.t
--- Package-Stash-0.20/t/impl-selection/10-basic-pp.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/impl-selection/10-basic-pp.t 2011-01-04 16:27:28.150397151 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 124;
use Test::Fatal;
BEGIN { $Package::Stash::IMPLEMENTATION = 'PP' }
@@ -420,5 +420,3 @@ like(exception {
"list_all_symbols CODE",
);
}
-
-done_testing;
diff -up Package-Stash-0.20/t/impl-selection/11-basic-xs.t.orig Package-Stash-0.20/t/impl-selection/11-basic-xs.t
--- Package-Stash-0.20/t/impl-selection/11-basic-xs.t.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/t/impl-selection/11-basic-xs.t 2011-01-04 16:27:28.151397179 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env perl
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 124;
use Test::Fatal;
use Test::Requires 'Package::Stash::XS';
@@ -421,5 +421,3 @@ like(exception {
"list_all_symbols CODE",
);
}
-
-done_testing;

View File

@ -5,30 +5,45 @@
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0) %global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
Name: perl-Package-Stash Name: perl-Package-Stash
Version: 0.08 Version: 0.20
Release: 2%{?dist} Release: 1%{?dist}
Summary: Routines for manipulating stashes Summary: Routines for manipulating stashes
Group: Development/Libraries Group: Development/Libraries
License: GPL+ or Artistic License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Package-Stash/ URL: http://search.cpan.org/dist/Package-Stash/
Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
Patch0: Package-Stash-0.08-EU::MM-version.patch Patch0: Package-Stash-0.20-EU::MM-version.patch
Patch1: Package-Stash-0.08-old-Test::More.patch Patch1: Package-Stash-0.20-old-Test::More.patch
Patch2: Package-Stash-0.20-no-Test::Requires.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch BuildArch: noarch
BuildRequires: perl(Dist::CheckConflicts)
BuildRequires: perl(ExtUtils::MakeMaker) BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Scalar::Util) BuildRequires: perl(Scalar::Util)
BuildRequires: perl(Package::DeprecationManager)
BuildRequires: perl(Package::Stash::XS)
BuildRequires: perl(Test::EOL) BuildRequires: perl(Test::EOL)
BuildRequires: perl(Test::Fatal)
BuildRequires: perl(Test::Exception) BuildRequires: perl(Test::Exception)
BuildRequires: perl(Test::More) BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoTabs) BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Pod) BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage) BuildRequires: perl(Test::Pod::Coverage)
# Pod::Coverage::TrustPod not yet in EPEL # Pod::Coverage::TrustPod and Test::Requires not in EPEL-4
%if 0%{?fedora} %if "%{?rhel}" != "4"
BuildRequires: perl(Pod::Coverage::TrustPod) BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Test::Requires)
%endif
# Test::LeakTrace and Test::Script not in EPEL-4 or EPEL-5
%if "%{?rhel}" != "4" && "%{?rhel}" != "5"
BuildRequires: perl(Test::LeakTrace)
BuildRequires: perl(Test::Script)
%endif %endif
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
# For performance and consistency
Requires: perl(Package::Stash::XS)
# Not found by rpm auto-provides
Provides: perl(Package::Stash::Conflicts) = 0
%{?perl_default_filter} %{?perl_default_filter}
@ -50,6 +65,11 @@ a simple API.
%patch1 -p1 %patch1 -p1
%endif %endif
# Work around absence of Test::Requires in EPEL-4
%if "%{?rhel}" == "4"
%patch2 -p1
%endif
%build %build
perl Makefile.PL INSTALLDIRS=vendor perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags} make %{?_smp_mflags}
@ -70,10 +90,36 @@ rm -rf %{buildroot}
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc Changes LICENSE README %doc Changes LICENSE README
%{_bindir}/package-stash-conflicts
%{perl_vendorlib}/Package/ %{perl_vendorlib}/Package/
%{_mandir}/man1/package-stash-conflicts.1*
%{_mandir}/man3/Package::Stash.3pm* %{_mandir}/man3/Package::Stash.3pm*
%{_mandir}/man3/Package::Stash::Conflicts.3pm*
%{_mandir}/man3/Package::Stash::PP.3pm*
%changelog %changelog
* Tue Jan 4 2011 Paul Howarth <paul@city-fan.org> - 0.20-1
- Update to 0.20
- Methods were renamed for brevity: s/_package//
- Convert Package::Stash into a module which loads either the XS or pure perl
implementation, depending on what's available
- Use Test::Fatal instead of Test::Exception
- Use Dist::CheckConflicts
- Silence deprecation warnings for the method renaming for now
- New script and manpage: package-stash-conflicts
- New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
- New build requirements:
- perl(Dist::CheckConflicts)
- perl(Package::DeprecationManager)
- perl(Package::Stash::XS)
- perl(Test::LeakTrace)
- perl(Test::Requires)
- perl(Test::Script)
- Update patches for old ExtUtils::MakeMaker and Test::More versions
- Add new patch to work around absence of Test::Requires in EPEL-4
- Require perl(Package::Stash::XS) for performance and consistency
- Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2 * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2
- Rebuild to fix problems with vendorarch/lib (#661697) - Rebuild to fix problems with vendorarch/lib (#661697)

View File

@ -1 +1 @@
3a34ef6de7c428a29f72e019db11624d Package-Stash-0.08.tar.gz c8194c1a5f477308fdc64c1be359ccd7 Package-Stash-0.20.tar.gz