perl-Package-Stash/Package-Stash-0.20-EU::MM-version.patch
Paul Howarth a39aa3c820 Update to 0.20
- New upstream release 0.20
  - Methods were renamed for brevity: s/_package//
  - Convert Package::Stash into a module which loads either the XS or pure perl
    implementation, depending on what's available
  - Use Test::Fatal instead of Test::Exception
  - Use Dist::CheckConflicts
  - Silence deprecation warnings for the method renaming for now
- New script and manpage: package-stash-conflicts
- New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
- New build requirements:
  - perl(Dist::CheckConflicts)
  - perl(Package::DeprecationManager)
  - perl(Package::Stash::XS)
  - perl(Test::LeakTrace)
  - perl(Test::Requires)
  - perl(Test::Script)
- Update patches for old ExtUtils::MakeMaker and Test::More versions
- Add new patch to work around absence of Test::Requires in EPEL-4
- Require perl(Package::Stash::XS) for performance and consistency
- Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
2011-01-07 12:09:42 +00:00

31 lines
771 B
Diff

--- Package-Stash-0.20/Makefile.PL.orig 2011-01-03 19:48:16.000000000 +0000
+++ Package-Stash-0.20/Makefile.PL 2011-01-04 13:33:09.585268028 +0000
@@ -3,7 +3,7 @@
BEGIN { require 5.8.3; }
use strict;
use warnings;
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker;
check_conflicts();
my %WriteMakefileArgs = (
@@ -16,7 +16,7 @@
},
'CONFIGURE_REQUIRES' => {
'Dist::CheckConflicts' => '0.02',
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Package-Stash',
'EXE_FILES' => [
@@ -49,6 +49,9 @@
}
}
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };