Re-synced to upstream sources
This commit is contained in:
parent
5968f8799e
commit
a80e8a1384
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@
|
|||||||
/pcs-withgems-0.9.139.tar.gz
|
/pcs-withgems-0.9.139.tar.gz
|
||||||
/pcs-withgems-0.9.140.tar.gz
|
/pcs-withgems-0.9.140.tar.gz
|
||||||
/pcs-withgems-0.9.141.tar.gz
|
/pcs-withgems-0.9.141.tar.gz
|
||||||
|
/pcs-withgems-0.9.144.tar.gz
|
||||||
|
61
fedfix.patch
61
fedfix.patch
@ -1,21 +1,26 @@
|
|||||||
From ec05be119b13fbbbea22052a79d61a8da883c16f Mon Sep 17 00:00:00 2001
|
From 7aa4bb635ccde8287a92d15c40b2233105f1b814 Mon Sep 17 00:00:00 2001
|
||||||
From: Tomas Jelinek <tojeline@redhat.com>
|
From: Tomas Jelinek <tojeline@redhat.com>
|
||||||
Date: Tue, 23 Jun 2015 16:29:02 +0200
|
Date: Mon, 7 Sep 2015 13:46:47 +0200
|
||||||
Subject: [PATCH] fedfix patch
|
Subject: [PATCH] fedfix patch
|
||||||
|
|
||||||
---
|
---
|
||||||
pcsd/Gemfile | 8 --------
|
pcsd/Gemfile | 15 +--------------
|
||||||
pcsd/Gemfile.lock | 21 ---------------------
|
pcsd/Gemfile.lock | 24 ------------------------
|
||||||
pcsd/Makefile | 2 +-
|
pcsd/Makefile | 4 ++--
|
||||||
3 files changed, 1 insertion(+), 30 deletions(-)
|
pcsd/ssl.rb | 4 ++--
|
||||||
|
4 files changed, 5 insertions(+), 42 deletions(-)
|
||||||
|
|
||||||
diff --git a/pcsd/Gemfile b/pcsd/Gemfile
|
diff --git a/pcsd/Gemfile b/pcsd/Gemfile
|
||||||
index db98546..e412e12 100644
|
index fb97a1a..e412e12 100644
|
||||||
--- a/pcsd/Gemfile
|
--- a/pcsd/Gemfile
|
||||||
+++ b/pcsd/Gemfile
|
+++ b/pcsd/Gemfile
|
||||||
@@ -1,16 +1,8 @@
|
@@ -1,21 +1,8 @@
|
||||||
source 'https://rubygems.org'
|
source 'https://rubygems.org'
|
||||||
|
|
||||||
|
-source 'https://tojeline.fedorapeople.org/rubygems/' do
|
||||||
|
- gem 'rpam-ruby19-feist', :platform => :ruby_18
|
||||||
|
-end
|
||||||
|
-
|
||||||
-gem 'sinatra'
|
-gem 'sinatra'
|
||||||
gem 'sinatra-contrib'
|
gem 'sinatra-contrib'
|
||||||
-gem 'rack'
|
-gem 'rack'
|
||||||
@ -26,19 +31,24 @@ index db98546..e412e12 100644
|
|||||||
gem 'backports'
|
gem 'backports'
|
||||||
gem 'sinatra-sugar'
|
gem 'sinatra-sugar'
|
||||||
gem 'monkey-lib'
|
gem 'monkey-lib'
|
||||||
gem 'rpam-ruby19'
|
-gem 'rpam-ruby19', :platform => [:ruby_19, :ruby_20, :ruby_21, :ruby_22]
|
||||||
|
-gem 'json'
|
||||||
-gem 'multi_json'
|
-gem 'multi_json'
|
||||||
-gem 'open4'
|
-gem 'open4'
|
||||||
|
+gem 'rpam-ruby19'
|
||||||
gem 'orderedhash'
|
gem 'orderedhash'
|
||||||
diff --git a/pcsd/Gemfile.lock b/pcsd/Gemfile.lock
|
diff --git a/pcsd/Gemfile.lock b/pcsd/Gemfile.lock
|
||||||
index 848758e..4ea6796 100644
|
index 3140d6f..4ea6796 100644
|
||||||
--- a/pcsd/Gemfile.lock
|
--- a/pcsd/Gemfile.lock
|
||||||
+++ b/pcsd/Gemfile.lock
|
+++ b/pcsd/Gemfile.lock
|
||||||
@@ -2,22 +2,10 @@ GEM
|
@@ -1,25 +1,11 @@
|
||||||
|
GEM
|
||||||
remote: https://rubygems.org/
|
remote: https://rubygems.org/
|
||||||
|
- remote: https://tojeline.fedorapeople.org/rubygems/
|
||||||
specs:
|
specs:
|
||||||
backports (3.6.4)
|
backports (3.6.4)
|
||||||
- eventmachine (1.0.7)
|
- eventmachine (1.0.7)
|
||||||
|
- json (1.8.3)
|
||||||
monkey-lib (0.5.4)
|
monkey-lib (0.5.4)
|
||||||
backports
|
backports
|
||||||
- multi_json (1.11.1)
|
- multi_json (1.11.1)
|
||||||
@ -57,7 +67,7 @@ index 848758e..4ea6796 100644
|
|||||||
sinatra-contrib (1.4.4)
|
sinatra-contrib (1.4.4)
|
||||||
backports (>= 2.0)
|
backports (>= 2.0)
|
||||||
multi_json
|
multi_json
|
||||||
@@ -28,23 +16,14 @@ GEM
|
@@ -30,24 +16,14 @@ GEM
|
||||||
sinatra-sugar (0.5.1)
|
sinatra-sugar (0.5.1)
|
||||||
monkey-lib (~> 0.5.0)
|
monkey-lib (~> 0.5.0)
|
||||||
sinatra (~> 1.0)
|
sinatra (~> 1.0)
|
||||||
@ -69,6 +79,7 @@ index 848758e..4ea6796 100644
|
|||||||
DEPENDENCIES
|
DEPENDENCIES
|
||||||
backports
|
backports
|
||||||
- eventmachine
|
- eventmachine
|
||||||
|
- json
|
||||||
monkey-lib
|
monkey-lib
|
||||||
- multi_json
|
- multi_json
|
||||||
- open4
|
- open4
|
||||||
@ -82,18 +93,32 @@ index 848758e..4ea6796 100644
|
|||||||
sinatra-sugar
|
sinatra-sugar
|
||||||
- tilt
|
- tilt
|
||||||
diff --git a/pcsd/Makefile b/pcsd/Makefile
|
diff --git a/pcsd/Makefile b/pcsd/Makefile
|
||||||
index 0d28b58..d320162 100644
|
index b430069..eb2f4c4 100644
|
||||||
--- a/pcsd/Makefile
|
--- a/pcsd/Makefile
|
||||||
+++ b/pcsd/Makefile
|
+++ b/pcsd/Makefile
|
||||||
@@ -7,7 +7,7 @@ else
|
@@ -1,5 +1,5 @@
|
||||||
endif
|
-build_gems: get_gems
|
||||||
|
|
||||||
build_gems_normal:
|
|
||||||
- bundle install --local --deployment
|
- bundle install --local --deployment
|
||||||
|
+build_gems:
|
||||||
+ bundle install --local --path vendor/bundle
|
+ bundle install --local --path vendor/bundle
|
||||||
|
|
||||||
# RHEL6 needs special rpam-ruby19 gem to work with 1.8.7
|
# RHEL6 needs special rpam-ruby19 gem to work with 1.8.7
|
||||||
build_gems_rhel6:
|
# also bundler is not available on RHEL6 in rpm
|
||||||
|
diff --git a/pcsd/ssl.rb b/pcsd/ssl.rb
|
||||||
|
index 97d131e..36c1a73 100644
|
||||||
|
--- a/pcsd/ssl.rb
|
||||||
|
+++ b/pcsd/ssl.rb
|
||||||
|
@@ -48,8 +48,8 @@ end
|
||||||
|
|
||||||
|
webrick_options = {
|
||||||
|
:Port => 2224,
|
||||||
|
- :BindAddress => '::',
|
||||||
|
- :Host => '::',
|
||||||
|
+ :BindAddress => nil,
|
||||||
|
+ :Host => nil,
|
||||||
|
:SSLEnable => true,
|
||||||
|
:SSLVerifyClient => OpenSSL::SSL::VERIFY_NONE,
|
||||||
|
:SSLCertificate => OpenSSL::X509::Certificate.new(crt),
|
||||||
--
|
--
|
||||||
1.9.1
|
1.9.1
|
||||||
|
|
||||||
|
9
pcs.spec
9
pcs.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcs
|
Name: pcs
|
||||||
Version: 0.9.141
|
Version: 0.9.144
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://github.com/feist/pcs
|
URL: http://github.com/feist/pcs
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -13,7 +13,7 @@ Summary: Pacemaker Configuration System
|
|||||||
Source0: https://tojeline.fedorapeople.org/pkgs/pcs/pcs-withgems-%{version}.tar.gz
|
Source0: https://tojeline.fedorapeople.org/pkgs/pcs/pcs-withgems-%{version}.tar.gz
|
||||||
Patch0: fedfix.patch
|
Patch0: fedfix.patch
|
||||||
Requires: pacemaker ruby python
|
Requires: pacemaker ruby python
|
||||||
Requires: psmisc
|
Requires: psmisc initscripts openssl
|
||||||
Requires: python-clufter
|
Requires: python-clufter
|
||||||
Requires: rubygem-sinatra rubygem-rack rubygem-rack-protection rubygem-tilt
|
Requires: rubygem-sinatra rubygem-rack rubygem-rack-protection rubygem-tilt
|
||||||
Requires: rubygem-eventmachine rubygem-rack-test rubygem-multi_json rubygem-json rubygem-open4
|
Requires: rubygem-eventmachine rubygem-rack-test rubygem-multi_json rubygem-json rubygem-open4
|
||||||
@ -76,6 +76,9 @@ chmod 755 $RPM_BUILD_ROOT/%{python_sitelib}/pcs/pcs.py
|
|||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 18 2015 Tomas Jelinek <tojeline@redhat.com> - 0.9.144-1
|
||||||
|
- Re-synced to upstream sources
|
||||||
|
|
||||||
* Tue Jun 23 2015 Tomas Jelinek <tojeline@redhat.com> - 0.9.141-2
|
* Tue Jun 23 2015 Tomas Jelinek <tojeline@redhat.com> - 0.9.141-2
|
||||||
- Added requirement for psmisc for killall
|
- Added requirement for psmisc for killall
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user