125 lines
2.8 KiB
Diff
125 lines
2.8 KiB
Diff
From 7aa4bb635ccde8287a92d15c40b2233105f1b814 Mon Sep 17 00:00:00 2001
|
|
From: Tomas Jelinek <tojeline@redhat.com>
|
|
Date: Mon, 7 Sep 2015 13:46:47 +0200
|
|
Subject: [PATCH] fedfix patch
|
|
|
|
---
|
|
pcsd/Gemfile | 15 +--------------
|
|
pcsd/Gemfile.lock | 24 ------------------------
|
|
pcsd/Makefile | 4 ++--
|
|
pcsd/ssl.rb | 4 ++--
|
|
4 files changed, 5 insertions(+), 42 deletions(-)
|
|
|
|
diff --git a/pcsd/Gemfile b/pcsd/Gemfile
|
|
index fb97a1a..e412e12 100644
|
|
--- a/pcsd/Gemfile
|
|
+++ b/pcsd/Gemfile
|
|
@@ -1,21 +1,8 @@
|
|
source 'https://rubygems.org'
|
|
|
|
-source 'https://tojeline.fedorapeople.org/rubygems/' do
|
|
- gem 'rpam-ruby19-feist', :platform => :ruby_18
|
|
-end
|
|
-
|
|
-gem 'sinatra'
|
|
gem 'sinatra-contrib'
|
|
-gem 'rack'
|
|
-gem 'rack-protection'
|
|
-gem 'tilt'
|
|
-gem 'eventmachine'
|
|
-gem 'rack-test'
|
|
gem 'backports'
|
|
gem 'sinatra-sugar'
|
|
gem 'monkey-lib'
|
|
-gem 'rpam-ruby19', :platform => [:ruby_19, :ruby_20, :ruby_21, :ruby_22]
|
|
-gem 'json'
|
|
-gem 'multi_json'
|
|
-gem 'open4'
|
|
+gem 'rpam-ruby19'
|
|
gem 'orderedhash'
|
|
diff --git a/pcsd/Gemfile.lock b/pcsd/Gemfile.lock
|
|
index 3140d6f..4ea6796 100644
|
|
--- a/pcsd/Gemfile.lock
|
|
+++ b/pcsd/Gemfile.lock
|
|
@@ -1,25 +1,11 @@
|
|
GEM
|
|
remote: https://rubygems.org/
|
|
- remote: https://tojeline.fedorapeople.org/rubygems/
|
|
specs:
|
|
backports (3.6.4)
|
|
- eventmachine (1.0.7)
|
|
- json (1.8.3)
|
|
monkey-lib (0.5.4)
|
|
backports
|
|
- multi_json (1.11.1)
|
|
- open4 (1.3.4)
|
|
orderedhash (0.0.6)
|
|
- rack (1.6.4)
|
|
- rack-protection (1.5.3)
|
|
- rack
|
|
- rack-test (0.6.3)
|
|
- rack (>= 1.0)
|
|
rpam-ruby19 (1.2.1)
|
|
- sinatra (1.4.6)
|
|
- rack (~> 1.4)
|
|
- rack-protection (~> 1.4)
|
|
- tilt (>= 1.3, < 3)
|
|
sinatra-contrib (1.4.4)
|
|
backports (>= 2.0)
|
|
multi_json
|
|
@@ -30,24 +16,14 @@ GEM
|
|
sinatra-sugar (0.5.1)
|
|
monkey-lib (~> 0.5.0)
|
|
sinatra (~> 1.0)
|
|
- tilt (1.4.1)
|
|
|
|
PLATFORMS
|
|
ruby
|
|
|
|
DEPENDENCIES
|
|
backports
|
|
- eventmachine
|
|
- json
|
|
monkey-lib
|
|
- multi_json
|
|
- open4
|
|
orderedhash
|
|
- rack
|
|
- rack-protection
|
|
- rack-test
|
|
rpam-ruby19
|
|
- sinatra
|
|
sinatra-contrib
|
|
sinatra-sugar
|
|
- tilt
|
|
diff --git a/pcsd/Makefile b/pcsd/Makefile
|
|
index b430069..eb2f4c4 100644
|
|
--- a/pcsd/Makefile
|
|
+++ b/pcsd/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
-build_gems: get_gems
|
|
- bundle install --local --deployment
|
|
+build_gems:
|
|
+ bundle install --local --path vendor/bundle
|
|
|
|
# RHEL6 needs special rpam-ruby19 gem to work with 1.8.7
|
|
# also bundler is not available on RHEL6 in rpm
|
|
diff --git a/pcsd/ssl.rb b/pcsd/ssl.rb
|
|
index 97d131e..36c1a73 100644
|
|
--- a/pcsd/ssl.rb
|
|
+++ b/pcsd/ssl.rb
|
|
@@ -48,8 +48,8 @@ end
|
|
|
|
webrick_options = {
|
|
:Port => 2224,
|
|
- :BindAddress => '::',
|
|
- :Host => '::',
|
|
+ :BindAddress => nil,
|
|
+ :Host => nil,
|
|
:SSLEnable => true,
|
|
:SSLVerifyClient => OpenSSL::SSL::VERIFY_NONE,
|
|
:SSLCertificate => OpenSSL::X509::Certificate.new(crt),
|
|
--
|
|
1.9.1
|
|
|