version 3.0.1, bugfixes: super-h support (#446600), broken libpci.pc
(#456469)
This commit is contained in:
parent
6962467427
commit
fe71594439
@ -1 +1 @@
|
|||||||
pciutils-3.0.0.tar.gz
|
pciutils-3.0.1.tar.gz
|
||||||
|
109
pciutils-3.0.1-multilib.patch
Normal file
109
pciutils-3.0.1-multilib.patch
Normal file
@ -0,0 +1,109 @@
|
|||||||
|
diff -up pciutils-3.0.1/lib/configure.multilib pciutils-3.0.1/lib/configure
|
||||||
|
--- pciutils-3.0.1/lib/configure.multilib 2008-08-26 17:08:52.000000000 +0200
|
||||||
|
+++ pciutils-3.0.1/lib/configure 2008-09-19 11:35:58.964527560 +0200
|
||||||
|
@@ -45,29 +45,62 @@ sys=`echo $host | sed 's/^\([^-]*\)-\([^
|
||||||
|
echo " $host $rel"
|
||||||
|
|
||||||
|
c=config.h
|
||||||
|
+cm=config.h.mk
|
||||||
|
m=config.mk
|
||||||
|
-echo >$c '#define PCI_CONFIG_H'
|
||||||
|
-echo >$c "#define PCI_ARCH_`echo $cpu | tr '[a-z]' '[A-Z]'`"
|
||||||
|
-echo >>$c "#define PCI_OS_`echo $sys | tr '[a-z]' '[A-Z]'`"
|
||||||
|
echo >$m 'WITH_LIBS='
|
||||||
|
+cat >$c <<EOF
|
||||||
|
+#define PCI_CONFIG_H
|
||||||
|
+#if defined(__x86_64__)
|
||||||
|
+#define PCI_ARCH_X86_64
|
||||||
|
+#elif defined(__ia64__)
|
||||||
|
+#define PCI_ARCH_IA64
|
||||||
|
+#elif defined(__i386__)
|
||||||
|
+#define PCI_ARCH_I386
|
||||||
|
+#define PCI_HAVE_PM_INTEL_CONF
|
||||||
|
+#elif defined(__ppc64__) || defined(__powerpc64__)
|
||||||
|
+#define PCI_ARCH_PPC64
|
||||||
|
+#elif defined(__ppc__) || defined(__powerpc__)
|
||||||
|
+#define PCI_ARCH_PPC
|
||||||
|
+#elif defined(__s390x__)
|
||||||
|
+define PCI_ARCH_S390X
|
||||||
|
+#elif defined(__s390__)
|
||||||
|
+#define PCI_ARCH_S390
|
||||||
|
+#elif defined(__alpha__)
|
||||||
|
+#define PCI_ARCH_ALPHA
|
||||||
|
+#else
|
||||||
|
+#error Unknown Arch
|
||||||
|
+#endif
|
||||||
|
+#define PCI_OS_LINUX
|
||||||
|
+#define PCI_HAVE_PM_LINUX_SYSFS
|
||||||
|
+#define PCI_HAVE_PM_LINUX_PROC
|
||||||
|
+#define PCI_HAVE_LINUX_BYTEORDER_H
|
||||||
|
+#define PCI_PATH_PROC_BUS_PCI "/proc/bus/pci"
|
||||||
|
+#define PCI_PATH_SYS_BUS_PCI "/sys/bus/pci"
|
||||||
|
+#define PCI_HAVE_64BIT_ADDRESS
|
||||||
|
+EOF
|
||||||
|
+
|
||||||
|
+rm -f $cm
|
||||||
|
+echo >$cm "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"
|
||||||
|
+echo >>$cm "#define PCI_OS_`echo $sys | tr 'a-z' 'A-Z'`"
|
||||||
|
|
||||||
|
echo_n "Looking for access methods..."
|
||||||
|
+echo_n " sysfs proc"
|
||||||
|
LIBRESOLV=-lresolv
|
||||||
|
|
||||||
|
case $sys in
|
||||||
|
linux*)
|
||||||
|
echo_n " sysfs proc"
|
||||||
|
- echo >>$c '#define PCI_HAVE_PM_LINUX_SYSFS'
|
||||||
|
- echo >>$c '#define PCI_HAVE_PM_LINUX_PROC'
|
||||||
|
- echo >>$c '#define PCI_HAVE_LINUX_BYTEORDER_H'
|
||||||
|
- echo >>$c '#define PCI_PATH_PROC_BUS_PCI "/proc/bus/pci"'
|
||||||
|
- echo >>$c '#define PCI_PATH_SYS_BUS_PCI "/sys/bus/pci"'
|
||||||
|
+ echo >>$cm '#define PCI_HAVE_PM_LINUX_SYSFS'
|
||||||
|
+ echo >>$cm '#define PCI_HAVE_PM_LINUX_PROC'
|
||||||
|
+ echo >>$cm '#define PCI_HAVE_LINUX_BYTEORDER_H'
|
||||||
|
+ echo >>$cm '#define PCI_PATH_PROC_BUS_PCI "/proc/bus/pci"'
|
||||||
|
+ echo >>$cm '#define PCI_PATH_SYS_BUS_PCI "/sys/bus/pci"'
|
||||||
|
case $cpu in
|
||||||
|
i386|x86_64) echo_n " i386-ports"
|
||||||
|
- echo >>$c '#define PCI_HAVE_PM_INTEL_CONF'
|
||||||
|
+ echo >>$cm '#define PCI_HAVE_PM_INTEL_CONF'
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
- echo >>$c '#define PCI_HAVE_64BIT_ADDRESS'
|
||||||
|
+ echo >>$cm '#define PCI_HAVE_64BIT_ADDRESS'
|
||||||
|
;;
|
||||||
|
sunos)
|
||||||
|
case $cpu in
|
||||||
|
@@ -123,7 +156,7 @@ case $sys in
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
-echo >>$c '#define PCI_HAVE_PM_DUMP'
|
||||||
|
+echo >>$cm '#define PCI_HAVE_PM_DUMP'
|
||||||
|
echo " dump"
|
||||||
|
|
||||||
|
echo_n "Checking for zlib support... "
|
||||||
|
@@ -146,6 +179,7 @@ else
|
||||||
|
echo >>$c '#define PCI_IDS "pci.ids"'
|
||||||
|
fi
|
||||||
|
echo >>$c "#define PCI_PATH_IDS_DIR \"$IDSDIR\""
|
||||||
|
+echo >>$cm "#define PCI_PATH_IDS_DIR \"$IDSDIR\""
|
||||||
|
|
||||||
|
echo_n "Checking for DNS support... "
|
||||||
|
if [ "$DNS" = yes -o "$DNS" = no ] ; then
|
||||||
|
@@ -160,6 +194,7 @@ else
|
||||||
|
fi
|
||||||
|
if [ "$DNS" = yes ] ; then
|
||||||
|
echo >>$c "#define PCI_USE_DNS"
|
||||||
|
+ echo >>$cm "#define PCI_USE_DNS"
|
||||||
|
echo >>$c "#define PCI_ID_DOMAIN \"pci.id.ucw.cz\""
|
||||||
|
echo >>$m "WITH_LIBS+=$LIBRESOLV"
|
||||||
|
fi
|
||||||
|
@@ -182,4 +217,5 @@ fi
|
||||||
|
echo >>$m 'PCILIBPC=$(LIBNAME).pc'
|
||||||
|
|
||||||
|
echo >>$c "#define PCILIB_VERSION \"$VERSION\""
|
||||||
|
-sed '/"/{s/^#define \([^ ]*\) "\(.*\)"$/\1=\2/;p;d;};s/^#define \(.*\)/\1=1/' <$c >>$m
|
||||||
|
+echo >>$cm "#define PCILIB_VERSION \"$VERSION\""
|
||||||
|
+sed '/"/{s/^#define \([^ ]*\) "\(.*\)"$/\1=\2/;p;d;};s/^#define \(.*\)/\1=1/' <$cm >>$m
|
||||||
|
\ No newline at end of file
|
12
pciutils-3.0.1-superh-support.patch
Normal file
12
pciutils-3.0.1-superh-support.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up pciutils-3.0.1/lib/configure.superh pciutils-3.0.1/lib/configure
|
||||||
|
--- pciutils-3.0.1/lib/configure.superh 2008-09-19 11:37:51.000000000 +0200
|
||||||
|
+++ pciutils-3.0.1/lib/configure 2008-09-19 11:38:46.133527866 +0200
|
||||||
|
@@ -71,6 +71,8 @@ define PCI_ARCH_S390X
|
||||||
|
#define PCI_ARCH_SPARC64
|
||||||
|
#elif defined(__sparc__)
|
||||||
|
#define PCI_ARCH_SPARC
|
||||||
|
+#elif defined(__sh__)
|
||||||
|
+#define PCI_ARCH_SH
|
||||||
|
#else
|
||||||
|
#error Unknown Arch
|
||||||
|
#endif
|
@ -1,15 +1,16 @@
|
|||||||
Name: pciutils
|
Name: pciutils
|
||||||
Version: 3.0.0
|
Version: 3.0.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/%{name}-%{version}.tar.gz
|
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/%{name}-%{version}.tar.gz
|
||||||
Patch1: pciutils-2.2.4-buf.patch
|
Patch1: pciutils-2.2.4-buf.patch
|
||||||
Patch2: pciutils-2.1.10-scan.patch
|
Patch2: pciutils-2.1.10-scan.patch
|
||||||
Patch3: pciutils-havepread.patch
|
Patch3: pciutils-havepread.patch
|
||||||
Patch6: pciutils-2.2.1-idpath.patch
|
Patch6: pciutils-2.2.1-idpath.patch
|
||||||
Patch7: pciutils-2.1.99-gcc4.patch
|
Patch7: pciutils-2.1.99-gcc4.patch
|
||||||
Patch8: pciutils-3.0.0-multilib.patch
|
Patch8: pciutils-3.0.1-multilib.patch
|
||||||
Patch9: pciutils-dir-d.patch
|
Patch9: pciutils-dir-d.patch
|
||||||
Patch10: pciutils-2.2.10-sparc-support.patch
|
Patch10: pciutils-2.2.10-sparc-support.patch
|
||||||
|
Patch11: pciutils-3.0.1-superh-support.patch
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
|
URL: http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -52,6 +53,8 @@ devices connected to the PCI bus.
|
|||||||
%patch8 -p1 -b .multilib
|
%patch8 -p1 -b .multilib
|
||||||
%patch9 -p1 -b .dird
|
%patch9 -p1 -b .dird
|
||||||
%patch10 -p1 -b .sparc
|
%patch10 -p1 -b .sparc
|
||||||
|
%patch11 -p1 -b .superh
|
||||||
|
|
||||||
sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
|
sed -i -e 's/^SRC=.*/SRC="http:\/\/pciids.sourceforge.net\/pci.ids"/' update-pciids.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -62,6 +65,12 @@ make clean
|
|||||||
|
|
||||||
make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
|
make SHARED="yes" ZLIB="no" STRIP="" OPT="$RPM_OPT_FLAGS" PREFIX="/usr" IDSDIR="/usr/share/hwdata" PCI_IDS="pci.ids" %{?_smp_mflags}
|
||||||
|
|
||||||
|
#fix lib vs. lib64 in libpci.pc (static Makefile is used)
|
||||||
|
mv lib/libpci.pc lib/libpci.pc.old
|
||||||
|
sed <lib/libpci.pc.old >lib/libpci.pc "s|^libdir=.*$|libdir=%{_libdir}|"
|
||||||
|
rm lib/libpci.pc.old
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -105,6 +114,11 @@ install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 19 2008 Michal Hlavinka <mhlavink@redhat.com> 3.0.1-1
|
||||||
|
- version 3.0.1
|
||||||
|
- add support for Super-H (sh3,sh4) (#446600)
|
||||||
|
- fix: broken -L in libpci.pc (#456469)
|
||||||
|
|
||||||
* Mon Sep 01 2008 Harald Hoyer <harald@redhat.com> 3.0.0-2
|
* Mon Sep 01 2008 Harald Hoyer <harald@redhat.com> 3.0.0-2
|
||||||
- rebuild to eliminate fuzz patches
|
- rebuild to eliminate fuzz patches
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user