auto-import changelog data from pciutils-2.1.99.test3-1.1.src.rpm

Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
This commit is contained in:
cvsdist 2004-09-09 10:03:35 +00:00
parent 668e42c621
commit 8bc765216f
5 changed files with 37 additions and 124 deletions

View File

@ -1 +1 @@
pciutils-2.1.11.tar.bz2
pciutils-2.1.99-test3.tar.bz2

View File

@ -1,71 +1,8 @@
--- pciutils-2.1.11/lib/sysfs.c.pread 2003-11-21 18:27:17.547950935 -0500
+++ pciutils-2.1.11/lib/sysfs.c 2003-11-21 18:27:56.021002787 -0500
@@ -24,60 +24,6 @@
#define SYSFS_PATH "/sys/bus/pci/devices"
-/*
- * We'd like to use pread/pwrite for configuration space accesses, but
- * unfortunately it isn't simple at all since all libc's until glibc 2.1
- * don't define it.
- */
-
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ > 0
-/* glibc 2.1 or newer -> pread/pwrite supported automatically */
-
-#elif defined(i386) && defined(__GLIBC__)
-/* glibc 2.0 on i386 -> call syscalls directly */
-#include <asm/unistd.h>
-#include <syscall-list.h>
-#ifndef SYS_pread
-#define SYS_pread 180
-#endif
-static int pread(unsigned int fd, void *buf, size_t size, loff_t where)
-{ return syscall(SYS_pread, fd, buf, size, where); }
-#ifndef SYS_pwrite
-#define SYS_pwrite 181
-#endif
-static int pwrite(unsigned int fd, void *buf, size_t size, loff_t where)
-{ return syscall(SYS_pwrite, fd, buf, size, where); }
-
-#elif defined(i386)
-/* old libc on i386 -> call syscalls directly the old way */
-#include <asm/unistd.h>
-static _syscall5(int, pread, unsigned int, fd, void *, buf, size_t, size, u32, where_lo, u32, where_hi);
-static _syscall5(int, pwrite, unsigned int, fd, void *, buf, size_t, size, u32, where_lo, u32, where_hi);
-static int do_read(struct pci_dev *d UNUSED, int fd, void *buf, size_t size, int where) { return pread(fd, buf, size, where, 0); }
-static int do_write(struct pci_dev *d UNUSED, int fd, void *buf, size_t size, int where) { return pwrite(fd, buf, size, where, 0); }
-#define HAVE_DO_READ
-
-#else
-/* In all other cases we use lseek/read/write instead to be safe */
-#define make_rw_glue(op) \
- static int do_##op(struct pci_dev *d, int fd, void *buf, size_t size, int where) \
- { \
- struct pci_access *a = d->access; \
- int r; \
- if (a->fd_pos != where && lseek(fd, where, SEEK_SET) < 0) \
- return -1; \
- r = op(fd, buf, size); \
- if (r < 0) \
- a->fd_pos = -1; \
- else \
- a->fd_pos = where + r; \
- return r; \
- }
-make_rw_glue(read)
-make_rw_glue(write)
-#define HAVE_DO_READ
-#endif
-
#ifndef HAVE_DO_READ
#define do_read(d,f,b,l,p) pread(f,b,l,p)
#define do_write(d,f,b,l,p) pwrite(f,b,l,p)
--- pciutils-2.1.11/lib/proc.c.pread 2003-11-21 18:27:23.749508565 -0500
+++ pciutils-2.1.11/lib/proc.c 2003-11-21 18:27:43.341951711 -0500
@@ -19,60 +19,6 @@
#include "internal.h"
--- pciutils-2.1.99-test3/lib/pread.h.pread 2004-02-25 01:51:55.369843832 -0500
+++ pciutils-2.1.99-test3/lib/pread.h 2004-02-25 01:52:01.405065807 -0500
@@ -6,60 +6,6 @@
* Can be freely distributed and used under the terms of the GNU GPL.
*/
-/*
- * We'd like to use pread/pwrite for configuration space accesses, but

View File

@ -1,42 +1,20 @@
--- pciutils-2.1.10/Makefile.strip 2002-03-30 10:42:16.000000000 -0500
+++ pciutils-2.1.10/Makefile 2002-07-18 21:15:59.000000000 -0400
@@ -2,7 +2,7 @@
# Makefile for Linux PCI Utilities
# (c) 1998--2002 Martin Mares <mj@ucw.cz>
--- pciutils-2.1.99-test3/Makefile.strip 2004-02-25 01:46:14.315787866 -0500
+++ pciutils-2.1.99-test3/Makefile 2004-02-25 01:47:45.478046260 -0500
@@ -1,7 +1,7 @@
# Makefile for The PCI Utilities
# (c) 1998--2003 Martin Mares <mj@ucw.cz>
-OPT=-O2 -fomit-frame-pointer
+OPT=-O2
#OPT=-O2 -g
CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes
CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes -Winline
@@ -59,7 +59,7 @@
install: all
# -c is ignored on Linux, but required on FreeBSD
$(DIRINSTALL) -m 755 $(SBINDIR) $(SHAREDIR) $(MANDIR)/man8
- $(INSTALL) -c -m 755 -s lspci setpci $(SBINDIR)
+ $(INSTALL) -c -m 755 lspci setpci $(SBINDIR)
$(INSTALL) -c -m 755 update-pciids $(SBINDIR)
$(INSTALL) -c -m 644 pci.ids $(SHAREDIR)
$(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(MANDIR)/man8
--- pciutils-2.1.9/lspci.c.old Tue May 28 23:54:03 2002
+++ pciutils-2.1.9/lspci.c Wed May 29 00:29:39 2002
@@ -1506,7 +1506,7 @@
break;
case 's':
if (msg = pci_filter_parse_slot(&filter, optarg))
- die("-f: %s", msg);
+ die("-s: %s", msg);
break;
case 'd':
if (msg = pci_filter_parse_id(&filter, optarg))
--- pciutils-2.1.10/Makefile.foo 2002-10-15 15:37:50.000000000 -0400
+++ pciutils-2.1.10/Makefile 2002-10-15 15:36:57.000000000 -0400
@@ -36,7 +36,7 @@
all: lib lspci setpci lspci.8 setpci.8 pci.ids
VERSION=2.1.99-test3
@@ -32,7 +32,7 @@
all: $(PCILIB) lspci setpci lspci.8 setpci.8 update-pciids update-pciids.8 pci.ids
lib: lib/config.h
$(PCILIB): $(PCIINC) force
- $(MAKE) -C lib all
+ CFLAGS="$(CFLAGS) -fPIC" $(MAKE) -C lib all
lib/config.h:
cd lib && ./configure $(PREFIX) $(VERSION)
force:

View File

@ -1,15 +1,11 @@
Name: pciutils
Version: 2.1.11
Release: 4
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/%{name}-%{version}.tar.bz2
Version: 2.1.99.test3
Release: 1.1
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/alpha/%{name}-2.1.99-test3.tar.bz2
Patch0: pciutils-strip.patch
Patch1: pciutils-bufsiz.patch
Patch3: pciutils-pciids.patch
Patch4: pciutils-ppc64.patch
Patch5: pciutils-2.1.10-scan.patch
Patch6: pciutils-sysfs.diff
Patch7: pciutils-havepread.patch
Patch8: pciutils-sysfs-err.patch
Patch1: pciutils-pciids.patch
Patch2: pciutils-2.1.10-scan.patch
Patch3: pciutils-havepread.patch
License: GPL
Buildroot: %{_tmppath}/%{name}-%{version}-root
ExclusiveOS: Linux
@ -35,24 +31,20 @@ This package contains a library for inspecting and setting
devices connected to the PCI bus.
%prep
%setup -q
%setup -q -n pciutils-2.1.99-test3
%patch0 -p1 -b .strip
%patch1 -p1 -b .bufsiz
%patch3 -p1 -b .pciids
%patch4 -p1 -b .ppc64
%patch5 -p1 -b .scan
%patch6 -p1 -b .sysfs
%patch7 -p1 -b .pread
%patch8 -p1 -b .err
%patch1 -p1 -b .pciids
%patch2 -p1 -b .scan
%patch3 -p1 -b .pread
%build
%ifarch i386
make OPT="$RPM_OPT_FLAGS" CC="diet gcc" PREFIX="/usr"
make OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE=1" CC="diet gcc" PREFIX="/usr"
mv lib/libpci.a lib/libpci_loader_a
make clean
%endif
make OPT="$RPM_OPT_FLAGS" PREFIX="/usr"
make OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE=1" PREFIX="/usr"
%install
rm -rf $RPM_BUILD_ROOT
@ -87,6 +79,12 @@ install lib/libpci_loader_a $RPM_BUILD_ROOT%{_libdir}/libpci_loader.a
rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Mon Dec 8 2003 Bill Nottingham <notting@redhat.com> 2.1.11-4
- fix paths for pci.ids, etc. (#111665)

View File

@ -1 +1 @@
2b3b2147b7bc91f362be55cb49fa1c4e pciutils-2.1.11.tar.bz2
b60386fd7593821071142a3ef5c8db53 pciutils-2.1.99-test3.tar.bz2