- rebuild to eliminate fuzz patches
This commit is contained in:
parent
b24a048def
commit
6962467427
@ -1,6 +1,7 @@
|
|||||||
--- pciutils-2.1.10/lib/access.c.foo Wed Feb 12 15:44:05 2003
|
diff -up pciutils-3.0.0/lib/access.c.scan pciutils-3.0.0/lib/access.c
|
||||||
+++ pciutils-2.1.10/lib/access.c Wed Feb 12 15:44:33 2003
|
--- pciutils-3.0.0/lib/access.c.scan 2008-04-10 21:15:47.000000000 +0200
|
||||||
@@ -180,7 +180,8 @@
|
+++ pciutils-3.0.0/lib/access.c 2008-09-01 15:15:27.000000000 +0200
|
||||||
|
@@ -16,7 +16,8 @@
|
||||||
void
|
void
|
||||||
pci_scan_bus(struct pci_access *a)
|
pci_scan_bus(struct pci_access *a)
|
||||||
{
|
{
|
||||||
|
@ -1,9 +1,7 @@
|
|||||||
Patch by Robert Scheck <redhat@linuxnetz.de> for pciutils >= 2.1.99, which make pciutils
|
diff -up pciutils-3.0.0/lib/i386-ports.c.glibcmacros pciutils-3.0.0/lib/i386-ports.c
|
||||||
rebuildable using gcc 4.
|
--- pciutils-3.0.0/lib/i386-ports.c.glibcmacros 2008-04-10 21:15:47.000000000 +0200
|
||||||
|
+++ pciutils-3.0.0/lib/i386-ports.c 2008-09-01 15:16:42.000000000 +0200
|
||||||
--- pciutils-2.1.99-test8/lib/i386-ports.c 2004-08-13 22:13:11.000000000 +0200
|
@@ -70,9 +70,9 @@ intel_sanity_check(struct pci_access *a,
|
||||||
+++ pciutils-2.1.99-test8/lib/i386-ports.c.gcc4 2005-03-14 09:30:06.000000000 +0100
|
|
||||||
@@ -57,9 +57,9 @@
|
|
||||||
for(d.dev = 0; d.dev < 32; d.dev++)
|
for(d.dev = 0; d.dev < 32; d.dev++)
|
||||||
{
|
{
|
||||||
u16 class, vendor;
|
u16 class, vendor;
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
--- pciutils-2.2.1/Makefile.idpath 2006-02-23 12:24:12.000000000 +0100
|
diff -up pciutils-3.0.0/Makefile.idpath pciutils-3.0.0/Makefile
|
||||||
+++ pciutils-2.2.1/Makefile 2006-02-23 12:24:18.000000000 +0100
|
--- pciutils-3.0.0/Makefile.idpath 2008-04-10 21:19:43.000000000 +0200
|
||||||
@@ -10,7 +10,7 @@
|
+++ pciutils-3.0.0/Makefile 2008-09-01 15:16:19.000000000 +0200
|
||||||
|
@@ -27,7 +27,7 @@ ABI_VERSION=.3
|
||||||
PREFIX=/usr/local
|
PREFIX=/usr/local
|
||||||
SBINDIR=$(PREFIX)/sbin
|
SBINDIR=$(PREFIX)/sbin
|
||||||
SHAREDIR=$(PREFIX)/share
|
SHAREDIR=$(PREFIX)/share
|
||||||
-IDSDIR=$(SHAREDIR)
|
-IDSDIR=$(SHAREDIR)
|
||||||
+IDSDIR=$(SHAREDIR)/hwdata
|
+IDSDIR=$(SHAREDIR)/hwdata
|
||||||
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
|
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
|
||||||
INSTALL=install
|
INCDIR=$(PREFIX)/include
|
||||||
DIRINSTALL=install -d
|
LIBDIR=$(PREFIX)/lib
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up pciutils-2.2.10/lib/configure.BAD pciutils-2.2.10/lib/configure
|
diff -up pciutils-3.0.0/lib/configure.sparc pciutils-3.0.0/lib/configure
|
||||||
--- pciutils-2.2.10/lib/configure.BAD 2008-05-26 18:28:51.000000000 -0500
|
--- pciutils-3.0.0/lib/configure.sparc 2008-09-01 15:17:44.000000000 +0200
|
||||||
+++ pciutils-2.2.10/lib/configure 2008-05-26 18:30:13.000000000 -0500
|
+++ pciutils-3.0.0/lib/configure 2008-09-01 15:17:44.000000000 +0200
|
||||||
@@ -57,6 +57,10 @@ cat >$c <<EOF
|
@@ -62,6 +62,10 @@ define PCI_ARCH_S390X
|
||||||
#define PCI_ARCH_S390
|
#define PCI_ARCH_S390
|
||||||
#elif defined(__alpha__)
|
#elif defined(__alpha__)
|
||||||
#define PCI_ARCH_ALPHA
|
#define PCI_ARCH_ALPHA
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- pciutils-2.2.4/lib/names.c.buf 2006-09-09 12:46:39.000000000 +0200
|
diff -up pciutils-3.0.0/lib/names.c.buf pciutils-3.0.0/lib/names.c
|
||||||
+++ pciutils-2.2.4/lib/names.c 2007-01-26 13:47:01.000000000 +0100
|
--- pciutils-3.0.0/lib/names.c.buf 2008-04-10 21:15:47.000000000 +0200
|
||||||
@@ -372,12 +372,27 @@
|
+++ pciutils-3.0.0/lib/names.c 2008-09-01 15:14:58.000000000 +0200
|
||||||
|
@@ -65,12 +65,27 @@ format_name(char *buf, int size, int fla
|
||||||
res = snprintf(buf, size, "%s", num);
|
res = snprintf(buf, size, "%s", num);
|
||||||
else if (!name)
|
else if (!name)
|
||||||
res = snprintf(buf, size, ((flags & PCI_LOOKUP_MIXED) ? "%s [%s]" : "%s %s"), unknown, num);
|
res = snprintf(buf, size, ((flags & PCI_LOOKUP_MIXED) ? "%s [%s]" : "%s %s"), unknown, num);
|
||||||
@ -30,9 +31,9 @@
|
|||||||
else
|
else
|
||||||
return buf;
|
return buf;
|
||||||
}
|
}
|
||||||
@@ -408,8 +423,24 @@
|
@@ -101,8 +116,24 @@ format_name_pair(char *buf, int size, in
|
||||||
else /* v && !d */
|
else /* v && !d */
|
||||||
res = snprintf(buf, size, "%s Unknown device %s", v, num+5);
|
res = snprintf(buf, size, "%s Device %s", v, num+5);
|
||||||
}
|
}
|
||||||
- if (res < 0 || res >= size)
|
- if (res < 0 || res >= size)
|
||||||
+ if (res < 0 || res >= size) {
|
+ if (res < 0 || res >= size) {
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up pciutils-3.0.0/lib/configure.multilib pciutils-3.0.0/lib/configure
|
diff -up pciutils-3.0.0/lib/configure.multilib pciutils-3.0.0/lib/configure
|
||||||
--- pciutils-3.0.0/lib/configure.multilib 2008-04-10 21:15:47.000000000 +0200
|
--- pciutils-3.0.0/lib/configure.multilib 2008-04-10 21:15:47.000000000 +0200
|
||||||
+++ pciutils-3.0.0/lib/configure 2008-06-02 06:46:35.000000000 +0200
|
+++ pciutils-3.0.0/lib/configure 2008-09-01 15:17:03.000000000 +0200
|
||||||
@@ -41,28 +41,61 @@ sys=`echo $host | sed 's/^\([^-]*\)-\([^
|
@@ -41,28 +41,61 @@ sys=`echo $host | sed 's/^\([^-]*\)-\([^
|
||||||
echo " $host $rel"
|
echo " $host $rel"
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up pciutils-3.0.0/lib/names-parse.c.dird pciutils-3.0.0/lib/names-parse.c
|
diff -up pciutils-3.0.0/lib/names-parse.c.dird pciutils-3.0.0/lib/names-parse.c
|
||||||
--- pciutils-3.0.0/lib/names-parse.c.dird 2008-04-10 21:15:47.000000000 +0200
|
--- pciutils-3.0.0/lib/names-parse.c.dird 2008-04-10 21:15:47.000000000 +0200
|
||||||
+++ pciutils-3.0.0/lib/names-parse.c 2008-06-02 07:39:59.000000000 +0200
|
+++ pciutils-3.0.0/lib/names-parse.c 2008-09-01 15:17:23.000000000 +0200
|
||||||
@@ -6,10 +6,13 @@
|
@@ -6,10 +6,13 @@
|
||||||
* Can be freely distributed and used under the terms of the GNU GPL.
|
* Can be freely distributed and used under the terms of the GNU GPL.
|
||||||
*/
|
*/
|
||||||
@ -101,7 +101,7 @@ diff -up pciutils-3.0.0/lib/names-parse.c.dird pciutils-3.0.0/lib/names-parse.c
|
|||||||
+}
|
+}
|
||||||
diff -up pciutils-3.0.0/lib/pci.h.dird pciutils-3.0.0/lib/pci.h
|
diff -up pciutils-3.0.0/lib/pci.h.dird pciutils-3.0.0/lib/pci.h
|
||||||
--- pciutils-3.0.0/lib/pci.h.dird 2008-04-10 21:23:05.000000000 +0200
|
--- pciutils-3.0.0/lib/pci.h.dird 2008-04-10 21:23:05.000000000 +0200
|
||||||
+++ pciutils-3.0.0/lib/pci.h 2008-06-02 07:39:41.000000000 +0200
|
+++ pciutils-3.0.0/lib/pci.h 2008-09-01 15:17:23.000000000 +0200
|
||||||
@@ -194,6 +194,7 @@ int pci_load_name_list(struct pci_access
|
@@ -194,6 +194,7 @@ int pci_load_name_list(struct pci_access
|
||||||
void pci_free_name_list(struct pci_access *a) PCI_ABI; /* Called automatically by pci_cleanup() */
|
void pci_free_name_list(struct pci_access *a) PCI_ABI; /* Called automatically by pci_cleanup() */
|
||||||
void pci_set_name_list_path(struct pci_access *a, char *name, int to_be_freed) PCI_ABI;
|
void pci_set_name_list_path(struct pci_access *a, char *name, int to_be_freed) PCI_ABI;
|
||||||
|
@ -1,5 +1,6 @@
|
|||||||
--- pciutils-2.1.99-test8/lib/pread.h.pread 2004-08-13 16:15:46.000000000 -0400
|
diff -up pciutils-3.0.0/lib/pread.h.pread pciutils-3.0.0/lib/pread.h
|
||||||
+++ pciutils-2.1.99-test8/lib/pread.h 2004-08-31 00:30:03.168157294 -0400
|
--- pciutils-3.0.0/lib/pread.h.pread 2006-05-05 14:18:24.000000000 +0200
|
||||||
|
+++ pciutils-3.0.0/lib/pread.h 2008-09-01 15:15:53.000000000 +0200
|
||||||
@@ -12,54 +12,6 @@
|
@@ -12,54 +12,6 @@
|
||||||
* don't define it.
|
* don't define it.
|
||||||
*/
|
*/
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: pciutils
|
Name: pciutils
|
||||||
Version: 3.0.0
|
Version: 3.0.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/%{name}-%{version}.tar.gz
|
Source: ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/%{name}-%{version}.tar.gz
|
||||||
Patch1: pciutils-2.2.4-buf.patch
|
Patch1: pciutils-2.2.4-buf.patch
|
||||||
Patch2: pciutils-2.1.10-scan.patch
|
Patch2: pciutils-2.1.10-scan.patch
|
||||||
@ -105,6 +105,9 @@ install -p lib/libpci.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 01 2008 Harald Hoyer <harald@redhat.com> 3.0.0-2
|
||||||
|
- rebuild to eliminate fuzz patches
|
||||||
|
|
||||||
* Mon Jun 02 2008 Harald Hoyer <harald@redhat.com> 3.0.0-1
|
* Mon Jun 02 2008 Harald Hoyer <harald@redhat.com> 3.0.0-1
|
||||||
- version 3.0.0
|
- version 3.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user