- Rebase on upstream stable release v3.2

- Drop upstream patches.
- Patch t0251 to use en_US.UTF-8 if possible. Fedora doesn't have C.UTF-8
This commit is contained in:
Brian C. Lane 2014-07-29 12:07:49 -07:00
parent 419aff7905
commit 06fca52438
5 changed files with 47 additions and 33 deletions

2
.gitignore vendored
View File

@ -9,3 +9,5 @@ clog
/parted-3.1.tar.xz.sig /parted-3.1.tar.xz.sig
/parted-3.1.90.tar.xz /parted-3.1.90.tar.xz
/parted-3.1.90.tar.xz.sig /parted-3.1.90.tar.xz.sig
/parted-3.2.tar.xz
/parted-3.2.tar.xz.sig

View File

@ -0,0 +1,33 @@
From 9489285380f256bb8072d5e24cecf906b80994b9 Mon Sep 17 00:00:00 2001
From: Fedora Ninjas <parted-owner@fedoraproject.org>
Date: Wed, 30 Jul 2014 07:48:49 -0700
Subject: [PATCH] tests: Fall back to C.UTF-8 if no en_US available
Not all distributions (Fedora) have C.UTF-8 so first try en_US and fall
back to it. This may still fail if neither exist.
* tests/t0251-gpt-unicode.sh: Test for en_US and fall back to C.UTF-8
---
tests/t0251-gpt-unicode.sh | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/tests/t0251-gpt-unicode.sh b/tests/t0251-gpt-unicode.sh
index c845950..a51f541 100755
--- a/tests/t0251-gpt-unicode.sh
+++ b/tests/t0251-gpt-unicode.sh
@@ -22,7 +22,11 @@ dev=loop-file
# create zeroed device
truncate -s 10m $dev || fail=1
-export LC_ALL=C.UTF-8
+if [ -e "/usr/share/locale/en_US/" ]; then
+ export LC_ALL=en_US.UTF-8
+else
+ export LC_ALL=C.UTF-8
+fi
# create gpt label with named partition
part_name=$(printf 'foo\341\264\244')
parted -s $dev mklabel gpt mkpart primary ext2 1MiB 2MiB name 1 $part_name > empty 2>&1 || fail=1
--
1.9.3

View File

@ -1,26 +0,0 @@
From 081ed98dabfd1d857139c71fd6a74f8898dd9dcb Mon Sep 17 00:00:00 2001
From: Jim Meyering <meyering@fb.com>
Date: Mon, 23 Jun 2014 07:20:27 -0700
Subject: [PATCH 134/134] maint: correct a POT-file updating rule
* doc/C/Makefile.am (updatepo): If there is no po/$name.pot,
create an empty one. Reported by Philip Susi.
---
doc/C/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/doc/C/Makefile.am b/doc/C/Makefile.am
index 42b3cb1..c3595f5 100644
--- a/doc/C/Makefile.am
+++ b/doc/C/Makefile.am
@@ -13,6 +13,7 @@ updatepo:
test -w . || exit 0; \
for name in $(dist_man8_MANS); do \
echo $$name; \
+ test -f po/$$name.pot || touch po/$$name.pot; \
cp po/$$name.pot po/$$name.new.pot; \
po4a-updatepo -f man -m $$name -p po/$$name.new.pot; \
diff -I '^\"POT-Creation-Date: ' po/$$name.pot po/$$name.new.pot 2>&1 > /dev/null; \
--
1.9.3

View File

@ -3,18 +3,18 @@
Summary: The GNU disk partition manipulation program Summary: The GNU disk partition manipulation program
Name: parted Name: parted
Version: 3.1.90 Version: 3.2
Release: 2%{?dist} Release: 1%{?dist}
License: GPLv3+ License: GPLv3+
Group: Applications/System Group: Applications/System
URL: http://www.gnu.org/software/parted URL: http://www.gnu.org/software/parted
Source0: http://alpha.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
Source1: http://alpha.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz.sig Source1: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz.sig
Source2: pubkey.jim.meyering Source2: pubkey.jim.meyering
Source3: pubkey.phillip.susi Source3: pubkey.phillip.susi
Patch0134: 0134-maint-correct-a-POT-file-updating-rule.patch Patch0001: 0001-tests-Fall-back-to-C.UTF-8-if-no-en_US-available.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: e2fsprogs-devel BuildRequires: e2fsprogs-devel
@ -156,6 +156,11 @@ fi
%changelog %changelog
* Wed Jul 30 2014 Brian C. Lane <bcl@redhat.com> 3.2-1
- Rebase on upstream stable release v3.2
- Drop upstream patches.
- Patch t0251 to use en_US.UTF-8 if possible. Fedora doesn't have C.UTF-8
* Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> 3.1.90-2 * Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> 3.1.90-2
- fix license handling - fix license handling

View File

@ -1,2 +1,2 @@
48a72b4155ad0e8ff05f7bfdf78c3b79 parted-3.1.90.tar.xz 0247b6a7b314f8edeb618159fa95f9cb parted-3.2.tar.xz
2f1e2fd988963ad0a5c0361d88f5ef50 parted-3.1.90.tar.xz.sig 1b7304b51580d7121a890376ea7406d7 parted-3.2.tar.xz.sig