rebase to version 1.3.2 (#2195988)
This commit is contained in:
parent
c333cb527f
commit
78e065f737
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
|||||||
/pappl-1.2.3.tar.gz
|
/pappl-1.2.3.tar.gz
|
||||||
/pappl-1.3.0.tar.gz
|
/pappl-1.3.0.tar.gz
|
||||||
/pappl-1.3.1.tar.gz
|
/pappl-1.3.1.tar.gz
|
||||||
|
/pappl-1.3.2.tar.gz
|
||||||
|
@ -1,45 +0,0 @@
|
|||||||
diff --git a/pappl/log.c b/pappl/log.c
|
|
||||||
index 0559034..f740c3b 100644
|
|
||||||
--- a/pappl/log.c
|
|
||||||
+++ b/pappl/log.c
|
|
||||||
@@ -565,7 +565,7 @@ write_log(pappl_system_t *system, // I - System
|
|
||||||
case 'e' :
|
|
||||||
case 'f' :
|
|
||||||
case 'g' :
|
|
||||||
- snprintf(bufptr, (size_t)(bufptr - bufend + 1), tformat, va_arg(ap, double));
|
|
||||||
+ snprintf(bufptr, (size_t)(bufend - bufptr), tformat, va_arg(ap, double));
|
|
||||||
bufptr += strlen(bufptr);
|
|
||||||
break;
|
|
||||||
|
|
||||||
@@ -579,18 +579,18 @@ write_log(pappl_system_t *system, // I - System
|
|
||||||
case 'x' :
|
|
||||||
# ifdef HAVE_LONG_LONG
|
|
||||||
if (size == 'L')
|
|
||||||
- snprintf(bufptr, (size_t)(bufptr - bufend + 1), tformat, va_arg(ap, long long));
|
|
||||||
+ snprintf(bufptr, (size_t)(bufend - bufptr), tformat, va_arg(ap, long long));
|
|
||||||
else
|
|
||||||
# endif // HAVE_LONG_LONG
|
|
||||||
if (size == 'l')
|
|
||||||
- snprintf(bufptr, (size_t)(bufptr - bufend + 1), tformat, va_arg(ap, long));
|
|
||||||
+ snprintf(bufptr, (size_t)(bufend - bufptr), tformat, va_arg(ap, long));
|
|
||||||
else
|
|
||||||
- snprintf(bufptr, (size_t)(bufptr - bufend + 1), tformat, va_arg(ap, int));
|
|
||||||
+ snprintf(bufptr, (size_t)(bufend - bufptr), tformat, va_arg(ap, int));
|
|
||||||
bufptr += strlen(bufptr);
|
|
||||||
break;
|
|
||||||
|
|
||||||
case 'p' : // Log a pointer
|
|
||||||
- snprintf(bufptr, (size_t)(bufptr - bufend + 1), "%p", va_arg(ap, void *));
|
|
||||||
+ snprintf(bufptr, (size_t)(bufend - bufptr), "%p", va_arg(ap, void *));
|
|
||||||
bufptr += strlen(bufptr);
|
|
||||||
break;
|
|
||||||
|
|
||||||
@@ -651,7 +651,7 @@ write_log(pappl_system_t *system, // I - System
|
|
||||||
break;
|
|
||||||
|
|
||||||
default : // Something else we don't support
|
|
||||||
- papplCopyString(bufptr, tformat, (size_t)(bufptr - bufend + 1));
|
|
||||||
+ papplCopyString(bufptr, tformat, (size_t)(bufend - bufptr));
|
|
||||||
bufptr += strlen(bufptr);
|
|
||||||
break;
|
|
||||||
}
|
|
10
pappl.spec
10
pappl.spec
@ -9,15 +9,12 @@
|
|||||||
|
|
||||||
Summary: Printer Application Framework (PAPPL)
|
Summary: Printer Application Framework (PAPPL)
|
||||||
Name: pappl
|
Name: pappl
|
||||||
Version: 1.3.1
|
Version: 1.3.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Apache-2.0 WITH LLVM-exception
|
License: Apache-2.0 WITH LLVM-exception
|
||||||
Source: https://github.com/michaelrsweet/pappl/releases/download/v%{version}/pappl-%{version}.tar.gz
|
Source: https://github.com/michaelrsweet/pappl/releases/download/v%{version}/pappl-%{version}.tar.gz
|
||||||
Url: https://www.msweet.org/pappl
|
Url: https://www.msweet.org/pappl
|
||||||
|
|
||||||
# https://github.com/michaelrsweet/pappl/pull/272
|
|
||||||
Patch0001: pappl-writelog.patch
|
|
||||||
|
|
||||||
BuildRequires: avahi-devel
|
BuildRequires: avahi-devel
|
||||||
BuildRequires: cups-devel
|
BuildRequires: cups-devel
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -91,6 +88,9 @@ rm -f %{buildroot}/%{_libdir}/libpappl.a
|
|||||||
%{_libdir}/pkgconfig/pappl.pc
|
%{_libdir}/pkgconfig/pappl.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 11 2023 Richard Lescak <rlescak@redhat.com> - 1.3.2-1
|
||||||
|
- rebase to version 1.3.2 (#2195988)
|
||||||
|
|
||||||
* Thu Apr 13 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1.3.1-3
|
* Thu Apr 13 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1.3.1-3
|
||||||
- fix crash due invalid buffer size in `write_log()`
|
- fix crash due invalid buffer size in `write_log()`
|
||||||
- use the correct license tag
|
- use the correct license tag
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pappl-1.3.1.tar.gz) = d0feb863a9398db89deaa1655b06b34a15631eeba11af0d5653f790117ef00a22b560efa089f420502e999c0479539f039198dafd32c19b4fc1e6f1d120b5dbc
|
SHA512 (pappl-1.3.2.tar.gz) = e73bbff6cab8b9952b704d0bfa424e6ec047e6a05c0edf48301ed02e5ac7b044be3a34c80a0924a875b48a1ffac08ead1bb21faf88af51535760731a94ab18a0
|
||||||
|
Loading…
Reference in New Issue
Block a user