Make it build
This commit is contained in:
parent
786ce63f9d
commit
fd5858157e
11
pam-1.3.1-console-build.patch
Normal file
11
pam-1.3.1-console-build.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up Linux-PAM-1.3.1/modules/pam_console/sed-static.console-build Linux-PAM-1.3.1/modules/pam_console/sed-static
|
||||||
|
--- Linux-PAM-1.3.1/modules/pam_console/sed-static.console-build 2014-01-31 14:17:53.000000000 +0100
|
||||||
|
+++ Linux-PAM-1.3.1/modules/pam_console/sed-static 2018-09-10 15:06:04.115302315 +0200
|
||||||
|
@@ -13,6 +13,7 @@ sed '
|
||||||
|
/^YY_BUFFER_STATE yy_scan_buffer/s/^/STATIC /
|
||||||
|
/^YY_BUFFER_STATE yy_scan_string/s/^/STATIC /
|
||||||
|
/^void yy_switch_to_buffer/s/^/STATIC /
|
||||||
|
+/^extern int yylex/s/^extern /STATIC /
|
||||||
|
/define YY_DECL int yylex/s/YY_DECL /YY_DECL STATIC /
|
||||||
|
/^int yyparse/s/^/STATIC /
|
||||||
|
/^void yyrestart/s/^/STATIC /
|
@ -156,7 +156,7 @@ index 17baabe..a9d9140 100644
|
|||||||
|
|
||||||
- if (vasprintf (&buf, fmt, ap) < 0)
|
- if (vasprintf (&buf, fmt, ap) < 0)
|
||||||
+ va_start(ap, fmt);
|
+ va_start(ap, fmt);
|
||||||
+ ret = vasprintf (&buf, fmt, ap)
|
+ ret = vasprintf (&buf, fmt, ap);
|
||||||
+ va_end(ap);
|
+ va_end(ap);
|
||||||
+ if (ret < 0)
|
+ if (ret < 0)
|
||||||
return 0;
|
return 0;
|
||||||
|
2
pam.spec
2
pam.spec
@ -43,6 +43,7 @@ Patch31: pam-1.1.8-audit-user-mgmt.patch
|
|||||||
Patch32: pam-1.2.1-console-devname.patch
|
Patch32: pam-1.2.1-console-devname.patch
|
||||||
Patch33: pam-1.3.0-unix-nomsg.patch
|
Patch33: pam-1.3.0-unix-nomsg.patch
|
||||||
Patch34: pam-1.3.1-coverity.patch
|
Patch34: pam-1.3.1-coverity.patch
|
||||||
|
Patch35: pam-1.3.1-console-build.patch
|
||||||
|
|
||||||
%define _pamlibdir %{_libdir}
|
%define _pamlibdir %{_libdir}
|
||||||
%define _moduledir %{_libdir}/security
|
%define _moduledir %{_libdir}/security
|
||||||
@ -125,6 +126,7 @@ cp %{SOURCE18} .
|
|||||||
%patch32 -p1 -b .devname
|
%patch32 -p1 -b .devname
|
||||||
%patch33 -p1 -b .nomsg
|
%patch33 -p1 -b .nomsg
|
||||||
%patch34 -p1 -b .coverity
|
%patch34 -p1 -b .coverity
|
||||||
|
%patch35 -p1 -b .console-build
|
||||||
autoreconf -i
|
autoreconf -i
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
Loading…
Reference in New Issue
Block a user