Port configure script to C99
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
c66885bc84
commit
bfff0f23a8
35
pam-1.5.2-configure-c99.patch
Normal file
35
pam-1.5.2-configure-c99.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From f07fc9cac78851d3dfad1e8c54ee2671e6351853 Mon Sep 17 00:00:00 2001
|
||||
From: Sam James <sam@gentoo.org>
|
||||
Date: Sun, 11 Sep 2022 16:37:59 +0100
|
||||
Subject: [PATCH] configure.ac: fix implicit function declaration in mail spool
|
||||
directory check
|
||||
|
||||
Fixes the following error with Clang 15 (which makes implicit function
|
||||
declarations an error by default):
|
||||
```
|
||||
+error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
|
||||
exit(0);
|
||||
^
|
||||
note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
|
||||
```
|
||||
|
||||
Signed-off-by: Sam James <sam@gentoo.org>
|
||||
---
|
||||
configure.ac | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 79113ad1..b12c8892 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -297,6 +297,7 @@ if test x$with_mailspool != x ; then
|
||||
else
|
||||
AC_RUN_IFELSE([AC_LANG_SOURCE([[
|
||||
#include <paths.h>
|
||||
+#include <stdlib.h>
|
||||
int main() {
|
||||
#ifdef _PATH_MAILDIR
|
||||
exit(0);
|
||||
--
|
||||
2.40.0
|
||||
|
7
pam.spec
7
pam.spec
@ -4,7 +4,7 @@
|
||||
Summary: An extensible library which provides authentication for applications
|
||||
Name: pam
|
||||
Version: 1.5.2
|
||||
Release: 17%{?dist}
|
||||
Release: 18%{?dist}
|
||||
# The library is BSD licensed with option to relicense as GPLv2+
|
||||
# - this option is redundant as the BSD license allows that anyway.
|
||||
# pam_timestamp and pam_loginuid modules are GPLv2+.
|
||||
@ -26,6 +26,7 @@ Patch1: pam-1.5.2-redhat-modules.patch
|
||||
Patch2: pam-1.5.0-noflex.patch
|
||||
Patch3: pam-1.3.0-unix-nomsg.patch
|
||||
Patch4: pam-1.5.2-pwhistory-config.patch
|
||||
Patch5: pam-1.5.2-configure-c99.patch
|
||||
|
||||
%{load:%{SOURCE3}}
|
||||
|
||||
@ -120,6 +121,7 @@ cp %{SOURCE18} .
|
||||
%patch2 -p1 -b .noflex
|
||||
%patch3 -p1 -b .nomsg
|
||||
%patch4 -p1 -b .pwhistory-config
|
||||
%patch5 -p1 -b .configure-c99
|
||||
|
||||
autoreconf -i
|
||||
|
||||
@ -355,6 +357,9 @@ done
|
||||
%{_pam_libdir}/libpam_misc.so.%{so_ver}*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 25 2023 Arjun Shankar <arjun@redhat.com> - 1.5.2-18
|
||||
- Port configure script to C99
|
||||
|
||||
* Thu Feb 9 2023 Iker Pedrosa <ipedrosa@redhat.com> - 1.5.2-17
|
||||
- Remove pam_console (#2166692)
|
||||
- Rebase to pam-redhat-1.2.0
|
||||
|
Loading…
Reference in New Issue
Block a user