- Rebase to release 1.6.1
- Disable nis support Signed-off-by: Iker Pedrosa <ipedrosa@redhat.com>
This commit is contained in:
parent
59eb6f7f14
commit
8c4a8fc39d
@ -1,24 +0,0 @@
|
||||
diff -up Linux-PAM-1.6.0/doc/Makefile.am.noflex Linux-PAM-1.6.0/doc/Makefile.am
|
||||
--- Linux-PAM-1.6.0/doc/Makefile.am.noflex 2024-01-23 13:19:04.681955581 +0100
|
||||
+++ Linux-PAM-1.6.0/doc/Makefile.am 2024-01-23 13:19:49.740014426 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
# Copyright (c) 2005, 2006 Thorsten Kukuk <kukuk@suse.de>
|
||||
#
|
||||
|
||||
-SUBDIRS = man specs sag adg mwg
|
||||
+SUBDIRS = man sag adg mwg
|
||||
|
||||
CLEANFILES = *~
|
||||
DISTCLEANFILES = custom-html.xsl custom-man.xsl
|
||||
diff -up Linux-PAM-1.6.0/Makefile.am.noflex Linux-PAM-1.6.0/Makefile.am
|
||||
--- Linux-PAM-1.6.0/Makefile.am.noflex 2024-01-23 13:19:04.681955581 +0100
|
||||
+++ Linux-PAM-1.6.0/Makefile.am 2024-01-23 13:21:03.428109219 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = 1.9 gnu dist-xz no-dist-gzip check-news
|
||||
|
||||
-SUBDIRS = libpam tests libpamc libpam_misc modules po conf xtests
|
||||
+SUBDIRS = libpam tests libpamc libpam_misc modules po doc xtests
|
||||
|
||||
if HAVE_DOC
|
||||
SUBDIRS += doc
|
@ -1,30 +0,0 @@
|
||||
From 470b5bdd8fd29d6b35e3a80f9a57bdd4b2438200 Mon Sep 17 00:00:00 2001
|
||||
From: Tobias Stoeckmann <tobias@stoeckmann.org>
|
||||
Date: Fri, 19 Jan 2024 10:09:00 +0100
|
||||
Subject: [PATCH] pam_unix: do not warn if password aging is disabled
|
||||
|
||||
Later checks will print a warning if daysleft is 0. If password
|
||||
aging is disabled, leave daysleft at -1.
|
||||
|
||||
Resolves: https://github.com/linux-pam/linux-pam/issues/743
|
||||
Fixes: 9ebc14085a3b ("pam_unix: allow disabled password aging")
|
||||
Signed-off-by: Tobias Stoeckmann <tobias@stoeckmann.org>
|
||||
---
|
||||
modules/pam_unix/passverify.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/modules/pam_unix/passverify.c b/modules/pam_unix/passverify.c
|
||||
index 5c4f862e..1bc98fa2 100644
|
||||
--- a/modules/pam_unix/passverify.c
|
||||
+++ b/modules/pam_unix/passverify.c
|
||||
@@ -314,7 +314,6 @@ PAMH_ARG_DECL(int check_shadow_expiry,
|
||||
}
|
||||
if (spent->sp_lstchg < 0) {
|
||||
D(("password aging disabled"));
|
||||
- *daysleft = 0;
|
||||
return PAM_SUCCESS;
|
||||
}
|
||||
if (curdays < spent->sp_lstchg) {
|
||||
--
|
||||
2.43.0
|
||||
|
24
pam-1.6.1-noflex.patch
Normal file
24
pam-1.6.1-noflex.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up Linux-PAM-1.6.1/doc/Makefile.am.noflex Linux-PAM-1.6.1/doc/Makefile.am
|
||||
--- Linux-PAM-1.6.1/doc/Makefile.am.noflex 2024-04-09 18:22:59.000000000 +0200
|
||||
+++ Linux-PAM-1.6.1/doc/Makefile.am 2024-04-10 11:09:39.304086982 +0200
|
||||
@@ -2,7 +2,7 @@
|
||||
# Copyright (c) 2005, 2006 Thorsten Kukuk <kukuk@suse.de>
|
||||
#
|
||||
|
||||
-SUBDIRS = man specs sag adg mwg
|
||||
+SUBDIRS = man sag adg mwg
|
||||
|
||||
CLEANFILES = *~
|
||||
DISTCLEANFILES = custom-html.xsl custom-man.xsl
|
||||
diff -up Linux-PAM-1.6.1/Makefile.am.noflex Linux-PAM-1.6.1/Makefile.am
|
||||
--- Linux-PAM-1.6.1/Makefile.am.noflex 2024-04-10 11:09:39.304086982 +0200
|
||||
+++ Linux-PAM-1.6.1/Makefile.am 2024-04-10 11:13:15.057352362 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = 1.9 gnu dist-xz no-dist-gzip check-news
|
||||
|
||||
-SUBDIRS = libpam_internal libpam tests libpamc libpam_misc modules po conf \
|
||||
+SUBDIRS = libpam_internal libpam tests libpamc libpam_misc modules po doc \
|
||||
xtests
|
||||
|
||||
if HAVE_DOC
|
14
pam.spec
14
pam.spec
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: An extensible library which provides authentication for applications
|
||||
Name: pam
|
||||
Version: 1.6.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.6.1
|
||||
Release: 1%{?dist}
|
||||
# The library is BSD licensed with option to relicense as GPLv2+
|
||||
# - this option is redundant as the BSD license allows that anyway.
|
||||
# pam_timestamp and pam_loginuid modules are GPLv2+.
|
||||
@ -23,9 +23,8 @@ Source15: pamtmp.conf
|
||||
Source17: postlogin.5
|
||||
Source18: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
||||
Patch1: pam-1.6.0-redhat-modules.patch
|
||||
Patch2: pam-1.6.0-noflex.patch
|
||||
Patch2: pam-1.6.1-noflex.patch
|
||||
Patch3: pam-1.5.3-unix-nomsg.patch
|
||||
Patch4: pam-1.6.0-unix-warn-passwd.patch
|
||||
|
||||
%{load:%{SOURCE3}}
|
||||
|
||||
@ -48,7 +47,6 @@ BuildRequires: gcc
|
||||
BuildRequires: gdbm-devel
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libeconf-devel
|
||||
BuildRequires: libnsl2-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: libtool
|
||||
@ -120,7 +118,6 @@ cp %{SOURCE18} .
|
||||
%patch -P 1 -p1 -b .redhat-modules
|
||||
%patch -P 2 -p1 -b .noflex
|
||||
%patch -P 3 -p1 -b .nomsg
|
||||
%patch -P 4 -p1 -b .unix-warn-passwd
|
||||
|
||||
autoreconf -i
|
||||
|
||||
@ -131,6 +128,7 @@ autoreconf -i
|
||||
--disable-rpath \
|
||||
--disable-static \
|
||||
--disable-prelude \
|
||||
--disable-nis \
|
||||
--enable-audit \
|
||||
--enable-openssl \
|
||||
--enable-selinux \
|
||||
@ -358,6 +356,10 @@ done
|
||||
%{_pam_libdir}/libpam_misc.so.%{so_ver}*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 10 2024 Iker Pedrosa <ipedrosa@redhat.com> - 1.6.1-1
|
||||
- Rebase to release 1.6.1
|
||||
- Disable nis support
|
||||
|
||||
* Thu Feb 15 2024 Iker Pedrosa <ipedrosa@redhat.com> - 1.6.0-2
|
||||
- pam_unix: do not warn if password aging is disabled (#2263689)
|
||||
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (Linux-PAM-1.6.0.tar.xz) = 7af07edb71a79275ad7f7f3bd82a4619b12a23a10f5fb2e5d810c6aadb718fd739ed17ca336c3420945d48d326e91874d8e45cfc5a4bf01a0cc5f9663bd2a0ad
|
||||
SHA512 (Linux-PAM-1.6.0.tar.xz.asc) = bfed774bf49b13f11ab4251fe6223ce04ecf57e7123ce245b8e885c345449af528317e8500360efef12beabd14b99cd3ae6d7ad61074955958018062c36ba476
|
||||
SHA512 (Linux-PAM-1.6.1.tar.xz) = ddb5a5f296f564b76925324550d29f15d342841a97815336789c7bb922a8663e831edeb54f3dcd1eaf297e3325c9e2e6c14b8740def5c43cf3f160a8a14fa2ea
|
||||
SHA512 (Linux-PAM-1.6.1.tar.xz.asc) = 609dd4dadac06ac50002684998f3dc3e19f7452bd39ccac67421bc402b2d95544a825ad6f2af14e6d2ce999bb1a716ebcaf7a947d459c365380320e42418abf5
|
||||
SHA512 (pam-redhat-1.2.0.tar.xz) = f676a6c8df0cf3836018b1a67ded1d40937b88ff046e5c6b22bac46cb05e27970ef6a7ce224269e4c0d1ca9375c72e77880cf9114e936a7de9c423bf443d27ee
|
||||
|
Loading…
Reference in New Issue
Block a user