import pam-1.3.1-16.el8_6.1
This commit is contained in:
parent
8983ea5e6f
commit
7ec2ee0342
1212
SOURCES/pam-1.3.1-faillock-load-conf-from-file.patch
Normal file
1212
SOURCES/pam-1.3.1-faillock-load-conf-from-file.patch
Normal file
File diff suppressed because it is too large
Load Diff
105
SOURCES/pam-1.3.1-inline.patch
Normal file
105
SOURCES/pam-1.3.1-inline.patch
Normal file
@ -0,0 +1,105 @@
|
||||
diff -up Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h.inline Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h
|
||||
--- Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h.inline 2022-05-26 10:44:31.702623614 +0200
|
||||
+++ Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h 2022-05-26 10:44:31.703623621 +0200
|
||||
@@ -44,4 +44,17 @@
|
||||
# define DIAG_POP_IGNORE_CAST_ALIGN /* empty */
|
||||
#endif
|
||||
|
||||
+/*
|
||||
+ * Evaluates to
|
||||
+ * 1, if the given two types are known to be the same
|
||||
+ * 0, otherwise.
|
||||
+ */
|
||||
+#if PAM_GNUC_PREREQ(3, 0)
|
||||
+# define PAM_IS_SAME_TYPE(x_, y_) \
|
||||
+ __builtin_types_compatible_p(__typeof__(x_), __typeof__(y_))
|
||||
+#else
|
||||
+/* Cannot tell whether these types are the same. */
|
||||
+# define PAM_IS_SAME_TYPE(x_, y_) 0
|
||||
+#endif
|
||||
+
|
||||
#endif /* PAM_CC_COMPAT_H */
|
||||
diff -up Linux-PAM-1.3.1/libpam/include/pam_inline.h.inline Linux-PAM-1.3.1/libpam/include/pam_inline.h
|
||||
--- Linux-PAM-1.3.1/libpam/include/pam_inline.h.inline 2022-05-26 10:44:31.703623621 +0200
|
||||
+++ Linux-PAM-1.3.1/libpam/include/pam_inline.h 2022-05-26 10:44:31.703623621 +0200
|
||||
@@ -0,0 +1,67 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2020 Dmitry V. Levin <ldv@altlinux.org>
|
||||
+ *
|
||||
+ * Handy inline functions and macros providing some convenient functionality
|
||||
+ * to libpam and its modules.
|
||||
+ */
|
||||
+
|
||||
+#ifndef PAM_INLINE_H
|
||||
+#define PAM_INLINE_H
|
||||
+
|
||||
+#include "pam_cc_compat.h"
|
||||
+#include <string.h>
|
||||
+
|
||||
+/*
|
||||
+ * Evaluates to
|
||||
+ * - a syntax error if the argument is 0,
|
||||
+ * 0, otherwise.
|
||||
+ */
|
||||
+#define PAM_FAIL_BUILD_ON_ZERO(e_) (sizeof(int[-1 + 2 * !!(e_)]) * 0)
|
||||
+
|
||||
+/*
|
||||
+ * Evaluates to
|
||||
+ * 1, if the given type is known to be a non-array type
|
||||
+ * 0, otherwise.
|
||||
+ */
|
||||
+#define PAM_IS_NOT_ARRAY(a_) PAM_IS_SAME_TYPE((a_), &(a_)[0])
|
||||
+
|
||||
+/*
|
||||
+ * Evaluates to
|
||||
+ * - a syntax error if the argument is not an array,
|
||||
+ * 0, otherwise.
|
||||
+ */
|
||||
+#define PAM_MUST_BE_ARRAY(a_) PAM_FAIL_BUILD_ON_ZERO(!PAM_IS_NOT_ARRAY(a_))
|
||||
+
|
||||
+/* Evaluates to the number of elements in the specified array. */
|
||||
+#define PAM_ARRAY_SIZE(a_) (sizeof(a_) / sizeof((a_)[0]) + PAM_MUST_BE_ARRAY(a_))
|
||||
+
|
||||
+/*
|
||||
+ * Returns NULL if STR does not start with PREFIX,
|
||||
+ * or a pointer to the first char in STR after PREFIX.
|
||||
+ * The length of PREFIX is specified by PREFIX_LEN.
|
||||
+ */
|
||||
+static inline const char *
|
||||
+pam_str_skip_prefix_len(const char *str, const char *prefix, size_t prefix_len)
|
||||
+{
|
||||
+ return strncmp(str, prefix, prefix_len) ? NULL : str + prefix_len;
|
||||
+}
|
||||
+
|
||||
+#define pam_str_skip_prefix(str_, prefix_) \
|
||||
+ pam_str_skip_prefix_len((str_), (prefix_), sizeof(prefix_) - 1 + PAM_MUST_BE_ARRAY(prefix_))
|
||||
+
|
||||
+/*
|
||||
+ * Returns NULL if STR does not start with PREFIX
|
||||
+ * (ignoring the case of the characters),
|
||||
+ * or a pointer to the first char in STR after PREFIX.
|
||||
+ * The length of PREFIX is specified by PREFIX_LEN.
|
||||
+ */
|
||||
+static inline const char *
|
||||
+pam_str_skip_icase_prefix_len(const char *str, const char *prefix, size_t prefix_len)
|
||||
+{
|
||||
+ return strncasecmp(str, prefix, prefix_len) ? NULL : str + prefix_len;
|
||||
+}
|
||||
+
|
||||
+#define pam_str_skip_icase_prefix(str_, prefix_) \
|
||||
+ pam_str_skip_icase_prefix_len((str_), (prefix_), sizeof(prefix_) - 1 + PAM_MUST_BE_ARRAY(prefix_))
|
||||
+
|
||||
+#endif /* PAM_INLINE_H */
|
||||
diff -up Linux-PAM-1.3.1/libpam/Makefile.am.inline Linux-PAM-1.3.1/libpam/Makefile.am
|
||||
--- Linux-PAM-1.3.1/libpam/Makefile.am.inline 2022-05-26 10:44:31.702623614 +0200
|
||||
+++ Linux-PAM-1.3.1/libpam/Makefile.am 2022-05-26 10:45:21.146977780 +0200
|
||||
@@ -18,7 +18,8 @@ include_HEADERS = include/security/_pam_
|
||||
include/security/pam_ext.h include/security/pam_modutil.h
|
||||
|
||||
noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
|
||||
- pam_modutil_private.h include/pam_cc_compat.h
|
||||
+ pam_modutil_private.h include/pam_cc_compat.h \
|
||||
+ include/pam_inline.h
|
||||
|
||||
libpam_la_LDFLAGS = -no-undefined -version-info 84:2:84
|
||||
libpam_la_LIBADD = @LIBAUDIT@ $(LIBPRELUDE_LIBS) @LIBDL@
|
63
SOURCES/pam-1.3.1-pam-cc-compat.patch
Normal file
63
SOURCES/pam-1.3.1-pam-cc-compat.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff -up Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h.pam-cc-compat Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h
|
||||
--- Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h.pam-cc-compat 2022-05-26 10:43:50.436328027 +0200
|
||||
+++ Linux-PAM-1.3.1/libpam/include/pam_cc_compat.h 2022-05-26 10:43:50.436328027 +0200
|
||||
@@ -0,0 +1,47 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2020 Dmitry V. Levin <ldv@altlinux.org>
|
||||
+ */
|
||||
+
|
||||
+#ifndef PAM_CC_COMPAT_H
|
||||
+#define PAM_CC_COMPAT_H
|
||||
+
|
||||
+#include "config.h"
|
||||
+#include <security/_pam_types.h>
|
||||
+
|
||||
+#if defined __clang__ && defined __clang_major__ && defined __clang_minor__
|
||||
+# define PAM_CLANG_PREREQ(maj, min) \
|
||||
+ ((__clang_major__ << 16) + __clang_minor__ >= ((maj) << 16) + (min))
|
||||
+#else
|
||||
+# define PAM_CLANG_PREREQ(maj, min) 0
|
||||
+#endif
|
||||
+
|
||||
+#if PAM_GNUC_PREREQ(4, 6)
|
||||
+# define DIAG_PUSH_IGNORE_CAST_QUAL \
|
||||
+ _Pragma("GCC diagnostic push"); \
|
||||
+ _Pragma("GCC diagnostic ignored \"-Wcast-qual\"")
|
||||
+# define DIAG_POP_IGNORE_CAST_QUAL \
|
||||
+ _Pragma("GCC diagnostic pop")
|
||||
+# define DIAG_PUSH_IGNORE_CAST_ALIGN \
|
||||
+ _Pragma("GCC diagnostic push"); \
|
||||
+ _Pragma("GCC diagnostic ignored \"-Wcast-align\"")
|
||||
+# define DIAG_POP_IGNORE_CAST_ALIGN \
|
||||
+ _Pragma("GCC diagnostic pop")
|
||||
+#elif PAM_CLANG_PREREQ(2, 6)
|
||||
+# define DIAG_PUSH_IGNORE_CAST_QUAL \
|
||||
+ _Pragma("clang diagnostic push"); \
|
||||
+ _Pragma("clang diagnostic ignored \"-Wcast-qual\"")
|
||||
+# define DIAG_POP_IGNORE_CAST_QUAL \
|
||||
+ _Pragma("clang diagnostic pop")
|
||||
+# define DIAG_PUSH_IGNORE_CAST_ALIGN \
|
||||
+ _Pragma("clang diagnostic push"); \
|
||||
+ _Pragma("clang diagnostic ignored \"-Wcast-align\"")
|
||||
+# define DIAG_POP_IGNORE_CAST_ALIGN \
|
||||
+ _Pragma("clang diagnostic pop")
|
||||
+#else
|
||||
+# define DIAG_PUSH_IGNORE_CAST_QUAL /* empty */
|
||||
+# define DIAG_POP_IGNORE_CAST_QUAL /* empty */
|
||||
+# define DIAG_PUSH_IGNORE_CAST_ALIGN /* empty */
|
||||
+# define DIAG_POP_IGNORE_CAST_ALIGN /* empty */
|
||||
+#endif
|
||||
+
|
||||
+#endif /* PAM_CC_COMPAT_H */
|
||||
diff -up Linux-PAM-1.3.1/libpam/Makefile.am.pam-cc-compat Linux-PAM-1.3.1/libpam/Makefile.am
|
||||
--- Linux-PAM-1.3.1/libpam/Makefile.am.pam-cc-compat 2022-05-26 10:43:50.436328027 +0200
|
||||
+++ Linux-PAM-1.3.1/libpam/Makefile.am 2022-05-26 10:44:00.865402730 +0200
|
||||
@@ -18,7 +18,7 @@ include_HEADERS = include/security/_pam_
|
||||
include/security/pam_ext.h include/security/pam_modutil.h
|
||||
|
||||
noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
|
||||
- pam_modutil_private.h
|
||||
+ pam_modutil_private.h include/pam_cc_compat.h
|
||||
|
||||
libpam_la_LDFLAGS = -no-undefined -version-info 84:2:84
|
||||
libpam_la_LIBADD = @LIBAUDIT@ $(LIBPRELUDE_LIBS) @LIBDL@
|
@ -3,7 +3,7 @@
|
||||
Summary: An extensible library which provides authentication for applications
|
||||
Name: pam
|
||||
Version: 1.3.1
|
||||
Release: 16%{?dist}
|
||||
Release: 16%{?dist}.1
|
||||
# The library is BSD licensed with option to relicense as GPLv2+
|
||||
# - this option is redundant as the BSD license allows that anyway.
|
||||
# pam_timestamp, pam_loginuid, and pam_console modules are GPLv2+.
|
||||
@ -69,6 +69,12 @@ Patch49: pam-1.3.1-namespace-gdm-doc.patch
|
||||
Patch50: pam-1.3.1-pam-userdb-prevent-garbage-characters-from-db.patch
|
||||
# https://github.com/linux-pam/linux-pam/commit/3234488f2c52a021eec87df1990d256314c21bff
|
||||
Patch51: pam-1.3.1-pam-limits-unlimited-value.patch
|
||||
# Needed by the next patch. Already upstreamed
|
||||
Patch52: pam-1.3.1-pam-cc-compat.patch
|
||||
Patch53: pam-1.3.1-inline.patch
|
||||
# https://github.com/linux-pam/linux-pam/commit/9bcbe96d9e82a23d983c0618178a8dc25596ac2d
|
||||
# https://github.com/linux-pam/linux-pam/commit/fc867a9e22eac2c9a0ed0577776bba4df21c9aad
|
||||
Patch54: pam-1.3.1-faillock-load-conf-from-file.patch
|
||||
|
||||
%define _pamlibdir %{_libdir}
|
||||
%define _moduledir %{_libdir}/security
|
||||
@ -168,6 +174,9 @@ cp %{SOURCE18} .
|
||||
%patch49 -p1 -b .namespace-gdm-doc
|
||||
%patch50 -p1 -b .pam-userdb-prevent-garbage-characters-from-db
|
||||
%patch51 -p1 -b .pam-limits-unlimited-value
|
||||
%patch52 -p1 -b .pam-cc-compat
|
||||
%patch53 -p1 -b .inline
|
||||
%patch54 -p1 -b .faillock-load-conf-from-file
|
||||
|
||||
autoreconf -i
|
||||
|
||||
@ -414,6 +423,9 @@ done
|
||||
%doc doc/specs/rfc86.0.txt
|
||||
|
||||
%changelog
|
||||
* Tue Aug 2 2022 Iker Pedrosa <ipedrosa@redhat.com> - 1.3.1-16.1
|
||||
- faillock: load configuration from file. Resolves: #2112889
|
||||
|
||||
* Fri Jan 28 2022 Iker Pedrosa <ipedrosa@redhat.com> - 1.3.1-16
|
||||
- pam_limits: "Unlimited" is not a valid value for RLIMIT_NOFILE. Resolves: #2047655
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user