- review
- don't free/malloc when unnecessary
This commit is contained in:
parent
43c3a5a46e
commit
790525d4ab
@ -1,6 +1,9 @@
|
||||
Written-by: Tomas Mraz <tmraz@redhat.com>
|
||||
Reviewed-by: Karel Zak <kzak@redhat.com>
|
||||
|
||||
diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.8.xml
|
||||
--- /dev/null 2007-09-17 08:57:19.474470099 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.8.xml 2007-09-19 17:18:43.000000000 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.8.xml 2007-09-19 19:37:26.000000000 +0200
|
||||
@@ -0,0 +1,182 @@
|
||||
+<?xml version="1.0" encoding='UTF-8'?>
|
||||
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.3//EN"
|
||||
@ -186,7 +189,7 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.8.x
|
||||
+</refentry>
|
||||
diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
--- /dev/null 2007-09-17 08:57:19.474470099 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c 2007-09-19 18:14:36.000000000 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c 2007-09-19 20:29:47.000000000 +0200
|
||||
@@ -0,0 +1,222 @@
|
||||
+/******************************************************************************
|
||||
+ * A module for Linux-PAM that allows/denies acces based on SELinux state.
|
||||
@ -255,7 +258,7 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
+ FILE *f;
|
||||
+ char *line = NULL;
|
||||
+ char *start;
|
||||
+ size_t n = 0;
|
||||
+ size_t len = 0;
|
||||
+ int matched = 0;
|
||||
+
|
||||
+ f = fopen(cfgfile, "r");
|
||||
@ -265,9 +268,11 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
+ return PAM_SERVICE_ERR;
|
||||
+ }
|
||||
+
|
||||
+ while (!matched && getline(&line, &n, f) != -1) {
|
||||
+ while (!matched && getline(&line, &len, f) != -1) {
|
||||
+ size_t n;
|
||||
+
|
||||
+ if (line[0] == '#')
|
||||
+ goto cleanup;
|
||||
+ continue;
|
||||
+
|
||||
+ start = line;
|
||||
+ while (isspace(*start))
|
||||
@ -277,7 +282,7 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
+ --n;
|
||||
+ }
|
||||
+ if (n == 0)
|
||||
+ goto cleanup;
|
||||
+ continue;
|
||||
+
|
||||
+ start[n] = '\0';
|
||||
+
|
||||
@ -305,11 +310,9 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
+ matched = 1;
|
||||
+ }
|
||||
+ }
|
||||
+cleanup:
|
||||
+ free(line);
|
||||
+ line = NULL;
|
||||
+ }
|
||||
+
|
||||
+ free(line);
|
||||
+ fclose(f);
|
||||
+ return matched ? 0 : -1;
|
||||
+}
|
||||
@ -412,7 +415,7 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/pam_selinux_permit.c
|
||||
+
|
||||
diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/sepermit.conf
|
||||
--- /dev/null 2007-09-17 08:57:19.474470099 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/sepermit.conf 2007-09-19 17:18:43.000000000 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/sepermit.conf 2007-09-19 19:37:26.000000000 +0200
|
||||
@@ -0,0 +1,6 @@
|
||||
+# /etc/security/sepermit.conf
|
||||
+#
|
||||
@ -422,7 +425,7 @@ diff -up /dev/null Linux-PAM-0.99.8.1/modules/pam_selinux/sepermit.conf
|
||||
+# - a SELinux user name, with %seuser syntax
|
||||
diff -up Linux-PAM-0.99.8.1/modules/pam_selinux/Makefile.am.permit Linux-PAM-0.99.8.1/modules/pam_selinux/Makefile.am
|
||||
--- Linux-PAM-0.99.8.1/modules/pam_selinux/Makefile.am.permit 2007-01-23 11:09:25.000000000 +0100
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/Makefile.am 2007-09-19 18:19:42.000000000 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_selinux/Makefile.am 2007-09-19 19:37:26.000000000 +0200
|
||||
@@ -5,20 +5,21 @@
|
||||
CLEANFILES = *~
|
||||
|
||||
|
@ -1,3 +1,6 @@
|
||||
Written-by: Tomas Mraz <tmraz@redhat.com>
|
||||
Reviewed-by: Karel Zak <kzak@redhat.com>
|
||||
|
||||
diff -up Linux-PAM-0.99.8.1/modules/pam_succeed_if/pam_succeed_if.c.in-operator Linux-PAM-0.99.8.1/modules/pam_succeed_if/pam_succeed_if.c
|
||||
--- Linux-PAM-0.99.8.1/modules/pam_succeed_if/pam_succeed_if.c.in-operator 2006-08-31 12:20:39.000000000 +0200
|
||||
+++ Linux-PAM-0.99.8.1/modules/pam_succeed_if/pam_succeed_if.c 2007-09-19 19:36:22.000000000 +0200
|
||||
|
Loading…
Reference in New Issue
Block a user