Autotools hackery to make it build.

This commit is contained in:
Tomas Mraz 2012-09-05 19:09:56 +02:00
parent 725d09d8bf
commit 72401d341e
2 changed files with 35 additions and 1 deletions

View File

@ -0,0 +1,31 @@
diff --git a/configure.in b/configure.in
index ae762a2..729e7f1 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,8 @@ AC_INIT
AC_CONFIG_SRCDIR([conf/pam_conv1/pam_conv_y.y])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE("Linux-PAM", 1.1.6)
-AC_PREREQ(2.61)
+LT_INIT
+AC_PREREQ([2.68])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_HOST
@@ -82,7 +83,6 @@ AM_PROG_LEX
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AC_PROG_LIBTOOL
AM_PROG_CC_C_O
PAM_LD_AS_NEEDED
PAM_LD_NO_UNDEFINED
@@ -532,7 +532,7 @@ AC_CHECK_FUNCS(unshare, [UNSHARE=yes], [UNSHARE=no])
AM_CONDITIONAL([HAVE_UNSHARE], [test "$UNSHARE" = yes])
AC_ARG_ENABLE([regenerate-docu],
- AC_HELP_STRING([--disable-regenerate-docu], [Don't re-build documentation from XML souces]),
+ AS_HELP_STRING([--disable-regenerate-docu],[Don't re-build documentation from XML sources]),
[enable_docu=$enableval], [enable_docu=yes])
dnl
dnl Check for xsltproc

View File

@ -46,6 +46,7 @@ Patch20: pam-1.1.5-unix-no-fallback.patch
Patch21: pam-1.1.6-install-empty.patch
#
Patch22: pam-1.1.5-unix-build.patch
Patch23: pam-1.1.6-autoupdate.patch
%define _sbindir /sbin
%define _moduledir /%{_lib}/security
@ -67,7 +68,7 @@ BuildRequires: autoconf >= 2.60
BuildRequires: automake, libtool
BuildRequires: bison, flex, sed
BuildRequires: cracklib-devel, cracklib-dicts >= 2.8
BuildRequires: perl, pkgconfig, gettext
BuildRequires: perl, pkgconfig, gettext-devel
%if %{WITH_AUDIT}
BuildRequires: audit-libs-devel >= 1.0.8
Requires: audit-libs >= 1.0.8
@ -123,12 +124,14 @@ mv pam-redhat-%{pam_redhat_version}/* modules
%patch20 -p1 -b .no-fallback
%patch21 -p1 -b .empty
%patch22 -p1 -b .build
%patch23 -p1 -b .autoupdate
%build
autoreconf
%configure \
--libdir=/%{_lib} \
--includedir=%{_includedir}/security \
--disable-static \
--disable-prelude \
%if ! %{WITH_SELINUX}
--disable-selinux \