install empty directories

This commit is contained in:
Tomas Mraz 2012-05-09 12:30:33 +02:00
parent 7f16b85d54
commit 14f4737e81
2 changed files with 34 additions and 0 deletions

View File

@ -0,0 +1,30 @@
diff -up Linux-PAM-1.1.5/modules/pam_namespace/Makefile.am.empty Linux-PAM-1.1.5/modules/pam_namespace/Makefile.am
--- Linux-PAM-1.1.5/modules/pam_namespace/Makefile.am.empty 2011-06-21 11:04:56.000000000 +0200
+++ Linux-PAM-1.1.5/modules/pam_namespace/Makefile.am 2012-05-09 12:23:20.691384345 +0200
@@ -38,7 +38,9 @@ if HAVE_UNSHARE
secureconf_DATA = namespace.conf
secureconf_SCRIPTS = namespace.init
- namespaced_DATA =
+
+install-data-local:
+ mkdir -p $(namespaceddir)
endif
diff -up Linux-PAM-1.1.5/modules/pam_sepermit/Makefile.am.empty Linux-PAM-1.1.5/modules/pam_sepermit/Makefile.am
--- Linux-PAM-1.1.5/modules/pam_sepermit/Makefile.am.empty 2011-06-21 11:04:56.000000000 +0200
+++ Linux-PAM-1.1.5/modules/pam_sepermit/Makefile.am 2012-05-09 12:23:14.291243402 +0200
@@ -32,9 +32,10 @@ endif
if HAVE_LIBSELINUX
secureconf_DATA = sepermit.conf
- sepermitlock_DATA =
-
securelib_LTLIBRARIES = pam_sepermit.la
+
+install-data-local:
+ mkdir -p $(sepermitlockdir)
endif
if ENABLE_REGENERATE_MAN
noinst_DATA = README pam_sepermit.8 sepermit.conf.5

View File

@ -52,6 +52,8 @@ Patch18: pam-1.1.5-unix-remember.patch
Patch19: pam-1.1.5-unix-crypt.patch
# FIPS related - non upstreamable
Patch20: pam-1.1.5-unix-no-fallback.patch
# Will be upstreamed
Patch21: pam-1.1.5-install-empty.patch
%define _sbindir /sbin
%define _moduledir /%{_lib}/security
@ -131,6 +133,7 @@ mv pam-redhat-%{pam_redhat_version}/* modules
%patch18 -p1 -b .remember
%patch19 -p1 -b .crypt
%patch20 -p1 -b .no-fallback
%patch21 -p1 -b .empty
libtoolize -f
autoreconf
@ -392,6 +395,7 @@ fi
- correctly check for crypt() returning NULL in pam_unix
- pam_unix - do not fallback to MD5 on password change
if requested algorithm not supported by crypt() (#818741)
- install empty directories
* Mon May 9 2012 Tomas Mraz <tmraz@redhat.com> 1.1.5-6
- add pam_systemd to session modules