30 lines
1.7 KiB
Diff
30 lines
1.7 KiB
Diff
diff -up ./bindings/ruby/Makefile.am.diff ./bindings/ruby/Makefile.am
|
|
--- ./bindings/ruby/Makefile.am.diff 2010-08-02 16:57:20.407937479 -0500
|
|
+++ ./bindings/ruby/Makefile.am 2010-08-02 16:57:54.718188163 -0500
|
|
@@ -4,8 +4,10 @@
|
|
|
|
SUBDIRS = openwsman tests
|
|
|
|
-rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
|
-rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
|
+#rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
|
+rubyarchdir = $(shell ruby -r rbconfig -e " print( Config::CONFIG['sitearchdir'])")
|
|
+#rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
|
+rubydir = $(shell ruby -r rbconfig -e " print(Config::CONFIG['sitelibdir'])")
|
|
rubyincdir = $(shell ruby -r rbconfig -e "print(Config::CONFIG['archdir'])")
|
|
|
|
INCLUDES = \
|
|
diff -up ./bindings/ruby/openwsman/Makefile.am.diff ./bindings/ruby/openwsman/Makefile.am
|
|
--- ./bindings/ruby/openwsman/Makefile.am.diff 2010-08-02 16:58:05.201189127 -0500
|
|
+++ ./bindings/ruby/openwsman/Makefile.am 2010-08-02 16:58:20.999937941 -0500
|
|
@@ -2,7 +2,8 @@
|
|
# Makefile.am for openwsman/bindings/ruby/openwsman
|
|
#
|
|
|
|
-rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
|
+#rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
|
+rubylibdir = $(shell ruby -r rbconfig -e "print( Config::CONFIG['sitelibdir'])")
|
|
|
|
install-data-local:
|
|
$(mkinstalldirs) $(DESTDIR)$(rubylibdir)/openwsman
|