fixed swig version check and ruby install path
This commit is contained in:
parent
45d316bdc4
commit
0acef03521
29
openwsman-sitelibdir.patch
Normal file
29
openwsman-sitelibdir.patch
Normal file
@ -0,0 +1,29 @@
|
||||
diff -up ./bindings/ruby/Makefile.am.diff ./bindings/ruby/Makefile.am
|
||||
--- ./bindings/ruby/Makefile.am.diff 2010-08-02 16:57:20.407937479 -0500
|
||||
+++ ./bindings/ruby/Makefile.am 2010-08-02 16:57:54.718188163 -0500
|
||||
@@ -4,8 +4,10 @@
|
||||
|
||||
SUBDIRS = openwsman tests
|
||||
|
||||
-rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
||||
-rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
||||
+#rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
||||
+rubyarchdir = $(shell ruby -r rbconfig -e " print( Config::CONFIG['sitearchdir'])")
|
||||
+#rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
||||
+rubydir = $(shell ruby -r rbconfig -e " print(Config::CONFIG['sitelibdir'])")
|
||||
rubyincdir = $(shell ruby -r rbconfig -e "print(Config::CONFIG['archdir'])")
|
||||
|
||||
INCLUDES = \
|
||||
diff -up ./bindings/ruby/openwsman/Makefile.am.diff ./bindings/ruby/openwsman/Makefile.am
|
||||
--- ./bindings/ruby/openwsman/Makefile.am.diff 2010-08-02 16:58:05.201189127 -0500
|
||||
+++ ./bindings/ruby/openwsman/Makefile.am 2010-08-02 16:58:20.999937941 -0500
|
||||
@@ -2,7 +2,8 @@
|
||||
# Makefile.am for openwsman/bindings/ruby/openwsman
|
||||
#
|
||||
|
||||
-rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
||||
+#rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
||||
+rubylibdir = $(shell ruby -r rbconfig -e "print( Config::CONFIG['sitelibdir'])")
|
||||
|
||||
install-data-local:
|
||||
$(mkinstalldirs) $(DESTDIR)$(rubylibdir)/openwsman
|
82
openwsman-swig-ver-check.patch
Normal file
82
openwsman-swig-ver-check.patch
Normal file
@ -0,0 +1,82 @@
|
||||
diff -up ./acinclude.m4.old ./acinclude.m4
|
||||
--- ./acinclude.m4.old 2010-08-02 12:13:27.135937703 -0500
|
||||
+++ ./acinclude.m4 2010-08-02 12:15:07.896938631 -0500
|
||||
@@ -157,6 +157,20 @@ AC_SUBST(SFCC_LDFLAGS)
|
||||
# may extend this special exception to the GPL to apply to your
|
||||
# modified version as well.
|
||||
|
||||
+AC_DEFUN([SWIG_VERSION_GOOD],[
|
||||
+ AC_MSG_NOTICE([SWIG executable is '$SWIG'])
|
||||
+ SWIG_LIB=`$SWIG -swiglib`
|
||||
+ AC_MSG_NOTICE([SWIG library directory is '$SWIG_LIB'])
|
||||
+ SWIG_VERSION=`echo $(( $available_major * 100 * 100 + $available_minor * 100 + $available_patch ))`
|
||||
+ AC_MSG_NOTICE([SWIG version is '$SWIG_VERSION'])
|
||||
+ # AM_CONDITIONAL(SWIG_NEW_OPTIONS, test "$SWIG_VERSION" \> 10331)
|
||||
+])
|
||||
+
|
||||
+AC_DEFUN([SWIG_VERSION_BAD],[
|
||||
+ AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
|
||||
+ SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
|
||||
+])
|
||||
+
|
||||
AC_DEFUN([AC_PROG_SWIG],[
|
||||
AC_PATH_PROG([SWIG],[swig])
|
||||
if test -z "$SWIG" ; then
|
||||
@@ -199,19 +213,44 @@ AC_DEFUN([AC_PROG_SWIG],[
|
||||
if test -z "$available_patch" ; then
|
||||
[available_patch=0]
|
||||
fi
|
||||
- if test $available_major -ne $required_major \
|
||||
- -o $available_minor -ne $required_minor \
|
||||
- -o $available_patch -lt $required_patch ; then
|
||||
- AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
|
||||
- SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
|
||||
- else
|
||||
- AC_MSG_NOTICE([SWIG executable is '$SWIG'])
|
||||
- SWIG_LIB=`$SWIG -swiglib`
|
||||
- AC_MSG_NOTICE([SWIG library directory is '$SWIG_LIB'])
|
||||
- SWIG_VERSION=`echo $(( $available_major * 100 * 100 + $available_minor * 100 + $available_patch ))`
|
||||
- AC_MSG_NOTICE([SWIG version is '$SWIG_VERSION'])
|
||||
- # AM_CONDITIONAL(SWIG_NEW_OPTIONS, test "$SWIG_VERSION" \> 10331)
|
||||
- fi
|
||||
+
|
||||
+
|
||||
+
|
||||
+ if test $available_major -gt $required_major; then
|
||||
+ # the available major is greater than required major --GOOD
|
||||
+ SWIG_VERSION_GOOD()
|
||||
+
|
||||
+ elif test $available_major -lt $required_major ; then
|
||||
+ # the avialable major is less than required major -- BAD
|
||||
+ SWIG_VERSION_BAD()
|
||||
+ else
|
||||
+ # the available and require major are equal check the minor and patch versions.
|
||||
+
|
||||
+ if test $available_minor -gt $required_minor ; then
|
||||
+ # GOOD
|
||||
+ SWIG_VERSION_GOOD()
|
||||
+ elif test $avaialble_minor -lt $required_minor ; then
|
||||
+ # BAD
|
||||
+ SWIG_VERSION_BAD()
|
||||
+ else
|
||||
+ # the minor version are also equal
|
||||
+
|
||||
+ if test $available_patch -gt $required_patch ; then
|
||||
+ # GOOD
|
||||
+ SWIG_VERSION_GOOD()
|
||||
+ elif test $available_minor -lt $required_minor ; then
|
||||
+ # BAD
|
||||
+ SWIG_VERSION_BAD()
|
||||
+ else
|
||||
+ # all the available major, minor and patch levels are the same as the required -- GOOD
|
||||
+ SWIG_VERSION_GOOD()
|
||||
+ fi
|
||||
+ fi
|
||||
+ fi
|
||||
+
|
||||
+
|
||||
+
|
||||
+
|
||||
else
|
||||
AC_MSG_WARN([cannot determine SWIG version])
|
||||
SWIG='echo "Error: Cannot determine SWIG version. You should look at http://www.swig.org" ; false'
|
@ -17,7 +17,7 @@ BuildRequires: perl-devel pkgconfig openssl-devel
|
||||
BuildRequires: libtool
|
||||
Requires: net-tools
|
||||
Version: 2.2.3
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Url: http://www.openwsman.org/
|
||||
License: BSD
|
||||
Group: Applications/System
|
||||
@ -26,6 +26,8 @@ Source: http://downloads.sourceforge.net/project/openwsman/%{name}/%{ver
|
||||
Patch0: %{name}-initscript.patch
|
||||
Patch1: %{name}-randfile.patch
|
||||
Patch2: %{name}-authors.patch
|
||||
Patch3: %{name}-swig-ver-check.patch
|
||||
Patch4: %{name}-sitelibdir.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
||||
|
||||
%description
|
||||
@ -139,6 +141,8 @@ This package provides Perl bindings to access the openwsman client API.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
sh autoconfiscate.sh
|
||||
@ -264,6 +268,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 2 2010 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.3-6
|
||||
- Fixed the version checking of swig and forced all the ruby files to be
|
||||
- installed into site{lib,arch} dirs
|
||||
|
||||
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.2.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user