- updated to 2.2.2

This commit is contained in:
Dan Horák 2022-01-31 13:06:49 +00:00
parent b4ad267b3e
commit 333e3d9cb8
3 changed files with 10 additions and 76 deletions

View File

@ -1,67 +0,0 @@
From a7c548a3226f4f46bdc5ad93f64136e287bd7399 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Fri, 21 Jan 2022 15:17:09 +0100
Subject: [ibmca PATCH] update for libica version 4
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
libica changed the soname to .4 after chaging its ABI, change the
sonames in ibmca accordingly.
Signed-off-by: Dan Horák <dan@danny.cz>
---
configure.ac | 4 ++--
src/gensamplecfg.pl | 4 ++--
test/enginectrl.c | 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index e12bd88..3af5ab1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,9 +52,9 @@ AC_ARG_WITH([libica-cex],
[])
if test "x$usecexonly" = xyes; then
- defaultlib="libica-cex.so.3"
+ defaultlib="libica-cex.so.4"
else
- defaultlib="libica.so.3"
+ defaultlib="libica.so.4"
fi
# In cex-only mode, testing the ciphers does not make any sense since
# they will fall back to OpenSSL without the engine. So remove these
diff --git a/src/gensamplecfg.pl b/src/gensamplecfg.pl
index fa6f8c1..8f6e4e4 100755
--- a/src/gensamplecfg.pl
+++ b/src/gensamplecfg.pl
@@ -62,8 +62,8 @@ dynamic_path = $libdir/ibmca.so
engine_id = ibmca
|);
- print $oh2 "libica = libica.so.3";
- print $oh3 "libica = libica-cex.so.3";
+ print $oh2 "libica = libica.so.4";
+ print $oh3 "libica = libica-cex.so.4";
printall($oh1, $oh2, $oh3, qq|
init = 1
diff --git a/test/enginectrl.c b/test/enginectrl.c
index 766093d..0172dbd 100644
--- a/test/enginectrl.c
+++ b/test/enginectrl.c
@@ -65,8 +65,8 @@ int testctrl(void)
int expectedinitval;
} params[] = {
{"doesnotexist", 0, 0},
- {"libica.so.3", 1, 1},
- {"libica-cex.so.3", 1, 1}
+ {"libica.so.4", 1, 1},
+ {"libica-cex.so.4", 1, 1}
};
engine = ENGINE_by_id("ibmca");
--
2.34.1

View File

@ -2,17 +2,15 @@
Summary: A dynamic OpenSSL engine for IBMCA
Name: openssl-ibmca
Version: 2.2.1
Release: 2%{?dist}
Version: 2.2.2
Release: 1%{?dist}
License: ASL 2.0
URL: https://github.com/opencryptoki
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
# https://github.com/opencryptoki/openssl-ibmca/pull/74
Patch0: openssl-ibmca-2.2.1-libica-4.patch
Requires: libica >= 3.8.0
Requires: libica >= 4.0.0
BuildRequires: make
BuildRequires: gcc
BuildRequires: libica-devel >= 3.8.0
BuildRequires: libica-devel >= 4.0.0
BuildRequires: automake libtool
BuildRequires: openssl
ExclusiveArch: s390 s390x
@ -29,7 +27,7 @@ A dynamic OpenSSL engine for IBMCA crypto hardware on IBM z Systems machines.
%build
%configure --libdir=%{enginesdir} --with-libica-cex
%configure --libdir=%{enginesdir} --with-libica-cex --with-libica-version=4
%make_build
@ -51,12 +49,15 @@ make check
%files
%license LICENSE
%doc ChangeLog README.md src/openssl.cnf.sample.%{_arch} src/gensamplecfg.pl
%doc ChangeLog README.md src/openssl.cnf.sample.%{_arch} src/ibmca-engine-opensslconfig
%{enginesdir}/ibmca.so
%{_mandir}/man5/ibmca.5*
%changelog
* Mon Jan 31 2022 Dan Horák <dan@danny.cz> - 2.2.2-1
- updated to 2.2.2
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (openssl-ibmca-2.2.1.tar.gz) = c60a8e00c43b5428208af238a8fc0e4839b5293babfe0a7007939a105ade43322888d56a8284f90ce425c1e706fec424b5ce335633ef9fdb3cd06c8b33c32560
SHA512 (openssl-ibmca-2.2.2.tar.gz) = c9f2ea35671b9d3915d561b3ce495d9ba8e29c2623f076f291c9165bd118585d023cd39310508cff32d4c8c0acb688b3ade59d5d59b20cb3ac98bc79017c1795