add the libica 4 patch

This commit is contained in:
Dan Horák 2022-01-21 16:47:51 +00:00
parent 0d6de86cd8
commit b4ad267b3e

View File

@ -0,0 +1,67 @@
From a7c548a3226f4f46bdc5ad93f64136e287bd7399 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Fri, 21 Jan 2022 15:17:09 +0100
Subject: [ibmca PATCH] update for libica version 4
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
libica changed the soname to .4 after chaging its ABI, change the
sonames in ibmca accordingly.
Signed-off-by: Dan Horák <dan@danny.cz>
---
configure.ac | 4 ++--
src/gensamplecfg.pl | 4 ++--
test/enginectrl.c | 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index e12bd88..3af5ab1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,9 +52,9 @@ AC_ARG_WITH([libica-cex],
[])
if test "x$usecexonly" = xyes; then
- defaultlib="libica-cex.so.3"
+ defaultlib="libica-cex.so.4"
else
- defaultlib="libica.so.3"
+ defaultlib="libica.so.4"
fi
# In cex-only mode, testing the ciphers does not make any sense since
# they will fall back to OpenSSL without the engine. So remove these
diff --git a/src/gensamplecfg.pl b/src/gensamplecfg.pl
index fa6f8c1..8f6e4e4 100755
--- a/src/gensamplecfg.pl
+++ b/src/gensamplecfg.pl
@@ -62,8 +62,8 @@ dynamic_path = $libdir/ibmca.so
engine_id = ibmca
|);
- print $oh2 "libica = libica.so.3";
- print $oh3 "libica = libica-cex.so.3";
+ print $oh2 "libica = libica.so.4";
+ print $oh3 "libica = libica-cex.so.4";
printall($oh1, $oh2, $oh3, qq|
init = 1
diff --git a/test/enginectrl.c b/test/enginectrl.c
index 766093d..0172dbd 100644
--- a/test/enginectrl.c
+++ b/test/enginectrl.c
@@ -65,8 +65,8 @@ int testctrl(void)
int expectedinitval;
} params[] = {
{"doesnotexist", 0, 0},
- {"libica.so.3", 1, 1},
- {"libica-cex.so.3", 1, 1}
+ {"libica.so.4", 1, 1},
+ {"libica-cex.so.4", 1, 1}
};
engine = ENGINE_by_id("ibmca");
--
2.34.1