d5591fb5ab
Apply upstream patches from the portable OpenSSH project to fix C99 compatibility issues in the configure script. For the PAM agent integration, apply a custom downstream fix, as the proposed upstream changes have not been merged yet. Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
27 lines
759 B
Diff
27 lines
759 B
Diff
commit 40b0a5eb6e3edfa2886b60c09c7803353b0cc7f5
|
|
Author: Sam James <sam@gentoo.org>
|
|
Date: Sun Nov 6 04:47:35 2022 +0000
|
|
|
|
configure.ac: Add <pty.h> include for openpty
|
|
|
|
Another Clang 16ish fix (which makes -Wimplicit-function-declaration
|
|
an error by default). github PR#355.
|
|
|
|
See: 2efd71da49b9cfeab7987058cf5919e473ff466b
|
|
See: be197635329feb839865fdc738e34e24afd1fca8
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 1e77ecfc..1866aea5 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2373,6 +2373,9 @@ if test ! -z "$check_for_openpty_ctty_bug"; then
|
|
#include <stdio.h>
|
|
#include <stdlib.h>
|
|
#include <unistd.h>
|
|
+#ifdef HAVE_PTY_H
|
|
+# include <pty.h>
|
|
+#endif
|
|
#include <sys/fcntl.h>
|
|
#include <sys/types.h>
|
|
#include <sys/wait.h>
|