245 lines
8.9 KiB
Diff
245 lines
8.9 KiB
Diff
diff -up openssh-5.8p2/entropy.c.entropy openssh-5.8p2/entropy.c
|
|
--- openssh-5.8p2/entropy.c.entropy 2011-05-03 02:00:08.000000000 +0200
|
|
+++ openssh-5.8p2/entropy.c 2011-05-28 21:13:09.302866730 +0200
|
|
@@ -145,6 +145,9 @@ seed_rng(void)
|
|
memset(buf, '\0', sizeof(buf));
|
|
|
|
#endif /* OPENSSL_PRNG_ONLY */
|
|
+#ifdef __linux__
|
|
+ linux_seed();
|
|
+#endif /* __linux__ */
|
|
if (RAND_status() != 1)
|
|
fatal("PRNG is not seeded");
|
|
}
|
|
diff -up openssh-5.8p2/openbsd-compat/Makefile.in.entropy openssh-5.8p2/openbsd-compat/Makefile.in
|
|
--- openssh-5.8p2/openbsd-compat/Makefile.in.entropy 2010-10-07 13:19:24.000000000 +0200
|
|
+++ openssh-5.8p2/openbsd-compat/Makefile.in 2011-05-28 21:13:09.449924419 +0200
|
|
@@ -20,7 +20,7 @@ OPENBSD=base64.o basename.o bindresvport
|
|
|
|
COMPAT=bsd-arc4random.o bsd-asprintf.o bsd-closefrom.o bsd-cray.o bsd-cygwin_util.o bsd-getpeereid.o bsd-misc.o bsd-nextstep.o bsd-openpty.o bsd-poll.o bsd-snprintf.o bsd-statvfs.o bsd-waitpid.o fake-rfc2553.o openssl-compat.o xmmap.o xcrypt.o
|
|
|
|
-PORTS=port-aix.o port-irix.o port-linux.o port-solaris.o port-tun.o port-uw.o
|
|
+PORTS=port-aix.o port-irix.o port-linux.o port-linux-prng.o port-solaris.o port-tun.o port-uw.o
|
|
|
|
.c.o:
|
|
$(CC) $(CFLAGS) $(CPPFLAGS) -c $<
|
|
diff -up openssh-5.8p2/openbsd-compat/port-linux-prng.c.entropy openssh-5.8p2/openbsd-compat/port-linux-prng.c
|
|
--- openssh-5.8p2/openbsd-compat/port-linux-prng.c.entropy 2011-05-28 21:13:09.540878930 +0200
|
|
+++ openssh-5.8p2/openbsd-compat/port-linux-prng.c 2011-05-28 21:13:09.547919624 +0200
|
|
@@ -0,0 +1,59 @@
|
|
+/* $Id: port-linux.c,v 1.11.4.2 2011/02/04 00:43:08 djm Exp $ */
|
|
+
|
|
+/*
|
|
+ * Copyright (c) 2011 Jan F. Chadima <jchadima@redhat.com>
|
|
+ *
|
|
+ * Permission to use, copy, modify, and distribute this software for any
|
|
+ * purpose with or without fee is hereby granted, provided that the above
|
|
+ * copyright notice and this permission notice appear in all copies.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+ */
|
|
+
|
|
+/*
|
|
+ * Linux-specific portability code - prng support
|
|
+ */
|
|
+
|
|
+#include "includes.h"
|
|
+
|
|
+#include <errno.h>
|
|
+#include <stdarg.h>
|
|
+#include <string.h>
|
|
+#include <stdio.h>
|
|
+#include <openssl/rand.h>
|
|
+
|
|
+#include "log.h"
|
|
+#include "xmalloc.h"
|
|
+#include "servconf.h"
|
|
+#include "port-linux.h"
|
|
+#include "key.h"
|
|
+#include "hostfile.h"
|
|
+#include "auth.h"
|
|
+
|
|
+void
|
|
+linux_seed(void)
|
|
+{
|
|
+ int len;
|
|
+ char *env = getenv("SSH_USE_STRONG_RNG");
|
|
+ char *random = "/dev/random";
|
|
+ size_t ienv, randlen = 6;
|
|
+
|
|
+ if (!env || !strcmp(env, "0"))
|
|
+ random = "/dev/urandom";
|
|
+ else if ((ienv = atoi(env)) > 6)
|
|
+ randlen = ienv;
|
|
+
|
|
+ errno = 0;
|
|
+ if ((len = RAND_load_file(random, randlen)) != randlen) {
|
|
+ if (errno)
|
|
+ fatal ("cannot read from %s, %s", random, strerror(errno));
|
|
+ else
|
|
+ fatal ("EOF reading %s", random);
|
|
+ }
|
|
+}
|
|
diff -up openssh-5.8p2/ssh.1.entropy openssh-5.8p2/ssh.1
|
|
--- openssh-5.8p2/ssh.1.entropy 2010-11-20 05:21:03.000000000 +0100
|
|
+++ openssh-5.8p2/ssh.1 2011-05-28 21:15:27.375920967 +0200
|
|
@@ -1250,6 +1250,20 @@ For more information, see the
|
|
.Cm PermitUserEnvironment
|
|
option in
|
|
.Xr sshd_config 5 .
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh FILES
|
|
.Bl -tag -width Ds -compact
|
|
.It Pa ~/.rhosts
|
|
diff -up openssh-5.8p2/ssh-add.1.entropy openssh-5.8p2/ssh-add.1
|
|
--- openssh-5.8p2/ssh-add.1.entropy 2010-11-05 00:20:14.000000000 +0100
|
|
+++ openssh-5.8p2/ssh-add.1 2011-05-28 21:16:43.891859186 +0200
|
|
@@ -158,6 +158,20 @@ Identifies the path of a
|
|
.Ux Ns -domain
|
|
socket used to communicate with the agent.
|
|
.El
|
|
+.It Ev SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh FILES
|
|
.Bl -tag -width Ds
|
|
.It Pa ~/.ssh/identity
|
|
diff -up openssh-5.8p2/ssh-agent.1.entropy openssh-5.8p2/ssh-agent.1
|
|
--- openssh-5.8p2/ssh-agent.1.entropy 2010-12-01 01:50:35.000000000 +0100
|
|
+++ openssh-5.8p2/ssh-agent.1 2011-05-28 21:13:10.086864993 +0200
|
|
@@ -198,6 +198,23 @@ sockets used to contain the connection t
|
|
These sockets should only be readable by the owner.
|
|
The sockets should get automatically removed when the agent exits.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-5.8p2/sshd.8.entropy openssh-5.8p2/sshd.8
|
|
--- openssh-5.8p2/sshd.8.entropy 2010-11-05 00:20:14.000000000 +0100
|
|
+++ openssh-5.8p2/sshd.8 2011-05-28 21:13:10.241861760 +0200
|
|
@@ -937,6 +937,23 @@ concurrently for different ports, this c
|
|
started last).
|
|
The content of this file is not sensitive; it can be world-readable.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh SEE ALSO
|
|
.Xr scp 1 ,
|
|
.Xr sftp 1 ,
|
|
diff -up openssh-5.8p2/ssh-keygen.1.entropy openssh-5.8p2/ssh-keygen.1
|
|
--- openssh-5.8p2/ssh-keygen.1.entropy 2010-11-05 00:20:14.000000000 +0100
|
|
+++ openssh-5.8p2/ssh-keygen.1 2011-05-28 21:13:10.389856432 +0200
|
|
@@ -655,6 +655,23 @@ Contains Diffie-Hellman groups used for
|
|
The file format is described in
|
|
.Xr moduli 5 .
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-add 1 ,
|
|
diff -up openssh-5.8p2/ssh-keysign.8.entropy openssh-5.8p2/ssh-keysign.8
|
|
--- openssh-5.8p2/ssh-keysign.8.entropy 2010-08-31 14:41:14.000000000 +0200
|
|
+++ openssh-5.8p2/ssh-keysign.8 2011-05-28 21:17:32.399856797 +0200
|
|
@@ -78,6 +78,23 @@ must be set-uid root if host-based authe
|
|
If these files exist they are assumed to contain public certificate
|
|
information corresponding with the private keys above.
|
|
.El
|
|
+.Sh ENVIRONMENT
|
|
+.Bl -tag -width Ds -compact
|
|
+.Pp
|
|
+.It Pa SSH_USE_STRONG_RNG
|
|
+The reseeding of the OpenSSL random generator is usually done from
|
|
+.Cm /dev/urandom .
|
|
+If the
|
|
+.Cm SSH_USE_STRONG_RNG
|
|
+environment variable is set to value other than
|
|
+.Cm 0
|
|
+the OpenSSL random generator is reseeded from
|
|
+.Cm /dev/random .
|
|
+The number of bytes read is defined by the SSH_USE_STRONG_RNG value.
|
|
+Minimum is 6 bytes.
|
|
+This setting is not recommended on the computers without the hardware
|
|
+random generator because insufficient entropy causes the connection to
|
|
+be blocked until enough entropy is available.
|
|
.Sh SEE ALSO
|
|
.Xr ssh 1 ,
|
|
.Xr ssh-keygen 1 ,
|