- upgrade to a new upstream version
This commit is contained in:
parent
f94d8f533f
commit
de2e7a36f5
@ -1,2 +1,2 @@
|
|||||||
x11-ssh-askpass-1.2.4.1.tar.gz
|
x11-ssh-askpass-1.2.4.1.tar.gz
|
||||||
openssh-4.1p1-noacss.tar.bz2
|
openssh-4.2p1-noacss.tar.bz2
|
||||||
|
@ -4,24 +4,15 @@
|
|||||||
# rest of the package can still be built.
|
# rest of the package can still be built.
|
||||||
#
|
#
|
||||||
> acss.c
|
> acss.c
|
||||||
patch -sp1 << EOF
|
patch -sp0 << EOF
|
||||||
--- openssh/cipher.c
|
--- cipher.c.orig 2005-07-17 09:02:10.000000000 +0200
|
||||||
+++ openssh/cipher.c
|
+++ cipher.c 2005-09-06 14:52:06.000000000 +0200
|
||||||
@@ -53,6 +53,7 @@
|
@@ -45,6 +45,8 @@
|
||||||
extern void ssh_rijndael_iv(EVP_CIPHER_CTX *, int, u_char *, u_int);
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#if 0
|
/* compatibility with old or broken OpenSSL versions */
|
||||||
#if !defined(EVP_CTRL_SET_ACSS_MODE)
|
#include "openbsd-compat/openssl-compat.h"
|
||||||
# if (OPENSSL_VERSION_NUMBER >= 0x00907000L)
|
+#undef USE_CIPHER_ACSS
|
||||||
extern const EVP_CIPHER *evp_acss(void);
|
|
||||||
@@ -62,6 +63,9 @@
|
|
||||||
# define EVP_acss NULL /* Don't try to support ACSS on older OpenSSL */
|
|
||||||
# endif /* (OPENSSL_VERSION_NUMBER >= 0x00906000L) */
|
|
||||||
#endif /* !defined(EVP_CTRL_SET_ACSS_MODE) */
|
|
||||||
+#else
|
|
||||||
+#define EVP_acss NULL
|
+#define EVP_acss NULL
|
||||||
+#endif /* 0 */
|
|
||||||
|
|
||||||
extern const EVP_CIPHER *evp_ssh1_bf(void);
|
extern const EVP_CIPHER *evp_ssh1_bf(void);
|
||||||
extern const EVP_CIPHER *evp_ssh1_3des(void);
|
extern const EVP_CIPHER *evp_ssh1_3des(void);
|
||||||
|
10
openssh.spec
10
openssh.spec
@ -73,8 +73,8 @@
|
|||||||
|
|
||||||
Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
|
Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
|
||||||
Name: openssh
|
Name: openssh
|
||||||
Version: 4.1p1
|
Version: 4.2p1
|
||||||
%define rel 5
|
%define rel 1
|
||||||
%if %{rescue}
|
%if %{rescue}
|
||||||
Release: %{rel}rescue
|
Release: %{rel}rescue
|
||||||
%else
|
%else
|
||||||
@ -104,7 +104,6 @@ Patch24: openssh-3.9p1-fromto-remote.patch
|
|||||||
Patch26: openssh-4.0p1-krb5-valid.patch
|
Patch26: openssh-4.0p1-krb5-valid.patch
|
||||||
Patch27: openssh-4.1p1-pam-loginuid.patch
|
Patch27: openssh-4.1p1-pam-loginuid.patch
|
||||||
Patch28: openssh-4.1p1-nologin.patch
|
Patch28: openssh-4.1p1-nologin.patch
|
||||||
Patch29: openssh-4.1p1-getpeername-race.patch
|
|
||||||
Patch30: openssh-4.0p1-exit-deadlock.patch
|
Patch30: openssh-4.0p1-exit-deadlock.patch
|
||||||
Patch31: openssh-3.9p1-skip-used.patch
|
Patch31: openssh-3.9p1-skip-used.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -246,7 +245,6 @@ environment.
|
|||||||
%patch26 -p0 -b .krb5-valid
|
%patch26 -p0 -b .krb5-valid
|
||||||
%patch27 -p1 -b .loginuid
|
%patch27 -p1 -b .loginuid
|
||||||
%patch28 -p1 -b .nologin
|
%patch28 -p1 -b .nologin
|
||||||
%patch29 -p0 -b .getpeername-race
|
|
||||||
%patch30 -p1 -b .exit-deadlock
|
%patch30 -p1 -b .exit-deadlock
|
||||||
%patch31 -p1 -b .skip-used
|
%patch31 -p1 -b .skip-used
|
||||||
|
|
||||||
@ -293,6 +291,7 @@ fi
|
|||||||
--with-privsep-path=%{_var}/empty/sshd \
|
--with-privsep-path=%{_var}/empty/sshd \
|
||||||
--enable-vendor-patchlevel="FC-%{version}-%{release}" \
|
--enable-vendor-patchlevel="FC-%{version}-%{release}" \
|
||||||
--disable-strip \
|
--disable-strip \
|
||||||
|
--without-zlib-version-check \
|
||||||
%if %{scard}
|
%if %{scard}
|
||||||
--with-smartcard \
|
--with-smartcard \
|
||||||
%endif
|
%endif
|
||||||
@ -525,6 +524,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 06 2005 Tomas Mraz <tmraz@redhat.com> 4.2p1-1
|
||||||
|
- upgrade to a new upstream version
|
||||||
|
|
||||||
* Tue Aug 16 2005 Tomas Mraz <tmraz@redhat.com> 4.1p1-5
|
* Tue Aug 16 2005 Tomas Mraz <tmraz@redhat.com> 4.1p1-5
|
||||||
- use x11-ssh-askpass if openssh-askpass-gnome is not installed (#165207)
|
- use x11-ssh-askpass if openssh-askpass-gnome is not installed (#165207)
|
||||||
- install ssh-copy-id from contrib (#88707)
|
- install ssh-copy-id from contrib (#88707)
|
||||||
|
Loading…
Reference in New Issue
Block a user