seccomp filter for MIPS (#1195065)
This commit is contained in:
parent
ad928ac7d1
commit
c06fe506bc
@ -16,7 +16,7 @@ diff --git a/configure.ac b/configure.ac
|
|||||||
index 24378a7..0bed910 100644
|
index 24378a7..0bed910 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -811,6 +811,18 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
|
@@ -811,6 +811,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
|
||||||
aarch64*-*)
|
aarch64*-*)
|
||||||
seccomp_audit_arch=AUDIT_ARCH_AARCH64
|
seccomp_audit_arch=AUDIT_ARCH_AARCH64
|
||||||
;;
|
;;
|
||||||
@ -31,6 +31,18 @@ index 24378a7..0bed910 100644
|
|||||||
+ ;;
|
+ ;;
|
||||||
+ powerpc64le-*)
|
+ powerpc64le-*)
|
||||||
+ seccomp_audit_arch=AUDIT_ARCH_PPC64LE
|
+ seccomp_audit_arch=AUDIT_ARCH_PPC64LE
|
||||||
|
+ ;;
|
||||||
|
+ mips-*)
|
||||||
|
+ seccomp_audit_arch=AUDIT_ARCH_MIPS
|
||||||
|
+ ;;
|
||||||
|
+ mipsel-*)
|
||||||
|
+ seccomp_audit_arch=AUDIT_ARCH_MIPSEL
|
||||||
|
+ ;;
|
||||||
|
+ mips64-*)
|
||||||
|
+ seccomp_audit_arch=AUDIT_ARCH_MIPS64
|
||||||
|
+ ;;
|
||||||
|
+ mips64el-*)
|
||||||
|
+ seccomp_audit_arch=AUDIT_ARCH_MIPSEL64
|
||||||
+ ;;
|
+ ;;
|
||||||
esac
|
esac
|
||||||
if test "x$seccomp_audit_arch" != "x" ; then
|
if test "x$seccomp_audit_arch" != "x" ; then
|
||||||
|
Loading…
Reference in New Issue
Block a user