- repair configure script of pam_ssh_agent
- repair error mesage in ssh-keygen
This commit is contained in:
parent
50a3ddbbcb
commit
b823409b8f
14
openssh-5.4p1-staterr.patch
Normal file
14
openssh-5.4p1-staterr.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up openssh-5.4p1/ssh-keygen.c.staterr openssh-5.4p1/ssh-keygen.c
|
||||||
|
--- openssh-5.4p1/ssh-keygen.c.staterr 2010-03-19 20:56:12.000000000 +0100
|
||||||
|
+++ openssh-5.4p1/ssh-keygen.c 2010-03-19 20:59:41.000000000 +0100
|
||||||
|
@@ -1829,7 +1829,9 @@ main(int argc, char **argv)
|
||||||
|
snprintf(dotsshdir, sizeof dotsshdir, "%s/%s", pw->pw_dir, _PATH_SSH_USER_DIR);
|
||||||
|
if (strstr(identity_file, dotsshdir) != NULL &&
|
||||||
|
stat(dotsshdir, &st) < 0) {
|
||||||
|
- if (mkdir(dotsshdir, 0700) < 0)
|
||||||
|
+ if (errno == EPERM)
|
||||||
|
+ error("Do not have permisions to stat directory '%s'.", dotsshdir);
|
||||||
|
+ else if (mkdir(dotsshdir, 0700) < 0)
|
||||||
|
error("Could not create directory '%s'.", dotsshdir);
|
||||||
|
else if (!quiet)
|
||||||
|
printf("Created directory '%s'.\n", dotsshdir);
|
10
openssh.spec
10
openssh.spec
@ -67,8 +67,13 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Do not forget to bump pam_ssh_agent_auth release if you rewind the main package release to 1
|
# Do not forget to bump pam_ssh_agent_auth release if you rewind the main package release to 1
|
||||||
|
<<<<<<< openssh.spec
|
||||||
|
%define openssh_rel 3
|
||||||
|
%define pam_ssh_agent_rel 24
|
||||||
|
=======
|
||||||
%define openssh_rel 2
|
%define openssh_rel 2
|
||||||
%define pam_ssh_agent_rel 25
|
%define pam_ssh_agent_rel 25
|
||||||
|
>>>>>>> 1.199
|
||||||
%define pam_ssh_agent_ver 0.9.2
|
%define pam_ssh_agent_ver 0.9.2
|
||||||
|
|
||||||
Summary: An open source implementation of SSH protocol versions 1 and 2
|
Summary: An open source implementation of SSH protocol versions 1 and 2
|
||||||
@ -111,6 +116,7 @@ Patch72: openssh-5.4p1-pka.patch
|
|||||||
Patch73: openssh-5.4p1-gsskex.patch
|
Patch73: openssh-5.4p1-gsskex.patch
|
||||||
Patch74: openssh-5.3p1-randclean.patch
|
Patch74: openssh-5.3p1-randclean.patch
|
||||||
Patch75: openssh-5.3p1-dso.patch
|
Patch75: openssh-5.3p1-dso.patch
|
||||||
|
Patch76: openssh-5.4p1-staterr.patch
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -264,6 +270,7 @@ popd
|
|||||||
%patch73 -p1 -b .gsskex
|
%patch73 -p1 -b .gsskex
|
||||||
%patch74 -p1 -b .randclean
|
%patch74 -p1 -b .randclean
|
||||||
%patch75 -p1 -b .dso
|
%patch75 -p1 -b .dso
|
||||||
|
%patch76 -p1 -b .staterr
|
||||||
|
|
||||||
autoreconf
|
autoreconf
|
||||||
pushd pam_ssh_agent_auth-%{pam_ssh_agent_ver}
|
pushd pam_ssh_agent_auth-%{pam_ssh_agent_ver}
|
||||||
@ -529,8 +536,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Mar 12 2010 Jan F. Chadima <jchadima@redhat.com> - 5.4p1-2 + 0.9.2-25
|
* Fri Mar 12 2010 Jan F. Chadima <jchadima@redhat.com> - 5.4p1-3 + 0.9.2-25
|
||||||
- repair configure script of pam_ssh_agent
|
- repair configure script of pam_ssh_agent
|
||||||
|
- repair error mesage in ssh-keygen
|
||||||
|
|
||||||
* Fri Mar 12 2010 Jan F. Chadima <jchadima@redhat.com> - 5.4p1-2
|
* Fri Mar 12 2010 Jan F. Chadima <jchadima@redhat.com> - 5.4p1-2
|
||||||
- source krb5-devel profile script only if exists
|
- source krb5-devel profile script only if exists
|
||||||
|
Loading…
Reference in New Issue
Block a user