Coverity reports applied

This commit is contained in:
Jakub Jelen 2017-03-03 15:51:39 +01:00
parent f499c489fd
commit a9ad706d82
2 changed files with 4 additions and 6 deletions

View File

@ -40,7 +40,7 @@ diff -up openssh-6.8p1/Makefile.in.kdf-cavs openssh-6.8p1/Makefile.in
diff -up openssh-6.8p1/ssh-cavs.c.kdf-cavs openssh-6.8p1/ssh-cavs.c diff -up openssh-6.8p1/ssh-cavs.c.kdf-cavs openssh-6.8p1/ssh-cavs.c
--- openssh-6.8p1/ssh-cavs.c.kdf-cavs 2015-03-18 11:23:46.348049354 +0100 --- openssh-6.8p1/ssh-cavs.c.kdf-cavs 2015-03-18 11:23:46.348049354 +0100
+++ openssh-6.8p1/ssh-cavs.c 2015-03-18 11:23:46.348049354 +0100 +++ openssh-6.8p1/ssh-cavs.c 2015-03-18 11:23:46.348049354 +0100
@@ -0,0 +1,383 @@ @@ -0,0 +1,380 @@
+/* +/*
+ * Copyright (C) 2015, Stephan Mueller <smueller@chronox.de> + * Copyright (C) 2015, Stephan Mueller <smueller@chronox.de>
+ * + *
@ -317,9 +317,6 @@ diff -up openssh-6.8p1/ssh-cavs.c.kdf-cavs openssh-6.8p1/ssh-cavs.c
+ hex, HEXOUTLEN, 0); + hex, HEXOUTLEN, 0);
+ printf("Integrity key (server to client) = %s\n", hex); + printf("Integrity key (server to client) = %s\n", hex);
+ +
+ free(ctoskeys);
+ free(stockeys);
+
+out: +out:
+ if (Kbn) + if (Kbn)
+ BN_free(Kbn); + BN_free(Kbn);

View File

@ -25,7 +25,7 @@ diff -up openssh-7.1p2/pam_ssh_agent_auth-0.10.2/iterate_ssh_agent_keys.c.psaa-a
#include <stdio.h> #include <stdio.h>
#include <openssl/evp.h> #include <openssl/evp.h>
#include "ssh2.h" #include "ssh2.h"
@@ -285,36 +286,43 @@ pamsshagentauth_find_authorized_keys(con @@ -285,36 +286,44 @@ pamsshagentauth_find_authorized_keys(con
{ {
Buffer session_id2 = { 0 }; Buffer session_id2 = { 0 };
Identity *id; Identity *id;
@ -35,7 +35,8 @@ diff -up openssh-7.1p2/pam_ssh_agent_auth-0.10.2/iterate_ssh_agent_keys.c.psaa-a
uint8_t retval = 0; uint8_t retval = 0;
uid_t uid = getpwnam(ruser)->pw_uid; uid_t uid = getpwnam(ruser)->pw_uid;
+ struct ssh_identitylist *idlist; + struct ssh_identitylist *idlist;
+ int r, i; + int r;
+ unsigned int i;
OpenSSL_add_all_digests(); OpenSSL_add_all_digests();
pamsshagentauth_session_id2_gen(&session_id2, user, ruser, servicename); pamsshagentauth_session_id2_gen(&session_id2, user, ruser, servicename);