compile ssh-askpass with corect CFLAGS
This commit is contained in:
parent
eed2da95a4
commit
56b50ec772
18
openssh-5.8p2-askpass-ld.patch
Normal file
18
openssh-5.8p2-askpass-ld.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -up openssh-5.8p2/contrib/Makefile.askpass-ld openssh-5.8p2/contrib/Makefile
|
||||
--- openssh-5.8p2/contrib/Makefile.askpass-ld 2011-08-08 22:54:06.050546199 +0200
|
||||
+++ openssh-5.8p2/contrib/Makefile 2011-08-08 22:54:43.364420118 +0200
|
||||
@@ -2,12 +2,12 @@ all:
|
||||
@echo "Valid targets: gnome-ssh-askpass1 gnome-ssh-askpass2"
|
||||
|
||||
gnome-ssh-askpass1: gnome-ssh-askpass1.c
|
||||
- $(CC) `gnome-config --cflags gnome gnomeui` \
|
||||
+ $(CC) ${CFLAGS} `gnome-config --cflags gnome gnomeui` \
|
||||
gnome-ssh-askpass1.c -o gnome-ssh-askpass1 \
|
||||
`gnome-config --libs gnome gnomeui`
|
||||
|
||||
gnome-ssh-askpass2: gnome-ssh-askpass2.c
|
||||
- $(CC) `pkg-config --cflags gtk+-2.0` \
|
||||
+ $(CC) ${CFLAGS} `pkg-config --cflags gtk+-2.0` \
|
||||
gnome-ssh-askpass2.c -o gnome-ssh-askpass2 \
|
||||
`pkg-config --libs gtk+-2.0 x11`
|
||||
|
@ -79,7 +79,7 @@
|
||||
|
||||
# Do not forget to bump pam_ssh_agent_auth release if you rewind the main package release to 1
|
||||
%define openssh_ver 5.8p2
|
||||
%define openssh_rel 18
|
||||
%define openssh_rel 19
|
||||
%define pam_ssh_agent_ver 0.9.2
|
||||
%define pam_ssh_agent_rel 31
|
||||
|
||||
@ -196,6 +196,8 @@ Patch66: openssh-5.8p2-ipv6man.patch
|
||||
Patch67: openssh-5.8p2-unconfined.patch
|
||||
#https://bugzilla.mindrot.org/show_bug.cgi?id=1924
|
||||
Patch68: openssh-5.8p2-sesftplog.patch
|
||||
#?
|
||||
Patch69: openssh-5.8p2-askpass-ld.patch
|
||||
#---
|
||||
#https://bugzilla.mindrot.org/show_bug.cgi?id=1604
|
||||
# sctp
|
||||
@ -434,6 +436,7 @@ popd
|
||||
%patch66 -p1 -b .ipv6man
|
||||
%patch67 -p1 -b .unconfined
|
||||
%patch68 -p1 -b .sesftplog
|
||||
%patch69 -p1 -b .askpass-ld
|
||||
|
||||
autoreconf
|
||||
pushd pam_ssh_agent_auth-%{pam_ssh_agent_ver}
|
||||
@ -771,6 +774,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 8 2011 Jan F. Chadima <jchadima@redhat.com> - 5.8p2-19 + 0.9.2-31
|
||||
- compile ssh-askpass with corect CFLAGS
|
||||
|
||||
* Mon Aug 8 2011 Jan F. Chadima <jchadima@redhat.com> - 5.8p2-18 + 0.9.2-31
|
||||
- improve selinux's change context log
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user