seccomp for secondary architecures patch already upstream (#2590)
This commit is contained in:
parent
05bc93847e
commit
4bd77fcccc
@ -1,36 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 24378a7..0bed910 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -811,6 +811,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
|
||||
aarch64*-*)
|
||||
seccomp_audit_arch=AUDIT_ARCH_AARCH64
|
||||
;;
|
||||
+ s390x-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_S390X
|
||||
+ ;;
|
||||
+ s390-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_S390
|
||||
+ ;;
|
||||
+ powerpc64-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_PPC64
|
||||
+ ;;
|
||||
+ powerpc64le-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_PPC64LE
|
||||
+ ;;
|
||||
+ mips-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_MIPS
|
||||
+ ;;
|
||||
+ mipsel-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_MIPSEL
|
||||
+ ;;
|
||||
+ mips64-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_MIPS64
|
||||
+ ;;
|
||||
+ mips64el-*)
|
||||
+ seccomp_audit_arch=AUDIT_ARCH_MIPSEL64
|
||||
+ ;;
|
||||
esac
|
||||
if test "x$seccomp_audit_arch" != "x" ; then
|
||||
AC_MSG_RESULT(["$seccomp_audit_arch"])
|
||||
|
@ -203,8 +203,6 @@ Patch920: openssh-6.6.1p1-ip-port-config-parser.patch
|
||||
Patch921: openssh-6.7p1-debian-restore-tcp-wrappers.patch
|
||||
# apply upstream patch and make sshd -T more consistent (#1187521)
|
||||
Patch922: openssh-6.8p1-sshdT-output.patch
|
||||
# Seccomp support for secondary architectures (#1195065)
|
||||
Patch924: openssh-6.9p1-seccomp-secondary.patch
|
||||
# Add sftp option to force mode of created files (#1191055)
|
||||
Patch926: openssh-6.7p1-sftp-force-permission.patch
|
||||
# Memory problems
|
||||
@ -461,7 +459,6 @@ popd
|
||||
%patch802 -p1 -b .GSSAPIEnablek5users
|
||||
%patch921 -p1 -b .tcp_wrappers
|
||||
%patch922 -p1 -b .sshdt
|
||||
%patch924 -p1 -b .seccomp
|
||||
%patch926 -p1 -b .sftp-force-mode
|
||||
%patch928 -p1 -b .memory
|
||||
%patch929 -p1 -b .root-login
|
||||
|
Loading…
Reference in New Issue
Block a user