- add buildrequires nss-devel to build with the nss-keys patch

This commit is contained in:
Tomáš Mráz 2007-06-20 19:11:49 +00:00
parent c3274ccb32
commit 0092bbd526
2 changed files with 7 additions and 12 deletions

View File

@ -88,7 +88,7 @@ diff -urpN openssh-4.5p1/configure.ac openssh-4.5p1.nss/configure.ac
+ AC_DEFINE(HAVE_LIBNSS,1,[Define if you want NSS support.]) + AC_DEFINE(HAVE_LIBNSS,1,[Define if you want NSS support.])
+ LIBNSS_MSG="yes" + LIBNSS_MSG="yes"
+ CPPFLAGS="$CPPFLAGS -I/usr/include/nss3 -I/usr/include/nspr4" + CPPFLAGS="$CPPFLAGS -I/usr/include/nss3 -I/usr/include/nspr4"
+ AC_CHECK_HEADERS(nss.h) + AC_CHECK_HEADERS(pk11pub.h)
+ LIBNSS="-lnss3" + LIBNSS="-lnss3"
+ fi + fi
+ ]) + ])
@ -1127,7 +1127,7 @@ diff -urpN openssh-4.5p1/ssh.c openssh-4.5p1.nss/ssh.c
extern char *__progname; extern char *__progname;
@@ -1227,9 +1230,12 @@ load_public_identity_files(void) @@ -1227,9 +1230,11 @@ load_public_identity_files(void)
int i = 0; int i = 0;
Key *public; Key *public;
struct passwd *pw; struct passwd *pw;
@ -1136,12 +1136,11 @@ diff -urpN openssh-4.5p1/ssh.c openssh-4.5p1.nss/ssh.c
Key **keys; Key **keys;
+#endif +#endif
+ debug("loaded %d keys", options.num_identity_files);
+#ifdef SMARTCARD +#ifdef SMARTCARD
if (options.smartcard_device != NULL && if (options.smartcard_device != NULL &&
options.num_identity_files < SSH_MAX_IDENTITY_FILES && options.num_identity_files < SSH_MAX_IDENTITY_FILES &&
(keys = sc_get_keys(options.smartcard_device, NULL)) != NULL) { (keys = sc_get_keys(options.smartcard_device, NULL)) != NULL) {
@@ -1250,6 +1256,27 @@ load_public_identity_files(void) @@ -1250,6 +1255,27 @@ load_public_identity_files(void)
xfree(keys); xfree(keys);
} }
#endif /* SMARTCARD */ #endif /* SMARTCARD */
@ -1169,14 +1168,6 @@ diff -urpN openssh-4.5p1/ssh.c openssh-4.5p1.nss/ssh.c
if ((pw = getpwuid(original_real_uid)) == NULL) if ((pw = getpwuid(original_real_uid)) == NULL)
fatal("load_public_identity_files: getpwuid failed"); fatal("load_public_identity_files: getpwuid failed");
if (gethostname(thishost, sizeof(thishost)) == -1) if (gethostname(thishost, sizeof(thishost)) == -1)
@@ -1269,6 +1296,7 @@ load_public_identity_files(void)
options.identity_files[i] = filename;
options.identity_keys[i] = public;
}
+ debug("loaded %d keys", options.num_identity_files);
}
static void
diff -urpN openssh-4.5p1/ssh-dss.c openssh-4.5p1.nss/ssh-dss.c diff -urpN openssh-4.5p1/ssh-dss.c openssh-4.5p1.nss/ssh-dss.c
--- openssh-4.5p1/ssh-dss.c 2006-11-07 13:14:42.000000000 +0100 --- openssh-4.5p1/ssh-dss.c 2006-11-07 13:14:42.000000000 +0100
+++ openssh-4.5p1.nss/ssh-dss.c 2007-05-25 15:45:19.000000000 +0200 +++ openssh-4.5p1.nss/ssh-dss.c 2007-05-25 15:45:19.000000000 +0200

View File

@ -125,6 +125,10 @@ BuildRequires: pam-devel
BuildRequires: krb5-devel BuildRequires: krb5-devel
%endif %endif
%if %{nss}
BuildRequires: nss-devel
%endif
%if %{WITH_SELINUX} %if %{WITH_SELINUX}
Requires: libselinux >= 1.27.7 Requires: libselinux >= 1.27.7
BuildRequires: libselinux-devel >= 1.27.7 BuildRequires: libselinux-devel >= 1.27.7