- Update to latest upstream version
This commit is contained in:
parent
319119304f
commit
3e3fe8c573
@ -1 +1,2 @@
|
|||||||
opensm-3.2.1.tar.gz
|
opensm-3.2.1.tar.gz
|
||||||
|
opensm-3.3.1.tar.gz
|
||||||
|
@ -1,113 +0,0 @@
|
|||||||
--- opensm-3.2.1/libvendor/Makefile.am.rpath 2008-01-15 15:23:51.000000000 -0500
|
|
||||||
+++ opensm-3.2.1/libvendor/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
||||||
@@ -94,8 +94,8 @@ EXTRA_DIST = $(srcdir)/libosmvendor.map
|
|
||||||
# name. What we can do it create a link to the installed file such
|
|
||||||
# that it will mark it with an alias...
|
|
||||||
# we find the new lib by traversing the links
|
|
||||||
-install-exec-hook:
|
|
||||||
- if test -L $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; fi; \
|
|
||||||
- lname=`\ls -l $(DESTDIR)/$(libdir)/libosmvendor.so | awk '{print $$NF}'`; \
|
|
||||||
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor_$(with_osmv).so; \
|
|
||||||
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so
|
|
||||||
+#install-exec-hook:
|
|
||||||
+# if test -L $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; fi; \
|
|
||||||
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libosmvendor.so | awk '{print $$NF}'`; \
|
|
||||||
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor_$(with_osmv).so; \
|
|
||||||
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so
|
|
||||||
--- opensm-3.2.1/opensm/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
||||||
+++ opensm-3.2.1/opensm/Makefile.am 2008-06-30 11:11:40.000000000 -0400
|
|
||||||
@@ -79,7 +79,7 @@ endif
|
|
||||||
if OSMV_SIM
|
|
||||||
USEGPPLINK = $(LIBTOOL) --mode=link g++ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
||||||
libopensm.la: $(libopensm_la_OBJECTS) $(libopensm_la_DEPENDENCIES)
|
|
||||||
- $(USEGPPLINK) -rpath $(libdir) $(libopensm_la_LDFLAGS) $(libopensm_la_OBJECTS) $(libopensm_la_LIBADD) $(LIBS)
|
|
||||||
+ $(USEGPPLINK) $(libopensm_la_LDFLAGS) $(libopensm_la_OBJECTS) $(libopensm_la_LIBADD) $(LIBS)
|
|
||||||
opensm$(EXEEXT): $(opensm_OBJECTS) $(opensm_DEPENDENCIES)
|
|
||||||
@rm -f opensm$(EXEEXT)
|
|
||||||
$(USEGPPLINK) $(opensm_LDFLAGS) $(opensm_OBJECTS) $(opensm_LDADD) $(LIBS)
|
|
||||||
@@ -87,9 +87,9 @@ endif
|
|
||||||
|
|
||||||
# we need to be able to load libraries from local build subtree before make install
|
|
||||||
# we always give precedence to local tree libs and then use the pre-installed ones.
|
|
||||||
-opensm_LDADD = -L../complib -L../libvendor -L. $(OSMV_LDADD) -lopensm -losmcomp -losmvendor
|
|
||||||
+opensm_LDADD = -L../complib -losmcomp -L../libvendor -losmvendor -L. -lopensm
|
|
||||||
|
|
||||||
-opensm_LDFLAGS = -Wl,--rpath -Wl,$(libdir) -lpthread -ldl
|
|
||||||
+opensm_LDFLAGS = -lpthread -ldl
|
|
||||||
|
|
||||||
opensmincludedir = $(includedir)/infiniband/opensm
|
|
||||||
|
|
||||||
@@ -124,10 +124,10 @@ EXTRA_DIST = $(srcdir)/libopensm.map $(s
|
|
||||||
# name. What we can do it create a link to the installed file such
|
|
||||||
# that it will mark it with an alias...
|
|
||||||
# we find the new lib by traversing the links
|
|
||||||
-install-exec-hook:
|
|
||||||
- if test -L $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; fi; \
|
|
||||||
- lname=`\ls -l $(DESTDIR)/$(libdir)/libopensm.so | awk '{print $$NF}'`; \
|
|
||||||
- ln -s $$lname $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so
|
|
||||||
+#install-exec-hook:
|
|
||||||
+# if test -L $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; fi; \
|
|
||||||
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libopensm.so | awk '{print $$NF}'`; \
|
|
||||||
+# ln -s $$lname $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so
|
|
||||||
|
|
||||||
# generate c and h files from the lex and yacc files
|
|
||||||
dist-hook: $(srcdir)/osm_qos_parser_y.c $(srcdir)/osm_qos_parser_l.c
|
|
||||||
--- opensm-3.2.1/osmtest/Makefile.am.rpath 2008-03-12 17:43:17.000000000 -0400
|
|
||||||
+++ opensm-3.2.1/osmtest/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
||||||
@@ -18,10 +18,10 @@ osmtest_CFLAGS = -Wall $(OSMV_CFLAGS) -D
|
|
||||||
else
|
|
||||||
osmtest_CFLAGS = -Wall $(OSMV_CFLAGS) -DVENDOR_RMPP_SUPPORT $(DBGFLAGS)
|
|
||||||
endif
|
|
||||||
-osmtest_LDADD = -L../complib -L../libvendor -L../opensm -L$(libdir) -L. \
|
|
||||||
- $(OSMV_LDADD) -lopensm -losmcomp -losmvendor
|
|
||||||
+osmtest_LDADD = -L../complib -losmcomp -L../libvendor -losmvendor \
|
|
||||||
+ -L../opensm -lopensm
|
|
||||||
|
|
||||||
-osmtest_LDFLAGS = -Wl,--rpath -Wl,$(libdir) -lpthread -L../opensm
|
|
||||||
+osmtest_LDFLAGS = -lpthread
|
|
||||||
# for linking with the simulator client library we have to use g++:
|
|
||||||
if OSMV_SIM
|
|
||||||
USEGPPLINK = $(LIBTOOL) --mode=link g++ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
||||||
--- opensm-3.2.1/complib/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
||||||
+++ opensm-3.2.1/complib/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
||||||
@@ -85,7 +85,7 @@ EXTRA_DIST = $(srcdir)/libosmcomp.map $(
|
|
||||||
# name. What we can do it create a link to the installed file such
|
|
||||||
# that it will mark it with an alias...
|
|
||||||
# we find the new lib by traversing the links
|
|
||||||
-install-exec-hook:
|
|
||||||
- if test -L $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; fi; \
|
|
||||||
- lname=`\ls -l $(DESTDIR)/$(libdir)/libosmcomp.so | awk '{print $$NF}'`; \
|
|
||||||
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so
|
|
||||||
+#install-exec-hook:
|
|
||||||
+# if test -L $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; fi; \
|
|
||||||
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libosmcomp.so | awk '{print $$NF}'`; \
|
|
||||||
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so
|
|
||||||
--- opensm-3.2.1/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
||||||
+++ opensm-3.2.1/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
||||||
@@ -9,16 +9,16 @@ MAINTAINERCLEANFILES = Makefile.in acloc
|
|
||||||
ACLOCAL = aclocal -I $(ac_aux_dir)
|
|
||||||
|
|
||||||
# we should provide a hint for other apps about the build mode of this project
|
|
||||||
-install-exec-hook:
|
|
||||||
- mkdir -p $(DESTDIR)/$(includedir)
|
|
||||||
-if DEBUG
|
|
||||||
- echo "define osm_build_type \"debug\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
||||||
-else
|
|
||||||
- echo "define osm_build_type \"free\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
||||||
-endif
|
|
||||||
- $(top_srcdir)/config/install-sh -m 755 -d $(DESTDIR)/$(sysconfdir)/init.d
|
|
||||||
- cp $(top_builddir)/scripts/opensm.init $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
||||||
- chmod 755 $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
||||||
+#install-exec-hook:
|
|
||||||
+# mkdir -p $(DESTDIR)/$(includedir)
|
|
||||||
+#if DEBUG
|
|
||||||
+# echo "define osm_build_type \"debug\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
||||||
+#else
|
|
||||||
+# echo "define osm_build_type \"free\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
||||||
+#endif
|
|
||||||
+# $(top_srcdir)/config/install-sh -m 755 -d $(DESTDIR)/$(sysconfdir)/init.d
|
|
||||||
+# cp $(top_builddir)/scripts/opensm.init $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
||||||
+# chmod 755 $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
||||||
|
|
||||||
|
|
||||||
man_MANS = man/opensm.8 man/osmtest.8
|
|
405
opensm.conf
405
opensm.conf
@ -1,129 +1,310 @@
|
|||||||
OPTIONS="-B"
|
#
|
||||||
# DEBUG mode
|
# DEVICE ATTRIBUTES OPTIONS
|
||||||
# This option specifies a debug option.
|
#
|
||||||
# These options are not normally needed.
|
# The port GUID on which the OpenSM is running
|
||||||
# The number following -d selects the debug
|
guid 0x0000000000000000
|
||||||
# option to enable as follows:
|
|
||||||
# OPT Description
|
|
||||||
# --- -----------------
|
|
||||||
# 0 - Ignore other SM nodes.
|
|
||||||
# 1 - Force single threaded dispatching.
|
|
||||||
# 2 - Force log flushing after each log message.
|
|
||||||
# 3 - Disable multicast support.
|
|
||||||
# 4 - Put OpenSM in memory tracking mode.
|
|
||||||
# 10.. Put OpenSM in testability mode.
|
|
||||||
# none, no debug options are enabled.
|
|
||||||
# OPTIONS="$OPTIONS -d 1"
|
|
||||||
|
|
||||||
# LMC
|
# M_Key value sent to all ports qualifying all Set(PortInfo)
|
||||||
# This option specifies the subnet's LMC value.
|
m_key 0x0000000000000000
|
||||||
# The number of LIDs assigned to each port is 2^LMC.
|
|
||||||
# The LMC value must be in the range 0-7.
|
|
||||||
# LMC values > 0 allow multiple paths between ports.
|
|
||||||
# LMC values > 0 should only be used if the subnet
|
|
||||||
# topology actually provides multiple paths between
|
|
||||||
# ports, i.e. multiple interconnects between switches.
|
|
||||||
# OpenSM defaults to LMC = 0, which allows
|
|
||||||
# one path between any two ports.
|
|
||||||
# OPTIONS="$OPTIONS -l 0"
|
|
||||||
|
|
||||||
# MAXSMPS
|
# The lease period used for the M_Key on this subnet in [sec]
|
||||||
# This option specifies the number of VL15 SMP MADs
|
m_key_lease_period 0
|
||||||
# allowed on the wire at any one time.
|
|
||||||
# Specifying -maxsmps 0 allows unlimited outstanding SMPs.
|
|
||||||
# Without -maxsmps, OpenSM defaults to a maximum of
|
|
||||||
# four outstanding SMP.
|
|
||||||
OPTIONS="$OPTIONS -maxsmps 0"
|
|
||||||
|
|
||||||
# REASSIGN_LIDS
|
# SM_Key value of the SM used for SM authentication
|
||||||
# This option causes OpenSM to reassign LIDs to all
|
sm_key 0x0000000000000001
|
||||||
# end nodes. Specifying "REASSIGN_LIDS=yes" on a running subnet
|
|
||||||
# may disrupt subnet traffic.
|
|
||||||
# With "REASSIGN_LIDS=no", OpenSM attempts to preserve existing
|
|
||||||
# LID assignments resolving multiple use of same LID.
|
|
||||||
# OPTIONS="$OPTIONS -r"
|
|
||||||
|
|
||||||
# SWEEP
|
# SM_Key value to qualify rcv SA queries as 'trusted'
|
||||||
# This option specifies the number of seconds between
|
sa_key 0x0000000000000001
|
||||||
# subnet sweeps. Specifying SWEEP=0 disables sweeping.
|
|
||||||
# OpenSM defaults to a sweep interval of 10 seconds.
|
|
||||||
# OPTIONS="$OPTIONS -s 10"
|
|
||||||
|
|
||||||
# TIMEOUT
|
# Note that for both values above (sm_key and sa_key)
|
||||||
# This option specifies the time in milliseconds
|
# OpenSM version 3.2.1 and below used the default value '1'
|
||||||
# used for transaction timeouts.
|
# in a host byte order, it is fixed now but you may need to
|
||||||
# Specifying -t 0 disables timeouts.
|
# change the values to interoperate with old OpenSM running
|
||||||
# Without -t, OpenSM defaults to a timeout value of
|
# on a little endian machine.
|
||||||
# 200 milliseconds.
|
|
||||||
# OPTIONS="$OPTIONS -t 200"
|
|
||||||
|
|
||||||
# OSM_LOG
|
# Subnet prefix used on this subnet
|
||||||
# This option defines the log to be the given file.
|
subnet_prefix 0xfe80000000000000
|
||||||
# By default the log goes to /tmp/osm.log, which isn't very suitable
|
|
||||||
# for a distribution, so we override it by default here.
|
|
||||||
# For the log to go to standard output use OSM_LOG=stdout.
|
|
||||||
OPTIONS="$OPTIONS -f /var/log/opensm.log"
|
|
||||||
|
|
||||||
# QoS
|
# The LMC value used on this subnet
|
||||||
# This option enable QoS support in opensm
|
lmc 0
|
||||||
# OPTIONS="$OPTIONS -Q"
|
|
||||||
|
|
||||||
# QoS_POLICY
|
# lmc_esp0 determines whether LMC value used on subnet is used for
|
||||||
# This option sets the file from which to load the QoS policy
|
# enhanced switch port 0. If TRUE, LMC value for subnet is used for
|
||||||
# OPTIONS="$OPTIONS -Y /etc/rdma/qos_policy"
|
# ESP0. Otherwise, LMC value for ESP0s is 0.
|
||||||
|
lmc_esp0 FALSE
|
||||||
|
|
||||||
# VERBOSE
|
# The code of maximal time a packet can live in a switch
|
||||||
# This option increases the log verbosity level.
|
# The actual time is 4.096usec * 2^<packet_life_time>
|
||||||
# The "-v" option may be specified multiple times
|
# The value 0x14 disables this mechanism
|
||||||
# to further increase the verbosity level.
|
packet_life_time 0x12
|
||||||
# "-V" option sets the maximum verbosity level and
|
|
||||||
# forces log flushing.
|
|
||||||
# The "-V" is equivalent to "-vf 0xFF -d 2".
|
|
||||||
# OPTIONS="$OPTIONS -v 0x00"
|
|
||||||
|
|
||||||
# ROUTING_ENGINE
|
# The number of sequential packets dropped that cause the port
|
||||||
# This option chooses the routing engine to use instead of the default
|
# to enter the VLStalled state. The result of setting this value to
|
||||||
# algorithm Min Hop
|
# zero is undefined.
|
||||||
# Supported engines are: updn, file, ftree, lash, dor
|
vl_stall_count 0x07
|
||||||
# OPTIONS="$OPTIONS -R updn"
|
|
||||||
|
|
||||||
# ROOT_GUID_FILE
|
# The number of sequential packets dropped that cause the port
|
||||||
# This option only allowed when UPDN algorithm is activated
|
# to enter the VLStalled state. This value is for switch ports
|
||||||
# It specifies the guid list file from which to fetch the root node guid list
|
# driving a CA or router port. The result of setting this value
|
||||||
# The file contain in each line only one valid guid
|
# to zero is undefined.
|
||||||
# OPTIONS="$OPTIONS -a /etc/rdma/root_guids"
|
leaf_vl_stall_count 0x07
|
||||||
|
|
||||||
# CN_GUID_FILE
|
# The code of maximal time a packet can wait at the head of
|
||||||
# This option only allowed when UPDN algorithm is activated
|
# transmission queue.
|
||||||
# It specifies the guid list file from which to fetch the compute node
|
# The actual time is 4.096usec * 2^<head_of_queue_lifetime>
|
||||||
# guid list
|
# The value 0x14 disables this mechanism
|
||||||
# The file contain in each line only one valid guid
|
head_of_queue_lifetime 0x12
|
||||||
# OPTIONS="$OPTIONS -u /etc/rdma/cn_guids"
|
|
||||||
|
|
||||||
# GUID
|
# The maximal time a packet can wait at the head of queue on
|
||||||
# This option specifies the local port GUID value
|
# switch port connected to a CA or router port
|
||||||
# with which OpenSM should bind. OpenSM may be
|
leaf_head_of_queue_lifetime 0x10
|
||||||
# bound to 1 port at a time.
|
|
||||||
# If GUID given is 0, opensm would list the available guids and wait for
|
|
||||||
# the user to select one (which obviously is no use in an init script)
|
|
||||||
# Without -g, OpenSM trys to use the default port.
|
|
||||||
# OPTIONS="$OPTIONS -g <guid in hex>"
|
|
||||||
|
|
||||||
# PRIORITY
|
# Limit the maximal operational VLs
|
||||||
# This option specifies the SM's PRIORITY.
|
max_op_vls 5
|
||||||
# This will effect the handover cases, where master
|
|
||||||
# is chosen by priority and GUID. Range goes
|
|
||||||
# from 0 (lowest priority) to 15 (highest).
|
|
||||||
OPTIONS="$OPTIONS -p 15"
|
|
||||||
|
|
||||||
# OSM_CACHE_DIR
|
# Force PortInfo:LinkSpeedEnabled on switch ports
|
||||||
# There is no command line option to opensm to set this, it can only be set
|
# If 0, don't modify PortInfo:LinkSpeedEnabled on switch port
|
||||||
# as an environment variable.
|
# Otherwise, use value for PortInfo:LinkSpeedEnabled on switch port
|
||||||
OSM_CACHE_DIR=/var/cache/opensm
|
# Values are (IB Spec 1.2.1, 14.2.5.6 Table 146 "PortInfo")
|
||||||
|
# 1: 2.5 Gbps
|
||||||
|
# 3: 2.5 or 5.0 Gbps
|
||||||
|
# 5: 2.5 or 10.0 Gbps
|
||||||
|
# 7: 2.5 or 5.0 or 10.0 Gbps
|
||||||
|
# 2,4,6,8-14 Reserved
|
||||||
|
# Default 15: set to PortInfo:LinkSpeedSupported
|
||||||
|
force_link_speed 15
|
||||||
|
|
||||||
# CACHE_OPTIONS
|
# The subnet_timeout code that will be set for all the ports
|
||||||
# Cache the given command line options into the file
|
# The actual timeout is 4.096usec * 2^<subnet_timeout>
|
||||||
# OSM_CACHE_DIR/opensm.opts for use next invocation
|
subnet_timeout 18
|
||||||
# Set to '--cache-options' or '-c' in order to enable
|
|
||||||
# OPTIONS="$OPTIONS -c"
|
# Threshold of local phy errors for sending Trap 129
|
||||||
|
local_phy_errors_threshold 0x08
|
||||||
|
|
||||||
|
# Threshold of credit overrun errors for sending Trap 130
|
||||||
|
overrun_errors_threshold 0x08
|
||||||
|
|
||||||
|
#
|
||||||
|
# PARTITIONING OPTIONS
|
||||||
|
#
|
||||||
|
# Partition configuration file to be used
|
||||||
|
partition_config_file /etc/ofed/partitions.conf
|
||||||
|
|
||||||
|
# Disable partition enforcement by switches
|
||||||
|
no_partition_enforcement FALSE
|
||||||
|
|
||||||
|
#
|
||||||
|
# SWEEP OPTIONS
|
||||||
|
#
|
||||||
|
# The number of seconds between subnet sweeps (0 disables it)
|
||||||
|
sweep_interval 10
|
||||||
|
|
||||||
|
# If TRUE cause all lids to be reassigned
|
||||||
|
reassign_lids FALSE
|
||||||
|
|
||||||
|
# If TRUE forces every sweep to be a heavy sweep
|
||||||
|
force_heavy_sweep FALSE
|
||||||
|
|
||||||
|
# If TRUE every trap will cause a heavy sweep.
|
||||||
|
# NOTE: successive identical traps (>10) are suppressed
|
||||||
|
sweep_on_trap TRUE
|
||||||
|
|
||||||
|
#
|
||||||
|
# ROUTING OPTIONS
|
||||||
|
#
|
||||||
|
# If TRUE count switches as link subscriptions
|
||||||
|
port_profile_switch_nodes FALSE
|
||||||
|
|
||||||
|
# Name of file with port guids to be ignored by port profiling
|
||||||
|
port_prof_ignore_file (null)
|
||||||
|
|
||||||
|
# Routing engine
|
||||||
|
# Multiple routing engines can be specified separated by
|
||||||
|
# commas so that specific ordering of routing algorithms will
|
||||||
|
# be tried if earlier routing engines fail.
|
||||||
|
# Supported engines: minhop, updn, file, ftree, lash, dor
|
||||||
|
routing_engine (null)
|
||||||
|
|
||||||
|
# Connect roots (use FALSE if unsure)
|
||||||
|
connect_roots FALSE
|
||||||
|
|
||||||
|
# Use unicast routing cache (use FALSE if unsure)
|
||||||
|
use_ucast_cache FALSE
|
||||||
|
|
||||||
|
# Lid matrix dump file name
|
||||||
|
lid_matrix_dump_file (null)
|
||||||
|
|
||||||
|
# LFTs file name
|
||||||
|
lfts_file (null)
|
||||||
|
|
||||||
|
# The file holding the root node guids (for fat-tree or Up/Down)
|
||||||
|
# One guid in each line
|
||||||
|
root_guid_file (null)
|
||||||
|
|
||||||
|
# The file holding the fat-tree compute node guids
|
||||||
|
# One guid in each line
|
||||||
|
cn_guid_file (null)
|
||||||
|
|
||||||
|
# The file holding the node ids which will be used by Up/Down algorithm instead
|
||||||
|
# of GUIDs (one guid and id in each line)
|
||||||
|
ids_guid_file (null)
|
||||||
|
|
||||||
|
# The file holding guid routing order guids (for MinHop and Up/Down)
|
||||||
|
guid_routing_order_file (null)
|
||||||
|
|
||||||
|
# SA database file name
|
||||||
|
sa_db_file (null)
|
||||||
|
|
||||||
|
#
|
||||||
|
# HANDOVER - MULTIPLE SMs OPTIONS
|
||||||
|
#
|
||||||
|
# SM priority used for deciding who is the master
|
||||||
|
# Range goes from 0 (lowest priority) to 15 (highest).
|
||||||
|
sm_priority 15
|
||||||
|
|
||||||
|
# If TRUE other SMs on the subnet should be ignored
|
||||||
|
ignore_other_sm FALSE
|
||||||
|
|
||||||
|
# Timeout in [msec] between two polls of active master SM
|
||||||
|
sminfo_polling_timeout 10000
|
||||||
|
|
||||||
|
# Number of failing polls of remote SM that declares it dead
|
||||||
|
polling_retry_number 4
|
||||||
|
|
||||||
|
# If TRUE honor the guid2lid file when coming out of standby
|
||||||
|
# state, if such file exists and is valid
|
||||||
|
honor_guid2lid_file FALSE
|
||||||
|
|
||||||
|
#
|
||||||
|
# TIMING AND THREADING OPTIONS
|
||||||
|
#
|
||||||
|
# Maximum number of SMPs sent in parallel
|
||||||
|
max_wire_smps 32
|
||||||
|
|
||||||
|
# The maximum time in [msec] allowed for a transaction to complete
|
||||||
|
transaction_timeout 200
|
||||||
|
|
||||||
|
# Maximal time in [msec] a message can stay in the incoming message queue.
|
||||||
|
# If there is more than one message in the queue and the last message
|
||||||
|
# stayed in the queue more than this value, any SA request will be
|
||||||
|
# immediately returned with a BUSY status.
|
||||||
|
max_msg_fifo_timeout 10000
|
||||||
|
|
||||||
|
# Use a single thread for handling SA queries
|
||||||
|
single_thread FALSE
|
||||||
|
|
||||||
|
#
|
||||||
|
# MISC OPTIONS
|
||||||
|
#
|
||||||
|
# Daemon mode
|
||||||
|
daemon TRUE
|
||||||
|
|
||||||
|
# SM Inactive
|
||||||
|
sm_inactive FALSE
|
||||||
|
|
||||||
|
# Babbling Port Policy
|
||||||
|
babbling_port_policy FALSE
|
||||||
|
|
||||||
|
#
|
||||||
|
# Event Plugin Options
|
||||||
|
#
|
||||||
|
event_plugin_name (null)
|
||||||
|
|
||||||
|
#
|
||||||
|
# Node name map for mapping node's to more descriptive node descriptions
|
||||||
|
# (man ibnetdiscover for more information)
|
||||||
|
#
|
||||||
|
node_name_map_name (null)
|
||||||
|
|
||||||
|
#
|
||||||
|
# DEBUG FEATURES
|
||||||
|
#
|
||||||
|
# The log flags used
|
||||||
|
log_flags 0x03
|
||||||
|
|
||||||
|
# Force flush of the log file after each log message
|
||||||
|
force_log_flush FALSE
|
||||||
|
|
||||||
|
# Log file to be used
|
||||||
|
log_file /var/log/opensm.log
|
||||||
|
|
||||||
|
# Limit the size of the log file in MB. If overrun, log is restarted
|
||||||
|
log_max_size 0
|
||||||
|
|
||||||
|
# If TRUE will accumulate the log over multiple OpenSM sessions
|
||||||
|
accum_log_file TRUE
|
||||||
|
|
||||||
|
# The directory to hold the file OpenSM dumps
|
||||||
|
dump_files_dir /var/log/
|
||||||
|
|
||||||
|
# If TRUE enables new high risk options and hardware specific quirks
|
||||||
|
enable_quirks FALSE
|
||||||
|
|
||||||
|
# If TRUE disables client reregistration
|
||||||
|
no_clients_rereg FALSE
|
||||||
|
|
||||||
|
# If TRUE OpenSM should disable multicast support and
|
||||||
|
# no multicast routing is performed if TRUE
|
||||||
|
disable_multicast FALSE
|
||||||
|
|
||||||
|
# If TRUE opensm will exit on fatal initialization issues
|
||||||
|
exit_on_fatal TRUE
|
||||||
|
|
||||||
|
# console [off|local]
|
||||||
|
console off
|
||||||
|
|
||||||
|
# Telnet port for console (default 10000)
|
||||||
|
console_port 10000
|
||||||
|
|
||||||
|
#
|
||||||
|
# QoS OPTIONS
|
||||||
|
#
|
||||||
|
# Enable QoS setup
|
||||||
|
qos FALSE
|
||||||
|
|
||||||
|
# QoS policy file to be used
|
||||||
|
qos_policy_file /etc/ofed/qos-policy.conf
|
||||||
|
|
||||||
|
# QoS default options
|
||||||
|
qos_max_vls 0
|
||||||
|
qos_high_limit -1
|
||||||
|
qos_vlarb_high (null)
|
||||||
|
qos_vlarb_low (null)
|
||||||
|
qos_sl2vl (null)
|
||||||
|
|
||||||
|
# QoS CA options
|
||||||
|
qos_ca_max_vls 0
|
||||||
|
qos_ca_high_limit -1
|
||||||
|
qos_ca_vlarb_high (null)
|
||||||
|
qos_ca_vlarb_low (null)
|
||||||
|
qos_ca_sl2vl (null)
|
||||||
|
|
||||||
|
# QoS Switch Port 0 options
|
||||||
|
qos_sw0_max_vls 0
|
||||||
|
qos_sw0_high_limit -1
|
||||||
|
qos_sw0_vlarb_high (null)
|
||||||
|
qos_sw0_vlarb_low (null)
|
||||||
|
qos_sw0_sl2vl (null)
|
||||||
|
|
||||||
|
# QoS Switch external ports options
|
||||||
|
qos_swe_max_vls 0
|
||||||
|
qos_swe_high_limit -1
|
||||||
|
qos_swe_vlarb_high (null)
|
||||||
|
qos_swe_vlarb_low (null)
|
||||||
|
qos_swe_sl2vl (null)
|
||||||
|
|
||||||
|
# QoS Router ports options
|
||||||
|
qos_rtr_max_vls 0
|
||||||
|
qos_rtr_high_limit -1
|
||||||
|
qos_rtr_vlarb_high (null)
|
||||||
|
qos_rtr_vlarb_low (null)
|
||||||
|
qos_rtr_sl2vl (null)
|
||||||
|
|
||||||
|
# Prefix routes file name
|
||||||
|
prefix_routes_file /etc/ofed/prefix-routes.conf
|
||||||
|
|
||||||
|
#
|
||||||
|
# IPv6 Solicited Node Multicast (SNM) Options
|
||||||
|
#
|
||||||
|
consolidate_ipv6_snm_req FALSE
|
||||||
|
|
||||||
|
17
opensm.initd
17
opensm.initd
@ -4,12 +4,12 @@
|
|||||||
#
|
#
|
||||||
# chkconfig: - 15 85
|
# chkconfig: - 15 85
|
||||||
# description: Activates/Deactivates InfiniBand Subnet Manager
|
# description: Activates/Deactivates InfiniBand Subnet Manager
|
||||||
# config: /etc/rdma/opensm.conf
|
# config: /etc/ofed/opensm.conf
|
||||||
#
|
#
|
||||||
### BEGIN INIT INFO
|
### BEGIN INIT INFO
|
||||||
# Provides: opensm
|
# Provides: opensm
|
||||||
# Default-Stop: 0 1 2 3 4 5 6
|
# Default-Stop: 0 1 2 3 4 5 6
|
||||||
# Required-Start: $rdma
|
# Required-Start: $openib
|
||||||
# Short-Description: Starts/Stops the InfiniBand Subnet Manager
|
# Short-Description: Starts/Stops the InfiniBand Subnet Manager
|
||||||
# Description: Starts/Stops the InfiniBand Subnet Manager
|
# Description: Starts/Stops the InfiniBand Subnet Manager
|
||||||
### END INIT INFO
|
### END INIT INFO
|
||||||
@ -17,24 +17,17 @@
|
|||||||
. /etc/rc.d/init.d/functions
|
. /etc/rc.d/init.d/functions
|
||||||
|
|
||||||
prog=/usr/sbin/opensm
|
prog=/usr/sbin/opensm
|
||||||
CONFIG=/etc/rdma/opensm.conf
|
|
||||||
PID_FILE=/var/run/opensm.pid
|
PID_FILE=/var/run/opensm.pid
|
||||||
ACTION=$1
|
ACTION=$1
|
||||||
|
|
||||||
start()
|
start()
|
||||||
{
|
{
|
||||||
local OSM_PID=
|
local OSM_PID=
|
||||||
if [ ! -f $CONFIG ]; then
|
|
||||||
echo -n "Starting opensm: $CONFIG missing"
|
|
||||||
echo_failure
|
|
||||||
return 6
|
|
||||||
fi
|
|
||||||
. $CONFIG
|
|
||||||
[ -f /var/lock/subsys/opensm ] && return 0
|
[ -f /var/lock/subsys/opensm ] && return 0
|
||||||
# Start opensm
|
# Start opensm
|
||||||
echo -n "Starting IB Subnet Manager:"
|
echo -n "Starting IB Subnet Manager:"
|
||||||
$prog $OPTIONS > /dev/null 2>&1
|
$prog -B > /dev/null 2>&1
|
||||||
sleep 1
|
sleep 1
|
||||||
OSM_PID=`pidof $prog`
|
OSM_PID=`pidof $prog`
|
||||||
checkpid $OSM_PID
|
checkpid $OSM_PID
|
||||||
RC=$?
|
RC=$?
|
||||||
@ -53,7 +46,7 @@ stop()
|
|||||||
|
|
||||||
OSM_PID=`cat $PID_FILE`
|
OSM_PID=`cat $PID_FILE`
|
||||||
|
|
||||||
checkpid "$OSM_PID"
|
checkpid $OSM_PID
|
||||||
RC=$?
|
RC=$?
|
||||||
if [ $RC -ne 0 ]; then
|
if [ $RC -ne 0 ]; then
|
||||||
rm -f $PID_FILE
|
rm -f $PID_FILE
|
||||||
|
13
opensm.spec
13
opensm.spec
@ -1,6 +1,6 @@
|
|||||||
Name: opensm
|
Name: opensm
|
||||||
Version: 3.2.1
|
Version: 3.3.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: OpenIB InfiniBand Subnet Manager and management utilities
|
Summary: OpenIB InfiniBand Subnet Manager and management utilities
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2 or BSD
|
License: GPLv2 or BSD
|
||||||
@ -9,10 +9,9 @@ Source0: http://www.openfabrics.org/downloads/management/%{name}-%{version}.tar.
|
|||||||
Source1: opensm.conf
|
Source1: opensm.conf
|
||||||
Source2: opensm.logrotate
|
Source2: opensm.logrotate
|
||||||
Source3: opensm.initd
|
Source3: opensm.initd
|
||||||
Patch0: opensm-3.2.1-rpath.patch
|
|
||||||
Patch1: opensm-3.2.1-elif.patch
|
Patch1: opensm-3.2.1-elif.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libibmad-devel >= 1.2.0, libtool, bison, flex, byacc
|
BuildRequires: libibmad-devel >= 1.3.0, libtool, bison, flex, byacc
|
||||||
Requires: %{name}-libs = %{version}-%{release}, logrotate, rdma
|
Requires: %{name}-libs = %{version}-%{release}, logrotate, rdma
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -47,9 +46,7 @@ Static version of opensm libraries
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .rpath
|
|
||||||
%patch1 -p1 -b .elif
|
%patch1 -p1 -b .elif
|
||||||
./autogen.sh
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-opensm-conf-sub-dir=rdma
|
%configure --with-opensm-conf-sub-dir=rdma
|
||||||
@ -60,6 +57,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
# remove unpackaged files from the buildroot
|
# remove unpackaged files from the buildroot
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
rm -fr $RPM_BUILD_ROOT%{_sysconfdir}/init.d
|
||||||
install -D -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rdma/opensm.conf
|
install -D -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rdma/opensm.conf
|
||||||
install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/opensm
|
install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/opensm
|
||||||
install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_initrddir}/opensm
|
install -D -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_initrddir}/opensm
|
||||||
@ -110,6 +108,9 @@ fi
|
|||||||
%{_libdir}/lib*.a
|
%{_libdir}/lib*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 22 2009 Doug Ledford <dledford@redhat.com> - 3.3.1-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
|
||||||
* Fri Mar 06 2009 Caolán McNamara <caolanm@redhat.com> - 3.2.1-3
|
* Fri Mar 06 2009 Caolán McNamara <caolanm@redhat.com> - 3.2.1-3
|
||||||
- fix bare elifs to rebuild
|
- fix bare elifs to rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user