114 lines
6.1 KiB
Diff
114 lines
6.1 KiB
Diff
--- opensm-3.2.1/libvendor/Makefile.am.rpath 2008-01-15 15:23:51.000000000 -0500
|
|
+++ opensm-3.2.1/libvendor/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
@@ -94,8 +94,8 @@ EXTRA_DIST = $(srcdir)/libosmvendor.map
|
|
# name. What we can do it create a link to the installed file such
|
|
# that it will mark it with an alias...
|
|
# we find the new lib by traversing the links
|
|
-install-exec-hook:
|
|
- if test -L $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; fi; \
|
|
- lname=`\ls -l $(DESTDIR)/$(libdir)/libosmvendor.so | awk '{print $$NF}'`; \
|
|
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor_$(with_osmv).so; \
|
|
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so
|
|
+#install-exec-hook:
|
|
+# if test -L $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so; fi; \
|
|
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libosmvendor.so | awk '{print $$NF}'`; \
|
|
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor_$(with_osmv).so; \
|
|
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmvendor-$(VERSION).so
|
|
--- opensm-3.2.1/opensm/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
+++ opensm-3.2.1/opensm/Makefile.am 2008-06-30 11:11:40.000000000 -0400
|
|
@@ -79,7 +79,7 @@ endif
|
|
if OSMV_SIM
|
|
USEGPPLINK = $(LIBTOOL) --mode=link g++ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
libopensm.la: $(libopensm_la_OBJECTS) $(libopensm_la_DEPENDENCIES)
|
|
- $(USEGPPLINK) -rpath $(libdir) $(libopensm_la_LDFLAGS) $(libopensm_la_OBJECTS) $(libopensm_la_LIBADD) $(LIBS)
|
|
+ $(USEGPPLINK) $(libopensm_la_LDFLAGS) $(libopensm_la_OBJECTS) $(libopensm_la_LIBADD) $(LIBS)
|
|
opensm$(EXEEXT): $(opensm_OBJECTS) $(opensm_DEPENDENCIES)
|
|
@rm -f opensm$(EXEEXT)
|
|
$(USEGPPLINK) $(opensm_LDFLAGS) $(opensm_OBJECTS) $(opensm_LDADD) $(LIBS)
|
|
@@ -87,9 +87,9 @@ endif
|
|
|
|
# we need to be able to load libraries from local build subtree before make install
|
|
# we always give precedence to local tree libs and then use the pre-installed ones.
|
|
-opensm_LDADD = -L../complib -L../libvendor -L. $(OSMV_LDADD) -lopensm -losmcomp -losmvendor
|
|
+opensm_LDADD = -L../complib -losmcomp -L../libvendor -losmvendor -L. -lopensm
|
|
|
|
-opensm_LDFLAGS = -Wl,--rpath -Wl,$(libdir) -lpthread -ldl
|
|
+opensm_LDFLAGS = -lpthread -ldl
|
|
|
|
opensmincludedir = $(includedir)/infiniband/opensm
|
|
|
|
@@ -124,10 +124,10 @@ EXTRA_DIST = $(srcdir)/libopensm.map $(s
|
|
# name. What we can do it create a link to the installed file such
|
|
# that it will mark it with an alias...
|
|
# we find the new lib by traversing the links
|
|
-install-exec-hook:
|
|
- if test -L $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; fi; \
|
|
- lname=`\ls -l $(DESTDIR)/$(libdir)/libopensm.so | awk '{print $$NF}'`; \
|
|
- ln -s $$lname $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so
|
|
+#install-exec-hook:
|
|
+# if test -L $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so; fi; \
|
|
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libopensm.so | awk '{print $$NF}'`; \
|
|
+# ln -s $$lname $(DESTDIR)/$(libdir)/libopensm-$(VERSION).so
|
|
|
|
# generate c and h files from the lex and yacc files
|
|
dist-hook: $(srcdir)/osm_qos_parser_y.c $(srcdir)/osm_qos_parser_l.c
|
|
--- opensm-3.2.1/osmtest/Makefile.am.rpath 2008-03-12 17:43:17.000000000 -0400
|
|
+++ opensm-3.2.1/osmtest/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
@@ -18,10 +18,10 @@ osmtest_CFLAGS = -Wall $(OSMV_CFLAGS) -D
|
|
else
|
|
osmtest_CFLAGS = -Wall $(OSMV_CFLAGS) -DVENDOR_RMPP_SUPPORT $(DBGFLAGS)
|
|
endif
|
|
-osmtest_LDADD = -L../complib -L../libvendor -L../opensm -L$(libdir) -L. \
|
|
- $(OSMV_LDADD) -lopensm -losmcomp -losmvendor
|
|
+osmtest_LDADD = -L../complib -losmcomp -L../libvendor -losmvendor \
|
|
+ -L../opensm -lopensm
|
|
|
|
-osmtest_LDFLAGS = -Wl,--rpath -Wl,$(libdir) -lpthread -L../opensm
|
|
+osmtest_LDFLAGS = -lpthread
|
|
# for linking with the simulator client library we have to use g++:
|
|
if OSMV_SIM
|
|
USEGPPLINK = $(LIBTOOL) --mode=link g++ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
--- opensm-3.2.1/complib/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
+++ opensm-3.2.1/complib/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
@@ -85,7 +85,7 @@ EXTRA_DIST = $(srcdir)/libosmcomp.map $(
|
|
# name. What we can do it create a link to the installed file such
|
|
# that it will mark it with an alias...
|
|
# we find the new lib by traversing the links
|
|
-install-exec-hook:
|
|
- if test -L $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; fi; \
|
|
- lname=`\ls -l $(DESTDIR)/$(libdir)/libosmcomp.so | awk '{print $$NF}'`; \
|
|
- ln -s $$lname $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so
|
|
+#install-exec-hook:
|
|
+# if test -L $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; then rm $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so; fi; \
|
|
+# lname=`\ls -l $(DESTDIR)/$(libdir)/libosmcomp.so | awk '{print $$NF}'`; \
|
|
+# ln -s $$lname $(DESTDIR)/$(libdir)/libosmcomp-$(VERSION).so
|
|
--- opensm-3.2.1/Makefile.am.rpath 2008-03-12 17:43:16.000000000 -0400
|
|
+++ opensm-3.2.1/Makefile.am 2008-06-30 11:03:22.000000000 -0400
|
|
@@ -9,16 +9,16 @@ MAINTAINERCLEANFILES = Makefile.in acloc
|
|
ACLOCAL = aclocal -I $(ac_aux_dir)
|
|
|
|
# we should provide a hint for other apps about the build mode of this project
|
|
-install-exec-hook:
|
|
- mkdir -p $(DESTDIR)/$(includedir)
|
|
-if DEBUG
|
|
- echo "define osm_build_type \"debug\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
-else
|
|
- echo "define osm_build_type \"free\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
-endif
|
|
- $(top_srcdir)/config/install-sh -m 755 -d $(DESTDIR)/$(sysconfdir)/init.d
|
|
- cp $(top_builddir)/scripts/opensm.init $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
- chmod 755 $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
+#install-exec-hook:
|
|
+# mkdir -p $(DESTDIR)/$(includedir)
|
|
+#if DEBUG
|
|
+# echo "define osm_build_type \"debug\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
+#else
|
|
+# echo "define osm_build_type \"free\"" > $(DESTDIR)/$(includedir)/infiniband/opensm/osm_build_id.h
|
|
+#endif
|
|
+# $(top_srcdir)/config/install-sh -m 755 -d $(DESTDIR)/$(sysconfdir)/init.d
|
|
+# cp $(top_builddir)/scripts/opensm.init $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
+# chmod 755 $(DESTDIR)/$(sysconfdir)/init.d/opensmd
|
|
|
|
|
|
man_MANS = man/opensm.8 man/osmtest.8
|