31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
commit 145a696d478a1694ef314659a3d374f03f75c1b1
|
|
Author: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
Date: Mon Jul 5 13:49:09 2021 +0200
|
|
|
|
CONFIGURE: Remove AC_FUNC_MALLOC and AC_FUNC_REALLOC
|
|
|
|
The AC_FUNC_MALLOC configure check might add the rpl_malloc() entry if it
|
|
does not like the default malloc implementation. The user would need to
|
|
provide the rpl_malloc implementation. This happens depending on compiler and
|
|
OS/distro being used. Same applies for AC_FUNC_REALLOC and rpl_realloc.
|
|
It happened for me when I configured it with address sanitizer (libubsan,
|
|
libasan) activated.
|
|
|
|
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d3374476..286b7408 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -39,10 +39,8 @@ dnl Checks for library functions.
|
|
AC_FUNC_ALLOCA
|
|
AC_FUNC_CHOWN
|
|
AC_FUNC_FORK
|
|
-AC_FUNC_MALLOC
|
|
AC_FUNC_MKTIME
|
|
AC_FUNC_MMAP
|
|
-AC_FUNC_REALLOC
|
|
AC_FUNC_STRERROR_R
|
|
AC_CHECK_FUNCS([atexit ftruncate gettimeofday localtime_r memchr memmove \
|
|
memset mkdir munmap regcomp select socket strchr strcspn \
|