opencryptoki/opencryptoki-2.4.3-locks.patch
2013-06-25 10:09:06 +02:00

17 lines
515 B
Diff

diff --git a/usr/Makefile.am b/usr/Makefile.am
index 20352d5..5d42b0f 100644
--- a/usr/Makefile.am
+++ b/usr/Makefile.am
@@ -6,5 +6,9 @@ SUBDIRS = lib $(DAEMONDIRS)
install-data-hook:
$(MKDIR_P) $(DESTDIR)$(lockdir)
- $(CHGRP) pkcs11 $(DESTDIR)$(lockdir)
- $(CHMOD) 0770 $(DESTDIR)$(lockdir)
+ if test `id` = 0; then \
+ $(CHGRP) pkcs11 $(DESTDIR)$(lockdir); \
+ $(CHMOD) 0770 $(DESTDIR)$(lockdir); \
+ else \
+ echo "Not running as root, you must set the correct group and mode manually!"; \
+ fi