Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/opencryptoki.git#692d1bc57b90f2a31bec54f1fe5bb265968af2cf
This commit is contained in:
parent
1d47492875
commit
4dd94ed261
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ opencryptoki-2.3.1.tar.gz
|
||||
/opencryptoki-3.13.0.tar.gz
|
||||
/opencryptoki-3.14.0.tar.gz
|
||||
/opencryptoki-3.15.0.tar.gz
|
||||
/opencryptoki-3.15.1.tar.gz
|
||||
|
@ -1,183 +0,0 @@
|
||||
From 456570f5d4f8d7e9ce75c62ace1a9f79e25b6ee5 Mon Sep 17 00:00:00 2001
|
||||
From: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
Date: Tue, 20 Oct 2020 08:47:24 +0200
|
||||
Subject: [PATCH] Remove now unused header timeb.h
|
||||
|
||||
Since ef62794ca1d065ea20b207990956f93ab2cc6e3b timeb.h is no longer used.
|
||||
Remove it from the testcases that still include it, and also do not
|
||||
check for it in configure.ac.
|
||||
|
||||
Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
testcases/login/digest_init.c | 1 -
|
||||
testcases/login/init_pin.c | 1 -
|
||||
testcases/login/login.c | 1 -
|
||||
testcases/login/set_pin.c | 1 -
|
||||
testcases/misc_tests/fork.c | 1 -
|
||||
testcases/misc_tests/multi_instance.c | 1 -
|
||||
testcases/misc_tests/obj_lock.c | 1 -
|
||||
testcases/misc_tests/reencrypt.c | 1 -
|
||||
testcases/misc_tests/speed.c | 1 -
|
||||
testcases/misc_tests/tok2tok_transport.c | 1 -
|
||||
testcases/misc_tests/tok_des.c | 1 -
|
||||
testcases/misc_tests/tok_rsa.c | 1 -
|
||||
13 files changed, 1 insertion(+), 13 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 43349169..851f5e00 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -16,7 +16,7 @@ AC_HEADER_STDC
|
||||
AC_CHECK_HEADER_STDBOOL
|
||||
AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h locale.h malloc.h \
|
||||
nl_types.h stddef.h sys/file.h sys/socket.h sys/time.h \
|
||||
- sys/timeb.h syslog.h termios.h])
|
||||
+ syslog.h termios.h])
|
||||
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_C_INLINE
|
||||
diff --git a/testcases/login/digest_init.c b/testcases/login/digest_init.c
|
||||
index 9998447f..875d8ed8 100644
|
||||
--- a/testcases/login/digest_init.c
|
||||
+++ b/testcases/login/digest_init.c
|
||||
@@ -14,7 +14,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
|
||||
diff --git a/testcases/login/init_pin.c b/testcases/login/init_pin.c
|
||||
index 62b6f984..c03b57ab 100644
|
||||
--- a/testcases/login/init_pin.c
|
||||
+++ b/testcases/login/init_pin.c
|
||||
@@ -14,7 +14,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
|
||||
diff --git a/testcases/login/login.c b/testcases/login/login.c
|
||||
index 79ca419a..3081b3e3 100644
|
||||
--- a/testcases/login/login.c
|
||||
+++ b/testcases/login/login.c
|
||||
@@ -14,7 +14,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
#include "regress.h"
|
||||
diff --git a/testcases/login/set_pin.c b/testcases/login/set_pin.c
|
||||
index f72ac7bf..b82d99ac 100644
|
||||
--- a/testcases/login/set_pin.c
|
||||
+++ b/testcases/login/set_pin.c
|
||||
@@ -15,7 +15,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
|
||||
diff --git a/testcases/misc_tests/fork.c b/testcases/misc_tests/fork.c
|
||||
index b11f2035..fc3f4af8 100644
|
||||
--- a/testcases/misc_tests/fork.c
|
||||
+++ b/testcases/misc_tests/fork.c
|
||||
@@ -20,7 +20,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
diff --git a/testcases/misc_tests/multi_instance.c b/testcases/misc_tests/multi_instance.c
|
||||
index e9b9df4a..40638fcb 100644
|
||||
--- a/testcases/misc_tests/multi_instance.c
|
||||
+++ b/testcases/misc_tests/multi_instance.c
|
||||
@@ -20,7 +20,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
diff --git a/testcases/misc_tests/obj_lock.c b/testcases/misc_tests/obj_lock.c
|
||||
index c5bbc870..229aa054 100644
|
||||
--- a/testcases/misc_tests/obj_lock.c
|
||||
+++ b/testcases/misc_tests/obj_lock.c
|
||||
@@ -21,7 +21,6 @@
|
||||
#include <pthread.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
diff --git a/testcases/misc_tests/reencrypt.c b/testcases/misc_tests/reencrypt.c
|
||||
index c427f8f6..fa9633f5 100644
|
||||
--- a/testcases/misc_tests/reencrypt.c
|
||||
+++ b/testcases/misc_tests/reencrypt.c
|
||||
@@ -20,7 +20,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
diff --git a/testcases/misc_tests/speed.c b/testcases/misc_tests/speed.c
|
||||
index ac803c08..8f5426be 100644
|
||||
--- a/testcases/misc_tests/speed.c
|
||||
+++ b/testcases/misc_tests/speed.c
|
||||
@@ -27,7 +27,6 @@
|
||||
#include <memory.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
#include "regress.h"
|
||||
diff --git a/testcases/misc_tests/tok2tok_transport.c b/testcases/misc_tests/tok2tok_transport.c
|
||||
index f9e88561..1c482c27 100644
|
||||
--- a/testcases/misc_tests/tok2tok_transport.c
|
||||
+++ b/testcases/misc_tests/tok2tok_transport.c
|
||||
@@ -20,7 +20,6 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
diff --git a/testcases/misc_tests/tok_des.c b/testcases/misc_tests/tok_des.c
|
||||
index d881c827..2a0e186e 100644
|
||||
--- a/testcases/misc_tests/tok_des.c
|
||||
+++ b/testcases/misc_tests/tok_des.c
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
#include "regress.h"
|
||||
diff --git a/testcases/misc_tests/tok_rsa.c b/testcases/misc_tests/tok_rsa.c
|
||||
index 52068561..07e24ec2 100644
|
||||
--- a/testcases/misc_tests/tok_rsa.c
|
||||
+++ b/testcases/misc_tests/tok_rsa.c
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <memory.h>
|
||||
|
||||
#include <dlfcn.h>
|
||||
-#include <sys/timeb.h>
|
||||
|
||||
#include "pkcs11types.h"
|
||||
#include "regress.h"
|
@ -1,6 +1,6 @@
|
||||
Name: opencryptoki
|
||||
Summary: Implementation of the PKCS#11 (Cryptoki) specification v2.11
|
||||
Version: 3.15.0
|
||||
Version: 3.15.1
|
||||
Release: 1%{?dist}
|
||||
License: CPL
|
||||
URL: https://github.com/opencryptoki/opencryptoki
|
||||
@ -12,9 +12,6 @@ Patch0: opencryptoki-3.11.0-group.patch
|
||||
# bz#1373833, change tmpfiles snippets from /var/lock/* to /run/lock/*
|
||||
Patch1: opencryptoki-3.11.0-lockdir.patch
|
||||
|
||||
# https://github.com/opencryptoki/opencryptoki/issues/330
|
||||
Patch2: opencryptoki-3.15.0-timeb.patch
|
||||
|
||||
# Use --no-undefined to debug missing symbols
|
||||
#Patch100: %%{name}-3.2-no-undefined.patch
|
||||
|
||||
@ -312,6 +309,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 02 2020 Than Ngo <than@redhat.com> - 3.15.1-1
|
||||
- Rebase to 3.15.1
|
||||
|
||||
* Mon Oct 19 2020 Dan Horák <dan[at]danny.cz> - 3.15.0-1
|
||||
- Rebase to 3.15.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (opencryptoki-3.15.0.tar.gz) = 23ff42245dee95fa3ea123fbf4faf620a10c13bb5d0f86470aa5e5c17b933fc528b77019d740a114ad86a706a60019c59b2d95bb612e7fad4d186bdd0428a72e
|
||||
SHA512 (opencryptoki-3.15.1.tar.gz) = fb1dfba09bd78ed02eab58c86728f0face29513a2940cf1670722aa584ee2da6965304be4359f7bb32279f6531b980403bb873fb1e3d9ad56e5f6b83d6ff22f2
|
||||
|
Loading…
Reference in New Issue
Block a user