Make inline function compatible for GCC5
This commit is contained in:
parent
a0b380ef34
commit
28bd174a0e
@ -197,3 +197,15 @@ diff --git a/usr/lib/pkcs11/tpm_stdll/Makefile.am b/usr/lib/pkcs11/tpm_stdll/Mak
|
|||||||
../common/loadsave.c \
|
../common/loadsave.c \
|
||||||
../common/utility.c \
|
../common/utility.c \
|
||||||
../common/mech_des.c \
|
../common/mech_des.c \
|
||||||
|
diff --git a/usr/lib/pkcs11/common/btree.c b/usr/lib/pkcs11/common/btree.c
|
||||||
|
--- a/usr/lib/pkcs11/common/btree.c
|
||||||
|
+++ b/usr/lib/pkcs11/common/btree.c
|
||||||
|
@@ -242,7 +242,7 @@ bt_node_free(struct btree *t, unsigned long node_num, void (*delete_func)(void *
|
||||||
|
*
|
||||||
|
* return 0 if binary tree has at least 1 node in use, !0 otherwise
|
||||||
|
*/
|
||||||
|
-inline int
|
||||||
|
+extern inline int
|
||||||
|
bt_is_empty(struct btree *t)
|
||||||
|
{
|
||||||
|
return (t->free_nodes == t->size);
|
||||||
|
Loading…
Reference in New Issue
Block a user