Auto sync2gitlab import of opencryptoki-3.18.0-1.el8.src.rpm
This commit is contained in:
parent
80c1420375
commit
0abc49b494
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/opencryptoki-3.17.0.tar.gz
|
/opencryptoki-3.17.0.tar.gz
|
||||||
|
/opencryptoki-3.18.0.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up opencryptoki-3.17.0/Makefile.am.me opencryptoki-3.17.0/Makefile.am
|
|
||||||
--- opencryptoki-3.17.0/Makefile.am.me 2021-11-09 09:45:49.032661898 +0100
|
|
||||||
+++ opencryptoki-3.17.0/Makefile.am 2021-11-09 09:46:41.353400986 +0100
|
|
||||||
@@ -76,7 +76,7 @@ if ENABLE_EP11TOK
|
|
||||||
endif
|
|
||||||
if ENABLE_P11SAK
|
|
||||||
test -f $(DESTDIR)$(sysconfdir)/opencryptoki || $(MKDIR_P) $(DESTDIR)$(sysconfdir)/opencryptoki || true
|
|
||||||
- test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || $(INSTALL) -g pkcs11 -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || true
|
|
||||||
+ test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || $(INSTALL) -m 0644 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || true
|
|
||||||
endif
|
|
||||||
if ENABLE_ICATOK
|
|
||||||
cd $(DESTDIR)$(libdir)/opencryptoki/stdll && \
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up opencryptoki-3.17.0/usr/lib/api/api_interface.c.me opencryptoki-3.17.0/usr/lib/api/api_interface.c
|
|
||||||
--- opencryptoki-3.17.0/usr/lib/api/api_interface.c.me 2022-01-17 12:04:18.937010924 +0100
|
|
||||||
+++ opencryptoki-3.17.0/usr/lib/api/api_interface.c 2022-01-17 12:04:54.020182038 +0100
|
|
||||||
@@ -2869,7 +2869,7 @@ CK_RV C_Initialize(CK_VOID_PTR pVoid)
|
|
||||||
|
|
||||||
rc = check_user_and_group();
|
|
||||||
if (rc != CKR_OK)
|
|
||||||
- return rc;
|
|
||||||
+ goto done;
|
|
||||||
|
|
||||||
if (!Anchor) {
|
|
||||||
Anchor = (API_Proc_Struct_t *) malloc(sizeof(API_Proc_Struct_t));
|
|
21
opencryptoki-3.18.0-p11sak.patch
Normal file
21
opencryptoki-3.18.0-p11sak.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up opencryptoki-3.18.0/Makefile.am.me opencryptoki-3.18.0/Makefile.am
|
||||||
|
--- opencryptoki-3.18.0/Makefile.am.me 2022-05-09 22:25:07.980238715 +0200
|
||||||
|
+++ opencryptoki-3.18.0/Makefile.am 2022-05-09 22:25:29.292722755 +0200
|
||||||
|
@@ -78,7 +78,7 @@ if ENABLE_EP11TOK
|
||||||
|
endif
|
||||||
|
if ENABLE_P11SAK
|
||||||
|
test -f $(DESTDIR)$(sysconfdir)/opencryptoki || $(MKDIR_P) $(DESTDIR)$(sysconfdir)/opencryptoki || true
|
||||||
|
- test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || $(INSTALL) -g pkcs11 -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || true
|
||||||
|
+ test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || $(INSTALL) -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || true
|
||||||
|
endif
|
||||||
|
if ENABLE_ICATOK
|
||||||
|
cd $(DESTDIR)$(libdir)/opencryptoki/stdll && \
|
||||||
|
@@ -129,7 +129,7 @@ endif
|
||||||
|
if ENABLE_DAEMON
|
||||||
|
test -f $(DESTDIR)$(sysconfdir)/opencryptoki || $(MKDIR_P) $(DESTDIR)$(sysconfdir)/opencryptoki || true
|
||||||
|
test -f $(DESTDIR)$(sysconfdir)/opencryptoki/opencryptoki.conf || $(INSTALL) -m 644 $(srcdir)/usr/sbin/pkcsslotd/opencryptoki.conf $(DESTDIR)$(sysconfdir)/opencryptoki/opencryptoki.conf || true
|
||||||
|
- test -f $(DESTDIR)$(sysconfdir)/opencryptoki/strength.conf || $(INSTALL) -m 640 -o root -g pkcs11 -T $(srcdir)/doc/strength-example.conf $(DESTDIR)$(sysconfdir)/opencryptoki/strength.conf || true
|
||||||
|
+ test -f $(DESTDIR)$(sysconfdir)/opencryptoki/strength.conf || $(INSTALL) -m 640 -o root -T $(srcdir)/doc/strength-example.conf $(DESTDIR)$(sysconfdir)/opencryptoki/strength.conf || true
|
||||||
|
if ENABLE_SYSTEMD
|
||||||
|
mkdir -p $(DESTDIR)/usr/lib/tmpfiles.d
|
||||||
|
cp $(srcdir)/misc/tmpfiles.conf $(DESTDIR)/usr/lib/tmpfiles.d/opencryptoki.conf
|
@ -1,7 +1,7 @@
|
|||||||
Name: opencryptoki
|
Name: opencryptoki
|
||||||
Summary: Implementation of the PKCS#11 (Cryptoki) specification v3.0
|
Summary: Implementation of the PKCS#11 (Cryptoki) specification v3.0
|
||||||
Version: 3.17.0
|
Version: 3.18.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: CPL
|
License: CPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: https://github.com/opencryptoki/opencryptoki
|
URL: https://github.com/opencryptoki/opencryptoki
|
||||||
@ -11,9 +11,8 @@ Patch0: opencryptoki-3.11.0-group.patch
|
|||||||
# bz#1373833, change tmpfiles snippets from /var/lock/* to /run/lock/*
|
# bz#1373833, change tmpfiles snippets from /var/lock/* to /run/lock/*
|
||||||
Patch1: opencryptoki-3.11.0-lockdir.patch
|
Patch1: opencryptoki-3.11.0-lockdir.patch
|
||||||
# add missing p11sak_defined_attrs.conf
|
# add missing p11sak_defined_attrs.conf
|
||||||
Patch2: opencryptoki-1.17.0-p11sak.patch
|
Patch2: opencryptoki-3.18.0-p11sak.patch
|
||||||
# upstream patches
|
# upstream patches
|
||||||
Patch100: opencryptoki-3.17.0-unlock-globmutex-if-user-and-group-check-fail.patch
|
|
||||||
|
|
||||||
Requires(pre): coreutils
|
Requires(pre): coreutils
|
||||||
Requires: (selinux-policy >= 3.14.3-70 if selinux-policy-targeted)
|
Requires: (selinux-policy >= 3.14.3-70 if selinux-policy-targeted)
|
||||||
@ -248,18 +247,24 @@ fi
|
|||||||
%doc ChangeLog FAQ README.md
|
%doc ChangeLog FAQ README.md
|
||||||
%doc doc/opencryptoki-howto.md
|
%doc doc/opencryptoki-howto.md
|
||||||
%doc doc/README.token_data
|
%doc doc/README.token_data
|
||||||
|
%doc %{_docdir}/%{name}/*.conf
|
||||||
%dir %{_sysconfdir}/%{name}
|
%dir %{_sysconfdir}/%{name}
|
||||||
%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
|
%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
|
||||||
%attr(0640, root, pkcs11) %config(noreplace) %{_sysconfdir}/%{name}/p11sak_defined_attrs.conf
|
%attr(0640, root, pkcs11) %config(noreplace) %{_sysconfdir}/%{name}/p11sak_defined_attrs.conf
|
||||||
|
%attr(0640, root, pkcs11) %config(noreplace) %{_sysconfdir}/%{name}/strength.conf
|
||||||
%{_tmpfilesdir}/%{name}.conf
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
%{_unitdir}/pkcsslotd.service
|
%{_unitdir}/pkcsslotd.service
|
||||||
%{_sbindir}/p11sak
|
%{_sbindir}/p11sak
|
||||||
%{_sbindir}/pkcstok_migrate
|
%{_sbindir}/pkcstok_migrate
|
||||||
%{_sbindir}/pkcsconf
|
%{_sbindir}/pkcsconf
|
||||||
%{_sbindir}/pkcsslotd
|
%{_sbindir}/pkcsslotd
|
||||||
|
%{_sbindir}/pkcsstats
|
||||||
%{_mandir}/man1/p11sak.1*
|
%{_mandir}/man1/p11sak.1*
|
||||||
%{_mandir}/man1/pkcstok_migrate.1*
|
%{_mandir}/man1/pkcstok_migrate.1*
|
||||||
%{_mandir}/man1/pkcsconf.1*
|
%{_mandir}/man1/pkcsconf.1*
|
||||||
|
%{_mandir}/man1/pkcsstats.1*
|
||||||
|
%{_mandir}/man5/policy.conf.5*
|
||||||
|
%{_mandir}/man5/strength.conf.5*
|
||||||
%{_mandir}/man5/%{name}.conf.5*
|
%{_mandir}/man5/%{name}.conf.5*
|
||||||
%{_mandir}/man5/p11sak_defined_attrs.conf.5*
|
%{_mandir}/man5/p11sak_defined_attrs.conf.5*
|
||||||
%{_mandir}/man7/%{name}.7*
|
%{_mandir}/man7/%{name}.7*
|
||||||
@ -341,6 +346,14 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 24 2022 Than Ngo <than@redhat.com> - 3.18.0-1
|
||||||
|
- Resolves: #2043845, rebase to 3.18.0
|
||||||
|
- Resolves: #2043854, add crypto counters
|
||||||
|
- Resolves: #2043855, support crypto profiles
|
||||||
|
|
||||||
|
* Fri Apr 15 2022 Than Ngo <than@redhat.com> - 3.17.0-4
|
||||||
|
- Resolves: #2066762, Dilithium support not available
|
||||||
|
|
||||||
* Mon Jan 17 2022 Than Ngo <than@redhat.com> - 3.17.0-3
|
* Mon Jan 17 2022 Than Ngo <than@redhat.com> - 3.17.0-3
|
||||||
- Resolves: #2040677, API: Unlock GlobMutex if user and group check fails
|
- Resolves: #2040677, API: Unlock GlobMutex if user and group check fails
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (opencryptoki-3.17.0.tar.gz) = 1e80f4cebfffef1b50f3a29577c003e3a3ac68f9c93c3fd49537dad5ab82d02ab54f62fa73e93cd20f2ea1517eb4aa3a0ac167df3597bb801e8781a4162f9d01
|
SHA512 (opencryptoki-3.18.0.tar.gz) = ec975ad15766d1565bb8134160c1a6373a1106486acc924f34d63d8a02c2f2b4d88caa443d17a5f7f92c8d99d3e5c1604073d879403e4f531019ced736422ea3
|
||||||
|
Loading…
Reference in New Issue
Block a user